Примечание.

Функция OpenGL в After Effects CS6 отличается от функция OpenGL в предыдущих версиях. Этот документ предназначен только для версий After Effects с CS4 по CS5.5. Для получения дополнительной информации о функции графического процессора After Effects CS6 см. это видео.

В этом документе содержатся рекомендации по решению проблем, связанных с OpenGL, проявляющихся при использовании After Effects. Проблемы с OpenGL могут проявляться различным образом, включая (но не ограничиваясь) следующее:

  • Adobe After Effects испытывает сбой или закрывается без ошибки при запуске.
  • Сбой или зависание при очистке шкалы времени или предварительном просмотре или рендеринге композиции.
  • Сбой при изменении настройки эффекта, когда включен предварительный просмотр OpenGL.
  • Сбой или зависание при включении или отключении предварительного просмотра OpenGL.
  • Перерисовка в окне композиции занимает очень много времени.
  • Артефакты или блоки «мусорных» пикселов отображаются в окне композиции.
  • Окно композиции отображается по-разному в браузере, когда предварительные просмотры OpenGL включены и отключены.
  • Сообщение об ошибке, например:

    «Предупреждение After Effects: Произошла ошибка при обработке команд OpenGL».

    «Инструкция 0x00fe1940 ссылается на память по адресу 0x000000000. Память не может быть «read»».

    «AE_OpenGL: не удалось создать карту теней (5065::0)»

    «Данная композиция слишком сложна для аппаратного обеспечения OpenGL».

    «Ошибка After Effects: AE_OpenGL: Ошибка создания текстуры. (5065 :: 0)»

Сведения о том, как настраивать параметры предварительного просмотра в After Effects для OpenGL, и список новых функций в After Effects, которые могут выполняться с помощью OpenGL, см. в разделе Рендеринг с помощью OpenGL в справке по After Effects.

Для того, чтобы данный документ принес вам пользу, выполняйте приведенные в нем задания по порядку. Запишите задания, которые вы выполняете, и запишите результаты каждого задания, в том числе ошибки и иные проблемы. Служба технической поддержки Adobe сможет использовать эту информацию, чтобы помочь вам в устранении неполадки.

Для того, чтобы произвести некоторые процедуры, перечисленные в этом документе, вы должны войти в систему как администратор.

В Windows, для некоторых из этих процедур требуется определение местонахождения скрытых файлов и скрытых папок. Для некоторых процедур требуется поиск файлов по их полному имени, включая расширения (например, example_filename.ini). По умолчанию Проводник Windows не показывает скрытые файлы и папки, а также расширения имен файлов, которые он распознает. См. Показать скрытые файлы и папки в Windows для получения подробной информации.

Для Windows Vista, упомянутые в данном документе уровни, которые ссылаются на Панель управления, являются ссылками на ее классический вид. Для получения информации о переключении Панели управления в классический вид и многих других общих процедурах операционной системы см. раздел Общие процедуры операционной системы.

Приведенные ниже рекомендации помогут вам решить самые распространенные проблемы, связанные с OpenGL. Перед выполнением любого из указанных действий создайте резервные копии всех личных файлов (например, созданных вами файлов After Effects). После обнаружения системной ошибки всегда перезагружайте компьютер, чтобы обновить память. Если Вы продолжите работу без перезагрузки компьютера, это может лишь усугубить проблему.

1. Обновите After Effects до самой последней версии

Чтобы проверить наличие обновлений, выберите в After Effects «Справка» > «Обновления».

2. Убедитесь, что система соответствует минимальным требованиям After Effects.

На этой странице можно ознакомиться со списком системных требований After Effects: Системные требования Adobe After Effects

3. Убедитесь, что видеокарта и драйверы соответствуют требованиям OpenGL.

Для использования OpenGL в After Effects необходима видеокарта с поддержкой OpenGL, поддерживающая стандарт OpenGL 2.0.

Чтобы определить, какой стандарт OpenGL поддерживает ваша карта, нажмите кнопку «Сведения об OpenGL» в параметрах Предварительного просмотра. В Mac OS выберите «After effects» > «Установки» > «Предварительный просмотр». В Windows выберите «Редактирование» > «Установки» > «Предварительный просмотр».

Дополнительные сведения о поддерживаемых аппаратных средствах OpenGL см. в разделе Возможности графического процессора (CUDA, OpenGL).

Более новые драйверы видеокарты могут улучшить ее возможности OpenGL. См. раздел Обновление драйвера видеокарты ниже.

4. Отключите OpenGL, чтобы определить, связана ли проблема с ним.

Чтобы отключить предварительный просмотр OpenGL:

  1. Выберите «After effects» > «Установки» > «Предварительный просмотр» (Mac OS) или «Редактирование» > «Установки» > «Предварительный просмотр» (Windows).
  2. Отмените выбор параметра «Включить OpenGL».

Примечание. OpenGL не поддерживает некоторые функции в After Effects и вид композиции может измениться в зависимости от предварительного просмотра с помощью OpenGL или предварительного просмотра с помощью программного рендеринга. Список поддерживаемых OpenGL функций можно увидеть в главе Рендеринг с помощью OpenGL в разделе «Рендеринг и экспорт» справки After Effects.

5. Удалите внешний модуль OpenGL из папки внешних модулей After Effects.

Чтобы определить, является ли OpenGL причиной проблемы, удалите внешний модуль OpenGL и перезапустите After Effects.

Чтобы удалить модуль OpenGL:

  1. Выйти из After Effects.
  2. Mac OS: Перетащите файл AE_OpenGL.plugin из папки Applications/Adobe After Effects CS4/Plug-ins/Extensions на рабочий стол.

    Windows: Перетащите файл AE_OpenGL.AEX file из папки C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Plug-ins\Extensions на рабочий стол.
  3. Перезапустите After Effects.

Если проблема возникает снова, то она не связана с OpenGL. Перетащите внешний модуль OpenGL обратно в исходное место. Если проблема больше не возникает, то причиной был OpenGL. См. раздел Обновление драйвера видеокарты ниже.

6. Обновление драйвера видеокарты.

Многие проблемы или конфликты с OpenGL решаются путем обновления драйвера видеокарты. Многие производители видеокарт часто обновляют свои программные драйверы. Если Вы давно не обновляли драйвер видеокарты, обратитесь к производителю видеокарты за обновленным драйвером или загрузите его с веб-сайта производителя.

7. Перезапустите After Effects и протестируйте ситуацию, в которой произошел сбой. (только Windows)

После сбоя, который вызвала проблема OpenGL в Windows, After Effects CS4 может автоматически отключить параметр «Не допускать фрагментации адресного пространства DLL». Эта настройка позволяет After Effects получить доступ к большему объему оперативной памяти, но может быть несовместима с некоторыми драйверами OpenGL.

Можно включить или отключить параметр «Не допускать фрагментации адресного пространства DLL», для чего нужно перейти в «Редактировать» > «Установки» > «Память и кэш».

Оставьте этот параметр включенным, если вы не уверены в том, с чем связан сбой - с OpenGL или с памятью. Если вы отключите параметр из-за проблемы с OpenGL, а позже обновите драйверы видеокарты, включите параметр снова. Затем протестируйте проблему опять.

8. Оптимизация параметра «Память текстур».

Ошибки OpenGL или сбои могут возникать, если After Effects пытается использовать слишком много памяти видеотекстур. Память текстур - объем оперативной памяти видеокарты (видеопамяти).

Установите параметр «Память текстур» в After Effects:

  1. Умножьте объем установленной видеопамяти на 80% для вычисления оптимального значения параметра «Память текстур».
  2. В After Effects выберите > After Effects > «Установки» (Mac OS) или «Редактирование» > «Установки» > «Предварительный просмотр» (Windows).
  3. Нажмите кнопку «Сведения об OpenGL».
  4. Введите значение, вычисленное в шаге 1, и нажмите кнопку «OK».

Идеальное значение величины для памяти текстур - 80% видеопамяти вашей видеокарты. (Если используется несколько видеокарт, вычислите 80% видеопамяти той видеокарты, которая определяется в диалоговом окне «Сведения об OpenGL».) Если параметр «Память текстур» в After Effects имеет значение 80% объема видеопамяти, то, возможно, недостаточно видеопамяти остается для обработки интерфейса пользователя или выполнения других задач. (Например, весь экран может стать белым). Если значение установлено ниже 80%, то предварительный просмотр с помощью OpenGL в After Effects может занять больше времени.

См. справку Mac OS или Windows для получения информации об определении объема видеопамяти видеокарты.

9. Очистите кэши изображений и видеопамять.

Если артефакты или «мусор» (блоки ненужных пикселов) отображаются в After Effects в окне композиции, видеопамять (VRAM) может быть заполнена, фрагментирована или повреждена. Очистите кэши изображений и видеопамять, чтобы очистить VRAM, и дайте After Effects перестроить просмотр композиции.

Чтобы очистить кэши изображений, выберите «Редактирование» > «Очистка» > «Кэши изображений».

Чтобы очистить видеопамять , выберите команду «Редактирование» > «Очистка» > «Память видеоданных».

Примечание. Некоторые экранные заставки, которые используют OpenGL (или Direct3D в Windows) могут повредить видеопамять, если они активируются во время работы After Effects. Смените или отключите экранную заставку, если у вас часто возникают проблемы с повреждением изображений в окне композиции после отключении экранной заставки.

10. Смените цветопередачу для видеокарты на Высокая (32-разрядная) (Windows) или Миллионы (Mac OS).

См. справки Mac OS или Windows для получения дополнительных сведений о смене видеокарты или параметров экрана.

11. Отключение расширенных функций видеокарты. (только Windows)

Большинство драйверов видеокарты включают утилиты, позволяющих обращаться к расширенным функциям карты. В частности, сглаживание и функции 16-разрядного режима могут конфликтовать с OpenGL и стать причиной сбоя After Effects. Установите дополнительные функции карты в их умолчания, а затем отключите сглаживание и функции 16-разрядного режима.

Если вы используете несколько мониторов с картой Nvidia, установите параметр Multimonitor в значение «Совместимый».

См. документацию для видеокарты или веб-сайт производителя, где приведены соответствующие инструкции о том, как получить доступ к расширенным функциям.

12. Используйте один монитор.

Если вы используете несколько мониторов и испытываете проблемы с использованием OpenGL в After Effects, попробуйте выполнить следующие действия:

  • Если вы переместили окно приложения After Effects или панель композиции на дополнительный монитор, переместите на основной монитор.
  • Отсоедините все, оставив только один монитор.
  • Если используется несколько видеокарт, отсоедините все, кроме одной. Для получения наилучших результатов с OpenGL, воспользуйтесь видеокартой с несколькимим выходами.

13. Поместите скрипт Reduce OpenGL Texture Size в папку скриптов запуска.

Reduce OpenGL Texture Size уменьшает количество памяти текстур, используемой After Effects, и обеспечивает лучшую совместимость с более старыми видеокартами.

Чтобы поместить скрипт Reduce OpenGL Texture Size в папку скриптов запуска:

  1. Перейдите в папку скриптов After Effects.

    В Mac OS: Applications/Adobe After Effects CS4/Scripts.

    В Windows: C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Scripts.
  2. Переместите файл Reduce OpenGL Texture Size.jsx из папки (support) в папку Startup.

Более новая видеокарта может улучшить возможности OpenGL компьютера и сделать скрипт ненужным. После установки новой карты и ее драйверов, переместите скрипт Reduce OpenGL Texture Size обратно в папку (support). Затем сбросьте установки After Effects.

14. Сбросьте установки After Effects.

Повторное создание файла параметров After Effects может помочь в устранении неполадок, которые могли вызывать поврежденные параметры OpenGL.

Чтобы воссоздать файл параметров After Effects, перезапустите After Effects. Удерживайте клавиши «Ctrl» + «Alt» + «Shift» (Windows) или «Command» + «Option» + «Shift» (Mac OS) при запуске приложения.

15. Свяжитесь со службой технической поддержки Adobe.

Если ни один из вышеупомянутых шагов не устранил ошибку, которая возникает на при использовании After Effects, вам следует связаться со службой технической поддержки Adobe. Информацию о поддержке можно найти в центре поддержки Adobe.

 

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет