На панелях разработки в рабочем пространстве Animate находятся элементы, предназначенные для управления созданием и публикацией содержимого. Их расположение можно изменить в соответствии со своими предпочтениями. Кроме того, любую панель можно открепить, изменить ее размер и расположить в любом месте экрана для быстрого доступа. Всплывающие меню Animate также позволяют вам закрепить панель в любом месте на экране. Если закрепить панель, она не будет двигаться при случайном перетаскивании во время работы. 

Панели Animate с возможностью закрепления
Панели Animate с возможностью закрепления

Сведения об инспекторе свойств

Инспектор свойств предоставляет быстрый доступ к большинству наиболее часто используемых атрибутов выделенного фрагмента в рабочей области или на временной шкале. Можно изменять атрибуты объекта или документа, не открывая меню или панели, также управляющие этими атрибутами.

В зависимости от того, какой объект выделен, инспектор свойств отображает информацию и настройки для текущего документа, текста, символа, фигуры, растрового изображения, видео, группы, кадра или инструмента. Если выделены объектов двух и более типов, то инспектор свойств отображает общее число выделенных объектов.

Чтобы отобразить инспектор свойств, выберите Окно > Свойства либо нажмите сочетание клавиш Control + F3 (Windows) или Command + F3 (Macintosh).

В выпуске Animate 2020 в инспектор свойств добавлены четыре вкладки: «Инструменты», «Объект», «Кадр» и «Документ».  Каждая вкладка соответствует свойствам для текущего выбора. 

Инструмент — указывает инструмент, который выбран в настоящий момент. Если инструмент не имеет действительного инспектора свойств, отображается инспектор свойств документа, а вкладка инспектора свойств инструмента отключена. На этой вкладке указаны свойства выбранного в настоящий момент инструмента.

Объект — указывает объект, который в настоящий момент выбран в рабочей области. Если объект не выбран, эта вкладка отключена. На этой вкладке указаны свойства выбранного в настоящий момент объекта.

Кадр — указывает кадр, который в настоящий момент выбран на временной шкале. Если кадр не выбран, эта вкладка отключена. На этой вкладке указаны свойства выбранного в настоящий момент кадра.

Документ — указывает документ, над которым вы работаете в настоящий момент. На этой вкладке перечислены свойства открытого в настоящий момент документа.

Инспектор свойств документа
Инспектор свойств документа
Инспектор свойств инструмента
Инспектор свойств инструмента
Инспектор свойств кадра
Инспектор свойств кадра
Инспектор свойств объекта
Инспектор свойств объекта

Дополнительные свойства панели свойств

Область захвата
Перетаскиваемые разделы

Перетаскиваемые разделы

Разделы инспектора свойств теперь можно перетаскивать и перегруппировывать. Область захвата отображается при наведении курсора мыши на перетаскиваемый раздел.

Раздел быстрых действий
Раздел быстрых действий

Панель инструментов быстрых действий

На панели свойств появился новый раздел быстрых действий и обновленные разделы заголовков, что позволяет просматривать режимы и соответствующие функциональные возможности и быстро получать к ним доступ.

Обновленный раздел заголовка
Обновленный раздел заголовка для растрового изображения
Обновленные настройки фильтра
Обновленные настройки фильтра

Обновленные настройки фильтра

Раздел фильтра обновлен, и теперь в нем проще применять комбинации фильтров. Кроме того, можно изменить порядок фильтров, перетащив один фильтр выше или ниже других фильтров.  

Цвет и стиль
Цвет и стиль

Обновленный раздел «Заливка и обводка»

  • Раздел «Заливка и обводка» переименован в «Цвет и стиль». 
  • Параметр «Альфа-канал» для цвета заливки и обводки добавлен вверху списка для удобного доступа.
  • Для обеспечения удобства и простоты редко используемые параметры в настройках обводки перенесены в меню «Эллипс» для параметров «Профиль стиля» и «Профиль ширины». Щелкните значок «Эллипс», чтобы выбрать эти параметры.
  • Параметры «Концы» и «Стыки» располагаются вверху списка.
  • Параметры «Обводка» и (или) «Заливка» отображаются в соответствии с выделенной частью объекта. 

Параметр «Удалить анимацию»

Удаление анимации
Удаление анимации

В разделе «Анимация» инспектора свойств теперь можно удалять анимацию.

Параметр «По содержимому» 

Параметр «По содержимому»
Параметр «По содержимому»

К параметру «По содержимому» теперь можно получить доступ одним нажатием в разделе настроек документа.

Обновленный инструмент «Камера» в инспекторе свойств

Обновленные параметры камеры
Обновленные параметры камеры

Теперь для камеры доступны все цветовые эффекты и фильтры

Обновленные свойства инструментов «Многоугольник», «Прямоугольник», «Овал», «Текст» и «Волшебная палочка»

Панель инспектора свойств обновлена для обеспечения доступа к инструментам «Многоугольник», «Прямоугольник», «Овал», «Текст» и «Волшебная палочка» и удобства пользователя.

Многоугольник
Многоугольник
Статический текст
Статический текст

Сведения о панели «Библиотека»

Панель Библиотека (Окно > Библиотека) позволяет хранить и упорядочивать символы, созданные в Animate. Также можно хранить импортированные файлы, включая растровую графику, звуковые файлы и видеоклипы. Панель Библиотека позволяет вам упорядочивать элементы библиотеки в папки. Также она позволяет смотреть, как часто элемент используется в документе и сортировать элементы по имени, типу и дате, а также использовать счет или идентификатор связей ActionScript®. Например, при импорте анимированного GIF-изображения в корневой папке будет создана папка с именем GIF, куда и будет помещен файл. На панели Библиотека можно также выполнять поиск, вводя в поле поиска имя символа или связи. Также можно задавать свойства сразу нескольким объектам (за редкими исключениями).

Панель «Библиотека» с выбранным аудиоклипом
Панель «Библиотека» с выбранным аудиоклипом

О панели «Действия»

Панель «Действия» позволяет создавать и редактировать программный код ActionScript для объекта или кадра. Она становится активной при выделении кадра, кнопки или фрагмента ролика. В зависимости от текущего выделенного элемента заголовок панели меняется на «Действия — кнопка», «Действия — фрагмент ролика» или «Действия — кадр».

Панель «Действия» отображает действие stop() в кадре.
Панель «Действия» отображает действие stop() в кадре.

Чтобы отобразить панель Действия, выберите меню Окно > Действия или нажмите клавишу F9. Дополнительные сведения о панели «Действия» см. в разделе Обзор панели «Действия»

Использование панели «Обзор ролика» (не поддерживается в Animate)

Панель «Обзор ролика» позволяет просматривать и упорядочивать содержимое документа, а также выбирать его элементы для изменения. Она отображает список используемых в настоящее время элементов в виде иерархического дерева с возможностью навигации.

Панель «Обзор ролика» применяется для выполнения следующих действий.

  • Фильтрации категорий элементов, отображающихся на панели «Обзор ролика».

  • Отображения выделенных категорий в виде монтажных кадров, определений символов либо того и другого.

  • Развертывания и свертывания дерева навигации.

  • Поиска элементов документа по имени.

  • Знакомство со структурой документа Animate, созданного другим разработчиком.

  • Поиска всех экземпляров конкретного символа или действия.

  • Печати списка отображения на панели «Обзор ролика».

Панель «Обзор ролика» содержит меню панели и контекстное меню с параметрами выполнения операций для выделенных элементов и изменения режима отображения. Галочка с треугольником под ней на панели «Обзор ролика» указывает меню «Панель».

Примечание.

Панель «Обзор ролика» реализует несколько иные возможности при работе с экранами.

Просмотр панели «Обзор ролика»

  1. Выберите меню Окно > Обзор ролика.

Фильтрация категорий элементов, отображаемых на панели «Обзор ролика»

  • Чтобы отображался текст, символы, код ActionScript, импортированные файлы, кадры или слои, нажмите одну или несколько кнопок фильтрации справа от параметра «Показать». Чтобы выбрать, какие элементы должны отображаться, нажмите кнопку «Настроить». Чтобы просмотреть эти элементы, в области Показать диалогового окна Настройки обзора ролика выберите параметры отображения. 

  • Чтобы отображались все элементы в монтажном кадре, выберите в меню панели «Обзор ролика» пункт Показать элементы ролика.

  • Чтобы отображалась информация о символах, выберите в меню панели «Обзор ролика» пункт «Показать определения символов».

Примечание.

Параметры Элементы ролика и Определения символов могут быть активными одновременно.

Поиск элемента с помощью поля «Найти»

  1. В поле «Найти» введите имя элемента, шрифта, строку кода ActionScript или номер кадра. Функция «Найти» выполняет поиск по всем элементам, отображенным на панели Обзор ролика.

Выделение элемента на панели «Обзор ролика»

  1. Нажмите элемент в дереве навигации. Удерживайте при этом нажатой клавишу «Shift», чтобы выделить нескольких элементов.

    В нижней части панели «Обзор ролика» отображается полный маршрут к выделенному элементу. Выделение монтажного кадра на панели «Обзор ролика» приводит к отображению первого кадра этого монтажного кадра в рабочей области. Выделение элемента приводит к его выделению в рабочей области, если слой, содержащий данный элемент, не заблокирован.

Использование команд панели меню и контекстного меню панели «Обзор ролика»

  1. Выполните одно из следующих действий.
    • Чтобы открыть меню панели, щелкните элемент управления меню «Панель» на панели «Обзор ролика».

    • Чтобы вызвать контекстное меню, щелкните элемент в дереве навигации правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу «Control» (Macintosh).

  2. Выберите в меню один из следующих параметров.

    Перейти к расположению

    Переходит к выделенному слою, монтажному кадру или кадру в документе.

    Перейти к определению символа

    Переходит к определению символа, который выделен в области «Элементы ролика» панели «Обзор ролика». Определение символа содержит список всех файлов, связанных с этим символом. (Для этого должен быть выбран параметр «Показать определения символов». Его определение см. в этом списке.)

    Выделить экземпляры символа

    Переходит к монтажному кадру, содержащему экземпляры символа, выделенного в области «Определения символов» панели «Обзор ролика». (Для этого должен быть выбран параметр «Показать элементы ролика».)

    Отображение в библиотеке

    Подсвечивает выделенный символ в библиотеке документа. (Если панель «Библиотека» не отображается на экране, Animate откроет ее.)

    Переименовать

    Позволяет ввести новое имя для выделенного элемента.

    Редактировать на месте

    Позволяет редактировать выделенный символ в рабочей области.

    Редактировать в новом окне

    Позволяет редактировать выделенный символ в новом окне.

    Показать элементы ролика

    Отображает элементы документа, упорядоченные в монтажные кадры.

    Показать определения символов

    Отображает все элементы, связанные с символом.

    Копировать весь текст в буфер обмена

    Копирует выделенный текст в буфер обмена. Для проверки правописания или редактирования вставьте этот текст во внешний текстовый редактор.

    Вырезать, Копировать, Вставить и Очистить

    Выполняет перечисленные операции с выделенным элементом. Изменение элемента в списке отображения приводит к изменению соответствующего элемента в документе.

    Раскрыть ветвь

    Развертывает дерево навигации для выделенного элемента.

    Свернуть ветвь

    Сворачивает дерево навигации для выделенного элемента.

    Свернуть остальные

    Сворачивает все ветви дерева навигации, кроме выделенного элемента.

    Печать

    Печатает иерархический список, отображаемый на панели «Обзор ролика».

Использование компонентов и панели компонентов Animate

Под компонентом в Animate подразумевается упакованный модуль многоразового использования, добавляющий определенную возможность в документ Animate. Компоненты могут включать графику и код. Таким образом, они представляют собой встроенные функции, которые можно с легкостью использовать в проектах Animate. Например, компонентом может быть кнопка-переключатель, диалоговое окно или полоса предварительной загрузки. Это может быть что-то совсем не относящееся к графике, например таймер, служебная программа подключения к серверу или пользовательский анализатор XML.

Если у вас мало опыта в использовании ActionScript, то в документ можно добавлять компоненты, настроить их параметры в инспекторе свойств или компонентов. Для обработки их событий используйте панель «Поведения». Например, можно назначить поведение «Перейти на веб-страницу» компоненту «Кнопка». Кнопка может открывать URL в веб-обозревателе при нажатии, не используя код ActionScript.

Если же вы программист и хотите создавать более функциональные приложения, можно создавать компоненты в динамическом режиме. Используйте ActionScript для задания свойств и вызывайте методы во время выполнения, а также используйте модель прослушивателя для обработки событий.

Вставка компонента с помощью панели «Компонент»

При добавлении компонента в документ проигрыватель Animate импортирует его в виде фрагмента ролика на панель «Библиотека». Также можно перетащить компонента с панели «Компоненты» прямо на панель «Библиотека», а затем добавить его экземпляр в рабочую область. В любом случае сначала компонент необходимо добавить в библиотеку, и только после этого можно использовать элементы его класса.

  1. Выберите меню Окно > Компонент.

  2. Выберите экземпляр компонента на панели «Компонента», перетащите его на рабочую область или на панель «Библиотека». После добавления компонента в библиотеку в рабочую область можно перетащить несколько экземпляров.
  3. Настройте компонент в соответствии со своими потребностями с помощью инспектора свойств или компонентов. Дополнительные сведения о параметрах, используемых компонентом, см. в документации по каждому компоненту для версии ActionScript, используемой в документе Animate.

Использование панели «Параметры компонентов»

Дизайнеры Animate свои внешние компоненты в Animate и использовать их для создания анимации. Чтобы сделать этот процесс проще, Animate предоставляет раздел «Параметры компонента» в виде панели. Данная функция позволяет изменять размер или перемещать панель в среде рабочей области Animate. Кроме того, можно закрепить панель на одном месте, щелкнув значок гамбургера в правом верхнем углу панели. Выберите пункт «Блокировать» в меню.

Вы можете открыть эту панель с помощью кнопки Показать параметры в инспекторе свойств, или выбрав Окно > Параметры компонента. Добавлять значения параметров можно в диалоговом окне. 

Кнопка «Показать параметры»
Кнопка «Показать параметры»
Панель «Параметры компонента»
Панель «Параметры компонента»

Кроме того, разработчики пользовательских компонентов HTML5 могут использовать пользовательский интерфейс на основе HTML/CSS для параметров.

Сведения о панели «Веб-службы»

На панели «Веб-службы» можно просмотреть или обновить список веб-служб, а также добавить или удалить их (не поддерживается в Animate). Выберите «Окно» > «Другие панели» > «Веб-службы». После добавления на панель «Веб-службы» веб-служба становится доступной любому создаваемому приложению.

Панель «Веб-службы» позволяет обновить все веб-службы сразу, если нажать кнопку Обновить веб-службы. Если применяется не рабочая область, а специально написанный код ActionScript, то панель «Веб-службы» может использоваться для управления веб-службами.