Можно задать установки для основных операций приложения, операций редактирования, кодирования и компиляции, параметров синхронизации, а также для функций рисования и ввода текста.

Категория «Общие» в диалоговом окне «Настройки».

Задание настроек

  1. Выберите меню «Правка» > «Настройки» (Windows) или «Animate» > «Настройки» (Macintosh).

  2. В списке «Категория» выберите соответствующую категорию и задайте нужные параметры.

Задание настроек «Общие»

При запуске

Укажите, какой документ откроется при запуске приложения.

Отменить на уровне документа/Отменить на уровне объекта

В режиме отмены на уровне документа сохраняется полный список действий в одном документе Animate. В режиме отмены на уровне объекта для каждого объекта в документе ведется отдельный список действий. Отмена на уровне документа позволяет отменять действия для одного объекта, не затрагивая другие объекты, которые были изменены позже целевого объекта.

 

Уровни отмены

Чтобы задать число уровней отмены и повторного выполнения, введите значение от 2 до 300. Уровни отмены занимают память. Чем больше число уровней отмены, тем больше нужно памяти. Значение по умолчанию равно 100.

Автовосстановление

При включении (настройка по умолчанию), эта функция сохраняет копию каждого открытого файла через указанные интервалы времени в той же папке, что и оригинал. Если файл еще не сохранен, Animate сохраняет копии в папке Temp. Имена файлов — это имена оригинальных файлов с добавленным в начало префиксом RECOVER_. Если Animate неожиданно завершает работу, то при последующем запуске появляется диалоговое окно, в котором можно открыть файл автоматического восстановления. При обычном завершении работы с Animate файлы автоматического восстановления удаляются.

Начиная с выпуска Animate CC 2015 приложение Animate не создает ненужные файлы автоматического восстановления. Файл автовосстановления создается, только если документ изменен с момента создания последнего файла автовосстановления. Файл автоматического восстановления удаляется только после успешного завершения операции сохранения. Чтобы предотвратить создание постоянного цикла автоматических восстановлений в случае установки малого промежутка времени между повторами этой операции, в каждом интервале автоматического восстановления создается снимок всех файлов, измененных с момента создания последнего автоматического восстановления. Следующий таймер автоматического восстановления запускается только после завершения сохранения предыдущего снимка. 

Интерфейс пользователя

Выберите предпочитаемый стиль интерфейса пользователя: темный, светлый или любой промежуточный вариант. Чтобы применить затенение к элемента интерфейса, выберите параметр «Включить затенение».

Рабочее пространство

Чтобы панели в режиме значков автоматически складывались при щелчке мышью за границами этих панелей, выберите «Автоматическое свертывание панелей значков». Чтобы при переходе в меню «Управление» > «Тест» открывалось отдельное окно, выберите параметр «Открывать документы Animate и сценария в отдельном окне». По умолчанию тестовый ролик открывается в отдельном окне.

Цвет подсветки

Чтобы использовался цвет обводки текущего слоя, выберите цвет из панели или установите параметр «Использовать цвет слоя».

Задание настроек «Синхр. настройки»

На вкладке «Синхр. настройки» можно выбрать настройки синхронизации Animate с учетной записью и библиотеками Creatve Cloud.

Вкладка «Синхр. настройки» в диалоговом окне «Настройки»
Вкладка «Синхр. настройки» в диалоговом окне «Настройки»

Adobe ID

Отображает идентификатор Adobe ID, используемый при входе в учетную запись Creative Cloud, а также дату и времени последней синхронизации с учетной записью Creative Cloud.

  • Для просмотра профиля и библиотеки Creative Cloud или для входа в систему с использованием другого Adobe ID нажмите кнопку «Управление учетной записью».
  • Для синхронизации настроек нажмите кнопку «Синхронизировать настройки».

Параметры синхронизации

Отображает варианты синхронизации Animate и учетной записи Creative Cloud. Можно синхронизировать установки приложений, рабочие области, настройки документов по умолчанию, сочетания клавиш, настройки сетки, направляющих и привязки, настройки таблиц спрайтов, настраиваемые профили ширины и пользовательские кисти.

  • Синхронизация. Задайте параметры синхронизации путем выбора варианта «Все» (синхронизация всех настроек), «Другое» (синхронизация настроек, выбранных из вариантов ниже) или «Отключено» (отключение синхронизации).
  • Для синхронизации настроек с настройками Creative Cloud нажмите кнопку «Синхронизировать настройки».

Дополнительные сведения о синхронизации установок с Creative Cloud и между несколькими компьютерами см. в разделе Синхронизация установок Animate с Creative Cloud

Дополнительные сведения о работе с библиотеками Creative Cloud см. в разделе Библиотеки Creative Cloud.

Задание настроек редактора кода

На вкладке «Редактор кода» можно выбрать вид кода в рабочей среде Animate.

Вкладка «Редактор кода» в диалоговом окне «Настройки»
Вкладка «Редактор кода» в диалоговом окне «Настройки»

В разделе Параметры редактирования можно изменить параметры по умолчанию для следующих элементов.

  • Шрифт. Выберите шрифт и его размер.
  • Стиль. Установите обычное начертание, курсив, полужирный шрифт или полужирный курсив.
  • Изменить цветовое оформление текста. Нажав на эту кнопку, вы можете задать цвет шрифта для заднего и основного фонов, ключевых слов, комментариев, идентификаторов и строк.
  • Автоматическое добавление скобки в коде. Включено по умолчанию. Все скобки в коде закрываются по умолчанию.
  • Автоматические отступы. Включено по умолчанию. Отключите этот параметр, если вам не требуется добавлять отступы при написании кода.
  • Подсказки кода. Включено по умолчанию. Снимите этот флажок, если вы не хотите видеть подсказки в процессе набора кода.
  • Файл кэша. Определите максимально допустимое количество файлов кэша. По умолчанию задано 800.
  • Размер шага табуляции. По умолчанию размер шага табуляции равен 4. Если вы хотите изменить его, укажите другое значение.

В разделе Форматирование кода можно задать следующие параметры и посмотреть отображение изменений в коде на панели предварительного просмотра.

  • Язык сценария. Можно выбрать язык сценария по умолчанию, например ActionScript или JavaScript. При выборе того или иного варианта появится пример кода.
  • Стиль скобки. Выберите предпочитаемый стиль скобки (в той же строке, что и операторы управления, в отдельной строке или только закрывающая скобка в отдельной строке). 
  • Разрывать цепные методы. При выборе этого параметра строки кода будут отображаться с учетом логических переносов.
  • Сохранить отступ массива. При выборе этого параметра в массивах будут сохраняться логические отступы.
  • Сохранение пробела после ключевых слов. Выбрано по умолчанию. Если вы не хотите, чтобы после каждого ключевого слова добавлялся пробел, измените значение для этого параметра.

Задание настроек «Файлы сценариев»

В разделе «Файлы сценариев» можно задать параметры импорта для файлов сценария.

Открыть. Выберите кодировку UTF-8 для открытия и импорта с помощью кодировки Юникода или выберите «Кодировка по умолчанию» для открытия и импорта с помощью кодировки, которую использует система.

Повторно загружать измененные файлы. Определяет действие, которое выполняется при изменении, перемещении или удалении файла сценария. Выберите «Всегда», «Никогда» или «Запрос».

  • «Всегда»: предупреждение не выводится, и файл автоматически перезагружается.
  • «Никогда»: предупреждение не выводится, и файл остается в текущем состоянии.
  • «Запрос» (по умолчанию): выводится предупреждение, и появляется возможность определить, нужно ли перезагрузить файл.

При создании приложения с внешними файлами сценариев эта установка помогает избежать замены сценария, который был изменен другим разработчиком после открытия приложения, или избежать публикации приложения со старыми версиями сценариев. Предупреждение позволяет автоматически закрыть сценарий и загрузить новую, измененную версию.

«Редактор классов». Выберите редактор для работы с классами. Доступны параметры Animate, Flash Builder и «Спрашивать».

Задание настроек «Компилятор»

На вкладке «Компилятор» в диалоговом окне «Настройки» можно выбрать следующие параметры компилятора для выбранного языка. Вы можете выбрать путь к папке либо SWC-файлу или указать новый путь.

  • Путь к комплекту средств разработки. Путь к папке, содержащей папки bin, frameworks, lib и другие.
  • Путь к источнику. Путь к папкам, содержащим файлы классов ActionScript.
  • Путь к библиотеке. Путь к SWC-файлам или папкам, содержащим SWC-файлы.
  • Путь к внешней библиотеке. Путь к SWC-файлам, используемым в качестве общих библиотек при исполнении.

Задание настроек «Текст»

На вкладке «Текст» можно задать следующие установки для текста.

  • Шрифт подстановки по умолчанию
  • Стиль
  • Показывать имена шрифтов на выбранном языке
  • Включить просмотр шрифтов
  • Размер просматриваемого шрифта

Задание настроек «Рисунок»

Инструмент «Перо». Позволяет задать свойства инструмента «Перо». Выберите «Просмотр пера», чтобы отображалась линия, проведенная из последней точки, в которой щелкали мышью, к текущему положению указателя. Выберите «Показывать сплошные точки», чтобы контрольные точки отображались в виде маленьких заполненных квадратов, а не пустых квадратов. Выберите «Показывать точные курсоры», чтобы курсор отображался в виде перекрестия, а не в виде пера, когда выбран инструмент «Перо». При выборе этого параметра место нажатия показывается более точно.

Инструмент «IK Кость». Для инструмента «Кость» по умолчанию выбран параметр «Установить точку преобразования автоматически».

Соединять линии. Определяет, насколько близко должен находиться конец рисуемой линии от отрезка существующей линии, прежде чем конечная точка будет привязана к ближайшей точке другой линии. Этот параметр также управляет распознаванием горизонтальных и вертикальных линий, то есть тем, насколько близко к горизонтали или вертикали должна быть проведена линия, чтобы приложение Animate сделало ее точно горизонтальной или вертикальной. Когда включен режим «Привязка к объектам», этот параметр определяет, насколько близко должны располагаться объекты, чтобы произошла их привязка друг к другу.

Сглаживать кривые. Указывает степень смягчения, применяемого к кривым линиям, проводимым с использованием инструмента «Карандаш», когда выбран режим рисования «Выпрямление» или «Смягчение». (Форму более гладких обводок проще изменять, тогда как более грубые обводки точнее соответствуют изначально нанесенными линиям.)

Примечание. Чтобы еще более смягчить существующие кривые сегменты, используйте команду «Модификация» > «Фигура» > «Смягчение» или «Модификация» > «Фигура» > «Оптимизировать».

Распознавать прямые. Определяет, насколько прямо должен быть проведен отрезок линии с помощью инструмент «Карандаш», прежде чем Animate распознает линию как прямую и сделает ее фактически прямой. Если во время рисования режим «Распознавать прямые» отключен, то линии можно выпрямить позднее, выделив один или несколько отрезков линии и выбрав команду «Модификация» > «Фигура» > «Выпрямление».

Распознавать фигуры. Задает, насколько точно должны быть нарисованы круги, овалы, квадраты, прямоугольники и 90- и 180-градусные дуги, чтобы программа распознала и точно перерисовала их в виде реальных геометричесих фигур. Параметры «Выкл.», «Точно», «Обычный» и «Приемлемо». В режиме «Точно» требуется, чтобы фигура была нарисована очень близко к выпрямленной. В режиме «Приемлемо» фигура может быть довольно неточной, а Animate перерисует ее. Если во время рисования режим «Распознавать фигуры» отключен, то линии можно выпрямить позднее, выделив одну или несколько фигур (например, соединенные отрезки линии) и выбрав команду «Модификация» > «Фигура» > «Выпрямление».

«Точность щелчка». Указывает, насколько близко к элементу должен находиться указатель, чтобы приложение Animate распознало элемент.

Восстановление всех настроек по умолчанию

  1. В диалоговом окне «Настройки» выберите «Сброс и выбор значений по умолчанию» или нажмите и удерживайте клавиши Control + Alt + Shift (Windows) или Command + Option + Shift (Mac OS) во время запуска Animate.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет