Версии: Illustrator CS2 до CS5

Темы

Программа Adobe Illustrator оптимизирована для печати PostScript. По сути, большинство расширенных возможностей Illustrator можно описать только языком для описания страниц PostScript. Для описания принтеров, не относящихся к PostScript (например, Hewlett-Packard LaserJets, Canon BubbleJets или Epson Stylus) используются языки, не являющиеся полноценными языками программирования (например, PCL или QuickDraw), с их помощью невозможно описать все предметы и атрибуты в объекте Illustrator. Большинству принтеров, не относящихся к PostScript, необходима информация об отображении, ресурсы компьютера и специализированные драйверы принтера для передачи данных печати на принтер.

При печати на принтере, не относящемся к PostScript, в Illustrator объекты иногда печатаются неправильно или не печатаются вовсе. Поведение может отличаться в зависимости от принтера и его версии программного обеспечения. Проблемы с печатью на принтерах, не относящихся к PostScript, могут проявляться различным образом, в том числе:

  • Текст или другие объекты полностью или частично отсутствуют на странице.
  • Возникает системная ошибка или зависание.

Однако с помощью шагов по устранению неполадок ниже вам удастся распечатать документы Illustrator на принтере, не относящемся к PostScript. В некоторых случаях, например, на старых принтерах, драйверы которых больше не обновляются, шаги по устранению неполадок не помогут решить проблему и потребуется использовать обходное решение. Есть несколько обходных решений — они перечислены в конце этого документа.

Действия по устранению неполадок

С помощью шагов в этом разделе можно выявить наиболее распространенные причины проблем при печати, которые происходят в Illustrator. Перед тем как приступить к этим шагам по устранению неполадок, убедитесь в том, что причиной проблемы не является поврежденный файл Illustrator: откройте новый файл и попытайтесь воспроизвести неполадку. Если проблема не возникает в новом файле, вероятно, поврежден файл Illustrator. Более подробная информация об устранении неполадок с поврежденными файлами Illustrator приведена в документе 320318 — «Устранение неполадок с поврежденными файлами (Illustrator CS2 и более поздние версии)».

Всегда перезагружайте компьютер после возникновения системной ошибки, чтобы обновить памяти компьютера. Если вы продолжите работу, это может лишь усугубить проблему.

1. Обновите или переустановите драйвер принтера.

Обратитесь к производителю принтера, чтобы получить новейшую версию драйвера принтера. Если вы используете последнюю версию используемого драйвера принтера и проблема повторяется, удалите драйвер, переустановите его с оригинального диска.

2. Измените параметр растровой печати в Illustrator.

Если вы используете Illustrator для Windows, измените параметр «Печатать как растровое изображение» в диалоговом окне «Печать». То есть, если этот флажок установлен, снимите его, а если снят — установите.

Чтобы изменить параметр «Печатать как растровое изображение» выберите пункт меню «Файл» > «Печать» > «Дополнительно» и установите или снимите флажок «Печатать как растровое изображение».

Примечание. Если снять флажок «Печатать как растровое изображение» в диалоговом окне «Печать», в Illustrator будет использована информация о Graphic Display Interface (GDI), и драйвером принтера будут созданы векторные данные, которые выводятся на печать быстрее, однако на некоторых устройствах печать может выполняться некорректно.

3. Используйте драйвер Enhanced PCL.

Если вы работаете в Windows и ваш принтер поддерживает драйвер Enhanced PCL, установите его. Чтобы получить инструкции по установке драйвера Enhanced PCL для конкретного принтера, см. документацию к принтеру или обратитесь к производителю.

4. Переключитесь на стандартный драйвер видеокарты Windows.

Переключитесь на стандартный драйвер видеокарты Windows, запустив Windows в режиме VGA:

  • В Windows Vista и Windows 7: выберите пункт «Включение видеорежима с низким разрешением (640 x 480)» в списке вариантов загрузки и нажмите клавишу Enter. Если это меню не отображается или слишком быстро исчезает, выберите «Пуск» > «Панель управления», щелкните «Система и безопасность», затем нажмите «Система» и выберите «Дополнительные параметры системы». Перейдите на вкладку «Дополнительно» и выберите «Параметры» в области «Загрузка и восстановление» и увеличьте значение времени для параметра «Отображать список операционных систем».
  • В Windows XP: перезапустите Windows, при появлении запроса нажмите клавишу F8 и выберите в меню «Включить режим VGA». Если это меню не отображается или слишком быстро исчезает, выберите «Пуск» > «Параметры» > «Панель управления», дважды щелкните «Система» и выберите вкладку «Дополнительно». Выберите «Параметры» в области «Загрузка и восстановление» и увеличьте значение времени для параметра «Отображать список операционных систем».
  • В Windows 2000: перезапустите Windows, при появлении запроса нажмите клавишу F8 и выберите в меню «Режим VGA». Если это меню не отображается или слишком быстро исчезает, выберите «Пуск» > «Параметры» > «Панель управления», дважды щелкните «Система» и выберите вкладку «Дополнительно». Выберите «Загрузка и восстановление» и увеличьте значение времени для параметра «Отображать список операционных систем» (в секундах).

Если вам удается без проблем печатать изображения в Illustrator при использовании драйвера SuperVGA или VGA, это может означать, что драйвер для видеокарты поврежден, устарел или несовместим с драйвером принтера или с Illustrator. Для получения обновленного драйвера видеокарты обратитесь к производителю видеокарты.

5. Измените формат текста.

Если текст печатается неправильно или вообще не печатается, сохраните копию файла Illustrator, а затем выполните одно из следующих действий:

  • Примените к типу белую обводку в нулевой точке.
  • Преобразуйте текст в контуры. Для текста небольшого размера (24 точки или меньше), примените белую обводку в нулевой точке, чтобы предотвратить искажение ею символов, преобразованных в контуры.
  • В Illustrator растрируйте текст, выделив текст с помощью инструмента «Выделение» и затем используя команду «Объект» > «Растрировать».

6. Добавьте скрытый цветной объект.

Если цветной текст, который является единственным цветным объектом на странице, печатается в черно-белом формате, создайте скрытый объект того же цвета, что и текст:

  1. Выберите инструмент «Прямоугольник», а затем нарисуйте прямоугольник и закрасьте его тем же цветом, в который окрашен текст.
  2. Нарисуйте прямоугольник, достаточно большой, чтобы полностью закрыть прямоугольник, созданный на шаге 1. Закрасьте новый прямоугольник белым цветом и расположите его так, чтобы он закрывал исходный прямоугольник.

7. Вместо параметра «Слои печати» выберите «Все слои».

Выберите пункт меню «Файл» > «Печать», щелкните «Основные» и выберите «Все слои» в меню «Слои печати».

8. Задайте принтер PostScript в качестве принтера по умолчанию. (только Windows)

Задайте принтер PostScript в качестве принтера по умолчанию в Windows. Чтобы задать принтер по умолчанию, выберите «Пуск» > «Параметры» > «Принтеры» (Windows XP, Windows 2000) или «Пуск» > «Панель управления» > «Оборудование и звук» > Принтеры (Windows Vista). Щелкните требуемый принтер правой кнопкой мыши и выберите «Установить по умолчанию».

Примечание. Если у вас нет принтера PostScript, все же можно установить драйвер PostScript и выбрать принтер, для которого он используется, как принтер по умолчанию:

  1. Выберите «Пуск» > «Параметры» > «Принтеры» (Windows XP, Windows 2000) или «Пуск» > «Панель управления» > «Оборудование и звук» > Принтеры (Windows Vista) и затем выберите «Добавить принтер».
  2. Следуйте инструкциям на экране и убедитесь в том, что добавлен принтер PostScript (например Apple LaserWriter Pro), а не принтер, не относящийся к PostScript (например, HP DeskJet). Инструкции по использованию мастера добавления принтера приведены в документации Windows.

Чтобы распечатать документ на принтере, не являющемся принтером по умолчанию в Illustrator в Windows, выполните следующие действия:

  1. Выберите меню «Файл» > «Печать».
  2. Выберите принтер в меню «Принтер».
  3. Нажмите кнопку «Готово», чтобы закрыть диалоговое окно «Печать» и сохранить принтер или нажмите «Печать», чтобы выполнить печать.

9. Выполните печать на локальном принтере.

Если принтер подключен к компьютеру через сеть, подключите его непосредственно к компьютеру. Если печать на локальном принтере выполняется без ошибок, неполадка может быть связана с работой сети. В этом случае обратитесь за помощью к администратору сети.

Обходные решения

Если после выполнения шагов по устранению неполадок вам по-прежнему не удается распечатать документ Illustrator на принтере PostScript, можно использовать следующие обходные решения.

10. Сохраните файл в формате Portable Document Format (PDF).

Сохраните файл Illustrator как PDF, выбрав Acrobat PDF во всплывающем меню в диалоговом окне «Сохранить как», и затем откройте и распечатайте файл PDF в Adobe Reader.

11. Используйте другое приложение для выполнения печати.

Распечатайте файл Illustrator в другом приложении (например, Adobe Photoshop или Adobe InDesign).

Примечание. В других приложениях также могут возникать проблемы при печати на принтере PostScript. Можно сохранить или экспортировать файл Illustrator в другом формате (например, TIFF или EPS) или дальше пробовать другие приложения до получения приемлемых результатов печати.

12. Выполните печать на другом принтере.

Выполните печать на принтере PostScript или на другом принтере, не относящемся к PostScript.

Примечание. Некоторые производители принтеров, не относящихся к PostScript (например, Hewlett-Packard или Epson) предлагают оборудование или программное обеспечение PostScript для выпускаемых принтеров. Чтобы определить, доступно ли оборудование или программное обеспечение PostScript для вашего принтера, свяжитесь с производителем.

 

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет