Описание палитры «Структура»

На панели «Структура» в иерархическом виде отображаются объекты документа, имеющие разметку XML-тегами. Эти объекты называются элементами. Элементы на панели «Структура» можно перемещать, определяя их порядок и иерархию. Каждый элемент представлен в виде имени тега и значка, указывающего его тип.

vb_30
Structure pane

A. Triangle to expand or collapse elements B. Element C. Text snippet D. Attribute 
vb_30_IC
Structure pane

A. Triangle to expand or collapse elements B. Element C. Text snippet D. Attribute 

Кроме того, элементы могут представлять следующую информацию.

Синий ромб

Синий ромб на значке элемента означает, что элемент присоединен к объекту страницы. Отсутствие синего ромба указывает на то, что элемент не присоединен ни к одному из объектов страницы.

Подчеркивание

Если объект страницы, которому соответствует данный элемент, выделен, то имя тега подчеркнуто. Например, при выделении текста, размеченного тегом Title, на панели «Структура» элемент Title будет подчеркнут. Подчеркивание показывает, соответствуют ли выделенные объекты страницы элементам панели «Структура».

Текстовый сниппет

Справа от элемента могут отображаться первые 32 символа текста с тегами (текстовый сниппет). Такие сниппеты помогают идентифицировать объект страницы, которому соответствует элемент.

Точка и атрибут

Атрибуты предоставляют метаданные элемента. Если к элементу присоединены атрибуты, под ним отображается черная точка, а также имена и значения атрибутов.

Использование панели «Структура»

  • Чтобы открыть панель «Структура», выберите «Просмотр» > «Структура» > «Показать структуру».
  • Чтобы закрыть панель «Структура», выберите меню «Просмотр» > «Структура» > «Скрыть структуру» или нажмите кнопку разделителя.
  • Чтобы свернуть или развернуть элемент (и скрыть или отобразить его дочерние элементы), нажмите треугольный значок, расположенный рядом с элементом.
  • Чтобы изменить размер панели «Структура», перетащите разделитель.
  • Чтобы свернуть или развернуть элемент, а также все содержащиеся в нем дочерние элементы, нажмите значок треугольника рядом с ним, удерживая нажатой клавишу Ctrl (Windows) или Command (Mac OS).
  • Чтобы отобразить или скрыть текстовые сниппеты, выберите в меню панели «Структура» команду «Показать сниппеты» или «Скрыть сниппеты».

Значки панели «Структура»

На панели «Структура» отображаются следующие значки.

Значок

Имени

Использовать

 

Корневой элемент

Каждый документ имеет один корневой элемент, расположенный в верхней строке, который может быть переименован, но не может быть ни удален, ни перемещен.

 

Элемент материала

Представляет размеченные тегами материалы (один или несколько связанных фреймов).

 

Текстовый элемент

Представляет текст с тегами, расположенный внутри фрейма.

 

Графический элемент

Представляет размеченный фрейм, содержащий изображение. Каждый графический элемент имеет атрибут «href», который указывает путь или URL связанного файла.

 

Неразмещенный текстовый элемент

Текстовый элемент, который еще не связан с элементом страницы.

 

Неразмещенный графический элемент

Графический элемент, который еще не связан с элементом страницы.

 

Элемент таблицы

Представляет таблицу.

 

Элемент ячейки заголовка

Представляет ячейку, расположенную в заголовочной строке таблицы.

 

Элемент ячейки основной строки

Представляет ячейку, расположенную в основной строке таблицы.

 

Элемент ячейки нижнего колонтитула

Представляет ячейку, расположенную в нижней строке таблицы.

 

Пустой элемент

С этим элементом связан пустой фрейм.

 

Атрибут

Содержит метаданные, например, ключевые слова или сведения о местоположении связанного изображения (атрибут HREF).

 

Комментарий

Включает комментарии, которые видны в XML-файле, но не в документе InDesign.

 

Инструкция для обработки

Содержит инструкцию, которая запускает какое-либо действие в приложениях, которые умеют считывать инструкции по обработке.

 

Элемент «DOCTYPE»

Указывает DTD-файл, который необходимо использовать при проверке XML-файла.

Изменение расположения структурных элементов

Порядок и положение в иерархии элементов на панели «Структура» могут быть изменены. При этом необходимо соблюдение следующих правил.

  • XML-документ должен иметь один корневой элемент, находящийся в верхней строке структуры. Корневой элемент включает в себя все остальные элементы и является их родителем. Выше корневого элемента на панели «Структура» могут находиться только DTD (который отображается в виде элемента DOCTYPE), комментарии и инструкции по обработке.

  • Изменения иерархической структуры XML могут повлиять на отображение размеченных тегами элементов на страницах InCopy. Например, если сделать текстовый элемент дочерним элементом какого-либо другого элемента в структуре, то текст в макете также переместится в другое место.

  • Перетаскивание элемента ячейки таблицы или других элементов в элемент таблицы не допускается.

  1. На панели «Структура» выполните одно из следующих действий:
    • Чтобы переместить элемент, перетащите его на новое место в пределах структуры. При перетаскивании отображается линия, указывающая место вставки элемента. Ширина линии показывает уровень в иерархии.

    • Чтобы сделать элемент дочерним другого элемента или разместить его над родительским элементом, выделите его или поместите среди родительских элементов других дочерних элементов, а затем отпустите кнопку мыши.

    • Чтобы переместить элемент в иерархии на уровень ниже, перетащите его под другой родительский элемент и немного передвиньте влево, пока линия, показывающая его размещение, не сравняется по ширине с родительским элементом.

    • Чтобы скопировать или вырезать элемент, выделите его (или несколько элементов) на панели «Структура» и выберите меню «Редактирование» > «Скопировать» или «Редактирование» > «Вырезать». Выделите элемент, перед которым необходимо вставить скопированный элемент, а затем выберите меню «Редактирование» > «Вставить».

Примечание.

При вырезании элемент вместе с содержимым помещается в буфер обмена. Фрейм, в котором он содержался, остается без изменений.

Вставка родительского элемента

Чтобы обеспечить правильность структуры XML и лучше упорядочить содержимое, вставьте на панель «Структура» родительский элемент. Но перед этим необходимо выделить элементы, которые будут его дочерними элементами. После вставки нового родительского элемента выделенные дочерние элементы перемещаются в структурной иерархии на один уровень ниже.

vp_structure_ID
With child elements selected (left); a newly inserted parent element includes the child elements (right).
vb_structure_IC
With child elements selected (left); a newly inserted parent element includes the child elements (right).
  1. На панели «Структура» выделите элементы, которые будут дочерними элементами нового родительского элемента. Обратите внимание на следующие моменты.

    • Нельзя выделить корневой элемент и элементы корневого уровня.

    • Нельзя выделить элемент «Материал» и элементы его уровня.

    • Элементы должны находиться на одном уровне иерархии.

    • Элементы должны быть смежными.

    • Выделение не должно включать ячейки таблиц или атрибуты.

  2. В меню панели «Структура» выберите пункт «Новый родительский элемент» или нажмите правой кнопкой мыши (Windows) или при нажатой клавише Control (Mac OS) пункт «Новый родительский элемент».

  3. Выберите для нового родительского элемента тег и нажмите кнопку «ОК».

Примечание.

Выбрав на палитре «Теги» команду «Добавить тег», а затем, щелкнув нужный тег на палитре, можно быстро вставить новый родительский элемент. Также можно щелкнуть элемент, выделенный на панели «Структура», правой кнопкой мыши (Windows) или кнопкой мыши при нажатой клавише Control (Mac OS), выбрать пункт «Новый родительский элемент», а затем выбрать элемент.

Работа с атрибутами

Атрибут предоставляет дополнительную информацию об XML-элементе. Каждый атрибут состоит из имени и значения. Атрибуты отображаются на панели «Структура». Они не помещаются в документ и не используются в качестве его содержимого. Можно добавлять атрибуты с элементами, что позволяет обеспечить преимущество при работе с файлами и приложениями, использующими XML-файлы, созданные в InCopy.

При разметке тегами изображений InDesign автоматически создает атрибут href со значением, которое указывает местоположение файла изображения на диске. Благодаря атрибуту href другие файлы и приложения могут найти изображение и отобразить его.

vb_31
An attribute includes a name (href, in this case) and a value.

Атрибуты могут быть добавлены к любым элементам, кроме DOCTYPE (DTD-файл), комментариев и инструкций по обработке. Например, чтобы добавить ключевые слова для поиска в целевом приложении, можно создать атрибут КлючевыеСлова. Кроме того, атрибуты могут создаваться для указания подстановочного текста, отслеживания названий статей и сохранения любой другой информации, касающейся содержимого документа.

Примечание.

Если используется DTD-файл, просмотрите его содержимое, чтобы определить, какие атрибуты допустимы. Имена атрибутов, как и имена тегов, должны соответствовать DTD.

Примечание.

InCopy распознает специальные атрибуты пространств имен, которые могут определять стили абзацев и символов, таблиц и их ячеек, а также управлять пробельными символами. Дополнительную информацию см. в техническом руководстве по XML, а также в других источниках информации по адресу www.adobe.com/go/learn_id_XMLscript_ru.

Добавить атрибут

  1. Выделите элемент.
  2. Выполните одно из следующих действий:
    • Нажмите кнопку «Добавить атрибут» .

    • Выберите в меню панели «Структура» команду «Новый атрибут».

    • Нажмите выделенный элемент правой кнопкой мыши (Windows) (удерживая клавишу Control (Mac OS)) и выберите команду «Новый атрибут».

  3. Укажите имя и значение атрибута, а затем нажмите кнопку «ОК».

Отображение и скрытие атрибутов на панели «Структура»

  1. В меню панели «Структура» выберите команду «Показать атрибуты» или «Скрыть атрибуты».

    Возможно, придется щелкнуть значок треугольника рядом с элементом, чтобы отобразить его атрибуты.

Редактирование или удаление атрибута

  1. Выделите атрибут на панели «Структура».
  2. Выполните одно из следующих действий:
    • Чтобы изменить атрибут, дважды нажмите его или выберите в меню панели «Структура» команду «Редактировать».

    • Чтобы удалить атрибут, нажмите значок «Удалить» или выберите в меню панели «Структура» команду «Удалить».

Редактирование атрибутов «href»

При обработке файлов изображений InCopy автоматически создает атрибуты href. Атрибут href задает расположение файла изображения на диске, делая возможным его отображение. При разметке тегами помещенного изображения InCopy создает атрибут href, содержащий путь к изображению и имя файла.

Путь может представлять собой абсолютную ссылку, относительную ссылку на папку, в которой хранится XML-файл, либо относительную ссылку на подпапку «Images» папки, в которой хранится XML-файл. Относительные пути ограничены папкой, в которой сохраняется документ.

  • Атрибут href, содержащий абсолютный путь, имеет следующий вид (в Windows и Mac OS):

    href=file:///C:/Images/Meadow.psd

    href=file:///Users/abhayc//Desktop/abc.jpg

  • Атрибут href для файла изображения, находящегося в той же папке, что и XML-файл, имеет следующий вид:

    href=file:Meadow.psd

  • Атрибут href для файла изображения, находящегося в папке «Images», имеет следующий вид:

    href=file:///Images/Meadow.psd

Атрибут href можно изменить, указав новую ссылку на изображение. Например, абсолютную ссылку можно заменить на относительную, обеспечив доступность файла изображения после экспорта.

  1. На панели «Структура» дважды нажмите атрибут href (возможно, придется щелкнуть значок треугольника рядом с элементом, чтобы отобразить этот атрибут).
  2. В качестве параметра «Значение» введите новый путь к изображению и нажмите кнопку «ОК».

Добавление комментариев и инструкций по обработке

InCopy позволяет добавлять в XML-файлы комментарии и инструкции для обработки. Комментарии содержат описательную информацию об элементе. Они доступны для просмотра в веб-браузерах и текстовых редакторах и могут помочь другим пользователям разобраться со структурой и тегами XML-файла. Инструкция по обработке — это специальная команда, специфичная для приложения. Например, это может быть инструкция по разрывам страницы, позволяющая приложению, для которого экспортируется XML-файл, вставлять в нужных местах разрывы страниц. Подготавливаемые пользователями в InCopy инструкции для обработки предназначены для использования в других программах. Сама программа InCopy их не обрабатывает.

Комментарии и инструкции по обработке отображаются на панели «Структура». Они могут быть перемещены, изменены или удалены, как и любые другие элементы на панели «Структура». Однако они не могут содержать ни дочерних элементов, ни атрибутов.

vb_36
InDesign Structure pane with text snippets showing

A. Processing instruction B. Comment 

Добавление комментария

  1. Выделите элемент, для которого необходимо добавить комментарий.

    Примечание.

    Чтобы добавить комментарий к таблице, выделите элемент ячейки таблицы. Комментарии могут добавляться к ячейкам таблиц, но не к таблицам.

  2. Выберите в меню панели «Структура» команду «Новый комментарий».
  3. Введите комментарий в диалоговом окне «Новый комментарий».

Добавление инструкции по обработке

  1. Выделите элемент, к которому необходимо добавить инструкцию по обработке.

    Примечание.

    Чтобы добавить инструкцию по обработке к таблице, выделите элемент ячейки таблицы. Инструкции по обработке могут добавляться к ячейкам таблиц, но не к таблицам.

  2. Выберите в меню панели «Структура» команду «Новая инструкция по обработке».
  3. В качестве параметра «Назначение» введите имя, соответствующее инструкции по обработке, которое понятно приложению, обрабатывающему XML-файл после экспорта.
  4. В качестве параметра «Данные» введите значение, указывающее приложению, что делать с инструкцией по обработке.

Просмотр комментариев и инструкций по обработке

  1. Выберите в меню панели «Структура» команду «Показать комментарии» или «Показать команды обработки».

Редактирование комментариев и инструкций по обработке

  1. Выделите комментарий или инструкцию по обработке.
  2. Выполните одно из следующих действий:
    • Дважды нажмите комментарий или инструкцию по обработке.

    • Выберите в меню панели «Структура» команду «Редактировать».

  3. Измените комментарий или инструкцию по обработке и нажмите кнопку «ОК».

Использование DTD-файлов для проверки XML

Проверка XML в документе заключается в сверке структуры, имен тегов элементов и атрибутов со спецификациями DTD-файла. Чтобы выполнить проверку на соответствие DTD-файлу, необходимо сначала загрузить его в документ InDesign.

Примечание.

При загрузке DTD-файла на палитру «Теги» импортируются имена тегов. Эти имена тегов заблокированы, и их невозможно удалить или переименовать до тех пор, пока DTD-файл не будет удален из документа.

После загрузки DTD-файла в документ в верхней части панели «Структура» отображается элемент DOCTYPE. Иногда DTD-файлы загружаются автоматически при импорте XML-файла. Чтобы заменить DTD-файл в документе, удалите существующий DTD-файл, а затем загрузите новый.

vb_05
Working with DTD files in InDesign

A. DOCTYPE element from the DTD file (Structure pane) B. Locked tag from the DTD file (Tags panel) 

Загрузка DTD-файла

При загрузке DTD-файла InDesign встраивает его в документ.

  1. Выполните одно из следующих действий:
    • В меню панели «Структура» выберите команду «Загрузить описание типа документа».

    • В меню палитры «Теги» выберите команду «Загрузить описание типа документа».

  2. Выберите DTD-файл, который необходимо импортировать, и нажмите кнопку «Открыть».

    Примечание.

    Чтобы просмотреть теги, указанные в DTD-файле, откройте палитру «Теги», выбрав меню «Окно» > «Утилиты» > «Теги».

Просмотр DTD-файла

DTD-файлы представлены в виде ASCII-текста. Они задают правильный порядок элементов и могут содержать встроенные инструкции и пояснения по применению тегов. InDesign позволяет просматривать DTD-файл только после его загрузки в документ.

vb_14
DTD file opened for viewing
  1. Выполните одно из следующих действий:
    • В меню панели «Структура» выберите команду «Просмотр описания типа документа».

    • Дважды нажмите элемент DOCTYPE на панели «Структура».

    Примечание.

    Чтобы напечатать DTD-файл, скопируйте код из окна «Просмотр DTD» и вставьте его в текстовый редактор.

Удаление DTD-файла

  1. Выберите в меню панели «Структура» команду «Удалить DTD».

    InDesign удаляет копию DTD-файла, сохраненную в документе InDesign, а не исходный DTD-файл. Импортированные из DTD-файла теги остаются на палитре «Теги», но теперь они разблокированы.

Проверка структуры XML

Если при проверке документа выяснится, что документ XML содержит отклонения от правил, установленных DTD-файлом, InCopy выдаст предупреждение. и предложит меры по исправлению возникших несоответствий. Исправить ошибки можно по отдельности или просмотреть все сразу в отдельном окне.

vb_06
Structure pane with Suggestions pane

A. Loaded DTD B. Error or invalidating condition C. Description of error with suggested fix D. Error count E. Validate button F. View all errors in a separate window 
ch_08
Structure pane with Suggestions section

A. DOCTYPE element from assigned DTD file B. Error or invalidating condition C. Description of error with suggested fixes D. Error count E. Validate button F. View all errors at once in a separate window 
  1. Выберите меню «Просмотр» > «Структура» > «Показать структуру».
  2. На палитре «Структура» нажмите кнопку «Проверить на корректность» .

    Примечание.

    Чтобы изменить корневой элемент, с которого InDesign начинает проверку, выберите в меню панели «Структура» пункт «Параметры описания типа документа».

  3. Чтобы исправить ошибки, отображаемые в области «Варианты», нажмите предложенное исправление, чтобы попробовать его применить, либо измените структуру и теги XML непосредственно на панели «Структура» и палитре «Теги».
  4. Чтобы просмотреть остальные ошибки, выполните одно из следующих действий:
    • Нажмите кнопку со стрелкой влево  или вправо .

    • Нажмите кнопку окна ошибок , чтобы просмотреть все ошибки в отдельном окне.

    • Выберите в меню палитры «Структура» команду «Отобразить список ошибок».

Примечание.

InCopy прекращает проверку после обнаружения 250 ошибок. При достижении предельного количества ошибок в поле «Счетчик ошибок» появляется знак «плюс».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет