Примечание.

В Photoshop CS6 функциональные возможности 3D были доступны в Photoshop Extended. Все возможности Photoshop Extended доступны в Photoshop. Photoshop не имеет специальной версии Extended.

Сведения о стеках изображений

Стек изображений объединяет группы изображений с похожими кадрами, но отличающихся качеством или содержанием. После объединения в стек можно обрабатывать сразу несколько изображений для создания совмещенного вида, не содержащего нежелательного содержимого или шума.

Использовать стеки изображений с целью улучшения качества изображений можно в следующих случаях.

  • Для уменьшения шума изображения и искажений судебных, медицинских или астрофотографических изображений.

  • Для удаления нежелательных или случайных объектов из последовательности стационарных фотографий или серии видеокадров. Например, может потребоваться удаление объекта, движущегося через изображение, или удаление изображения машины, движущейся перед основным объектом.

Стеки изображений хранятся в виде смарт-объектов. Параметры обработки, которые можно применять к стеку, называются режимами стека. Применение режима стека к стеку изображений является безопасным редактированием. Для создания разнообразных эффектов можно изменять режимы стека. Данные в исходных изображениях остаются неизменными. Для предотвращения изменений после применения режима стека сохраните результат в качестве нового изображения или растрируйте смарт-объект. Стек изображений можно создать вручную или с помощью сценария.

Создание стека изображений

Для получения наилучшего результата изображения, содержащиеся в стеке, должны обладать одинаковыми размерами и обычно похожим содержанием, например набор неподвижных изображений, полученных с фиксированной точки съемки, или серия кадров со стационарной видеокамеры. Схожесть содержимого изображений должна быть достаточной для того, чтобы позволить совмещать или выравнивать их относительно других изображений набора.

  1. Объедините отдельные изображения в одно многослойное изображение. См. раздел Дублирование слоев.

    Примечание.

    Стек изображений должен содержать по меньшей мере два слоя.

    Изображения можно объединять также с помощью сценариев («Файл» > «Сценарии» > «Загрузить файлы в стек...»).

  2. Выберите меню «Выделение» > «Все слои».

    Примечание.

    Чтобы фоновый слой мог быть выбран с помощью команды «Все слои», его необходимо преобразовать в обычный слой.

  3. Выберите пункт меню «Редактирование» > «Автоматически выравнивать слои» и установите параметр выравнивания равным «Авто». Если значение этого параметра, равное «Авто», не позволяет выполнить хорошую приводку слоев, попробуйте присвоить ему значение «Перемещение».
  4. Выберите «Слой» > «Смарт-объекты» > «Преобразовать в смарт-объект».
  5. Выберите «Слой» > «Смарт-объекты» > «Режим стека», затем выберите из вложенного меню необходимый режим.
    • Для уменьшения шума используйте внешние модули «Среднее» или «Медиана».

    • Для удаления объектов из изображения используйте внешний модуль «Медиана».

      Результатом является составное изображение с тем же размером, что и исходный стек изображений. Возможно, для получения наилучшего результата для конкретного изображения может потребоваться поэкспериментировать с различными внешними модулями.

      Для изменения эффекта рендеринга выберите из подменю другой режим стека. Рендеринг стека не является накопительной, каждый эффект рендеринга обрабатывает исходные данные изображения в стеке и заменяет предыдущие эффекты.

Режимы стека

Режимы стека применяются только к отдельным каналам и только к непрозрачным пикселям. Например, режим «Максимум» возвращает максимальные значения красного, зеленого и синего каналов для пересечения пикселов и объединяет их в одно составное значение пикселя отображаемого изображения.

Название внешнего модуля рендеринга

Результат

Комментарии

Энтропия

энтропия = – sum( (вероятностное значение) * log2( вероятностное значение) )

Вероятностное значение = (число появлений значения) / (общее число непрозрачных пикселей)

Бинарная энтропия (или энтропия нулевого порядка) определяет минимальное количество бит, необходимое для кодирования без потерь информации в наборе.

Эксцесс

эксцесс = ( sum( (значение – среднее)4 ) превышение непрозрачных пикселей ) / ( ( число непрозрачных пикселей – 1 ) * (стандартное отклонение)4 ).

Измерение эксцесса или линейности производится относительно нормального распределения. Эксцесс для стандартного нормального распределения равен 3,0. Эксцесс со значением более 3 указывает на островершинное распределение, а эксцесс со значением менее 3 указывает на плосковершинное распределение (относительно нормального распределения).

Максимум

Максимальные значения канала для всех непрозрачных пикселей

Среднее

Средние значения канала для всех непрозрачных пикселей

Эффективно для уменьшения шума

Медиана

Медианные значения канала для всех непрозрачных пикселей

Эффективно для уменьшения шума и удаления нежелательного содержимого из изображения

Минимальный

Минимальные значения канала для всех непрозрачных пикселей

Диапазон

Разница между максимальным и минимальным значениями непрозрачного пикселя

Асимметрия

коэффициент асимметрии = ( sum( (значение – среднее)3 ) превышение непрозрачных пикселей ) / ( ( число непрозрачных пикселей – 1 ) * (стандартное отклонение)3 )

Коэффициент асимметрии является мерой симметрии или асимметрии относительно статистического среднего

Стандартное отклонение

стандартное отклонение = корень квадратный(отклонение)

Суммирование

Сумма значений канала для всех непрозрачных пикселей

Отклонение

отклонение = ( sum( (значение – среднее)2 ) превышение непрозрачных пикселей ) / ( число непрозрачных пикселей – 1 )

Удаление рендеринга стека

  1. Выберите меню «Слой» > «Смарт-объекты» > «Режим стека» > «Нет» для удаления из стека изображений любого рендеринга и преобразования его обратно в обычный смарт-объект.

Редактирование стека изображений

Так как стек изображений является смарт-объектом, то редактировать исходные изображения, составляющие слои стека, можно в любое время.

  1. Выберите меню «Слой» > «Смарт-объекты» > «Редактировать содержимое» или дважды щелкните миниатюру слоя. После сохранения отредактированного смарт-объекта стек автоматически отображается с последними примененными к нему параметрами рендеринга.

Преобразование стека изображений

Для сохранения визуальных эффектов стека изображений преобразуйте смарт-объект в обычный слой. (В случае необходимости воссоздания стека изображений перед преобразованием можно создать копию смарт-объекта.)

  1. Выберите меню «Слой» > «Смарт-объекты» > «Растрировать».

Использование сценария для создания стека изображений

Для автоматического создания и рендеринга стека изображений можно использовать сценарий «Статистика».

  1. Выберите меню «Файл» > «Сценарии» > «Статистика».
  2. Выберите нужный режим в меню «Выбрать режим стека».
  3. Примените режим стека к открытым в настоящее время файлам либо выберите необходимую папку или отдельные файлы.

    Выбранные файлы отобразятся в диалоговом окне.

  4. При желании выберите команду «Попытаться автоматически выровнять исходные изображения» (это эквивалентно выбору Редактирование > Автовыравнивание слоев). Затем нажмите кнопку «ОК».

    Photoshop объединяет несколько изображений в одно многослойное изображение, преобразует слои в смарт-объекты, а затем применяет выбранный режим стека.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет