Adobe Acrobat PDFMaker (knappen Konvertera till Adobe PDF i verktygsfältet/fliken PDFMaker) är ett tillägg som skapar PDF-filer via Microsoft Office-program. Den här funktionen installeras med Acrobat Professional och Standard.

  • I MS Office 2003 och tidigare använder PDFMaker Adobe PDF-skrivaren för att skapa en PostScript-fil. Därefter samarbetar Adobe PDF-skrivarens gränssnitt med Adobe Acrobat Distiller-programmet och genererar en PDF-fil.
  • I MS Office 2007, 2010, 2016 och 365 använder PDFMaker AdobePDF Library för att konvertera ett Microsoft Office-dokument till PDF.
  • Acrobat Distiller eller Adobe PDF-skrivaren kan även användas enskilt för att skapa PDF-filer.

Det här dokumentet hjälper dig att felsöka problem som uppstår när du försöker skapa PDF-filer från Office-program med Acrobat PDFMaker. Även om det här dokumentet avser Microsoft Word är de flesta felsökningsprocedurer även tillämpbara på Microsoft PowerPoint och Microsoft Excel.

 

Menyfliken för Acrobat är inte tillgängligt i Office 2016 eller Office 365-program på Windows

Gäller Office 2016 eller Office 365-versioner av Word, Excel och PowerPoint

Prova följande steg för att åtgärda problemet:  

  1. Högerklicka på Word-ikonen och välj Kör som administratör.

    Om du ser prompten Användarkontokontroll klickar du på Ja.

  2. Öppna ett tomt dokument – välj Tomt dokument-mallen. Alternativt kan du öppna ett befintligt Word-dokument.

  3. På menyn Arkiv väljer du Alternativ. Dialogrutan Wordalternativ visas.

  4. Välj Tillägg i alternativlistan. I rullgardinsmenyn Hantera välj COM-tillägg och klicka Sök.

    Word-tillägg
  5. I dialogrutan COM-tillägg, markera kryssrutan Acrobat PDFMaker Office COM Tillägg, om den inte redan är markerad och klicka sedan på OK.

    PDFMaker Office COM-tillägg

PDFMaker kraschar med Office 2016 och Office 365 under Windows

Acrobat PDFMaker kraschar med Office 2016 och Office 365 under Windows efter Office 2016:s uppdatering från februari.

Adobe undersöker problemet och arbetar med Microsoft för att få det löst så fort som möjligt. Skapa PDF-filer med denna lösning under tiden.

Kontrollera Acrobats kompatibilitet med Microsoft Office

Säkerställ att Acrobat-versionen som du kör är kompatibel med den aktuella Office-version innan du påbörjar felsökningen. Ytterligare information finns i Kompatibla webbläsare och PDFMaker-program | Acrobat, Reader.

Felsökning av Acrobat Distiller och Adobe PDF-skrivaren (endast tillämpbart på PDFMaker för MS Office 2003 och tidigare)

Acrobat PDFMaker (för MS Office 2003 och tidigare) använder Adobe PDF-skrivaren som i sin tur använder Acrobat Distiller-programmet för att konvertera Word-dokument. Därför är det första steget i felsökningen att fastställa om Acrobat Distiller fungerar korrekt:

Prova att skapa en PDF-fil i Word med Adobe PDF-skrivaren. 

  1. Öppna valfritt dokument i Word och välj Arkiv > Skriv ut.
  2. Välj Adobe PDF i skrivarens meny och klicka sedan på OK.

Prova att skapa en PDF med Acrobat Distiller

Obs! Den här metoden stöder inte avancerade PDFMaker-funktioner som att bibehålla länkar och dokumentstruktur.

  1. Öppna ett Word-dokument och välj sedan Arkiv > Skriv ut.
  2. I dialogrutan Skriv ut väljer du en PostScript-skrivare (till exempel Adobe PDF-skrivaren), välj sedan Skriv ut till fil och klicka på OK.

    En postscript-fil (.ps eller .prn) genereras.

    Obs! Om du inte har en PostScript-skrivare kan du hämta en PostScript-skrivardrivrutin från Adobes webbplats. När du har installerat drivrutinen slutför du steg 2. Om du väljer Adobe PDF-skrivaren avmarkerar du Skicka inte teckensnitt till Adobe PDF för att skapa en PostScript-fil.

  3. I Acrobat väljer du > Acrobat Distiller.
  4. Välj en inställning i listan över standardinställningar (eller låt standardvärdet vara kvar).
  5. Välj Arkiv > Öppna, välj Alla filer i menyn Filtyper, markera den PS- eller PRN-fil du har skapat och klicka sedan på Öppna.
  6. Ange namn och plats för PDF-filen och klicka på Spara.
    • Om Acrobat Distiller skapar en PDF-fil fortsätter du till Felsökning av Acrobat PDFMaker.
    • Om Acrobat Distiller inte skapar en PDF-fil fortsätter du till nästa steg.
  7. Öppna messages.log-filen i följande Windows-mapp (NT, 2000, XP, Vista, 7): %AppData%\Adobe\Acrobat\Distiller [versionsnummer]

  8. Kontrollera messages.log-filen för felsökningsinformation:

    • Om filen anger varför Acrobat Distiller inte kunde generera PDF-filen använder du textrutan för sökning på Hjälp och support för Acrobat.com Om till exempel ett PostScript-fel anges av filen felsöker du felet enligt rekommendationerna i Felsökning av PostScript-fel.
    • Om filen inte anger varför Acrobat Distiller inte kunde skapa PDF-filen skapar du ett Word-dokument som endast innehåller några få ord. Prova sedan att skapa en PDF-fil av det dokumentet med hjälp av Adobe PDF-skrivaren och Acrobat Distiller-programmet:
    • Om du kan skapa en PDF-fil från det nya dokumentet kan problemet bero på PDFMaker. Fortsätt till Felsökning av Acrobat PDFMaker.
    • Om du inte kan skapa en PDF-fil från det nya dokumentet måste du använda en fil från ett annat program. Prova sedan att skapa en PDF-fil med Acrobat Distiller. Om problem uppstår med filen från ett annat program installerar du om Acrobat Distiller. Om problemet inte kvarstår med filen från ett annat program, felsöker du det specifika beteendet med de dokument som anges i Relaterat innehåll. Eller sök i Hjälpavsnittet för Acrobat. Om du behöver mer hjälp kontaktar du Acrobats tekniska support.

Felsökning av Acrobat PDFMaker

Om du kan skapa en PDF-fil med Adobe PDF-skrivaren eller Acrobat Distiller men inte med Acrobat PDFMaker kan problemet bero på en Acrobat PDFMaker-funktion. Kontrollera om några av dessa funktioner orsakar problemet genom att inaktivera dem. Prova sedan att skapa en PDF-fil:

  1. I Word väljer du Adobe PDF > Ändra konverteringsinställningar.
  2. Välj den minsta filstorleken i menyn över konverteringsinställningar.
  3. Klicka på Word-fliken och avmarkera sedan alla alternativ.
  4. Klicka på fliken Bokmärken och avmarkera sedan alla alternativ för Bokmärken.
  5. Klicka på fliken Säkerhet och avmarkera sedan alla Säkerhetsalternativ.
  6. Klicka på OK.
  7. Prova att skapa en PDF-fil:
  • Om du inte kan skapa en PDF-fil fortsätter du till Felsökning av dokumentspecifika problem.
  • Om du kan skapa en PDF-fil fastställer du vilka funktioner som orsakar problemet. Aktivera en funktion och prova att skapa en PDF-fil. Upprepa detta tills problemet återkommer. Skapa sedan ett Word-dokument som bara innehåller några ord. Prova att skapa en PDF-fil från dokumentet med samma Acrobat PDFMaker-inställningar:
  • Om du kan skapa en PDF-fil från det nya dokumentet är problemet dokumentspecifikt. Fortsätt till Felsökning av dokumentspecifika problem.
  • Om du inte kan skapa en PDF-fil från det nya dokumentet är det den funktion som aktiverades senast som orsakar problemet. Installera Acrobat PDFMaker på nytt. Om problemet kvarstår kontaktar du Support för Acrobat.

Felsöka dokumentspecifika problem

Tillämpa följande felsökning om du anser att problemet är dokumentspecifikt.

Aktivera endast de Acrobat PDFMaker-funktioner som dokumentet använder

Om dokumentet till exempel endast innehåller rubrikstilarna Rubrik 1 och Rubrik 2, inaktiverar du de andra rubrikstilarna i dialogrutan Acrobat PDFMaker.

Växla till Normal dokumentvy i Word och skapa sedan PDF-filen med Acrobat PDFMaker

Skapa Word-dokumentet på nytt för att eliminera eventuell skada

Gör något eller några av följande:

  • Kopiera och klistra in innehållet i Word-dokumentet till ett nytt dokument och skapa sedan PDF-filen.
  • Markera all text i dokumentet, ändra teckensnittet och spara sedan dokumentet med ett nytt namn. Word skriver om dokumentet som kan ta bort element i konflikt med Acrobat PDFMaker. När du har sparat dokumentet kan du formatera om det till önskat teckensnitt.
  • Om dokumentet skapades i en annan Word-version än den du använde för att skapa PDF-filen gör du en liten ändring i dokumentet. Spara det sedan med ett nytt namn. Denna process tvingar Word att skriva om dokumentet och eliminera eventuella element som står i konflikt med Acrobat PDFMaker.

Återskapa eventuella anpassade rubrikstilar i dokumentet och generera sedan PDF-filen

Identifiera element som kan påverka dokumentet

  1. Skapa ett nytt Word-dokument.
  2. Kopiera hälften av det ursprungliga Word-dokumentet till det nya Word-dokumentet.
  3. Konvertera det nya Word-dokumentet till PDF med Acrobat PDFMaker
  • Om problemet återkommer finns det ett element som påverkar det nya Word-dokumentet. Upprepa steg 1–3 för att ytterligare isolera det oförenliga elementet och kopiera halva delen av det andra Word-dokumentet till ett annat nytt Word-dokument.
  • Om problemet inte kvarstår finns det oförenliga elementet i det ursprungliga Word-dokumentet. Identifiera problemet ytterligare genom att upprepa steg 1–3 och kopiera den andra halvan av det ursprungliga Word-dokumentet till ett annat nytt Word-dokument. Om båda delar av dokumentet konverteras korrekt stänger du övriga program som körs, inklusive Office-programmet. Ta bort .tmp-filer (finns ofta i Windows/Temp-mappen).

Installera om program

Ta bort både Acrobat och Office eller det specifika Office-programmet (Word, PowerPoint eller Excel). Installera om Office eller det specifika Office-programmet och installera om Acrobat.

Ta bort Acrobat via panelen Lägg till/ta bort program. Anvisningar om hur du tar bort Office finns i Office-dokumentationen, alternativt kontaktar du Microsoft.

Om Word-dokumentet är skyddat tar du bort skyddet

Anvisningar om hur du tar bort skyddet finns i Word-dokumentationen, alternativt kan du kontakta Microsoft. 

Felsökning av konflikter med övriga makron i Microsoft Word

PDFMaker kan hamna i konflikt med övriga makron som virus- eller fax-programvara. Om övriga felsökningar misslyckas eller om PDFMaker har problem efter installationen av ett makro från tredje part felsöker du konflikter med övriga makron. Makron som är kända för inkompatibilitet omfattar Duden Korrektor Plus 2.0, ViaVoice 10 och tidigare, Personal Translator 2002 Office Plus, OfficeReady Stuffit, Leuchter Informatic AG WordPlus och GoldMine Link to Word.

Fastställ om PDFMaker är i konflikt med övriga makron genom att ta bort eller inaktivera övriga makron, ett i taget (se tillämpbar länk nedan). Prova sedan att konvertera ett dokument till en PDF med PDFMaker på nytt. Om problemet inte återkommer kontaktar du makrots tillverkare.

Felsöka problem i Microsoft Word

Starta Word med ett /a-kommando och lägg till PDFMaker manuellt

Kommandot /a startar Word och förhindrar att tillägg och globala mallar (inklusive den normala mallen) läses in automatiskt.Dessutom låser kommandot /a inställningsfilerna som därför inte kan läsas eller ändras om du använder detta kommando.

Obs! När Word avslutas går ändringar av inställningar, anpassningar eller makron som gjorts med kommandot /a i Word förlorade.

Starta Word med kommandot/a:

  1. Avsluta alla program.
  2. Välj Start > Kör.
  3. I dialogrutan Kör anger du winword.exe /a.
  4. Klicka på OK. Dialogrutan Kör avslutas och Word startar.

Läs in PDFMaker manuellt (endastAcrobat 6.x ):

  1. Avsluta alla program.
  2. Välj verktyg > Mallar och tillägg.
  3. Välj PDFMaker.dot (inte PDFMakerA.dot) och klicka på OK.

    PDFMaker-ikoner visas.

För Acrobat 7.x, 8.x, 9.x, X (om tillämpligt) 

Läsa in PDFMaker manuellt (MS Word 2003 eller tidigare):

  1. Avsluta alla program.
  2. Välj verktyg > Anpassa och klicka sedan på fliken Kommandon.
  3. Klicka på Verktyg i panelen Kategorier.
  4. Dra COM-tillägg från Kommando-panelen till Verktygsmenyn medan du håller ned musknappen. När menyn Verktyg visar kommandomenyn drar du COM-tilläggen under alternativet Anpassa och släpper sedan musknappen.
  5. Klicka på Stäng.
  6. Klicka på COM-tillägg i menyn Verktyg.
  7. Klicka på Lägg till, sök efter tillägget (PDFMaker-tillägget finns i [Acrobat-installationens sökväg]\PDFMaker\Office\PDFMOfficeAddIn.dll) och klicka sedan på OK.

  8. Tryck på Alt + F11 för att starta Visual Basic Editor.
  9. Tryck på Alt + F11 för att starta direktfönstret för Visual Basic Editor.
  10. Om du vill starta PDFMaker i Word skriver du Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True. Stäng Visual Basic Editor.
  11. Kontrollera att Adobe PDF-menyn visas till höger om Hjälp i menyfältet för Microsoft Word.

Läs in PDFMaker manuellt (MS Word 2007 och 2010):

  1. Avsluta alla program.
  2. Klicka på Microsoft Office-knappen och sedan på Word-alternativ.

  3. Klicka på Tillägg.

  4. I dialogrutan Hantera lista klickar du på COM-tillägg och sedan på Kör.

  5. Om Acrobat PDFMaker COM-tillägget visas och är markerat i dialogrutan COM-tillägg gör du följande. Annars fortsätter du till steg 6.

  6. Klicka för att avmarkera kryssrutan för Acrobat PDFMaker COM-tillägget.

  7. Klicka på OK för att stänga dialogrutan för COM-tillägg.

  8. Upprepa steg 1 till 3 och klicka sedan för att välja/markera Acrobat PDFMaker COM-tilläggets kryssruta i dialogrutan för COM-tillägg.

  9. Kontrollera att Acrobat-fliken visas i menyfliken för MS Word.

  10. Om Acrobat PDFMaker COM-tillägg INTE visas i dialogrutan över COM-tillägg följer du steg 7 till 10 i avsnittet Läsa in PDFMaker manuellt (MS Word 2003 eller tidigare)

Skapa ett Word-dokumenttest och starta PDFMaker: 

  1. Skriv in text i Word-dokumentet.
  2. Välj Fil > Spara och spara testdokumentet till skrivbordet.
  3. Klicka på konvertera till Adobe PDF.

Om du åtgärdar problemet när du använder kommandot /a för att starta Word tar du bort varje komponent som läses in vid aktivering av Word. Ta bort dessa komponenter en i taget, i den ordning som de visas i Word. Följande komponenter läser in vid start av Word:

  • Automakron för Word
  • global mall (Normal.dot)
  • Tillägg (WLLs)
  • Mallar i startmappen för Word och i startmapparna för Office
  • COM-tillägg
  • Word-datanyckel i Windows-registret
  • Word-alternativnyckel i Windows-registret
  • Automakron för Word

Obs! Se följande supporttjänster för Microsoft-produkter för ytterligare felsökning vid start av Word.

Byt namn på Normal.dot-mallfilen

Anvisningar om hur du byter namn på den globala mallfilen finns i avsnittet Global mall (Normal.dotm eller Normal.dot) i Microsoft Support-artikeln Så här återställer du användaralternativ och registerinställningar i Word. Rulla ned på sidan för att komma till artikeln.

Viktigt: Använd inte kommandot /a för att starta om Word efter att du har slutfört stegen.

Om du löser problemet när du byter namn på din globala mall, är problemet en skadad Normal.dot-mall. Det är ibland nödvändigt att ändra flera inställningar för att återställa dina alternativ. Om Normal.dot-filen som du bytte namn på innehåller anpassningar som format, makron eller AutoText-inmatningar som inte kan återskapas enkelt kan du prova att använda Sorteraren för att kopiera anpassningarna från den gamla Normal.dot-filen till den nya Normal.dot-filen.

Följ de här stegen för mer information om hur du använder Sorteraren:

  1. Starta Word.
  2. Välj hjälp > Hjälp för Microsoft Word.
  3. Skriv Sorterare i Office-assistenten eller i svarsguiden.

  4. Klicka på Sök för att visa ämnen som returneras.

Om du inte löser problemet kan du välja att använda en äldre global mall (Normal.dot) istället för den nya globala mallen. Använd din gamla Normal.dot-mall genom att byta namnet på den nya Normal.dot-mallen till den gamla Normal.dot-mallens namn. Om problemen med PDFMaker kvarstår efter att du har använt detta dokument kontaktar du Acrobat Support.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy