Emails are being sent from Adobe Sign but the Recipient (Signers / Sender / CC'd users / Users added under External Archive) is not receiving the Notification Emails from Adobe Sign (adobesign@adobesign.com).
Cause
This can happen when emails are getting blocked/filtered by the email server of the recipient.
Resolution
There are several troubleshooting things you can do to ensure that you can receive emails from Adobe Sign.
Check the Spam/Junk folder for the e-mails.
Add adobesign@adobesign.com to the address book or safe list.
If the email has a stringent security setting that blocks emails with active html links, attachments or images then that setting will need to be reduced.