Adobe Acrobat PDFMaker (tlačidlo Previesť do Adobe PDF na paneli s nástrojmi alebo karte PDFMaker) je doplnok na vytváranie súborov PDF z aplikácií balíka Microsoft Office. Táto funkcia sa inštaluje s aplikáciami Acrobat Professional a Standard.

  • Pri balíku MS Office 2003 a starších verziách používa doplnok PDFMaker tlačiareň Adobe PDF na vytvorenie súboru PostScript. Tlačiareň Adobe PDF potom vytvorí súbor PDF pomocou aplikácie Adobe Acrobat Distiller.
  • Pri balíku MS Office 2007, 2010, 2016 a 365 používa doplnok PDFMaker knižnicu Adobe PDF Library na prevod dokumentu balíka Microsoft Office na súbor PDF.
  • Na vytváranie súborov PDF sa dá aplikácia Acrobat Distiller alebo tlačiareň Adobe PDF používať aj samostatne.

Tento dokument vám môže pomôcť pri riešení problémov, ktoré sa môžu vyskytnúť pri pokuse o vytvorenie súborov PDF z aplikácií balíka Office pomocou doplnku Acrobat PDFMaker. Hoci sa tento dokument týka aplikácie Microsoft Word, väčšina postupov riešenia problémov platí aj pre aplikácie Microsoft PowerPoint a Microsoft Excel.

 

Pás s nástrojmi Acrobat nie je k dispozícii v balíkoch Office 2016 ani Office 365 pre systém Windows.

Platí pre verzie aplikácií Word, Excel a PowerPoint v balíkoch Office 2016 alebo Office 365.

Skúste problém opraviť pomocou týchto krokov:  

  1. Pravým tlačidlom myši kliknite na ikonu programu Word a vyberte možnosť Spustiť ako správca.

    Ak sa zobrazí výzva kontroly používateľských kont, kliknite na možnosť Áno.

  2. Otvorte prázdny dokument: vyberte šablónu Prázdny dokument. Môžete tiež otvoriť existujúci dokument programu Word.

  3. V ponuke Súbor vyberte položku Možnosti. Zobrazí sa dialógové okno možností programu Word.

  4. V zozname možností vyberte položku Doplnky. V rozbaľovacej ponuke Správa vyberte možnosť Doplnky COM a potom kliknite na položku PREJSŤ.

    Doplnky programu Word
  5. Ak v dialógovom okne doplnkov COM nie je začiarknuté pole Doplnok Acrobat PDFMaker Office COM, začiarknite ho a potom kliknite na tlačidlo OK.

    Doplnok Acrobat PDFMaker Office COM

PDFMaker zlyháva s aplikáciou Office 2016 a Office 365 v systéme Windows

Acrobat PDFMaker zlyháva s aplikáciou Office 2016 a Office 365 v systéme Windows po februárovej aktualizácii Office 2016

Spoločnosť Adobe vyšetruje tento problém a spolupracuje so spoločnosťou Microsoft, aby sa čo najskôr vyriešil. Medzitým môžete na vytváranie súborov PDF používať toto alternatívne riešenie.

Kontrola kompatibility aplikácie Acrobat s balíkom Microsoft Office

Skôr než začnete riešiť problémy, uistite sa, že vaša verzia aplikácie Acrobat je kompatibilná s vašou verziou balíka Office. Podrobnosti nájdete v časti Kompatibilné webové prehliadače a aplikácie PDFMaker | Acrobat, Reader.

Riešenie problémov s aplikáciou Acrobat Distiller a tlačiarňou Adobe PDF (len pre doplnok PDFMaker pre balík MS Office 2003 a staršie verzie)

Doplnok Acrobat PDFMaker (pre balík MS Office 2003 a staršie verzie) používa na prevod dokumentov aplikácie Word tlačiareň Adobe PDF, ktorá zase používa aplikáciu Acrobat Distiller. Prvým krokom pri riešení problémov je preto overenie správnej funkčnosti aplikácie Acrobat Distiller:

Pokus o vytvorenie súboru PDF z aplikácie Word pomocou tlačiarne Adobe PDF

  1. Otvorte dokument v aplikácii Word a vyberte položky Súbor > Tlačiť.
  2. V menu Názov tlačiarne vyberte tlačiareň Adobe PDF a kliknite na tlačidlo OK.

Pokus o vytvorenie súboru PDF pomocou aplikácie Acrobat Distiller

Poznámka: Tento spôsob nepodporuje pokročilé funkcie doplnku PDFMaker, ako je napríklad spravovanie prepojení a štruktúry dokumentu.

  1. Otvorte dokument aplikácie Word a vyberte položky Súbor > Tlačiť.
  2. V dialógovom okne Tlačiť vyberte tlačiareň PostScript (napríklad tlačiareň Adobe PDF), vyberte položku Tlačiť do súboru a kliknite na tlačidlo OK.

    Vytvorí sa súbor PostScript (.ps alebo .prn).

    Poznámka: Ak nemáte tlačiareň PostScript, z webovej lokality spoločnosti Adobe môžete prevziať ovládač tlačiarne PostScript. Po nainštalovaní ovládača dokončite krok 2. Ak vyberiete tlačiareň Adobe PDF, pri vytváraní súboru PostScript zrušte začiarknutie políčka „Neposielať písma do tlačiarne Adobe PDF“.

  3. V aplikácii Acrobat vyberte položky Ďalšie voľby > Acrobat Distiller.
  4. V zozname Predvolené nastavenia vyberte požadované nastavenie (alebo nechajte predvolenú možnosť).
  5. Vyberte položky Súbor > Otvoriť, v menu Súbory typu vyberte položku Všetky súbory, vyberte súbor PS alebo PRN, ktorý ste vytvorili, a kliknite na tlačidlo Otvoriť.
  6. Zadajte názov a umiestnenie súboru PDF a kliknite na tlačidlo Uložiť.
  7. Otvorte súbor messages.log v nasledujúcom priečinku systému Windows (NT, 2000, XP, Vista, 7): %AppData%\Adobe\Acrobat\Distiller [číslo verzie]

  8. V súbore messages.log vyhľadajte informácie o riešení problému:

    • Ak je v súbore uvedené, prečo aplikácia Acrobat Distiller nemohla vytvoriť súbor PDF, pomocou poľa na vyhľadávanie textu na stránke Vzdelávanie a podpora k aplikácii Acrobat vyhľadajte súvisiace dokumenty. Ak je napríklad v súbore uvedená chyba jazyka PostScript, vyriešte ju podľa odporúčaní v časti Odstraňovanie chýb jazyka PostScript.
    • Ak v súbore nie je uvedené, prečo aplikácia Acrobat Distiller nemohla vytvoriť súbor PDF, vytvorte dokument aplikácie Word, ktorý obsahuje iba niekoľko slov. Potom skúste vytvoriť z tohto dokumentu súbor PDF pomocou tlačiarne Adobe PDF a aplikácie Acrobat Distiller:
    • Ak sa z nového dokumentu dá vytvoriť súbor PDF, problém môže súvisieť s doplnkom PDFMaker. Prejdite na časť Riešenie problémov s doplnkom Acrobat PDFMaker.
    • Ak sa z nového dokumentu nedá vytvoriť súbor PDF, použite súbor z inej aplikácie. Potom skúste vytvoriť súbor PDF pomocou aplikácie Acrobat Distiller. Ak sa problém vyskytne aj pri súbore z inej aplikácie, aplikáciu Acrobat Distiller preinštalujte. Ak sa pri súbore z inej aplikácie problém nevyskytne, tento špecifický problém vyriešte pomocou dokumentov uvedených v časti Súvisiaci obsah. Prípadne vyhľadajte riešenie problému v Pomocníkovi aplikácie Acrobat. Ak potrebujete ďalšiu pomoc, kontaktujte technickú podporu aplikácie Acrobat.

Riešenie problémov s doplnkom Acrobat PDFMaker

Ak sa súbor PDF dá vytvoriť pomocou tlačiarne Adobe PDF alebo aplikácie Acrobat Distiller, ale nie pomocou doplnku Acrobat PDFMaker, problém môže spočívať v doplnku Acrobat PDFMaker. Ak chcete určiť, či problém spôsobuje niektorá z týchto funkcií, vypnite ich. Potom skúste vytvoriť súbor PDF:

  1. V aplikácii Word vyberte položky Adobe PDF > Zmeniť nastavenie prevodu.
  2. V menu Nastavenie prevodu vyberte možnosť Najmenšia veľkosť súboru.
  3. Kliknite na kartu Word a zrušte začiarknutie všetkých políčok.
  4. Kliknite na kartu Záložky a zrušte začiarknutie všetkých políčok.
  5. Kliknite na kartu Zabezpečenie a zrušte začiarknutie všetkých políčok.
  6. Kliknite na tlačidlo OK.
  7. Skúste vytvoriť súbor PDF:
  • Ak sa súbor PDF nedá vytvoriť, prejdite na časť Riešenie problémov špecifických pre konkrétny dokument.
  • Ak sa súbor PDF dá vytvoriť, zistite, ktoré funkcie spôsobujú problém: zapnite jednu funkciu a skúste vytvoriť súbor PDF. Tento postup opakujte, kým sa problém znova nevyskytne. Potom vytvorte dokument aplikácie Word, ktorý obsahuje iba niekoľko slov. Skúste vytvoriť z tohto dokumentu súbor PDF pomocou rovnakých nastavení doplnku Acrobat PDFMaker:
  • Ak sa z nového dokumentu dá vytvoriť súbor PDF, problém je špecifický pre konkrétny dokument. Prejdite na časť Riešenie problémov špecifických pre konkrétny dokument.
  • Ak sa z nového dokumentu nedá vytvoriť súbor PDF, naposledy zapnutá funkcia ďalej spôsobuje problémy. Preinštalujte doplnok Acrobat PDFMaker. Ak problém pretrváva, kontaktujte podporu aplikácie Acrobat

Riešenie problémov špecifických pre konkrétny dokument

Ak zistíte, že problém je špecifický pre konkrétny dokument, riešte ho nasledujúcim spôsobom.

Zapnutie len funkcií doplnku Acrobat PDFMaker používaných dokumentom

Ak napríklad dokument obsahuje len štýly nadpisov Nadpis 1 a Nadpis 2, v dialógovom okne doplnku Acrobat PDFMaker vypnite ostatné štýly nadpisov.

Prepnutie na normálne zobrazenie dokumentu v aplikácii Word a vytvorenie súboru PDF pomocou doplnku Acrobat PDFMaker

Opätovné vytvorenie dokumentu aplikácie Word, aby sa odstránilo prípadné poškodenie

Vykonajte jeden alebo viac z týchto úkonov:

  • Skopírujte a prilepte obsah dokumentu aplikácie Word do nového dokumentu a potom vytvorte súbor PDF.
  • Vyberte všetok text v dokumente, zmeňte jeho písmo a dokument uložte pod novým názvom. Aplikácia Word prepíše dokument, čím sa môžu odstrániť prvky, ktoré sú v konflikte s doplnkom Acrobat PDFMaker. Po uložení dokumentu môžete zmeniť jeho formát pomocou požadovaného písma.
  • Ak bol dokument vytvorený vo verzii aplikácie Word odlišnej od verzie, pomocou ktorej vytvárate súbor PDF, v dokumente urobte malú zmenu. Potom ho uložte pod novým názvom. Tento postup prinúti aplikáciu Word, aby dokument prepísala, čím sa môžu odstrániť prvky, ktoré sú v konflikte s doplnkom Acrobat PDFMaker.

Opätovné vytvorenie všetkých vlastných štýlov nadpisov v dokumente a vytvorenie súboru PDF

Identifikácia konfliktných prvkov v dokumente

  1. Vytvorte dokument aplikácie Word.
  2. Skopírujte polovicu pôvodného dokumentu aplikácie Word do nového dokumentu aplikácie Word.
  3. Preveďte nový dokument aplikácie Word na súbor PDF pomocou doplnku Acrobat PDFMaker.
  • Ak sa problém vyskytne znova, v novom dokumente aplikácie Word existuje konfliktný prvok. S cieľom ďalej izolovať konfliktný prvok zopakujte kroky 1 – 3 a skopírujte polovicu druhého dokumentu aplikácie Word do ďalšieho nového dokumentu aplikácie Word.
  • Ak sa problém nevyskytne, v pôvodnom dokumente aplikácie Word existuje konfliktný prvok. S cieľom ďalej izolovať problém zopakujte kroky 1 – 3 a skopírujte druhú polovicu pôvodného dokumentu aplikácie Word do ďalšieho nového dokumentu aplikácie Word. Ak sa obe polovice dokumentu prevedú správne, zatvorte ostatné spustené programy vrátane aplikácie balíka Office. Odstráňte súbory .tmp (často sa nachádzajú v priečinku Windows/Temp).

Opätovná inštalácia programov

Odinštalujte aplikáciu Acrobat aj balík Office alebo konkrétnu aplikáciu balíka Office (Word, PowerPoint alebo Excel). Znova nainštalujte balík Office alebo konkrétnu aplikáciu balíka Office a potom znova nainštalujte aplikáciu Acrobat.

Na odinštalovanie aplikácie Acrobat použite položku Pridanie alebo odstránenie programov na ovládacom paneli. Pokyny na odinštalovanie balíka Office nájdete v dokumentácii k balíku Office alebo kontaktujte spoločnosť Microsoft.

Odstránenie ochrany dokumentu aplikácie Word, ak je chránený

Pokyny na odstránenie ochrany nájdete v dokumentácii k aplikácii Word alebo kontaktujte spoločnosť Microsoft. 

Riešenie konfliktov s inými makrami v aplikácii Microsoft Word

Doplnok PDFMaker môže byť v konflikte s inými makrami, ako sú napríklad aplikácie na kontrolu vírusov alebo faxový softvér. Ak ostatné pokyny na riešenie problémov zlyhajú alebo má doplnok PDFMaker problémy po nainštalovaní makra tretej strany, vyriešte konflikty s inými makrami. Makrá spôsobujúce nekompatibilitu obsahuje napríklad softvér Duden Korrektor Plus 2.0, ViaVoice 10 a staršie verzie, Personal Translator 2002 Office Plus, OfficeReady Stuffit, Leuchter Informatic AG WordPlus a GoldMine Link to Word.

Ak chcete určiť, či je doplnok PDFMaker v konflikte s iným makrom, ostatné makrá po jednom odstráňte alebo deaktivujte (pozrite si príslušné prepojenie uvedené nižšie). Potom znova skúste previesť dokument na súbor PDF pomocou doplnku PDFMaker. Ak sa problém nevyskytne, kontaktujte výrobcu daného makra.

Riešenie problémov v aplikácii Microsoft Word

Kroky uvedené nižšie sú založené na článkoch databázy Microsoft Knowledge Base:

Ak potrebujete podrobnejšie informácie o riešení problémov s aplikáciou Microsoft Word, navštívte webovú lokalitu spoločnosti Microsoft a vyhľadajte príslušný článok.

Spustenie aplikácie Word pomocou prepínača /a a ručné pridanie doplnku PDFMaker

Prepínač /a spustí aplikáciu Word a zabráni automatickému načítaniu doplnkov a globálnych šablón (vrátane normálnej šablóny). Prepínač /a tiež zamkne súbory nastavenia. To znamená, že pri použití tohto prepínača sa súbory nastavenia nedajú čítať ani upravovať.

Poznámka: Ak aplikáciu Word spustíte pomocou prepínača /a, pri jej ukončení sa stratia všetky zmeny predvolieb, prispôsobenia a makrá.

Spustenie aplikácie Word pomocou prepínača /a:

  1. Ukončite všetky programy.
  2. Vyberte položky Štart > Spustiť.
  3. V dialógovom okne Spustiť zadajte príkaz winword.exe /a.
  4. Kliknite na tlačidlo OK. Dialógové okno Spustiť sa zatvorí a spustí sa aplikácia Word.

Ručné načítanie doplnku PDFMaker (len pri verzii Acrobat 6.x):

  1. Ukončite všetky programy.
  2. Vyberte položky Nástroje > Šablóny a doplnky.
  3. Vyberte súbor PDFMaker.dot (nie PDFMakerA.dot) a kliknite na tlačidlo OK.

    Zobrazia sa ikony doplnku PDFMaker.

Aplikácia Acrobat 7.x, 8.x, 9.x, X (ak je to použiteľné) 

Ručné načítanie doplnku PDFMaker (MS Word 2003 alebo staršia verzia):

  1. Ukončite všetky programy.
  2. Vyberte položky Nástroje > Prispôsobiť a kliknite na kartu Príkazy.
  3. Na paneli Kategórie kliknite na položku Nástroje.
  4. Držte stlačené tlačidlo myši a potiahnite položku Doplnky architektúry COM z panela Príkazy do menu Nástroje. Keď sa zobrazia príkazy menu Nástroje, potiahnite položku Doplnky architektúry COM pod položku Prispôsobiť a uvoľnite tlačidlo myši.
  5. Kliknite na tlačidlo Zatvoriť.
  6. Kliknite na položku Doplnky architektúry COM v menu Nástroje.
  7. Kliknite na tlačidlo Pridať, vyhľadajte doplnok (doplnok PDFMaker sa nachádza v súbore [Inštalačná cesta aplikácie Acrobat]\PDFMaker\Office\PDFMOfficeAddIn.dll) a kliknite na tlačidlo OK.

  8. Stlačením klávesov Alt + F11 spustite editor jazyka Visual Basic.
  9. Stlačením klávesov Ctrl + G zobrazte okno Hodnoty editora jazyka Visual Basic.
  10. Na spustenie doplnku PDFMaker v aplikácii Word zadajte text Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True. Zatvorte editor jazyka Visual Basic.
  11. Skontrolujte, či sa na paneli s menu aplikácie Microsoft Word zobrazilo menu Adobe PDF napravo od menu Pomocník.

Ručné načítanie doplnku PDFMaker (MS Word 2007 a 2010):

  1. Ukončite všetky programy.
  2. Kliknite na tlačidlo Microsoft Office a potom na tlačidlo Možnosti aplikácie Word.

  3. Kliknite na položku Doplnky.

  4. V zozname Spravovať kliknite na položku Doplnky architektúry COM a potom kliknite na tlačidlo Spustiť.

  5. Ak je v dialógovom okne Doplnky architektúry COM zobrazený a vybratý doplnok Acrobat PDFMaker COM, postupujte nasledujúcim spôsobom. V opačnom prípade prejdite na krok 6.

  6. Kliknutím zrušte začiarknutie políčka Acrobat PDFMaker COM.

  7. Kliknutím na tlačidlo OK zatvorte dialógové okno Doplnky architektúry COM.

  8. Zopakujte kroky 1 až 3 a potom kliknutím začiarknite políčko Acrobat PDFMaker COM v dialógovom okne Doplnky architektúry COM.

  9. Skontrolujte, či sa na páse s nástrojmi aplikácie Word zobrazila karta Acrobat.

  10. Ak doplnok Acrobat PDFMaker COM NIE JE zobrazený v dialógovom okne Doplnky architektúry COM, vykonajte kroky 7 až 10 v časti Ručné načítanie doplnku PDFMaker (MS Word 2003 alebo staršia verzia)

Vytvorenie testovacieho dokumentu aplikácie Word a spustenie doplnku PDFMaker: 

  1. V dokumente aplikácie Word zadajte nejaký text.
  2. Vyberte položky Súbor > Uložiť a uložte testovací dokument na pracovnú plochu.
  3. Kliknite na tlačidlo Previesť do Adobe PDF.

Ak problém vyriešite spustením aplikácie Word pomocou prepínača /a, odstráňte všetky komponenty, ktoré sa načítavajú počas spúšťania aplikácie Word. Tieto komponenty odstraňujte po jednom v poradí, v akom sú zobrazené v aplikácii Word. Počas spúšťania aplikácie Word sa načítavajú nasledujúce komponenty:

  • Automatické makrá aplikácie Word
  • Globálna šablóna (Normal.dot)
  • Doplnky (WLL)
  • Šablóny v spúšťacom priečinku aplikácie Word a balíka Office
  • Doplnky architektúry COM
  • Kľúč Data aplikácie Word v databáze Registry systému Windows
  • Kľúč Options aplikácie Word v databáze Registry systému Windows
  • Automatické makrá aplikácie Word

Poznámka: Informácie o riešení problémov so spúšťaním aplikácie Word nájdete v nasledujúcich službách podpory produktov spoločnosti Microsoft:

Premenovanie súboru šablóny Normal.dot

Pokyny na premenovanie súboru globálnej šablóny nájdete v časti „Globálna šablóna (Normal.dotm alebo Normal.dot)“ v článku podpory spoločnosti Microsoft Obnovenie používateľského nastavenia a nastavenia databázy Registry v aplikácii Word. Na stránke sa posuňte nadol.

Dôležité: Po vykonaní týchto krokov nepoužite pri opätovnom spustení aplikácie Word prepínač /a.

Ak problém vyriešite premenovaním globálnej šablóny, problém spôsobovala poškodená šablóna Normal.dot. Na obnovenie vášho nastavenia je niekedy potrebné zmeniť niekoľko nastavení. Ak súbor Normal.dot, ktorý ste premenovali, obsahuje prispôsobenia, ako sú napríklad štýly, makrá alebo položky automatického textu, ktoré sa nedajú jednoducho opätovne vytvoriť, skúste použiť Organizátora na skopírovanie týchto prispôsobení zo starého súboru Normal.dot do nového súboru Normal.dot.

Ďalšie informácie o používaní Organizátora získate vykonaním týchto krokov:

  1. Spustite aplikáciu Word.
  2. Vyberte položky Pomocník > Pomocník aplikácie Microsoft Word.
  3. V Asistentovi balíka Office alebo Sprievodcovi odpoveďami zadajte text Organizátor.

  4. Kliknite na tlačidlo Hľadať a zobrazia sa nájdené témy.

Ak problém nevyriešite, zvážte použitie starej globálnej šablóny (Normal.dot) namiesto novej globálnej šablóny. Ak chcete použiť starú šablónu Normal.dot, premenujte novú šablónu Normal.dot späť na Normal.dot. Ak problémy s doplnkom PDFMaker pretrvávajú aj po práci s týmto dokumentom, kontaktujte podporu aplikácie Acrobat.

Licencia na používanie tohto diela sa poskytuje v súlade s podmienkami licencie Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Na príspevky v sociálnych sieťach Twitter™ a Facebook sa nevzťahujú podmienky licencií Creative Commons.

Právne upozornenia   |   Zásady ochrany osobných údajov online