User Guide Cancel

Workspace basics

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Customize your workspace in InDesign
      3. Toolbox
      4. Set preferences
      5. Properties panel
      6. Touch workspace
      7. Default keyboard shortcuts
      8. Document recovery and undo
    3. Generative AI
      1. Text to Image
      2. Generative AI FAQ
  3. Create and layout documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Convert PDFs to InDesign files in InDesign (Beta)
      7. Create book files
      8. Add basic page numbering
      9. Number pages, chapters, and sections
      10. Convert QuarkXPress and PageMaker documents
      11. Share content
      12. Understand a basic managed-file workflow
      13. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
      2. Align and distribute objects using rulers
      3. Measure objects using the Measure tool
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. South-East Asian Scripts
      4. Arabic and Hebrew features in InDesign
      5. Create type on a path
      6. Bullets and numbering
      7. Glyphs and special characters
      8. Text composition
      9. Text variables
      10. Generate QR codes
      11. Edit text
      12. Align text
      13. Wrap text around objects
      14. Anchored objects
      15. Linked content
      16. Format paragraphs
      17. Format characters
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Auto Style text
      3. Work with Style Packs
      4. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Spell check and language dictionaries
      1. Check spelling, autocorrect, and dynamic spelling
      2. Create, add, and manage dictionaries and words
      3. Change dictionary preferences
      4. Duden dictionary
    6. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    7. Styles
      1. Paragraph and character styles
      2. Map, export, and manage styles
      3. Object styles
      4. Drop caps and nested styles
      5. Work with styles
      6. Leading
    8. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    9. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
    10. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Frames and objects
      10. Align and distribute objects
      11. Linked and embedded graphics
      12. Integrate AEM assets
    11. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Understand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Find and replace
    1. Find and replace text
    2. Find and replace fonts
    3. Find and replace glyphs
    4. Find and replace using GREP expressions and queries
    5. Find and replace objects
    6. Find and replace colors
    7. Search options to find and replace
  6. Share
    1. Save and access cloud documents
    2. Organize, manage, and share cloud documents
    3. View and manage versions in cloud documents
    4. Common questions about InDesign cloud documents
    5. Share and collaborate        
    6. Share for Review
    7. Review a shared InDesign document
    8. Manage feedback 
  7. Publish
    1. Place, export, and publish
      1. Publish online
      2. Publish online dashboard
      3. Copy, insert graphics
      4. Export content for EPUB
      5. Adobe PDF options
      6. Export content to HTML
      7. Export to Adobe PDF
      8. Export to JPEG format
      9. Export HTML
      10. DPS and AEM Mobile overview
      11. Supported File Formats
      12. Export and import User Settings
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  8. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting
  9. Troubleshooting
    1. Fixed issues
    2. Known issues
    3. Crash on launch
    4. Preference folder read-only issue
    5. Troubleshoot file issues
    6. Unable to export PDF
    7. InDesign document recovery

Learn the basics of workspace in InDesign for efficient design workflows and panel organization.

To create and manage documents in Adobe Creative Cloud applications, you can use various elements, such as panels, bars, and windows. Any arrangement of these elements is called a workspace. These workspaces share a consistent appearance for easy application switching. You can customize them to suit your workflow by selecting preset options or creating your own.

Home screen

The Home screen appears when you launch InDesign or have no documents open. Use it to access tutorials, create documents, or open existing ones.

Start workspace
Home screen

The Home screen has the following tabs and buttons:

New file

Select this button to create a new document. You can create a document by selecting one of the numerous templates and presets available in InDesign.

Open

Select this button to open an existing document in InDesign.

Home

Select this tab to view the files that you've recently modified.

Learn

Select this tab to open a list of basic and advanced tutorials on InDesign to get started with the application.

Note:

To disable the Home screen from the Preferences dialog, deselect Show Home Screen When No Documents Are Open (Preferences > General). The keyboard shortcuts Ctrl/Cmd + O and Ctrl/Cmd + N continue to be available for use.

Workspace overview

The workspace in InDesign provides a customizable layout for windows, panels, and tools that allows you to create a personalized design environment.

workspace
Default InDesign workspace

A. Tabbed Document windows B. Workspace switcher C. Search bar with autocomplete suggestions D. Panel title bar E. Collapse To Icons button F. Panel groups in vertical dock G. Status bar H. Tools panel 

  • The Application frame integrates all workspace elements into one window, ensuring they function as a unified unit. Resizing or moving the frame and its elements triggers responsive adjustments to prevent overlapping. Panels remain visible when switching or clicking outside the application. If you're working with multiple applications, you can arrange them side by side or across multiple monitors. On macOS, the traditional user interface can be enabled or disabled by selecting Window > Application Frame.
  • The Application bar across the top contains a workspace switcher, menus (Windows only), and other application controls. On macOS, the application bar is available only when the Application frame is off. You can toggle it on or off using the Window menu.
  • The Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related tools are grouped.
  • The Control panel displays options for the currently selected object.
  • The Document window displays the file you’re working on. Document windows can be tabbed and, in certain cases, grouped and docked.
  • Panels help you monitor and modify your work. Panels can be grouped, stacked, or docked.
  • The Application frame groups all the workspace elements in a single, integrated window that lets you treat the application as a single unit. When you move or resize the Application frame or any of its elements, all the elements within it respond to each other so none overlap. Panels don’t disappear when you switch applications or when you accidentally click out of the application. If you work with two or more applications, you can position each application side by side on the screen or on multiple monitors. If you are using a Mac and prefer the traditional, free-form user interface, you can turn off the Application frame. Select Window > Application Frame to toggle it on or off.
  • The Application bar across the top contains a workspace switcher, menus (Windows only), and other application controls. On Mac, the application bar is available only when Application frame is off. You can toggle it on or off using the Window menu.
  • The Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related tools are grouped.
  • The Control panel displays options for the currently selected object.
  • The Document window displays the file you’re working on. Document windows can be tabbed and, in certain cases, grouped and docked.
  • Panels help you monitor and modify your work. Panels can be grouped, stacked, or docked.

Change screen modes

To modify the document window visibility, choose View > Screen Mode menu. When the toolbox is in a single column, select the current mode button to access and choose different modes from the menu.

Normal Mode  

Displays artwork in a standard window with all visible grids and guides showing, non-printing objects showing, and a white pasteboard.

Preview Mode  

Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects) and the pasteboard set to the preview background color defined in Preferences.

Bleed Mode  

Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects), the pasteboard set to the preview background color defined in Preferences, and any printing elements within the document's bleed area (defined in Document Setup) showing.

Slug Mode  

Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects), the pasteboard set to the preview background color defined in Preferences, and any printing elements within the document's slug area (defined inDocument Setup) showing.

Presentation Mode  

Displays artwork as if it were a slideshow presentation, with no menus, panels, or tools displayed. See Use Presentation Mode.

Use the status bar

The lower left status bar in the document window provides file information and enables page navigation. Access its menu to:

  • Reveal the file in the file system (Windows) Reveal In Explorer, or (macOS) Reveal In Finder).
  • Reveal the file in Adobe Bridge (Choose Reveal in Bridge).
Note:

In macOS, you can display the zoom percentage in the status bar by hiding the application bar (Window > Application Bar). In Windows, you cannot hide the application bar.

Control panel overview

The Control panel (Window > Control) provides easy access to options, commands, and related panels for selected page items. It is initially docked at the top but can be docked at the bottom, converted to a floating panel, or hidden.

The Control panel shows different options based on your selection:

  • Frames: Resize, reposition, skew, rotate or apply object styles.
  • Text: Character or paragraph options. Select the icons on the left to switch between them.
  • Tables: Adjust dimensions, merge cells, align text, and add strokes.

As the options in the Control panel change, you can get more information about each option by using Tooltips.  Tooltips are the pop‑up descriptions that appear when you hover over an icon or option label with the pointer. To open dialog boxes associated with Control panel icons, Alt‑click (Windows) or Option‑click (macOS) as you select a Control panel icon. 

control panel menu
Control panel menu

Control panel with tool tip displayed
Control panel with tool tip displayed

Use context menus

Context-sensitive menus show tool or selection-related commands, unlike the top screen menus. They provide a convenient option for accessing commonly used commands quickly. To use it, hover the pointer over the document, object, or panel, and right-click the mouse.

Note:

(macOS) If you don’t have a two-button mouse, you can display a context menu by pressing the Control key as you click with the mouse.

Change Interface preferences

To change the Interface Preferences, choose Edit > Preferences > Interface (Windows) or InDesign > Preferences > Interface (macOS).

Specify the following settings:

Color Theme

Select the color theme for InDesign interface. Choose from Dark, Medium Dark, Medium Light, or Light Color Theme.

Match Pasteboard To Theme Color

Select this option to match pasteboard color with the theme color of interface.

Tool Tips

Tool tips appear when you hold the pointer over interface items such as tools in the toolbar and options in the Control panel. Choose None to turn off tool tips.

Show Thumbnails on Place

When you place a graphic, a thumbnail of the image appears in the loaded graphics cursor. Similarly, a thumbnail of the first few lines of text appears in the loaded text cursor. Deselect this option if you don’t want thumbnails to appear when placing graphics or text.

Show Transformation Values

When you’re creating, sizing, or rotating an object, the cursor displays the [x,y] coordinates, width and height, or rotation information.

Enable Multi-Touch Gestures

Select this option to allow Windows and Mac OS multi-touch mouse gestures to work in InDesign. For example, when you use the Magic Mouse in Mac OS, the swipe gesture scrolls up or down or moves to the previous or next page or spread, and the rotate gesture rotates the spread.

Highlight Object Under Selection Tool

Select this option to highlight the frame edges of objects when the direct selection tool is moved over it.

Floating Tools Panel

Specify whether the toolbar appears as a single column, double column, or single row.

Auto-Collapse Icon Panels

When this option is selected, clicking the document window closes the open panel automatically.

Auto-Show Hidden Panels

When you hide panels by pressing Tab, holding the pointer over the side of the document window temporarily reveals the panels if this option is selected. If this option is not selected, you must press Tab again to display panels.

Open Documents As Tabs

When this option is deselected, documents you create or open appear as floating windows rather than tabbed windows.

Enable Floating Document Window Docking

If this option is selected, you can dock floating documents with each other as tabbed windows. If this option is deselected, floating document windows aren’t docked with other document windows, unless you hold down Ctrl (Windows) or Command (Mac OS) while dragging.

Large Tabs

Select this option to increase the height of panel and document tabs.

Hand Tool

To control whether to greek text and images when you scroll a document, drag the Hand Tool slider to the desired level of performance versus quality.

Live Screen Drawing

Select an option to determine whether the image redraws as you drag an object.

  • Immediate: The image redraws while you drag. 
  • Never: Dragging an image moves only the frame, and then the image is moved when you release the mouse button. 
  • Delayed: The image redraws only if you pause before dragging.

Greek Vector Graphics On Drag

Select this to increase the speed of a complex vector object's movement.

You can directly access the content in AEM Assets without logging into AEM Assets. Adobe Asset Link is installed as an extension in the InDesign application. Your IT admin has to configure and deploy the panel. Once installed and configured, choose Window > Extensions > Adobe Asset Link.

For easy access, you can configure your workspace to include the Adobe Asset Link panel and manage it.

More like this

Have a question or an idea?

Ask the Community

We would love to hear from you. Share your thoughts with the Adobe InDesign Community

 Adobe

Get help faster and easier

New user?