The Graphics workspace and Essential Graphics panel in Premiere Pro provides a powerful workflow that allows you to create titles, graphics, and animations directly within Premiere Pro.

Note:

You can also use the Essential Graphics panel to customize Motion Graphics templates (.mogrt files) that have been created in After Effects or Premiere Pro. For more information on Motion Graphics templates, see Using Motion Graphics templates in Premiere Pro

Access the Graphics workspace and the Essential Graphics panel

To access the Graphics workspace: Click Graphics in the workspace bar at the top of the screen or select Window > Workspaces > Graphics from the main menu.

To access the Essential Graphics panel: By default, the Essential Graphics panel is a part of the Graphics workspace. However, if you do not see it, you can directly open it by clicking Window > Essential Graphics.

Parts of the Essential Graphics panel

Essential Graphics panel
Essential Graphics panel

A. Browse tab B. Edit tab 

Browse

Use this tab to browse Motion Graphics templates (.mogrt files) in Adobe Stock. These are professionally designed templates you can easily drag to your timeline and customize. Adobe Stock is a marketplace for video footage, Motion Graphics templates, photos, and more. For more information, see Browsing and managing Motion Graphics templates.

Edit

Use this tab to:

  • Align and transform layers, change appearance properties, edit text properties and more.
  • Add keyframes to your Premiere Graphics (prgraphics)
  • Modify exposed properties for your After Effects Graphics (aegraphics)

Create graphics

Premiere Graphics can contain multiple text, shape and clip layers, similar to layers in Photoshop. Multiple Layers can be contained inside a single Graphic track item in your sequence. When you create a new layer, a graphic clip containing that layer is added to your timeline, starting at the playhead location. If you already have a graphic track item selected then the next layer you create gets added to the existing graphic clip.

Any graphics you create in Premiere Pro can be exported as a Motion Graphics Template (.mogrt) to Local Templates Folder, Local Drive, Creative Cloud libraries for sharing or reuse.

Note:

You can create Graphic Layers even if the sequence does not yet contain any video clips.

Create text layers

Create a title using the Type tool in the Program Monitor or the New Layer > Text commands in the Graphics Menu.

Viewing time: 1 minutes 28 seconds


 To create a text layer in Premiere Pro, do the following:

  1. Select the Type Tool (T) or Vertical Type Tool from the tools panel. 

  2. Click the Program Monitor where you want to position your text, and start typing. A single click creates text on a point. A click drag creates text in a box, which allows the text to wrap automatically within the border of the box. 

  3. Use the Selection Tool (V) to manipulate text and shape layers directly in the Program Monitor. You can adjust the position of a layer and rotate it. You can also change the anchor point and scale of a text layer as well as the dimensions of a text in a box.

    Note:

    Make sure that the text tool is deselected. If not, you will create an extra text layer. Before making further changes using Direct Manipulation, make sure to select the Selection Tool.

  4. Adjust the appearance of your text using the Edit tab of the Essential Graphics panel. 

    Create text layer
    A. Align and Transform B. Text C. Fill D. Stroke 

    Some of the properties you can edit are:

    • Text styles: Change the font of your selected text by selecting a font from the drop down list. You can also change a Font Style of your text (such as Bold or Italic). If a font doesn’t include the style you want, you can apply faux styles—Faux Bold, Faux Italics, All Caps, Small Caps, Superscript, Subscript and Underline.
    • Fill: Change the color of text by selecting the text, clicking the Fill/Stroke swatch in the Appearance section of the Essential Graphics panel, and choosing a color.
    • Stroke: Change the stroke (border) of the text by choosing the text, clicking the Stroke color and choosing a color. You can also change the stroke width, stroke styles or add multiple strokes to your text and create cool effects. For more information, see Create multiple strokes.
    • Background: Change the background of the text by choosing the text, and clicking the Background color option. You can then adjust the opacity and size of the background. If you don't want any background for the text, deselect the Background option. 
    • Shadow: Change the shadow of the text by choosing the text, and clicking the Shadow color option. You can then adjust various shadow properties such as distance, angle, opacity, size, and blur.

Replace fonts in projects

You can replace fonts in a project, updating all fonts simultaneously instead of updating them individually. For example, if you have a graphic with multiple layers of text and you decide to change the font, you can use the Replace Fonts in Projects command to change the font of all the layers simultaneously.

  1. Select Graphics > Replace Fonts in Project.

  2. The Replace Fonts in Projects window panel opens containing a list of fonts used in the project.

  3. Under Replacement Font, type in the font you want to replace with.

    Note:

    Replace Fonts will replace all instances of the chosen fonts across all sequences and all open projects. It is not just for changing fonts for all layers in one Graphic.

    Replace Fonts in projects
    Replace Fonts in projects
  4. Once the Replacement Font has been selected, click OK.

Create shape layers

Premiere Pro has a Pen Tool, a Rectangle Tool, and an Ellipse Tool for creating free-form shapes and paths. 

Note:

Only the pen tool creates free shapes, but it can be used to modify a rectangle or ellipse into a more irregular shape.

  1. Click and hold on the Pen tool to expose the Rectangle and Shape tools. Then, select the desired shape tool from the toolbar and draw a shape.

    Note:

    Hold down the shift key while dragging to create a shape with locked dimensions such as a square or circle.

    Create shape layer
    Create shape layer

    A. Align and Transform B. Fill C. Stroke D. Shadow 
  2. Use the Selection tool (V) to directly manipulate your shape, including change the position, scale, rotation, and Anchor point. 

  3. The Pen tool (P) can be used to manipulate the vertices and handles of a shape.

  4. Adjust the appearance of shapes using the Edit tab of the Essential Graphics panel.

Create clip layers

You can add still image and video clips as layers within your graphic. You can create clip layers using one of the following methods:

  • In the Edit tab of the Essential Graphics panel, select the New Layer icon and choose From File.
  • In the application menu bar, select Graphics > New Layer > From File.
  • Select a still image or a video item in your Project panel. Drag and drop that item into the Layers panel of the Essential Graphics panel or onto an existing Graphic in your Timeline.

Note:

Make sure that the graphic is selected in the Program Monitor. If the graphic is not selected, the options are not available.

Also note that there are various Editable properties for each type of selected layer, multiple selected layers, and for whole Graphics (Graphic is selected but no layers are).

Add Responsive Design features to your graphics

Responsive Design for Motion Graphics makes it possible to design rolls and graphics that adjust to changes in duration and layer positioning.

Responsive Design - Position

You can design your graphics to automatically adapt to changes in the video frame aspect ratio, or to the position or scale properties of another graphic layer. For example, you might want an underlying shape layer to respond to the width, height and position of your text.

Small blue pins on the Program Monitor indicate whether the currently selected layer is pinned to another layer.

To define spatial relationships between layers:

  1. Select a Graphic in your timeline and navigate to the Edit tab of the Essential Graphics panel.

  2. Select a layer that you want to make responsive to the changes in another layer.

  3. Under Responsive Design – Position > Pin To, specify which layer the currently selected layer should be pinned to.

    The currently selected layer gets parented by the layer you choose from the drop-down list.

  4. To define which edges the child layer should be pinned to, use the diagram on the right side  - Top, Bottom, Left or Right of the parent. You can also click the center of the diagram to pin to all edges or unpin from all edges.

    For example, you have a rectangle containing text. If you pin the rectangle to the text, the text responds automatically to any change in the rectangle.

    Note:

    Use the square in the center to quickly toggle on or off pinning for all edges.

  5. The selected layer now responds in position, length/width, and scale based on changes to its parent layer. When you select this layer in the program monitor, its parent layer displays small blue pins on the pinned edges. 

    Set responsive design - osition
    Set responsive design - position

Responsive Design - Time

Create rolls

You can create title or credit rolls that move vertically over the screen by enabling Roll. When Roll is enabled, you see a translucent blue scroll bar in the Program Monitor.

This Document View scroll bar allows you to scroll the text and graphics in your credit roll for easier editing. You do not have to move the playhead in the timeline to a specific position.

Note:

The duration of the Roll-enabled Graphic and the combined height of all that Graphic's layers determine the speed of the roll. 

To enable rolls for your graphics:

  1. Select a Graphic in your timeline and navigate to the Edit tab of the Essential Graphics panel.

    Enable rolls
    Enable rolls
  2. Make sure that the graphic you selected has none of its individual  layers selected.

    Note:

    Make sure that the text layer in the Program monitor is deselected. If one or more layers are selected in the Program Monitor, the Roll option is not visible.

  3. Select the check-box next to Roll to enable credit rolls.

  4. Specify whether or not you want your text or other layers to start or end offscreen.

  5. Adjust the timing for Preroll, Postroll, Ease in, and Ease out using the timecode for each property.

    Roll scroll bar
    Roll scroll bar

Preserve Intro and Outro Animation

You can define segments of your graphics that preserve intro and outro keyframes, even when the overall duration of the graphic changes. Keyframes that fall within the intro and outro time ranges are protected when the Graphic is trimmed in or out. With these keyframes protected, you can trim your graphic clip and still preserve intro and outro animations. Keyframes that fall between intro and outro regions will be stretched or compressed as needed to fit.

A transparent white overlay on your Graphic in the timeline and in the Effect Controls panel indicate the intro and outro segments of the clip. These segments can be defined either in the Essential Graphics panel or in the Effect Controls panel. 

Set responsive design - time
Set responsive design - time

Define intro and outro segments and preserve animations using the Essential Graphics panel

  1. Select the graphic in your timeline and navigate to the Edit tab of the Essential Graphics panel.

  2. Make sure that the graphic that you selected has none of its individual layers selected.

  3. Under Intro duration, specify the amount of time that you want to define as the intro/entrance section using the timecode controls.       

  4. Under outro duration, specify the amount of time that you want to define as the outro/exit section using the timecode controls.

Define intro and outro segments and preserve animations using the Effect Controls panel

  1. Select the graphic in your timeline and navigate to the Effect Controls panel.

  2. At the top of the Effect Controls panel is a small blue handle at the beginning and end of the selected clip.

  3. Drag the left handle out to define the intro/entrance segment. You see a grey overlay that covers the keyframes that fall within the specified time range.

  4. Drag the right handle out to define the outro/exit segment. You see a transparent white overlay that covers the keyframes that fall within the specified time range.

Specify intro and outro duration using keyboards shortcuts

You can set keyboard shortcuts for specifying Intro and Outro duration using the keyboard shortcut map. Go to Edit > Keyboard Shortcuts (Windows) or Premiere Pro > Keyboard Shortcuts(macOS). These keyboard shortcuts are not assigned by default. These commands are used to assign keyboard shortcuts:

  • Set Intro End
  • Set Outro Start

To use your keyboard shortcuts for Intro and Outro duration:

  1. Select the graphic clip in the timeline for which you want to preserve an intro or outro animation.

  2. Position the playhead to the position that you want to set the Intro or Outro setting and click the keyboard shortcut that was assigned.

Note:

The keyboard shortcuts are enabled only when the timeline is selected.

Manipulate graphic layers

Align and distribute graphic layers

You can select multiple layers within a graphic clip and align or distribute them in the Essential Graphics Panel.

You can align layers by their top edges, vertical centers, bottom edges, left edges, horizontal centers, or right edges. You can also distribute layers vertically or horizontally.

Select the graphic and click the align icons in the Edit tab of the Essential Graphics panel.

Options to align and distribute layers in the Essential Graphics panel
Options to align and distribute layers in the Essential Graphics panel

Note:

When you have only one layer selected, using the align buttons aligns the shape or text layer to the video frame. When you have two or more layers selected, the buttons align the layers in relation to each other.

Distribute commands are unavailable until three or more layers are selected.

Group text and shape layers

Grouping text and graphic layers is useful when working with complex text and graphic elements. Grouping layers keeps the Edit tab of the Essential Graphics panel uncluttered, and is also useful when you want to create cool masking effects.

  1. Select multiple layers in the Essential Graphics panel.

  2. Do one of the following:

    • Click the Create Group icon at the bottom of the Edit section of the Essential Graphics panel.
    • Right-click the selected layers and select Create Group from the context menu.
    Creating groups using the Create Group icon or the context menu
    Creating groups using the Create Group icon or the context menu
  3. To add layers to a group, do one of the following:

    • Drag a layer to the group folder.
    • Drag a group folder into another group folder. The group and all of its layers move.
  4. To ungroup layers, select the layers and move them out of the group.

Rename layers

Premiere Pro supports inline name editing. Shape layers and clip layers can be renamed in the Essential Graphics Panel. To rename a layer in the Essential Graphics Panel, do the following:

  1. Click on the name of the layer.

  2. Edit the name in the text field.

    Inline rename layer
    Inline rename layer
  3. To save the new name, do one of the following:

    • Click Enter.
    • Click away from the text field.

Note:

Inline name editing does not work for text layers because the name of the text layer is the text shown in the Program Monitor.

Alternately, you can right-click on a shape or clip layer in the Essential Graphics Panel. Select Rename from the pop-up list. Type a new name in the text field and click OK.

Rename layer
Rename layer

Create Master Styles and Graphics

Create Master Styles

Master Styles allow you to define text properties such as font, color, and size as styles. This feature enables you to apply the same style quickly across multiple layers in different graphics in your timeline.

Once you apply a Master Style to a graphic clip or to a text layer within a graphic clip, the text automatically inherits all changes from the Master Style. You can change multiple graphics at once.

Creating Master Style
Creating Master Style

To create a Master Style:

  1. Select the graphic clip in your timeline and navigate to the Edit tab of the Essential Graphics panel.      

  2. Select a text layer and give it the stylistic properties that you want for font, size, and appearance.

  3. When you have the desired look, under the Master Styles section from the drop-down list, select Create Master Text Style.

  4. Name your text style and click OK.

  5. The Master Style appears in your project panel and is available in the Master Style drop-down list. You can then apply this style to other text layers and graphic clips in your project.

    Applying Master Styles on Graphics
    Applying Master Styles on Graphics

When you create a Master Style, a thumbnail image of the style gets added to your project panel. To update all the text layers in a Graphic at once, drag the Master Style item from the Project Panel and drop it onto a Graphic in the Timeline.

You can also update individual text layers of a title to a particular style by selecting the text layer in the Essential Graphics panel. Then, choose the desired Master Style from the drop-down list.

Note:

Align and Transform properties are not included as part of Master Styles.

Create Master Graphics

You can use the Upgrade to Master Graphic option to create a Master Clip item in your Project Panel from a graphic clip in your sequence.

Any new graphics made from a Master Graphic, including the one you upgraded from, are always exact duplicates of each other. This include the source text string. Any changes made to the text, style, or contents in an instance of a Master Graphic get reflected in all other instances of the Master Graphic.

To create a Master Graphic, select Graphics > Upgrade to Master Graphic.

Change stroke styles

Lines and shapes that you draw in the Essential Graphics panel have a solid line by default

Create Stroke Styles

  1. Select the layer in the Essential Graphics Panel, and navigate to the Edit tab.

  2. Select the wrench icon under Appearance. You can also select the hamburger icon  next to the Essential Graphics Panel.

    Graphic Properties
    Graphic Properties
  3. The Graphics Properties dialog box opens. Configure the following fields:

    • Line Join – Line Join sets the lines to miter, round, or bevel.
    Line Join
    Line Join
    • Line Cap – Line Cap sets the caps of lines to butt, round, or square.
    Line Cap
    Line Cap
    • Miter – Miter limit defines the maximum miter length before a miter join turns into a bevel. The default miter limit is 2.5.
    Miter
    Miter

    Note:

    Miter is only enabled if the Line Join attribute is set to miter. It is the distance between the inner corner and the outer corner where two lines meet.

  4. Once the stroke style has been set, click OK.

Note:

Instead of setting Stroke Styles for each layer, you can set a global behavior under Text Properties of the Essential Graphics Panel. Text properties are found in the Essential Graphics Panel's spanner menu. Although settings applied from the wrench menu under Appearance, overrides the global settings temporarily.

Create multiple strokes

You can create multiple strokes for the same object. Adding multiple strokes to an object is the basis for creating many interesting effects. For example, you can create a second, narrower stroke on top of a wide stroke to make the text or shape more vibrant.

How to Create a Multiple Strokes Text Effect in Premiere Pro
Caroline Sears

  1. Select a text or shape object, or a layer in the Essential Graphics panel.

  2. Enable stroke for layer by clicking on the checkbox next to Stroke. Click the + icon next to Stroke in the Appearance section of the Essential Graphics panel.

    Adding multiple strokes
    Adding multiple strokes
  3. Set the color and stroke width properties of the stroke.

    Here's a GIF illustrating how you can use this feature to create cool title effects.

    Creating cool titles using multiple strokes
    Creating cool titles using multiple strokes

Create mask layers

You can use masks to create dynamic transitions, reveals, and wipe animations in Premiere Pro titles by converting text and shape to mask layers. Masks hide portions of a layer and reveal other portions of the layers below the graphic in the Essential Graphic panel layer stack.

  1. Select a text or graphics layer in the Edit tab of the Essential Graphics panel.

  2. Select the Mask with Shape or Mask with Text check box in the Appearance section of the Essential Graphics Panel. 

    Mask with Text
    Mask with Text
    Mask with Shape
    Mask with Shape

    Premiere Pro creates a mask of that layer and renders everything outside the layer transparently, revealing the layers below it. 

    If you have created layer groups, then when you select a layer to mask, the mask is applied only for the other layers in that group. The mask does not extend to layers outside the group.

    Example of the type of effect you can create using masked layers
    Example of the type of effect you can create using masked layers
  3. Select Invert if you want everything visible outside the layer and transparent within the layer.

Check out the examples and sample files to learn how you can create fun reveal animations using masking techniques.

Animate layers in your graphics

You can animate text layers, shape layers, and paths using keyframes. You can add animation directly from within the Essential Graphics panel, or by using the Effect Controls panel.

Animating using the Essential Graphics panel

To add animation to your graphics using the Essential Graphics panel:

  1. Select the layer you want to animate in the Essential Graphics panel.

  2. Click the icon next to the property you want to animate (Position, Anchor Point, Scale, Rotation, or Opacity).

    This action toggles on animation for the property. The icon for the selected property turns blue to indicate that animation is active.

    Toggle animation for graphic layers
    Toggle animation for graphic layers

    Note:

    Clicking the icon in Essential Graphics panel is the same as clicking the Stopwatch in Effect Controls panel. If you toggle on animation in one location, it appears active in the other view too.

    With animation toggled on in the Essential Graphics panel, each time you change the animated property, a new Keyframe is added to the Essential Graphics panel or Timeline.

  3. Move your playhead and adjust this property in the Essential Graphics panel or directly in the Program Monitor to record the keyframes.

  4. Refine your animation using the Effect Controls panel or by adjusting the keyframes in your timeline using the Show Clip Keyframes option.

Animating using the Effect Controls panel

To add animation to your graphics using the Effect Controls panel:

  1. Locate the layer you want to animate in the Effect Controls panel.

  2. To toggle animation for the desired property, click the Stopwatch icon.

  3. To achieve the effect you want, click Add/Remove keyframes

  4. To access interpolation settings such as Bezier curves and Ease In/Ease Out, right click a keyframe.

Edit and transform vector graphics

You can edit and transform vector graphics without rasterizing them using vector motion controls. It prevents pixelation and eliminates boundaries caused by undesired cropping.

You can edit vector graphics directly from within the Essential Graphics panel, or by using the Effect Controls panel.

  1. Double click in the Program Monitor to apply changes to the whole graphic using Vector Motion.

    Make sure that you do not double click on a Layer in the Program Monitor. That will select the layer for direct manipulation and not the whole graphic.

  2. You can apply changes to the whole graphic using Vector Motion in the Effect Controls panel. You can also use Motion, but this change rasterizes graphics and pixelates them when scaled.

    Note:

    To remove pixelated text, remove existing keyframes. Re-create the animation using Vector Motion.

  3. You can edit parameters for Position, Scale, Rotation, and Anchor Points.

  4. Refine your animation using the Effect Controls panel or by adjusting the keyframes in your timeline using the Show Video Keyframes option.

Export your graphic as a Motion Graphics template

Export your Graphic, including all layers, effects and keyframes, as a Motion Graphics template for future reuse or sharing. 

Select Graphics > Export Motion Graphics template. You can also right-click the graphic clip in your timeline and select Export As Motion Graphics Template.

This export feature is only available for graphics created in Premiere Pro, not for .mogrt files that were originally created in After Effects. 

Note:

The Export As Motion Graphics Template option is unavailable or greyed out when two or more Graphics are selected or if it is an After Effects Graphic.

Export as Motion Graphics Template
Export as Motion Graphics Template

TIP:

If you are creating a Motion Graphics template for your own future reuse, save it to the Local Templates folder. It is also available without installation if you export to a Library. You may have to filter to show that Library in the Broswe tab of the Essential Graphics panel.

Examples and sample files

For this exercise you need the latest version of Premiere Pro (13.1) and this free clip from Adobe Stock (clip ID 222379417).

Viewing time: 10 minutes


For this exercise you need the latest version of Premiere Pro (13.1) and this free clip from Adobe Stock (clip ID 222369757).

Viewing time: 10 minutes


Use the example below to learn how you can create cool reveal animations using a shape layer and a text layer. 

  1. Create a shape layer and a text layer.

  2. To convert the shape layer to a mask, select the shape and click Mask with Shape

    Mask text with shape
    Mask text with shape
  3. In the Effect Controls panel, animate the position of the text. 

    Animating the position of the title using the Effect Controls panel
    Animating the position of the title using the Effect Controls panel
  4. To position the text outside the masking shape layer for frame 0, click the Keyframe tool  in the Effect Controls panel.

  5. Move the playhead in the Effect Controls panel to the right and change the Position value of the text until it is revealed in the shape mask. 

  6. Move the playhead back to frame 0 and press Play. Check and tweak the animation if necessary.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy