Your performance of a scene’s puppets can be captured during recording. Each recording of a specific armed behavior parameter for a puppet is called a take.

A scene’s timeline (shown in the Timeline panel) represents each puppet instance as a selectable track item. When selected, the Properties panel shows the behaviors for the source (master definition) of the puppet, plus any overridden behavior parameter values for this specific instance. For example, the same puppet can be added multiple times to a scene, with each puppet’s track item having a different Position transform for placement within the scene.

A scene has three modes:

  • Stop: Scenes open in this mode. Behaviors (except for Breathe, Cycle Layers, Physics, Handle Fixer, Transform, and Wiggler) do not affect the puppet unless armed for record. When not armed, the latest recorded take for a behavior at the current time indicator (playhead) is used. While stopped, no imported audio, including audio in takes, play back. You can rehearse behaviors in this mode — nothing is recorded.
  • Play: This mode plays back takes and audio. The current time indicator moves in time. Changes to behavior parameter values do not affect the results if a take of the same parameter exists at a given time; if no take data exists, the parameter’s value is used but not recorded.
  • Record: While recording, values for armed behavior parameters are captured as a take for each parameter, and any existing takes are played back. You can also record at a slower speed for finer capture of a performance. Playback is always at normal speed.

There are transport controls for these modes. Using these modes, you can perform basic recording of a performance, playback, and reviewing of recorded takes, and re-recording of a performance to correct mistakes. This lets you do a multi-track recording of different inputs and layer several takes.

The Go to Start button moves the current time back to the start of the scene (if stopped) or the start of playback (if in Play). The Go to Previous Frame and Go to Next Frame buttons move one frame backward or forward in time (when stopped).

When you open the Rig or the Stream workspaces, transport controls don’t appear as part of the default panel controls. To view transport controls, select Always Show Play and Record Controls option in the Rig or the Stream workspace menu.

 

Opmerking:

Your audio input and output hardware must share sample rate.

Record takes

The movement of your head to control a puppet’s face, the dragging of a character’s hand to make it wave, and other actions to capture a performance is done by recording a take. You can perform these tasks in the Record workspace.

Countdown to record

A 3-second countdown starts by default before recording starts. Use this time to prepare for recording or capture a specific pose for your puppet. To enable or disable countdown, follow this step:

  • Open Timeline and enable the Countdown Before Recording option. 
Countdown before record
Countdown before record

Record a performance of your puppets

  1. Calibrate the video or audio inputs, as needed:

    • To control puppets via webcam, make sure the Camera Input button in the Camera & Microphone panel is enabled (blue icon). Also, to improve face tracking results, set your rest pose using the Set Rest Pose button.
    • To record audio during the performance, make sure that the Microphone Input button Camera & Microphone panel is enabled (the default setting). When enabled, the Audio Level meter monitors audio input levels from –48 dB to 0 dB. The meter turns red at 0 dB. If the meter displays “Audio Level Too Low”, try boosting your microphone levels in the operating system’s Sound control panel or move closer to the microphone.
  2. To arm the track for recording, select the puppet (either its track item or puppet name in the track header on the left side of the panel).

    A selected/armed puppet allows you to isolate recording to ajust its track. By default, clicking a puppet track item or header, or adding a puppet to a scene, deselects/disarms other puppets in the scene. To select multiple puppets to arm for record, press Cmd-/Ctrl-click. An armed puppet track appears with a red background in the track header.

  3. In the Properties panel, enable the Arm for Record button (small circle next to the behavior’s name) for all behaviors you want to record for the puppet. Also enable the Arm for Record buttons for individual behavior parameters you want to capture in the take.

    Armed behaviors appear with a filled red circle (like a small record button). For an armed behavior, its armed parameter also appears with a filled red circle next to the parameter’s name. Values for the armed behavior parameters on the armed tracks are captured. You can switch between different puppets to capture by selecting (arming) a puppet’s track item or header without needing to disarm behaviors on other puppets.

    When a behavior's Arm for Record button is a dim red, it means that none of its parameters are armed. Disarmed behaviors are not included in the next recording.

  4. (Optional) To capture detailed movements of Dragger or other behaviors, set the Recording Speed to lower than normal speed. For example, choose half (0.5x) speed.

    Recording occurs at a slower speed, but playback is at normal speed.

    Opmerking:

    Disable the Microphone Input unless you want to sound like a chipmunk.

  5. Set the start time for the recording.

    You can start at the beginning of the scene by clicking the Go to Start button, play, and then stop at a specific time. You can also click or scrub along the time ruler at the top of the Timeline panel.

    Opmerking:

    To “punch in” during playback, you can start recording (described next) without first pausing.

  6. Start recording by clicking the Record button in the Scene panel.

    Opmerking:

    If you rerecord a scene and don’t want previous audio takes included, use headphones during recording.

  7. Do your performance using webcam, microphone, keyboard, and mouse inputs, and adjustments to armed behavior parameter values.

    Opmerking:

    If you armed Camera Input or Audio Input parameters for behaviors but the respective Camera Input and Microphone Input buttons (in the Camera & Microphone panel) are disabled, no takes are captured for those parameters. Similarly, if you armed Mouse Input and Keyboard Input parameters but don’t actually click in the Scene panel or press a key, takes are not captured.

  8. Stop recording by clicking Record again or Stop.

     

The recorded take is saved to a Recordings folder on disk (in the Ch Media subfolder of the current project folder). The take is also imported into the Project panel in the Recordings folder and added into the scene. If microphone input was recorded, the WAV file for it appears as an audio track item.

The puppet’s track is collapsed by default. A lighter-colored take summary bar indicating the presence of recorded takes appears along the bottom of the puppet track item’s bar.

Opmerking:

To select a camera, choose it from the panel menu in the Camera & Microphone panel. The available camera sources are listed by name.

  • If no compatible camera is available, the panel menu will show the message No Camera Detected.
  • If there is a delay in receiving the first frame of video, the panel menu message will show Waiting for camera.
  • If a camera needs to be selected from the panel menu, or if there is no camera available, the panel menu message will show No camera selected.
  • If another application is using the camera when Character Animator launches, the message says Selected camera is unavailable.
  • If the selected camera is no longer available, for example, if it was unplugged, the message shows Camera was disconnected.

 

If the Camera Input button gets disabled due to an issue, clicking (enabling) it will attempt to reacquire video from the selected camera.

Arm puppet for record

Each puppet track has its own Arm for Record button that can be controlled separately from the puppet track being selected. 

Arm for record a puppet track
Arm for record a puppet track

Clicking puppet track items or track headers still switches arming to that puppet. Deselecting a puppet track by clicking away from it (for example, by editing a take or viseme bar on a different puppet track) does not disarm the previously armed puppet tracks.
You can arm multiple puppet tracks by Shift-clicking or Cmd/Ctrl-clicking the Arm for Record buttons for those tracks. To ensure that puppet tracks do not get disarmed, select only the takes or visemes on puppet tracks or audio tracks.

Camera selection

To select a camera, choose it from the panel menu in the Camera & Microphone panel. The available camera sources are listed by name.

Select camera from options
Select camera from options

If no compatible camera is available, the panel menu will show No Camera Detected. If there are issues with the camera input, the panel will show one of the following errors:

  • If there is a delay in receiving the first frame of video, the error message says Waiting for camera.
  • If a camera needs to be selected from the panel menu, or if there is no camera available, the message says No camera selected.
  • If another application is using the camera when Character Animator launches, the message says Selected camera is unavailable.
  • If the selected camera is no longer available, such as if it was unplugged, the error message reads Camera was disconnected.

If the Camera Input button gets disabled due to an issue, clicking (enabling) it will attempt to reacquire video from the selected camera.

Recording speed

To capture the finer movements, you can record and perform at a speed slower than the frame rate of the scene.

To change the recording speed for a scene, do the following:

  • Open the scene in the Scene panel, then change the Recording Speed setting at the bottom of the panel.

These scene settings will be used for the next scene created.

Timeline work area

A scene’s timeline has a work area that you can enable to isolate operations to a range of frames in a scene. You can enable the work area when needed, and disable it when not needed.

To enable or disable the work area, follow these steps:

  • Either click the work area bar at the top of the time ruler or toggle the Enable Work Area command in the Timeline menu or Context menu above the work area bar. 
  • Dragging any part of a disabled work area bar enables it.
A) Work are disabled B) Work area enabled
A) Work are disabled B) Work area enabled

When enabled, the work area is a lighter-gray bar and its range of time is highlighted in the track area. When disabled, the work area bar is a subtle darker-gray color.

Setting the work area

To change the start or end time for the work area, do either of the following:

• Drag the left edge (start) or right edge (end) of the work area bar.

• Place the playhead at the specific frame in time and then choose Set Work Area Start to Playhead (Option/Alt+I) or Set Work Area End to Playhead (Option/Alt+O) from either the Timeline menu or the context menu for the work area bar.

Note: You cannot set the start time after the end of the work area, or vice versa.

To set the work area to match the selected tracks or take bars:

Choose Set Work Area to Selection (Option/Alt+/) from either the Timeline menu or the context menu above the work area bar. The work area will span the earliest and latest times in the selection.

To shift the work area in time, do the following:

Drag the middle of the work area bar horizontally. Dragging the edges or middle of the work area bar will snap the start or end of the work area bar to the edges of puppet track bars, take bars, and markers. Similarly, dragging the edges of puppet track bars or take bars or markers, will snap them to the start or end of the work area bar.

Jumping to the start or end of the work area

To jump to the start or end of the work area, do the following:

  • Right-click above the work area bar, then choose Go to Work Area Start or Go to Work Area End from the context menu.
  • Use the keyboard shortcut Option/Alt+Left Arrow and Option/Alt+Right Arrow.

Editing selected takes using the work area

When the work area is enabled, you can perform the following edits:

  • To delete the segment of selected takes within the work area, either choose Timeline > Clear to leave a gap (no recordings in the work area) or Timeline > Ripple Delete to close the gap by shifting the selected takes originally after the work area to the start of the work area.
A) Before  B) Clear  C) Ripple delete
A) Before B) Clear C) Ripple delete
  • To insert a gap in time the duration of the work area for the selected takes, choose Timeline > Insert Time.
A) Before  B) Insert time
A) Before B) Insert time

The Clear, Ripple Delete, and Insert Time commands are also available in the context menu above the work area bar.

Looping playback within the work area

When the work area is enabled, playback of the scene will automatically loop within the work area. Playback starts at the current time, and will loop when the playhead reaches the end of the work area. If the playhead is after the work area, playback will not loop.

Recording takes using the work area

When the work area is enabled, the Timeline > Record Take for Work Area command (Cmd/Ctrl+3) creates a new take. The new take covers the duration of the work area for the armed behavior parameters.

Exporting the work area

When the work area is enabled, the scene export commands (File > Export > Video via Adobe Media Encoder and File > Export > PNG Sequence and WAV) only use the segment of time within the work area.

Note: Scenes with puppets that use Physics simulations (Dangle, Collide, Particles) will still require frames before the start of the work area to be rendered (that is, a run-up) to export the intended results for the frames in the work area.

When the work area is disabled, those commands export the full duration of the scene.

Note: The work area is ignored when dragging a scene into After Effects or Premiere Pro. The scene’s duration is used in these Dynamic Link workflows

Trimming the scene to the work area

When the work area is enabled, you can trim the scene to just the segment of time within the work area by choosing Timeline > Trim Scene to Work Area or the same command in the context menu above the work area bar.

Playback speed

The Playback Speed setting allows you to review finer movements or changes in a performance by playing back the scene at a slower speed. You can use this control with the controllable recording speed.

To change the playback speed for a scene, open the scene in the Scene panel, and change the Playback Speed setting from the Playback and Recording Speed control. This option is present at the bottom of the panel.

When playback and recording speeds are different, both values are indicated, with recording speed in red. When they’re the same, only that value is shown.

Unlike other scene properties but like recording speed, new scenes always default to normal (1.0x) playback speed, instead of the last-used playback speed.

Play back a performance

After recording takes, play back the recordings to check your work.

To start at a specific time in the scene

Click or drag along the time ruler (at the top of the Timeline panel). Dragging also scrubs audio in the scene.

To start playback

Click Play or press Spacebar. Recorded takes play back, and the displayed time code updates accordingly.

To control playback speed for a scene

Open the scene in the Scene panel, then change the Playback Speed setting in the Playback and Recording Speed control at the bottom of the panel.

When playback and recording speeds are different, both the values are indicated, with recording speed in red. When both the speeds are the same, only that value is shown.

To stop playback

Click Stop or press Spacebar again.

The playhead snaps to frame boundaries by default, and when zoomed in time in the Timeline panel you can see the duration of a frame shaded in a light blue (similar to the shading seen in After Effects and Photoshop).

Opmerking:

The Scene panel shows the middle time within this frame duration, but audio can still play across the frame duration. Track and take operations, such as recording, split, and snapping, still happen at the red line (left edge).

To unsnap the playhead from frame boundaries for finer positioning or audio scrubbing, hold down Cmd (Mac) or Ctrl (Windows) as you drag the playhead.

Replaying the same range of time

By default, stopping playback leaves the playhead where it stopped, but you can have the playhead return to its previous start time so that you can repeat the same range of time by pressing Space. This option is helpful when refining the timing of visemes for a word or phrase.
To return the playhead to its previous start time when the playback stops, follow this step:

  • Select Timeline > Return to Start Position on Stop option.

Scrolling through time via keyboard

To scroll through time in a scene, you can use the following keyboard shortcuts.

  • Page Up or Page Down: Scrolls left or right one “page” at a time within visible range of time.
  • Command/ Control+ Page Up or Command/ Control + Page Down: Scrolls left or right less than a page at a time.

Scrolling the timeline panel’s content during playback and recording

In order to keep the playhead visible, the Timeline Panel’s content scrolls during playback or recording.

To prevent scrolling in time during playback and recording, follow this step:

  • Deselect the Timeline > Scroll During Playback option.

Hold Takes

If you want to extend the pose of a character’s recorded performance (takes) at the current time, create hold takes. Hold takes duplicate the values of the selected takes at the playhead, allowing you to extend them to the required duration and optionally blend them with the earlier recorded takes. To create hold takes, follow these steps:

  1. Move the playhead to the frame showing the pose you want to hold.

    Tip: Disarm the puppet track to see the results of the recorded takes.

  2. Select one or more takes whose values at the current time you want to hold.

  3. Choose Timeline > New Hold Take (Command+Shift+Option+D / Ctrl+Shift+Alt+D).

Each selected take has a new, one-second hold take above it. You can lengthen and move hold takes as needed, and even blend them into the takes below them for smoother transitions. The tick marks along the bottom edge of each hold take indicate that the value is constant, extending both earlier and later in time.

Opmerking:

Hold takes for Lip Sync or Trigger takes can be lengthened from either end, but the start of the viseme or trigger bar doesn’t extend automatically. You can still drag it manually as needed.

Show or hide recorded takes for a puppet

To show or hide the puppet's recordings, click the disclosure triangle next to a puppet’s name in the track header in the Timeline panel. Each recorded behavior parameter appears as a separate projection bar that summarizes the takes within it. If you don’t see any projection bars under a puppet’s track item, check that you armed at least one behavior parameter for recording and that the track was selected/armed before recording.

You can modify all takes for a parameter from its projection bar, or make finer adjustments to specific takes by clicking the disclosure triangle for the projection bar.

Opmerking:

If more than one take was recorded for a parameter, the topmost take bar at any given time is used, and any information from take bars below it is ignored (and shown without color as if in a shadow). Transition points between takes for a parameter are indicated by a vertical line on the parameter’s projection bar.

To start at the beginning of the scene

Click the Go to Start button or press Home.

Replays: Reusable and triggerable recordings

Replays let you trigger the recorded takes for a puppet, either live or for rerecording. Use it for making record and replay easier and more efficient. For information about replays, see Replays: Reusable and triggerable recordings.

Record behavior in take groups

Take groups enable multiple performances for a specific handle compose together, without affecting performances for other handles you drag. The Dragger behavior records each Draggable handle that you move as a separate take group. By grouping Dragger takes by dragged handles, you don’t have to use multiple Dragger behaviors to capture multiple dragged handles. The Timeline panel shows each Dragger takes grouped by handle name as “Handle (handle-name)”.

Step record to capture one- or two-frame takes

You can capture the current pose of a character, specifically the behavior parameters armed for record, as one- or two-frame takes to animate “on ones” or “on twos.” For example, if you have the Dragger behavior’s After Move parameter set to Hold in Place, you can pose a character’s arms, record a one-frame take, change the pose, record another one-frame take, and so on. Like any recorded take, you can extend its duration afterwards to, for example, hold a pose longer.

To record one- or two-frame takes for armed parameters, choose either Timeline > Record 1-frame Take (Cmd/Ctrl+1) or Record 2-frame Take (Cmd/Ctrl+2).

You can blend performances at the beginning and the end of a take to smoothly transition between existing takes or the default appearance. You can also customize blend durations or quickly set a take to blend with the default duration. For more information, see Blend performances together.

Adjust time and reorder scene contents

You can change the timing and order of puppets, recorded takes, and audio to fine-tune your work. Puppets and audio appear as track items (larger bars), and recorded takes appear as shorter bars under puppet track items. You can also zoom in or out in time for easier access to track bars or a temporal overview of the scene.

When zoomed into the duration of a frame of time in the Timeline panel, the horizontal center of the frame is denoted with a dashed line to indicate the exact time that the track item or take is being sampled.

Drag the Zoom Timeline slider or click the Zoom Timeline In, Zoom Timeline Out, or Zoom Timeline to Fit Entire Scene buttons in the lower-right corner of the Timeline panel. The buttons have keyboard shortcuts (–, =, and \).

Scroll through time when zoomed in

Use the horizontal scrollbar below the scrollable region of the Timeline panel or swipe horizontally on the trackpad.

Scroll through the stack of puppet and audio tracks

Use the vertical scrollbar or swipe vertically on the trackpad.

Select or deselect track items

  • Click the track’s name (for a puppet) or the track item’s bar to select it. 
    Select a track item for a puppet to modify the behavior parameter values for the puppet’s instance in the scene, overriding the values in the source (master) definition of the puppet. 
    Selecting a puppet track automatically arm the puppet for recording.
  • To toggle the selection of a puppet, Shift-click or Cmd-/Ctrl-click the puppet’s track item or the track’s name (track header on the left side of the panel). Toggle selection allows you to select multiple puppets at the same time.
  • To deselect all contents click away from any track item bar.

Hierarchical selection

Selected track items appear solid blue in the Timeline panel. When a take or projection bar for a puppet is selected (either directly selected or after recording takes), the bar becomes solid blue. The puppet track gets outlined in blue to indicate that something in the puppet’s hierarchy is selected. This hierarchical selection also allows the puppet’s behavior parameters to be visible in the Properties panel and modified immediately after adjusting takes.

Select or deselect takes

  • Click a take to select it and other takes captured during the same recording pass. These takes are linked by default, and can be dragged and trimmed in unison.
  • Shift-click or Cmd-/Ctrl-click a take to toggle the selection of linked takes.
When multiple parameters are recorded at the same time, the takes are linked. By default, selecting one take doesn't select or affect its linked takes, but you can manage all linked takes at the same time by clicking the Linked Selection command from the Timeline menu.
When a take is selected, the corresponding section of the summary bar (along with the bottom of a puppet track item) appears highlighted in blue, which is informative when the track item is collapsed and you can’t see the take bars.

Split track items and takes

Shorten a puppet or an audio track item or take by splitting it at the playhead (current time). This operation essentially duplicates the selection, and trims the original and the new bars.

To split track items or takes:

  1. Select the items and place the playhead at the split time.
  2. Choose Edit > Split (Shift+Cmd/Ctrl+D).

Duplicate track items and takes

Create a copy of a track item or takes to use later.

To duplicate track item or takes:

  1. Select the items or takes.
  2. Choose Edit > Duplicate (Cmd/Ctrl+D).

Adjust timing of a track item or take

  • To shift it in time, drag the middle part of the bar horizontally.
  • To trim its start or end time, drag the left or right end of the bar.

Extending a take bar from either end holds the take's recorded values before the original In point and after the original Out point of the take.

Opmerking:

If you split a take, extending from the split point just reveals the trimmed part.

Override snapping to edges and for finer control

Hold down the Cmd/Ctrl key while dragging a track item or take bar.

Reorder a track

To reorder a track, for example, to change the rendering order of puppet, select the track, then choose Timeline > Arrange > Move Up or Move Down, or press Cmd+Up/Down Arrow or Ctrl+Up/Down Arrow.

Delete a track item

Select a track item, then choose Edit > Delete or press Delete or Backspace. Deleting an audio track item does not remove its track.

Move takes

Move selected takes for the same parameter up or down via Timeline > Move Up or Move Down commands. The commands can still be used for selected tracks.

Delete a take

Select the take bar and press Delete or choose Edit > Delete.

  • To delete a puppet’s takes, select all the takes and press Delete.
  • To delete the puppet track, press Delete after the takes are deleted and the selection is at the puppet track.

Take reuse between puppets and projects

All types of takes can be cut, copied, and pasted between puppets and projects. To reuse takes, follow these steps:

  1. Select the takes to reuse.

    • To remove them from the puppet, choose Edit > Cut (Command/Ctrl+X). 
    • To retain the original takes and duplicate them, choose Edit > Copy (Command/Ctrl+C).
  2. Select a different puppet track item in the Timeline, in either the current or another project. Reposition the playhead to where you want the take to start and choose Edit > Paste (Command/Ctrl+V).

The selected take is pasted relative to the playhead. Any behavior associated with the copied takes are applied to the target puppet if it doesn’t have those behaviors. If the puppet has multiple behaviors (for the take), each of them gets a copy of the take. You can also copy multiple takes. They are pasted in the order they were selected.

For more information about taking Character Animator visemes into After Effects for use on different characters, see Lip Sync: Take export for After Effects.

Opmerking:

  • Pasting a behavior that is hidden by default but isn’t hidden while being copied (Cycle Layers) pastes the new instance as hidden.
  • Pasted behaviors are always added at the top level of the puppet, even if the copied take was for a behavior lower in the puppet structure.
  • Pasted behaviors do not retain any custom behavior names.
  • Copied takes for multiple instances of the same behavior (two instances of Face at different places in the puppet structure) gets pasted into a single instance of the behavior.

Blend performances together

You can blend performances at the beginning and the end of a take to smoothly transition between a puppet’s default appearance and its recorded performances. You can also customize blend durations or quickly set a default duration.

Blending a behavior's parameter’s take

1. Expand the puppet and projection bar that contains a blendable take. 

You can blend the following takes:

  • Numeric parameters like Dangle’s Wind Strength or Transform’s Scale
  • Angle parameters like Transform’s Rotation
  • Face’s Camera Input parameter
  • Dragger’s Mouse & Touch Input parameter

2. Do one of the following:

  • To use a custom blend duration, drag the small square at either top corner of the take bar inward; the cursor changes to a finger with arrows on either side when above the square. The farther you drag from the edge of the bar, the more gradually you can ease into or out from the recorded performance.
  • To use a default (half-second) blend duration, select the projection or take bar, then choose Timeline > Blend Take submenu. You can blend only the incoming (Blend In), outgoing (Blend Out), or both sides (Blend In and Out) of the take. You can further customize the duration by dragging the small squares.
  • To cycle through available default blend durations, choose Timeline > Blend Take > Next Blend (Cmd/Ctrl+B) or Previous Blend (Shift+Cmd/Ctrl+B).

When you trim a take, in (left side) and out (right side) blend durations do not change unless the take bar duration becomes shorter than the blend durations.

Opmerking:

The Timeline > Blend Take commands set a default duration for the incoming and outgoing blends, but don’t set the ease to a specific type of curve. The default is Ease In & Out.

To set the blend easing curve:

1. Right-click above the incoming blend and then choose Blend In Curve, above the outgoing blend and then choose Blend Out Curve, or in the middle of the take bar and then choose Blend.

2. Choose an easing type from the submenu: No Easing (linear curve), Ease In (ease into the blend), Ease Out (ease out from the blend), or Ease In & Out (ease both ends of the blend).

Removing blending of a take

Do one of the following:

  • Choose Timeline > Blend Take > Remove Blend.
  • Drag the small square toward the edges of the take bar.

Markers

Markers let you mark up specific changes (for example, when a character is looking to the left) in a scene’s timeline. Stop markers allow playback to stop when they are reached. You can switch between a regular informational marker and a stop marker at any time.

To create a marker, move the playhead to the intended time, then do either of the following:

  • For a regular marker, choose Timeline > Add Marker (Ctrl+8 on Mac, Numpad * on Windows).
  • For a stop marker, choose Timeline > Add Stop Marker (Ctrl+Shift+8 on Mac, Shift+Numpad * on Windows).The icon for a stop marker shows a small square sign.

Note: You can switch a regular marker to a stop marker, or conversely. To switch, right-click the marker, and enable or disable the Stop Playback at Marker option.

  • To rename a marker, double-click/ Enter, and then enter a new name.
  • To move a marker to a different time, drag it horizontally. Markers can snap to other items in the timeline, and conversely.
  • To delete a marker, select it (Shift-click to select multiple), and then choose Edit > Delete.

Working with Markers

Working with Markers
Learn how to work with Markers

Audio waveform and audio track resize

The audio track shows the waveform of the audio file helping you adjust the timing of puppets, takes, and visemes to the audio. Audio tracks appear twice as tall as other tracks by default, and can be resized as needed by dragging the bottom edge of the track header vertically.

Resize audio track
Resize audio track

Collapse view of a parameter’s takes

By default, multiple recordings for a parameter creates take bars on separate rows in the Timeline panel, but you can collapse them into a single lane to reduce vertical scrolling and still have access to them individually. 

Click the twirl arrow to collapse or expand a parameter’s takes. The twirl arrow only appears if a parameter has multiple takes. 

Collapsed view of takes
Collapsed view of takes

When collapsed into a single lane, you can click different parts to select the individual take bars. When selected, information about the take is displayed on its bar, blend curves are visible, and blend handles are adjustable.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid