Adobe Media Encoder uses existing presets or custom settings to encode and transcode media files in different video and audio formats.

The encoding process

To encode a video or audio item, add the item to the encoding queue in Adobe Media Encoder. Select existing encoding presets or create your own custom settings. You can instruct the application to start encoding after you add an item to the queue. Or you can tell the application to wait until you decide to start encoding. You can perform the following actions using Adobe Media Encoder:

  • Add an item to the encoding queue: Drag video or audio files into the queue panel in Adobe Media Encoder. For more information, see Import items into the encoding queue.
  • Encode the item using presets: Select formats and presets from the Format and Presets drop-down list with the item in the queue. Or choose a preset from the Preset Browser and drag it to any item in the Queue. For more information, see Encode using presets.
  • Encode the item using custom settings: Select the desired items in the queue panel and select Edit > Export Settings or click the Format and Preset listed, in the queue panel and then choose your settings. For more information, see Encode using custom settings.

To start encoding items in the queue automatically after specified duration, select the Start queue automatically when idle for option. Set the desired duration for idle state in the Preferences dialog box. 

Preferences
Preferences

Once enabled the countdown appears in the Encoding Panel. For more information, see Preferences.

Encoding countdown
Encoding countdown

Import items into the encoding queue

To add video or audio files into the encoding queue, do one of the following:

  • Drag one more files into the Queue panel from the desktop or the media browser.
  • Click the Add Source button in the Queue panel and choose one or more files.
  • Double-click an open area in the Queue panel and choose one or more files.

Import from Premiere Pro

To add an Adobe Premiere Pro sequence, do one of the following:

  • Navigate within an Adobe Premiere Pro project in the Media Browser and click drag sequences to the Queue Panel.
  • Choose File > Add Premiere Pro Sequence. Select a Premiere Pro project and select one or more sequences from that project.
  • Click drag a sequence from the Project panel in Adobe Premiere Pro into the Queue panel.
  • Click drag a Premiere Pro project from the desktop on the Queue panel.

Import from After Effects

To add an Adobe After Effects composition, do one of the following:

  • Navigate within an Adobe After Effects project in the Media Browser and drag-and-drop compositions to the Queue panel.
  • Choose File > Add After Effects Composition, select an After Effects project, and select a composition from that project.
  • Click drag a composition from the Project panel in After Effects into the Queue panel.
  • Click drag an After Effects project from the desktop on the Queue panel.

Stop encoding

To stop encoding, do one of the following

  • To stop encoding the current item, Choose File > Stop Current Item. Adobe Media Encoder continues encoding the remaining items in the Queue.
  • To stop encoding all items in the Queue, choose File > Stop Queue.

Stitching clips

You can combine multiple media files into a single file when adding them to the queue. To stitch media files together, do the following:

  1. Select File > Add Source or click the Add Source button from the Queue panel. The File Explorer opens.

  2. Select the assets you want to stitch together.

  3. Check the Stitch clips together check box.

    Stitch clips together
    Stitch clips together
  4. Click Open to add the stitched clip to the queue.

Alternately, select the clips you want to stitch. Drag them to the Queue panel and release on top of the option Drop here to stitch clips together.

Drop here to stitch clips together
Drop here to stitch clips together

The stitched clips are loaded in the queue. To view the individual clips, click Show sources. By default, the clips are sorted alphabetically. You can rearrange them according to your preference.

The name of the stitched clips is automatically set to the first clip in the series. To change the name of a clip, click the name. For more information, see Stitching clips together using Adobe Media Encoder.

Opmerking:

Stitched clips adhere to In and Out Points set in media browser. However, you cannot edit the duration of sources once they have been added to a stitched clip.

Identify missing items in the encoding queue

Before you start encoding, you can identify items in the queue that contain missing items. This process helps you identify and fix issues before you encode. A warning status is displayed next to the source or output that contains missing items. To view a summary of the error which is associated with this problem, hover over the icon.

Adobe Media Encoder shows a warning icon in the following cases:

  • Premiere Pro projects contain offline media. In this case, Adobe Media Encoder uses proxy media in place of the missing set of media. If there are no proxies, a graphic is used that displays the message 'Media offline'.
  • Some fonts are missing from Premiere Pro projects.
  • Some effects are missing in Premiere Pro projects.
  • Some files are missing in Overlay effects.
Summary of error
Summary of error

Interpret items in the encoding queue

When Adobe Media Encoder imports a video asset, it attempts to determine the frame rate, pixel aspect ratio, field order, and alpha channel for the video asset. If Adobe Media Encoder is wrong about any of these characteristics, you can manually assign the correct interpretation.

  1. Select one or more video items from the encoding queue.

  2. Do one of the following:

    • Choose File > Interpret Footage
    • Right click the file and choose Interpret Footage.
  3. Choose the appropriate interpretation settings.

Interpret footage
Interpret footage

Opmerking:

The Interpret Footage option appears unavailable if you select an asset that is not a video or image asset.

Encode using presets or custom settings

Encode using presets

preset
A. Format B. Preset C. Destination 
  1. Add items to the Queue panel. For information, see Import items into the encoding queue.

  2. Choose a format that is compatible with the output device by clicking the text for the Format(A) to open the Format pop up containing supported file formats.

  3. Choose a preset that is compatible with the output device by clicking the text for the Preset(B) to open the Preset pop up containing industry standard presets. For more information, see Create custom presets for Media Encoder.

    Or drag a preset from the Preset Browser and drop it in the Queue.

    Apply preset
    Apply preset
  4. Choose a location for your export by clicking the text for Output(C), and then finding the directory or folder for your exports in the Save As dialog box. Click Save.

  5. Press the Start Queue button.

Your files begin to be encoded to your desired format, using your chosen preset in the location you chose. After a file has been encoded, click the output file path to open the folder containing the encoded file.

output file
A. Output file after encoding  B. Output file before encoding 

Opmerking:

During the encoding process, click the Start Queue button once more if you would like to pause the encoding process.

Encode using custom settings

To encode using custom settings, do the following:

  1. Add items to the Queue panel. For information, see Import items into the encoding queue.

  2. Open the Export Settings dialog box by doing one of the following:

    • Select the item’s row for the text showing Format, preset and output file path in the queue panel and select Edit > Export Settings
    • Right-click the row for the text showing Format, preset and output file path file and select Export Settings
    • Click the Format or Preset name to open the Export Settings dialog box.
  3. Set export options and click OK. For more information, see Export settings reference for Media Encoder.

  4. With the Export Settings dialog box closed, click the Start Queue button to begin encoding your files.

Opmerking:

For optimum performance during encoding, close the Encoding panel. Instead you can use the progress bars in the Queue panel to view the status of the encoding process.

You can do any of the following in the Export Settings dialog box:

  • Choose a video, audio, or still-image format from the Format menu. For more information, see File formats supported for export.

  • Choose an encoding preset from the Preset menu.

  • Select Export Video, Export Audio, or both.

  • Specify pre-encoding options, including cropping, trimming. For more information, see Export Settings dialog.

  • Set options for XMP metadata export. For more information, see Export and thin XMP metadata.

  • Select Use Maximum Render Quality or Render At Maximum Bit Depth.

  • Select Use Frame Blending.

  • Specify a filename and location for the encoded file by clicking the underlined text next to Output Name in the upper-right section of the Export Settings dialog box and entering a filename and location. If you don’t specify a filename, Adobe Media Encoder uses the filename of the source video clip.

Opmerking:

When the format is set to P2 Movie, the user-assigned filename is not applied. Instead, such encodes are given a six character alphanumeric name by Adobe Media Encoder. The Output Name is saved to the clip’s metadata, and is shown as the clip name in Adobe Premiere Pro.

You can specify a destination folder in which to save the encoded file relative to the folder containing the source video clip. When specifying a destination folder, ensure that the destination folder you specify exists. If you specify a folder that does not exist, an error message informs you that the file cannot be encoded because the folder cannot be found.

Save the encoding queue

The encoding queue and encoding settings are saved automatically when you exit Adobe Media Encoder. The encoding queue is also saved automatically when a user starts an encoding process.

To manually save the encoding queue, choose File > Save Queue.

Opmerking:

Turn off the Preferences > Remove completed files from the queue on exit check box if you want to keep completed encoded items in the Queue when you close and restart Adobe Media Encoder.

Change output file path for multiple sources

Follow the steps below to change the Output File path for multiple outputs (at the same time):

  1. Select multiple sources in the Queue using Shift-click.

  2. Click the text for the Output File of one source in the current selection.

  3. Choose a path in the Select an output folder dialog and click Choose.

Selected outputs point to the new directory but retain their unique output filenames.

Watch folder

You can configure Adobe Media Encoder to look for files in certain folders called watch folders. Adobe Media Encoder automatically encodes the files placed in the watch folder. When Adobe Media Encoder finds a video or audio file in a watch folder, it encodes the file using the encoding settings assigned to the folder. It then exports the encoded file to an Output folder created inside the watch folder.

Using watch folders, Adobe Media Encoder automates the process of Queuing and Rendering of media files. You can create multiple versions of a source by adding different output instances using different formats or presets.

Watch Folders panel
Watch Folders panel

The Watch Folders panel in In Adobe Media Encoder can be used to add and manage folders. You can add a watch folder in one of the following ways:

  • Choose File > Add Watch Folder and select a folder.
  • Double click an empty area in the Watch Folders panel and select a folder.
  • Create a folder in Explorer (Windows) or Finder (Mac OS), and then drag it to the Watch Folders panel.

The items added to the encoding queue by the watch folder is encoded along with other items in the queue when you start the queue.

Opmerking:

If you have the “start queue automatically when idle for” preference selected, encoding begins when the specified amount of time has elapsed after the watch folder has added an item to the encoding queue.

Keep the Auto-Encode Watch Folders check box enabled to automatically encode items when they are added to the watch folder.

Create output in multiple formats using watch folders

You can generate multiple outputs with a single operation by using watch folders. For example, you want to generate an AVI movie, and a JPEG thumbnail image whenever you transcode a video asset.

To create these files with a single user operation, follow these steps:

  1. Create a folder using File Explorer (Windows) or Finder (macOS) called “My_WatchFolder”.

  2. Create a watch folder by clicking the Add Folder button, and then navigate to the folder you just made, “My_Watchfolder.”

    • Click Format and select MPEG4 as the format from the pop-up menu.
    • Click Preset and select the desired setting from the Preset pop-up menu.
    Export settings
    Export settings
    • Click Output Folder. Select a location where you would like the output to be generated.
  3. Create a Watch Folder item that also points to the folder “My_Watchfolder,” just like Step 2.

    • Click Format and select AVI as the format from the pop-up menu.
    • Click Preset and select the desired setting from the Preset pop-up menu.
    • Click Output Folder. Select a location where you would like the output to be generated.
  4. Create a Watch Folder item that also points to the folder “My_Watchfolder,” just like Step 2 and Step 3.

    • Click Format and select JPEG as the format from the pop-up menu.
    • Click Preset and select the desired setting from the Preset pop-up menu.
    • Click Output Folder. Select a location where you would like the output to be generated.
  5. Click drag the source file into “My_WatchFolder,” and then click the Start Queue button. The encoding process begins automatically if the Auto-Encode Watch Folders is enabled.

When complete, each file is in its expected output locations.

Remove, duplicate, and skip items in the encoding queue

Remove, duplicate, and skip items in the encoding queue
Remove, duplicate, and skip items in the encoding queue

Remove items from the encoding queue

To remove items from the encoding queue, do the following:

  1. Select the item, or items that you want to remove from the encoding queue.

  2. Do one of the following:

    • Right-click the file and choose the Remove button.
    • Choose Edit > Clear, or press the Delete key.
    • Select Yes to confirm the Removal. (Check Don’t ask again to avoid the confirmation window to appear every time you remove an item from Queue)

Duplicate items in the encoding queue

To duplicate items in the encoding queue, do the following:

  1. Select the item, or items that you want to duplicate from the encoding queue.

  2. Do one of the following:

    • Right-click the file and choose Duplicate.
    • Click the Duplicate button, choose Edit > Duplicate
    • Press Ctrl+D (Windows), or Command+D (macOS)

Skip items in the encoding queue

To skip items in the encoding queue, do the following:

  1. Select the item, or items that you want to skip in the encoding queue.

  2. Do one of the following:

    • Choose Edit > Skip Selection.
    • Right-click the file and choose Skip Selection.

Reset status of items in the encoding queue

To reset the status of a file in the encoding queue, do the following:

  1. Select the items in the encoding queue that you want to reset to the Ready state.

  2. Do one of the following:

    • Choose Edit > Reset Status.
    • Right-click the file and choose Edit > Reset Status.

Monitor encoding progress

While an item is being encoded, the Status column of the encoding queue provides the status of each item. Adobe Media Encoder can encode multiple outputs from a single source simultaneously. However, source files are processed sequentially based on their order in the Queue.

You can continue to work on the application while encoding is in progress. You can add, remove, or reorder items in the queue or watch folder. However, outputs that are currently being encoded cannot be edited.

  • Ready
    The item is in the encoding queue but has not been encoded. You can remove a file from the queue that has not been encoded and is not being encoded.
  • Done
    The item has been successfully encoded.
  • Stopped 
    The user canceled the encoding process while the item was being encoded.
  • Failed 
    Adobe Media Encoder encountered an error when attempting to encode the specified item.
  • Skip
    The user can skip one, or more selected files. With the files selected, choose Edit > Skip Selection.

Audible alerts when jobs completed (successfully and with errors)

Adobe Media Encoder has audible alerts. It plays an audible alert at the completion of the jobs in the Queue. A different alert sounds if any error conditions are detected. If you do not want to hear them, these alerts can be disabled in preferences.

Preferences
Preferences

Display log

To see a tool tip with the error message, hover over the status icon. To open the log for any item for which encoding has been completed successfully, stopped, or failed, click the status.

Display log
Display log

Parallel encoding

Adobe Media Encoder encodes all sources in sequence, but encodes all outputs of a source in parallel. It is used to export multiple formats for the same source simultaneously, but it cannot be used to export different sources simultaneously.

Parallel encoding
Parallel encoding

Opmerking:

Parallel encoding is on by default. To disable parallel encoding, select Edit > Preferences, and deselect Enable Parallel Encoding.

When you encode multiple outputs simultaneously, the Encoding panel displays a thumbnail preview, progress bar, and the completion time estimate of each encoding output.

In certain cases, export settings require an output to encode in serial rather than in parallel mode. In such cases, the queue returns to parallel encoding after temporary serial encoding is complete.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid