Opmerkingen bij de actuele release
Huidige versie: 9.2.17
Video over Adobe Sign voor Dynamics
Klik om de video te bekijken


Veel voorkomende vragen

  1. Meld u aan bij MS Dynamics.

  2. Ga naar Instellingen > Aanpassing.

    Navigeren naar Aanpassen
  3. Klik op de optie Het systeem aanpassen.

    Het systeem aanpassen
  4. Klik in het linkernavigatievenster op de vereiste aangepaste entiteit.
    Bijvoorbeeld: Yukti_test.

  5. Om de velden en besturingselementen weer te geven, klikt u op de naam van de entiteit.

  6. Ga naar Formulieren en klik vervolgens op de koppeling Informatie die is gekoppeld aan het formuliertype Hoofdformulier.

    Het hoofdformuliertype koppelen
  7. Voeg een nieuw veld en voer een naam in voor het veld.

    Nieuw veld toevoegen
  8. Sla het veld op en sluit het venster.

  9. Plaats het veld via slepen en neerzetten in de entiteit, sla vervolgens alle wijzigingen op en publiceer deze. 

    Het veld neerzetten in de entiteit

  1. Meld u aan bij MS Dynamics.

  2. Ga naar Instellingen > Aanpassing.

    Navigeren naar Aanpassen
  3. Klik op de optie Het systeem aanpassen.

    Het systeem aanpassen
  4. Klik in het linkernavigatievenster op de vereiste aangepaste entiteit.

    Bijvoorbeeld: Klant.

  5. Om de velden en besturingselementen weer te geven, klikt u op de naam van de entiteit.

  6. Kopieer de waarde van het veld Naam (in dit voorbeeld is de waarde new_customer). 
    Dit is de interne systeemnaam van uw aangepaste entiteit.

    De naamwaarde kopiëren
  7. Ga naar de optie 1:N-relaties onder uw aangepaste entiteit.
    Klik op de knop Nieuwe 1-veel-relatie.

    Een-naar-veel
  8. De relatie instellen:

    1. Kies Overeenkomst in het veld Gerelateerde entiteit.
      De naam van het veld verandert in {entityName}_adobe_agreement.
    2. Plak de naam van uw aangepaste entiteit, bijvoorbeeld new_customer in het veld Weergavenaam.
      Het veld Naam verandert in de waarde “new_” + {entityName} + “Id”. (new_new_customerID).
    Nieuwe relatie

        c. Klik op Opslaan en Sluiten.
            Het venster Relatie wordt gesloten.

        d. Klik op Alle aanpassingen publiceren boven aan de pagina 1:N-relaties.

    Een-naar-veel-relaties

Er is een bekend probleem met On-Premise CRM-omgevingen met meerdere servers (CRM op de ene server en DB op een andere server) waarbij hun SPN niet correct is geconfigureerd. 

Dit resulteert in een blanco pagina Beheerinstellingen.

De beste oplossing voor dit probleem is om contact op te nemen met Microsoft Dynamics-ondersteuning en hun steun in te schakelen bij het correct configureren van de SPN.

Een kort overzicht van de SPN-configuratie vindt u hier.

 

Een tijdelijke oplossing voor het probleem die werkt bij de meeste omgevingen:

  • Download de Microsoft Dynamics CRM SDK
  • Voer MicrosoftDynamics365SDK.exe uit
  • Zoek en voer de plug-in-registratietool uit (SDK\Tools\PluginRegistration)
  • Koppel de plug-in-registratietool aan uw Dynamics-instantie (klik hier voor instructies)
  • Blader door de AdobeSign-assembly
  • Geef de Isolatiemodus de waarde Geen
  • Klik op de knop Geselecteerde plug-ins bijwerken als u klaar bent
De isolatiemodus opgeven

Als deze tijdelijke oplossing het probleem niet oplost, neem dan contact op met Microsoft CRM-ondersteuning om de SPN voor uw omgeving te onderzoeken.

Zodra het SPN-probleem is opgelost, kan de instelling Isolatiemodus worden teruggezet naar Sandbox.

Een afzender krijgt de volgende foutmelding bij het verzenden van een record ter ondertekening. De foutmelding treedt op wanneer de overeenkomstrecord wordt gemaakt.

Fout in bedrijfsproces

De fout verschijnt wanneer de afzender naar meer opties gaat en vervolgens klikt op "Verzenden ter ondertekening". Het probleem doet zich alleen voor in een productieomgeving waarin de applicatiebeveiliging (F5) en loadbalancers zijn ingesteld.

Antwoord:

Wanneer de beheerde oplossing voor Adobe Sign wordt geïmporteerd in CRM, worden de bijbehorende plug-inbibliotheken geregistreerd onder de isolatiemodus: sandbox. Dit veroorzaakt problemen in productieomgevingen. Werk de instelling handmatig bij naar "Geen".

Hoe kunnen we met de functie Rapport verzenden ter ondertekening, de sjabloon voor de functie bijwerken? Wanneer u de functie gebruikt, heet de overeenkomst die wordt weergegeven "Nieuwe overeenkomst", zonder bericht en zijn geen van de overeenkomstopties ingesteld. Met andere woorden, is er een manier om een sjabloon toe te wijzen aan de functie Rapport verzenden ter ondertekening?

Antwoord:

Dit wordt niet ondersteund.

De functie 'Rapport verzenden ter ondertekening' is ad-hocfunctionaliteit in zowel v5 als v6, wat betekent dat u naar het doelrecord moet gaan en het verzenden van rapporten handmatig moet uitvoeren.

Probleem:

De volgende fouten verschijnen bij het importeren van Microsoft Dynamics v6:

Fouten:

  • "Het importeren van Adobe Sign-oplossing is mislukt"
  • "Er is een SQL Server-fout opgetreden. Probeer deze actie opnieuw. Als het probleem aanhoudt, ga dan naar de Microsoft Dynamics CRM-community voor oplossingen of neem contact op met de Microsoft Dynamics CRM-beheerder van uw organisatie. Ten slotte kunt u contact opnemen met Microsoft Support"

Oorzaak:

De fout tijdens de upgrade van de oplossing wijst op een SQL-serverfout. Dit betekent overbelasting van het verkeer in de DB-verbinding van CRM, of een slechte staat van de SQL-server.

 

Resolutie:

  1. De CRM-beheerder moet het gebeurtenislogboek van de CRM-server controleren om te zien of daar een andere fout te zien is die zou kunnen wijzen op problemen met de SQL-server.
  2. Zet de fulltext-index handmatig neer op de tabellen adobe_agreementBase en adobe_agreementtemplateBase in SQL Server.