Sobre arquivos do Animate

No Animate, é possível trabalhar com diversos tipos de arquivo, sendo que cada um deles tem um propósito separado:

  • Os arquivos FLA, os principais arquivos com os quais você trabalha no Animate, contêm a mídia básica, a linha do tempo e as informações sobre o script de um documento do Animate. Os Objetos de mídia são objetos gráficos, de texto, de som e de vídeo que abrangem o conteúdo do seu documento Animate. A Linha do tempo é onde você mostra ao Animate quando os objetos de mídia específicos devem aparecer no Palco. Você pode adicionar o código do ActionScript® aos documentos do Animate para obter um melhor controle de seu comportamento e possibilitar que respondam às interações do usuário.

  • Os arquivos XFL não compactados são similares aos arquivos FLA. Um arquivo XFL e os demais arquivos associados dentro da mesma pasta são nada mais do que o equivalente descompactado do arquivo FLA. Esse formato faz com que os grupos de usuários trabalhem com mais facilidade em diferentes elementos de um projeto Animate simultaneamente. Para obter mais informações, consulte Como trabalhar com arquivos XFL descompactados.

  • Os arquivos SWF, as versões compiladas dos arquivos FLA são os arquivos exibidos na página da Web. Ao publicar seu arquivo FLA, o Animate cria um arquivo SWF.

    O formato de arquivo SWF do Animate é um padrão aberto compatível com outros aplicativos. Para obter mais informações sobre os formatos de arquivo do Animate, consulte www.adobe.com/go/flashplayer_br.

  • Os arquivos AS são arquivos do ActionScript. Você pode usá-los para manter alguns ou todos os códigos do ActionScript fora de seus arquivos FLA, o que é útil para a organização de códigos e para os projetos nos quais várias pessoas trabalham em diferentes partes do conteúdo do Animate.

  • Os arquivos SWC contêm os componentes reutilizáveis do Animate. Cada arquivo SWC contém um clipe de filme compilado, o código do ActionScript e quaisquer outros ativos que o componente exija. Observação: os arquivos SWC não podem ser importados para o Animate.
  • Os arquivos ASC são usados para armazenar o ActionScript que será executado em um computador que executa o Adobe Media Server. Esses arquivos fornecem a capacidade de implementar a lógica do servidor que funciona em conjunto com o ActionScript em um arquivo SWF. Observação: arquivos ASC não são compatíveis com o Animate CC.
  • Os arquivos JSFL são arquivos JavaScript que podem ser usados para adicionar novas funcionalidades à ferramenta de autoria do Animate.
  • Arquivos APR permitem agrupar o modelo de publicação da tela de desenho com as configurações de perfil de publicação correspondentes. Além disso, qualquer novo ativo vinculado a um perfil de publicação também é agrupado e compartilhado. Para obter mais informações, consulte Configurações de publicação.

 

 

O que é o Animate CC?

O que é o Animate CC?
Adobe

Os vídeos e tutoriais adicionais a seguir demonstram o trabalho com o Animate/Flash Pro. Alguns vídeos podem mostrar o Flash CS3 ou CS4, mas também valem para o Flash Pro CS5.

Trabalho com outros aplicativos da Adobe

O Animate foi criado para trabalhar juntamente com outros aplicativos da Adobe® para possibilitar uma ampla gama de fluxos de trabalho criativos. Você pode importar arquivos do Illustrator ® e do Photoshop® diretamente para o Animate. Também é possível criar vídeos no Animate e editá-los no Adobe® Premiere® Pro ou no After Effects®, ou ainda importar vídeos desses aplicativos para o Animate. Ao publicar os arquivos SWF, você pode usar o Dreamweaver® para incorporar o conteúdo nas páginas da Web e iniciar o Animate diretamente do Dreamweaver para editar o conteúdo.

Como abrir arquivos XFL

A partir do Animate CC, XFL é o formato interno dos arquivos FLA criados. Quando você salva um arquivo no Animate, o formato padrão é FLA, mas o formato interno do arquivo é XFL.

Outros aplicativos da Adobe®, como o After Effects®, podem exportar arquivos no formato XFL. Esses arquivos têm a extensão de arquivo XFL em vez da extensão FLA. O InDesign® pode exportar diretamente no formato FLA, que internamente e XFL. Isso permite que você trabalhe em um projeto no After Effects ou InDesign primeiro e depois continue trabalhando com ele no Animate.

Você pode abrir e trabalhar com arquivos XFL no Animate da mesma forma que abriria um arquivo FLA. Quando você abre um arquivo XFL no Animate, é possível salvá-lo como um arquivo FLA, ou como um arquivo XFL descompactado.

Os tutoriais em vídeo a seguir demonstram a exportação do InDesign e do AfterEffects para o Animate por XFL e FLA:

Para abrir um arquivo XFL no Animate:

  1. Em outro aplicativo da Adobe®, como o InDesign ou o After Effects, exporte o trabalho como arquivo XFL.

    O aplicativo preserva todas as camadas e objetos do arquivo original no arquivo XFL.

  2. No Animate, selecione Arquivo > Abrir e navegue até o arquivo XFL. Clique em Abrir.

    O arquivo XFL abre no Animate da mesma forma que um arquivo FLA. Todas as camadas do arquivo original aparecem na Linha do tempo e os objetos originais aparecem no painel Biblioteca.

    Agora você pode trabalhar com o arquivo normalmente.

  3. Para salvar o arquivo, selecione Arquivo > Salvar.

    O Animate solicita a criação de um nome para o novo arquivo FLA na caixa de diálogo Salvar como.

  4. Digite um nome e salve o arquivo FLA.

Como trabalhar com arquivos XFL descompactados

A partir do Animate CC, você pode optar por trabalhar com seus arquivos Animate no formato XFL descompactado. Este formato permite ver cada uma das partes separadas, ou subarquivos, que compõem o arquivo do Animate. Essas partes incluem:

  • Um arquivo XML que descreve o arquivo do Animate como um todo.

  • Arquivos XML separados para descrever cada símbolo da Biblioteca.

  • Arquivos XML adicionais que contêm configurações de publicação e configurações móveis, entre outras.

  • Pastas que contêm ativos externos, como arquivos bitmap, usados pelo arquivo do Animate.

Ao trabalhar com o formato XFL descompactado, você pode permitir que pessoas diferentes trabalhem separadamente em cada parte do arquivo do Animate. Você também pode usar um sistema de controle de origem para gerenciar as alterações feitas em cada subarquivo contido no arquivo XFL descompactado. Juntos, esses recursos permitem a colaboração muito mais fácil em projetos maiores com vários designers e desenvolvedores.

Utilizando a atualização ao vivo com arquivos XFL

Com a atualização ao vivo de ativos editáveis para documentos XFL descompactados, você pode editar qualquer ativo de biblioteca a partir de um documento XFL descompactado enquanto o documento estiver aberto no Animate. As alterações feitas no ativo se refletem no Animate quando você termina de editá-lo em outro aplicativo.

Para editar um ativo a partir de um documento XFL descompactado em outro aplicativo:

  1. Salve um documento do Animate no formato XFL descompactado.

  2. Em um editor apropriado, como o Photoshop, abra o ativo que você deseja editar a partir da pasta BIBLIOTECA do documento XFL descompactado.

  3. Edite o ativo e salve as alterações.

  4. Retorne ao Animate.

    A atualização do ativo é refletida no Animate imediatamente.

Editar um arquivo SWF do Dreamweaver no Animate 

Se você tem o Animate e o Dreamweaver instalados, é possível selecionar um arquivo SWF em um documento do Dreamweaver e usar o Animate para editá-lo. O Animate não edita diretamente o arquivo SWF; ele edita o documento de origem (arquivo FLA) e reexporta o arquivo SWF.

  1. No Dreamweaver, abra o Inspetor de propriedades (Janela > Propriedades).
  2. No documento do Dreamweaver, siga um destes procedimentos:
    • Clique no espaço reservado para o arquivo SWF para selecioná-lo; então, no Inspetor de propriedades, clique em Editar.

    • Clique com o botão direito do mouse (Windows) ou com a tecla Control pressionada (Macintosh) no espaço reservado para o arquivo SWF, em seguida, selecione Editar com Animate no menu de contexto.

      O Dreamweaver muda o foco para o Animate e o Flash tenta localizar o arquivo de criação do Animate (FLA) para o arquivo SWF selecionado. Se o Animate não conseguir localizar o arquivo de criação, será solicitado que você o localize.

      Observação: se os arquivos FLA ou SWF estiverem bloqueados, verifique-os no Dreamweaver.

  3. No Animate, edite o arquivo FLA. A janela Documento do Animate indica que você está modificando o arquivo no Dreamweaver.

  4. Quando terminar a edição, clique em Concluído.

    O Animate atualiza o arquivo FLA, reexporta-o como um arquivo SWF e é encerrado. Em seguida, o foco retorna ao documento do Dreamweaver.

    Observação:

    Para atualizar o arquivo SWF e manter o Animate aberto, no Animate, selecione Arquivo > Atualizar para Dreamweaver.

  5. Para exibir o arquivo atualizado no documento, clique em Reproduzir no Inspetor de propriedades do Dreamweaver ou pressione F12 para visualizar a página em uma janela do navegador.
  1. Inicie o Animate.

  2. Na janela principal do Animate, selecione Criar Novo > Arquivo do Animate (móvel).

  3. No Device Central, selecione uma versão do Player e uma versão do ActionScript.
  4. Selecione um tipo de conteúdo.
  5. Na lista Dispositivos Disponíveis, selecione um único dispositivo de destino ou vários dispositivos (ou selecione um conjunto ou dispositivo individual na lista Conjuntos de Dispositivos).
  6. Clique em Criar.
  7. Adicione o conteúdo ao novo documento do Animate.

  8. Para testar o documento, selecione Controlar > Testar.

Criação de um novo documento

Você pode criar um novo documento ou abrir um documento salvo anteriormente no Animate e pode também abrir uma nova janela enquanto trabalha. É possível definir propriedades para os documentos novos ou existentes.

É possível escolher o destino para uma animação usando qualquer um dos propósitos; o Animate fornece os formatos de predefinição. Selecione o propósito desejado nas guias da parte superior da tela, como Animação de personagem, Social, Jogos, Ensino, Anúncios, Web e Avançado.

Selecione as predefinições adequadas para cada um dos propósitos e clique em Criar para começar a criar animações. Encontre os ativos usados recentemente no painel esquerdo. Os ativos de amostra são fornecidos na parte inferior da tela de inicialização.

Launch-screen

Criação de um novo documento

  1. Selecione Arquivo > Novo.

    Novo documento
    Novo documento
  2. Selecione o propósito desejado nas guias da parte superior da tela, como Animação de personagem, Social, Jogos, Ensino, Anúncios, Web e Avançado.

  3. Selecione as predefinições adequadas para cada um dos propósitos e clique em Criar.

    Além disso, você também pode escolher as configurações do documento. Consulte Configurar propriedades de um documento novo ou existente.

Criar um novo documento a partir de um modelo

  1. Selecione Arquivo > Novo a partir do modelo.

    Novo a partir da caixa de diálogo Modelo
    Novo a partir da caixa de diálogo Modelo
  2. Selecione uma categoria da lista Categoria, selecione um documento da lista Itens de categoria e clique em OK. É possível selecionar os modelos padrão que vêm com o Animate ou um modelo já salvo.

Abrir um documento existente

  1. Selecione Arquivo > Abrir.

  2. Na caixa de diálogo Abrir, navegue até o arquivo ou digite o caminho para o arquivo na caixa Ir para.
  3. Clique em Abrir.

Visualizar um documento quando vários documentos estiverem abertos

Ao abrir vários documentos, as guias no topo da janela Documento identificam os documentos abertos e permitem que você navegue facilmente entre eles. As guias aparecem somente quando os documentos estão maximizados na janela Documento.

  1. Clique na guia do documento que você deseja visualizar.

    Por padrão, as guias aparecem na ordem em que os documentos foram criados. Você pode arrastar as guias do documento para mudar sua ordem.

Abra uma nova janela para o documento atual

  1. Selecione Janela > Duplicar janela.

Definir as propriedades de um documento novo ou existente

  1. Com o documento aberto, selecione Modificar > Documento.

    A caixa de diálogo Configurações do documento é exibida.

  2. Para definir as Dimensões do palco, faça o seguinte:
    • Para especificar o tamanho do Palco em pixels, digite os valores nas caixas Largura e Altura. O tamanho mínimo é 1 x 1 pixel; o máximo é 2880 x 2880 pixels.

    • Para corresponder o tamanho do Palco à quantidade exata de espaço usado pelos seus conteúdos, selecione a opção Ajustar aos Conteúdos.

    • Para definir o tamanho do Palco conforme a área máxima de impressão disponível, clique em Ajustar à Impressora. Essa área é determinada pelo tamanho do papel, menos a margem selecionada na área das Margens da caixa de diálogo Configurar página (Windows) ou Margens de impressão (Macintosh).

    • Para definir o tamanho do Palco como o tamanho padrão, 550 x 400 pixels, clique em Ajustar ao Padrão.

  3. Para ajustar a posição e a orientação de objetos 3D no Palco para manter sua aparência em relação às bordas do Palco, selecione Ajustar Ângulo de Perspectiva 3D para Preservar a Projeção do Palco Atual.

    Essa opção só estará disponível se você alterar o tamanho do Palco.

  4. (Somente para CS5.5) Para escalar automaticamente os conteúdos do palco proporcionalmente à alteração do tamanho do palco, selecione Escalar Conteúdo com o Palco.

    Essa opção só estará disponível se você alterar o tamanho do Palco. Em Preferências, você pode escolher se irá dimensionar o conteúdo nas camadas bloqueadas e ocultas. Para obter mais informações, consulte Definir preferências gerais.

  5. Para especificar a unidade de medida das réguas exibidas no espaço de trabalho, selecione uma opção no menu Unidades da Régua. (Esta configuração também determina as unidades usadas no painel Informações).
  6. Para definir a cor do plano de fundo do seu documento, clique na amostra da Cor do plano de fundo e selecione uma cor da paleta.
  7. Em Taxa de quadros, digite o número de quadros de animação para aparecer a cada segundo.

    Para a maioria das animações exibidas por computador, especialmente aquelas reproduzidas em um site da Web, 8 quadros por segundo (Qps) a 15 fps são suficientes. Ao alterar a taxa de quadros, a nova taxa de quadros torna-se o padrão para os novos documentos.

  8. (CS5.5 somente) Para salvar automaticamente o documento em um intervalo de tempo especificado, marque a opção Salvamento automático e especifique um número de minutos entre os salvamentos.
  9. Siga um destes procedimentos:
    • Para aplicar as novas configurações somente ao documento atual, clique em OK.

    • Para tornar padrões as novas configurações das propriedades em todos os novos documentos, clique em Tornar padrão.

Alterar propriedades do documento usando o Inspetor de propriedades

  1. Clique no espaço de trabalho fora do Palco para desmarcar todos os objetos no Palco. As propriedades do documento são exibidas no Inspetor de propriedades. Para abrir o Inspetor de propriedades, escolha (Janela > Propriedades).
  2. (Somente CS5.5) Na seção Publicação, escolha uma versão do Flash Player e uma versão do ActionScript para o documento. Para acessar configurações adicionais de Publicação, clique no botão Configurações de publicação. Para obter mais informações, consulte Configurações de publicação.

  3. Na seção Propriedades para QPS (quadros por segundo), introduza o número de quadros de animação a executar a cada segundo.
  4. Para alterar o tamanho do Palco, insira valores para a largura e altura do Palco.
  5. Para selecionar uma cor de plano de fundo para o Palco, clique na amostra de cor ao lado da propriedade Palco e selecione uma cor da paleta.
  6. Para editar propriedades de documentos adicionais, clique no botão Editar ao lado das propriedades Tamanho. Para obter mais informações sobre todas as propriedades do documento, consulte Definir propriedades para um documento novo ou existente .

Adição de metadados XMP em um documento

Você pode incluir dados XMP (Extensible Metadata Platform) como título, autor, descrição, direitos autorais e mais em seus arquivos FLA. O XMP é um formato de metadados que alguns outros aplicativos Adobe ® conseguem interpretar. Os metadados são visíveis no Animate e no Adobe® Bridge. Para obter mais informações sobre metadados XMP, consulte a seção Metadados e palavras-chave na Ajuda do Bridge.

Observação: o Adobe Animate CC não é compatível com o Bridge de 32 bits.

Incorporar metadados melhora a capacidade dos mecanismos de pesquisa baseados na Web para retornar resultados de pesquisa significativos para o conteúdo do Animate. Os metadados de pesquisa são baseados nas especificações XMP (Extensible Metadata Platform) e são armazenados no arquivo FLA em um formato compatível com W3C.

Os metadados de um arquivo contêm informações sobre o conteúdo, status de direitos autorais, origem e histórico do arquivo. Na caixa de diálogo Informações do arquivo, você pode visualizar e editar os metadados do arquivo atual.

Dependendo do arquivo selecionado, os seguintes tipos de metadados podem aparecer:

Descrição

Contém o nome do autor, título, direitos autorais e outras informações.

IPTC

Exibe os metadados editáveis. Você pode adicionar legendas aos seus arquivos, bem como informações de direitos autorais. O IPTC Core é uma especificação aprovada pelo IPTC (International Press Telecommunications Council) em outubro de 2004. É diferente do antigo IPTC (IIM, anterior) em que novas propriedades foram adicionadas, alguns nomes de propriedades foram alterados e algumas propriedades foram excluídas.

Dados da câmera (Exif)

Exibe informações atribuídas por câmeras digitais, incluindo as configurações da câmera utilizadas quando a imagem foi capturada.

Dados de vídeo

Exibe metadados de arquivos de vídeo, incluindo proporção de pixels da tela, cena e captura.

Dados de áudio

Exibe metadados de arquivos de áudio, incluindo artista, álbum, número da faixa e gênero.

SWF móvel

Revela informações sobre os arquivos SWF, incluindo título, autor, descrição e direitos autorais.

Histórico

Mantém um registro de alterações feitas nas imagens com o Photoshop.

Observação: A preferência de Log de histórico deve estar ativada no Photoshop para que log seja salvo com os metadados do arquivo.

Version Cue

Revela informações de qualquer versão de arquivos do Version Cue.

DICOM

Exibe informações sobre imagens salvas no formato DICOM (Digital Imaging and Communications in Medicine).

Para adicionar metadados:

  1. Selecione Arquivo > Informações do arquivo.
  2. Na caixa de diálogo Informações do arquivo exibida, insira os metadados que deseja incluir. Você pode adicionar ou remover metadados no arquivo FLA a qualquer momento.

Salvar documentos do Animate

É possível salvar um documento Animate FLA usando seu nome e local atuais ou usando um nome ou local diferente.

Quando um documento contiver alterações não salvas, aparecerá um asterisco (*) depois do nome do documento na barra do título do documento, na barra do título do aplicativo e na guia documento. Ao salvar o documento, o asterisco é removido.

Salvar um documento do Animate no formato FLA padrão

  1. Siga um destes procedimentos:
    • Para sobrescrever a versão atual no disco, selecione Arquivo > Salvar.

    • Para salvar o documento em um local diferente e/ou com um nome diferente ou para compactar o documento, selecione Arquivo > Salvar como.

  2. Se você tiver selecionado Salvar como ou se o documento nunca tiver sido salvo antes, digite o nome e o local do arquivo.
  3. Clique em Salvar.

Salvar um documento no formato XFL descompactado

  1. Escolha Arquivo > Salvar Como.
  2. No menu Salvar como tipo, escolha Documento não compactado do Animate CC (*xfl).

  3. Escolha um nome e um local para o arquivo e clique em Salvar.

Reverter para a última versão salva de um documento

  1. Selecione Arquivo > Reverter.

Salvar um documento como modelo

  1. Selecione Arquivo > Salvar como modelo.
  2. Na caixa de diálogo Salvar como modelo, digite um nome para o modelo na caixa Nome.
  3. Selecione uma categoria no menu pop-up Categoria ou digite um nome para criar uma nova categoria.
  4. Digite uma descrição do modelo na caixa Descrição (até 255 caracteres) e clique em OK.

    A descrição aparecerá quando o modelo for selecionado na caixa de diálogo Novo documento.

    Para excluir um modelo de salvo, vá até uma das seguintes pastas e exclua o arquivo de modelo FLA da pasta da categoria que o contém.

    • Windows XP - C:\Documents and Settings\<userName>\Local Settings\Application Data\Adobe\Flash CS5\pt_BR\Configuration\Templates\

    • Windows Vista and 7 - C:\Users\<userName>\AppData\Local\Adobe\Flash CS5\<language>\Configuration\Templates\

    • Mac OS - <HardDisk>/Users/<userName>/Library/Application Support/Adobe/Flash CS5/<language>/Configuration/Templates/

Salvar um documento como documento do Animate CC

  1. Selecione Arquivo > Salvar como.
  2. Digite o nome e o local do arquivo.
  3. Selecione o documento do Animate CC no menu pop-up Formato e clique em Salvar.

    Observação:

    Se uma mensagem de alerta indicar que o conteúdo será excluído se você salvar no formato Animate CC, clique em Salvar como Animate CC para continuar. Isso pode acontecer se o seu documento contiver recursos disponíveis apenas no Animate CC. O Animate não preserva esses recursos quando você salva o documento no formato Animate CC.

Salvar documentos ao sair do Animate

  1. Selecione Arquivo > Sair (Windows) ou Animate > Sair do Animate (Macintosh).

  2. Se houver documentos abertos com alterações não salvas, o Animate envia um aviso para salvar ou descartar as alterações de cada documento.

    • Clique em Sim para salvar as alterações e fechar o documento.

    • Clique em Não para fechar o documento sem salvar as alterações.

Imprimir documentos do Animate (descontinuado após o Flash Professional CC)

Para visualizar e editar seus documentos, imprima quadros de documentos do Adobe Animate ou especifique quadros que poderão ser impressos do Flash Player pelo visualizador.

Ao imprimir quadros de um documento do Animate, use a caixa de diálogo Imprimir para especificar o intervalo de cenas ou quadros a ser impresso, bem como o número de cópias. No Windows, a caixa de diálogo Configurar Página especifica o tamanho e a orientação do papel e outras opções de impressão - inclusive configurações de margem e se todos os quadros serão impressos em cada página. No Macintosh, estas opções são divididas entre as caixas de diálogo Configurar Página e Margens de Impressão.

As caixas de diálogo Imprimir e Configurar Página são padrão em ambos os sistemas operacionais, e sua aparência depende do driver de impressão selecionado.

  1. Selecione Arquivo > Configurar Página (Windows) ou Arquivo > Margens de Impressão (Macintosh).
  2. Defina as margens de impressão. Selecione ambas as opções Centro para imprimir o quadro no centro da página.
  3. No menu Quadros, selecione se irá imprimir todos os quadros no documento ou somente o primeiro quadro de cada cena.
  4. Na guia Layout, selecione uma das seguintes opções:

    Tamanho real

    Imprime o quadro em seu tamanho real. Digite um valor de Dimensionamento para reduzir ou ampliar o quadro impresso.

    Ajustar a uma página

    Reduz ou amplia cada quadro de forma a preencher a área de impressão da página.

    Storyboard

    Imprime várias miniaturas em uma página. Selecione entre as opções Caixas, Grade ou Em branco. Digite o número de miniaturas por página na caixa Quadros. Defina o espaço entre as miniaturas na caixa Margem dos quadros e selecione Rotular quadros para imprimir o rótulo do quadro como miniatura.

  5. Para imprimir quadros, selecione Arquivo > Imprimir.

Uso de rótulos de quadros para desabilitar a impressão

Para não imprimir algum quadro da Linha do tempo principal, rotule o quadro como !#p para que todo o arquivo SWF não seja impresso. Rotular quadro como !#p faz esmaecer o comando Imprimir no menu de contexto do Flash Player. Você também pode remover o menu de contexto do Flash Player.

Se você desabilitar a impressão do Flash Player, o usuário ainda poderá usar o comando Imprimir do navegador para imprimir quadros. Como esse comando é um recurso do navegador, não é possível usar o Animate para controlá-lo ou desabilitá-lo.

Desabilitar a impressão no menu de contexto do Flash Player

  1. Abra ou ative o documento do Animate (arquivo FLA) a ser publicado.

  2. Selecione o primeiro quadro-chave da Linha do tempo principal.
  3. Selecione Janela > Propriedades para exibir o Inspetor de propriedades.
  4. No Inspetor de propriedades, para Rótulo do quadro, digite !#p para especificar o quadro como não imprimível.

    Especifique somente um !#protular para esmaecer o comando Imprimir no menu de contexto.

    Observação:

    Você também pode selecionar um quadro em branco (em vez de um quadro-chave) e rotular o quadro como #p.

Desabilitar a impressão removendo o menu de contexto do Flash Player

  1. Abra ou ative o documento do Animate (arquivo FLA) a ser publicado.

  2. Selecione Arquivo > Configurações de publicação.
  3. Selecione a guia HTML, desmarque Exibir menu e clique em OK.

Especificar uma área de impressão ao imprimir quadros

  1. Abra o documento do Animate (arquivo FLA) que contém os quadros que serão definidos para impressão.

  2. Selecione um quadro que você não especificou para impressão com rótulo de quadro #p que esteja na mesma camada do quadro rotulado como #p.

    Para organizar seu trabalho, selecione o próximo quadro após o quadro rotulado #p.

  3. Crie uma forma no Palco com o tamanho da área de impressão desejada. Para usar uma caixa delimitadora de quadro, selecione um quadro com qualquer objeto do tamanho da área de impressão adequada.
  4. Selecione o quadro na Linha do tempo que contenha a forma a ser usada para a caixa delimitadora.
  5. No Inspetor de propriedades (Janela > Propriedades), digite #b para que o Rótulo do quadro especifique a forma selecionada como caixa delimitadora da área de impressão.

    Somente é permitido um rótulo de quadro #b por Linha do tempo. Essa opção é o mesmo que selecionar a opção da caixa delimitadora Filme com a ação Print.

Alteração da cor de plano de fundo impressa

Você pode imprimir a cor de plano de fundo definida na caixa de diálogo Propriedades do documento. Altere a cor de plano de fundo somente dos quadros a serem impressos colocando um objeto colorido na camada mais baixa da Linha do tempo que está sendo impressa.

  1. Coloque uma forma preenchida que cubra o Palco na camada mais baixa da Linha do tempo a ser impressa.
  2. Selecione a forma e escolhe Modificar > Documento. Selecione uma cor para o plano de fundo da impressão.

    Esta ação altera a cor de plano de fundo do documento inteiro, incluindo a dos clipes de filme e de arquivos SWF carregados.

  3. Siga um destes procedimentos:
    • Para imprimir essa cor como plano de fundo do documento, designe a impressão do quadro no qual você inseriu a forma.

    • Para manter uma cor de plano de fundo diferente para os quadros que não serão impressos, repita as etapas 2 e 3. Em seguida, coloque a forma na camada mais baixa da Linha do tempo, em todos os quadros não designados para impressão.

Use o comando Imprimir do menu de contexto do Flash Player para imprimir quadros de qualquer arquivo SWF do Animate.

O comando Imprimir do menu de contexto não imprime efeitos de transparência ou cor e não pode imprimir quadros de outros clipes de filme; para obter recursos de impressão mais avançados, use o objeto PrintJob ou a função print().

  1. Abra o documento.

    O comando imprime os quadros rotulados #p usando o Palco da área de impressão ou a caixa delimitadora especificada.

    Se você não designou quadros específicos a serem impressos, todos os quadros da Linha do tempo principal do documento serão impressos.

  2. Selecione Arquivo > Publicar visualização > Padrão ou pressione F12 para ver o conteúdo do Animate em um navegador.

  3. Clique com o botão direito do mouse (Windows) ou com a tecla Control pressionada (Macintosh) no conteúdo do Animate na janela do navegador para exibir o menu de contexto do Flash Player.

  4. Selecione Imprimir no menu de contexto do Flash Player para desabilitar a caixa de diálogo Imprimir.
  5. No Windows, selecione o intervalo de impressão para escolher os quadros a serem impressos.
  6. No Macintosh, na caixa de diálogo Imprimir, selecione as páginas a serem impressas.
  7. Selecione outras opções de impressão de acordo com as propriedades da impressora.
  8. Clique em OK (Windows) ou Imprimir (Macintosh).

Observação:

A impressão do menu de contexto não interage com as chamadas ao objeto PrintJob.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online