Visão geral da interface

Saiba mais sobre a interface e o espaço de trabalho do Substance 3D Designer.

O Designer pode parecer intimidador no início, mas, depois que você souber para que serve cada parte da interface, ficará muito mais fácil de entender.

Um diagrama mostrando uma versão simplificada do layout da interface do usuário do Designer, com rótulos apontando para cada seção.

A. Barra de ferramentas principal B. Explorer C. Gráfico D. Propriedades E. Visualização 2D F. Visualização 3D G. Biblioteca 

Observação:

Talvez você não reconheça alguns dos termos desta página. Se encontrar uma palavra ou conceito desconhecido, verifique o Glossário para ver definições ou leia sobre Conceitos básicos do Substance Designer.

Barra de ferramentas principal

Encontre os menus principais e os botões de acesso rápido úteis.

O menu Arquivo permite:

  • Salvar e abrir pacotes
  • Criar pacotes e gráficos
  • Recarregar todo o conteúdo
  • Sair do aplicativo

O menu Editar permite Desfazer e Refazer ações. O menu Editar também dá acesso à janela Preferências, onde você pode ajustar as configurações do aplicativo.

O menu Ferramentas permite ajustar as opções do Substance Engine. O Substance Engine é o processo que calcula gráficos do Substance. No menu Ferramentas , você pode pausar, redefinir e ajustar as configurações do Engine. O menu Ferramentas também dá acesso ao Gerenciador de plug-ins.

O menu Janelas permite gerenciar as janelas que compõem a interface do Designer. Você pode abrir novas janelas, alternar a visibilidade de janelas individuais ou usar Janela > Redefinir layout para retornar o Designer ao estado padrão.

No menu Ajuda , você pode acessar recursos como a documentação, tutoriais e notas de versão do Designer. Você também pode nos enviar feedback e informar bugs ou encontrar mais informações sobre licenciamento e versões.

O painel Explorer

Gerencie pacotes e recursos.

Dois exemplos do menu do botão direito do mouse aberto no painel Explorer. A primeira imagem mostra o menu do botão direito do mouse de um pacote, a segunda imagem mostra o menu do botão direito do mouse de um gráfico.
O menu do botão direito do mouse muda dependendo do tipo de recurso em que você clicar. À esquerda, você pode ver o menu do botão direito do mouse de um pacote, enquanto à direita, o menu de um gráfico.

O painel Explorer é a sua principal maneira de interagir com arquivos e recursos no Designer. 

O painel Explorer lista todos os pacotes abertos e mostra seu conteúdo. Clique com o botão direito do mouse em pacotes, gráficos ou outros recursos para obter um menu sensível ao conteúdo. Todos os recursos têm um conjunto de opções padrão que inclui

  • Abrir
  • Fechar
  • Renomear
  • Copiar e colar

Alguns recursos têm opções exclusivas que estão disponíveis somente no menu do botão direito do mouse. Você também pode clicar com o botão direito do mouse em um espaço vazio no painel Explorer para criar um novo pacote vazio.

Há botões na parte superior do painel Explorer para gerenciar seus recursos. Para habilitar esses botões, selecione primeiro um pacote ou gráfico.

Se você clicar em qualquer recurso, o painel Propriedades atualizará e mostrará as propriedades da seleção atual.

É possível abrir vários painéis do Explorer. Use Janelas > Novo Explorer para abrir outro painel Explorer.

A Janela de visualização Gráfico

Crie gráficos baseados em nó.

Uma captura de tela da janela de gráfico do Designer. Esta imagem mostra a barra de ferramentas do gráfico na parte superior da janela e a janela de visualização do gráfico abaixo da barra de ferramentas.
A janela de visualização Gráfico consiste na barra de ferramentas Gráfico e na Exibição do gráfico. A barra de ferramentas Nó faz parte da barra de ferramentas Gráfico

A janela de visualização Gráfico é onde você passa a maior parte do seu tempo no Designer. Ela exibe os gráficos que você cria ou abre com o Designer e é onde você pode adicionar, remover e organizar nós.

Há duas áreas distintas: a barra de ferramentas e a área de exibição.

Barra de ferramentas Gráfico

Uma captura de tela recortada da barra de ferramentas Gráfico.

A barra de ferramentas Gráfico contém ferramentas para gerenciar o gráfico e muitos dos nós mais usados. Para simplificar as coisas, botões com fundos coloridos são nós enquanto outros botões são ferramentas. Visão geral da interface

Você pode encontrar as seguintes ferramentas na barra de ferramentas principal:

  •  Foco — Volta a exibir sua seleção. Se não houver um nó selecionado, Foco mostrará o gráfico inteiro. Foco ajuda a navegar ou localizar sua seleção rapidamente. A tecla de atalho F tem a mesma função.
  •  Redefinir Zoom — Define o nível de zoom de volta ao nível padrão 1:1. A tecla de atalho Z tem a mesma função.
  •  Captura de tela — Salva uma captura de tela PNG de todo o gráfico, com transparência. Uma caixa de diálogo de arquivo será aberta para que você possa definir o nome do arquivo e o local.
  •  Informações — Abre um menu suspenso no qual você pode alternar Nomes de conector, Emblema do nó, Tamanho do nó e Tempos do nó. Quando habilitadas, essas opções adicionam informações aos Nós na área de exibição.
  •  Pesquisar — Pesquisa nós e parâmetros no gráfico filtrando por tipo e texto.
  •  Realçar fluxo — Esclarece quais nós estão conectados à seleção atual. Os nós não conectados ficam esmaecidos.
  •  Barra de ferramentas de nó — Alterna a exibição dos botões para nós atômicos. 
  •  Barra de ferramentas principal — Alterna a exibição do controle Resolução principal na barra de ferramentas.
  •  Modos de criação de vínculo — Permite escolher qual dos três modos de link usar (Padrão, Material ou Material Compacto). Os atalhos do teclado 1, 2 e 3 executam as mesmas funções.
  •  Vínculos de retângulo — Alterna entre vínculos como curvas suaves ou como ângulos retangulares.
  •  Controle de tempo — Permite redefinir exibições de tempo. Controle de tempo só é relevante se os Tempos dos nós estiverem ativados no menu suspenso Informações.
  •  Ferramentas — Permite acessar uma lista suspensa com opções diversas. 
    • Limpar remove nós não utilizados do gráfico.
    • Exportar saídas apresenta a caixa de diálogo Exportar, permitindo exportar arquivos bitmap.
    • Reexportar saídas executa uma saída anterior novamente com as mesmas opções, sem apresentar a caixa de diálogo.
    • Exportador PSD abre o painel Exportar do PSD adicional. O painel Exportar do PSD é exibido à direita da Visualização do gráfico.
  •  Barra de ferramentas de miniaturas — Alterna a exibição do menu suspenso de opções de miniaturas na barra de ferramentas.
  •  Ferramentas de alinhamento — Alterna a exibição das ferramentas de Alinhamento na barra de ferramentas. As ferramentas de Alinhamento permitem alinhar e organizar os nós na grade do gráfico.

 Visão geral da interface

Barra de ferramentas de nó

Barra de ferramentas de nó

Clique em um nó na barra de ferramentas do nó para adicioná-lo ao gráfico. A barra de ferramentas do nó contém os nós atômicos do Designer. Nós atômicos são os nós fundamentais dos gráficos do Designer, eles são os elementos que você pode usar para criar redes complexas. Para obter mais informações sobre nós, consulte a página Visão geral de nós.

Observação:

A barra de ferramentas do nó é apenas uma maneira de adicionar nós, e há muito mais nós disponíveis além daqueles contidos na barra de ferramentas. O artigo Criar um Gráfico possui mais informações.

Exibição do Gráfico

Visualização do gráfico

A área de exibição do gráfico contém os nós que compõem o gráfico. Insira e conecte nós para criar um gráfico que gere suas texturas. Visão geral da interface

Consulte a página Criar um gráfico para obter mais informações sobre como trabalhar com o gráfico.

O painel Propriedades

Modifique as propriedades sensíveis ao contexto.

Capturas de tela lado a lado do painel Propriedades. A primeira imagem mostra o painel Propriedades como ele aparece quando o gráfico é selecionado. A segunda imagem mostra como o painel aparece quando um nó de mesclagem é selecionado.
O painel Propriedades muda de aparência dependendo do recurso selecionado. A imagem à esquerda mostra como o painel Propriedades é exibido com um gráfico selecionado. A imagem à direita mostra como o painel Propriedades é exibido com um nó de mesclagem selecionado.

O painel Propriedades é sensível ao contexto e exibe parâmetros que alteram o comportamento do recurso ou nó selecionado. Combinados, os painéis Gráfico e Propriedades são onde você passa a maior parte do seu tempo no Designer.

Devido ao alto número de controles que podem ser mostrados de uma vez, o painel Propriedades tem categorias para manter os controles organizados. Abaixo você pode ler uma descrição das principais categorias:

  • Parâmetros básicos é uma categoria presente nos recursos de gráfico e em cada nó. Eles permitem alterar os parâmetros principais relacionados à resolução e à configuração do gráfico. Alguns parâmetros importantes estão listados abaixo.
    • Tamanho da saída — Define a resolução do gráfico ou nó. 
    • Formato de saída — Define o formato ou a precisão do gráfico ou nó. 
    • Modo Revestimento — Define se uma imagem será envolvida fora de seus limites.
    • Semente aleatória — Altera a semente aleatória usada para geração processual.

O comportamento dos parâmetros básicos depende do método de herança (). Relativo significa que o comportamento do nó é definido em outro lugar (pelo gráfico ou por um nó anteriormente conectado). Absoluto significa que é definido usando os controles de parâmetro. Se um parâmetro básico estiver acinzentado, é provável que o modo de herança esteja definido como Relativo.

  • Atributos contêm metadados relacionados ao gráfico ou nó. Você pode usar metadados para criar categorias na Biblioteca.
  • Parâmetros de entrada são visíveis somente para gráficos. Você pode encontrar todos os seus parâmetros expostos aqui.
  • Parâmetros de instância/específicos são visíveis somente para nós. O nome difere entre os nós atômicos e de instância, mas a funcionalidade é a mesma: permite ajustar configurações específicas para esse nó. Você pode alterar a cor da saída, a opacidade de uma operação de mesclagem ou a escala de um ruído de um nó, por exemplo.
  • Entradas são visíveis somente para gráficos. Elas listam todos os nós de entrada ou parâmetros expostos e permite configurar nomes e propriedades para eles. 
  • Valores de entrada são visíveis somente para nós. Permitem adicionar entradas de valor a um nó. Você só usa valores de entrada em fluxos de trabalho avançados.
  • Saídas são visíveis somente para gráficos. Elas listam todos os nós de saída (ou slots) e permite configurar nomes e propriedades para eles a partir de um local central.

Janela de visualização 2D

Obtenha uma visualização de imagem sensível ao contexto.

Visualização 2D

A Janela de visualização 2D exibe o conteúdo dos nós. Clique duas vezes em um nó de imagem no gráfico e a visualização 2D exibirá a saída do nó.

Sua interação com a Janela de visualização 2D é limitada ao uso de zoom e de panorâmica quando ampliado. Você pode aumentar e diminuir o zoom rolando. Use os botões no canto inferior direito da Janela de visualização 2D para controlar o zoom. Você também pode redefinir o zoom com a tecla de atalho Z ou focar na tela com F.

Na parte superior da Janela de visualização 2D você pode encontrar os seguintes controles:

  •  Imagem de fundo — Define uma imagem de fundo para mostrar se há pixels transparentes.
  •  Salvar visualização — Permite salvar a imagem atual na Janela de visualização 2D em um arquivo bitmap.
  •  Copiar para área de transferência — Copia o conteúdo da Janela de visualização 2D para a área de transferência. 
  •  Selecionar saída — Permite alternar entre as diferentes saídas do nó.
  •  Selecionar conjunto UV — Permite selecionar qual canal UV exibir. Esse botão estará esmaecido, a menos que Exibir UVs em Visualização 2D do menu Cena da Janela de visualização 3D esteja ativo.

No canto inferior esquerdo da visualização 2D, podem ser encontrados botões com funções adicionais:

  •  Exibição de canal — Permite ativar e desativar os canais R, G e B. Melhor quando usado no modo de tons de cinza.
  •  Transparência — Alterna entre a exibição de pixels transparentes como uma textura quadriculada ou como preto plano.
  •  Alternar tons de cinza/cor — Alterna entre a exibição da Janela de visualização 2D em cores ou em tons de cinza.
  •  Revestimento repetido — Organiza a imagem lado a lado na Janela de visualização 2D. Dessa forma, você pode encontrar artefatos lado a lado facilmente. Enquanto o mouse estiver sobre a Janela de visualização 2D, a barra de espaço atua como um atalho.
  •  Usar tamanho físico — Alterna o uso de informações de tamanho físico para a exibição da visualização.
  •  Informações da imagem — Abre um painel de informações da imagem, exibindo valores exatos dos pixels sobre os quais você passa o cursor.
  •  Histograma — Abre um painel que mostra uma análise de Histograma da visualização atual.
  •  Alternar sRGB — Ativa ou desativa a exibição no espaço de cores sRGB.
  •  Alternar pré-multiplicação — Alterna a pré-multiplicação de pixels com um canal alfa com a cor de fundo.

Visualização 3D

Interagir com uma visualização 3D do material completo.

Visualização 3D

A Janela de visualização 3D exibe seu material. Ao contrário da Janela de visualização 2D, por padrão, ela usa os mapas de saída do gráfico para renderizar um material completo. Na Janela de visualização 3D você pode ver como seus canais, como cor de base, normal e aspereza se combinam para criar um resultado final.

Para visualizar seu material na Janela de visualização 3D, clique com o botão direito do mouse em uma área vazia na área de exibição do gráfico e selecione Exibir saídas na Visualização 3D. Você também pode enviar mapas individuais para a Visualização 3D clicando com o botão direito do mouse no nó e selecionando Exibir na Visualização 3D

Você pode usar um mouse de 3 botões e um teclado para interagir com a janela de visualização da seguinte maneira:

  • Arrastar com o botão esquerdo do mouse orbita a câmera em torno da malha.
  • Arrastar com o botão do meio do mouse desloca a câmera.
  • Arrastar com o botão direito do mouse ou rolar amplia ou reduz a malha.
  • O atalho do teclado F focaliza a câmera de volta na malha central, caso você perca o controle dela.
  • Ctrl + Shift + botão direito do mouse (Cmd + Shift + botão direito do mouse no Mac) gira as luzes ambiente.

Os sete principais menus estão descritos abaixo:

  • Cena permite alterar a malha exibida na janela de visualização. Você também pode salvar e carregar o estado da janela de visualização. Para exibir a malha personalizada na Janela de visualização 3D, clique duas vezes nela no ícone painel Explorer.
  • Materiais mostram todos os slots de material na malha e permitem escolher qual sombreamento e parâmetros serão usados. Nesse menu, é possível configurar opções como lado a lado com UV, deslocamento de altura e renderização não PBR.
  • Luzes é um menu das versões anteriores do Designer. As luzes nesse menu estão desabilitadas por padrão e recomendamos não usá-las, a menos que você abra arquivos antigos. Escolha a opção Editar para acessar as configurações de luz.
  • Câmera permite alternar entre ângulos de câmera predefinidos. Também permite salvar capturas renderizadas na janela de visualização 3D. Escolha Editar para alterar as configurações de pós-processamento.
  • Ambiente tem opções para ajustar a iluminação baseada em imagem da cena. Para alterar a imagem HDR na Visualização 3D, arraste e solte um recurso da categoria Visualização 3D do painel Biblioteca.
  • Exibição permite alterar algumas configurações diversas da janela de visualização, como wireframe e tela de resolução.
  • Renderizador é um menu importante que permite mudar da renderização OpenGL em tempo real para rastreamento de raios IRay acelerado por GPU. Quando o IRay é escolhido como renderizador, mais opções de IRay ficam disponíveis.

O painel Biblioteca

Encontre recursos para seus gráficos.

Visualização Biblioteca

No painel Biblioteca, você tem acesso a todo o conteúdo padrão do Designer. Para entender melhor os diferentes tipos de nós na biblioteca, confira a Visão geral de Nós.

Você pode adicionar conteúdo da Biblioteca ao gráfico simplesmente arrastando-o para a área de exibição do gráfico. Você também pode usar os atalhos do teclado da barra de espaço ou da Tab ao passar o mouse sobre a área de exibição do gráfico para abrir um menu para pesquisar rapidamente os nós.

As miniaturas grandes do painel Biblioteca podem ajudar você na procura de conteúdo. Ajuste o tamanho da miniatura com o menu suspenso no canto superior direito ().

Qual o próximo passo?

Uma vez que já abordamos a interface, você estará pronto para entrar nos Conceitos principais do Designer. 

Tem alguma pergunta ou uma ideia?

Se você tiver alguma dúvida ou ideia para compartilhar, junte-se a outros usuários do Designer na Comunidade do Substance 3D Designer. Obtenha ajuda, sugira alterações que possam ser incorporadas ao Designer ou exiba seu trabalho e técnicas.

Se você tiver novas ideias para nós ou recursos do Designer, compartilhe-as conosco aqui!

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?