Learn about new features and enhancements in the October 2020 release of Bridge (version 11.0)
Video thumbnail preview

Video thumbnail preview

Hover over your video thumbnails in Bridge to watch a quick preview of the frames in your videos and select the ones you like for your project. 

Encode in Adobe Media Encoder

Encode in Adobe Media Encoder

Encode or easily stitch selected videos from Adobe Bridge directly in Adobe Media Encoder.

Edit in Adobe Premiere Pro

Edit in Adobe Premiere Pro

Easily select assets in Adobe Bridge and take them to Adobe Premiere Pro to create a sequence for further editing.

Resize images to Fit or Fill

Resize images to Fit or Fill

Use the Export Panel to resize images to Fit or Fill a target rectangle. Also, preview the output image size before exporting.

Reorder export presets

Rearrange export presets

Move your export presets to arrange them in the desired order for easy access.

Other enhancements

Other enhancements

Enjoy improved cache workflows, preview generation, and the new Onboarding dialog.

Video thumbnail preview

It's now easy to browse through your videos in Adobe Bridge with the new video thumbnail preview for all supported video files. Video thumbnail previews speed up your workflow by showing you a quick preview of all frames in your video, without an audio playback. You can then easily select the video clips that are useful for your project.

Video thumbnail preview

To enable the video thumbnail preview feature, do the following:

  1. Go to Edit > Preferences > Thumbnails.
  2. In the Thumbnails menu, under the Video section, enable Preview Video on Mouse Hover.

Once you enable this option, you can simply hover your pointer over a video in the Content panel to see a quick video preview. The video thumbnail preview stops as you move the pointer away and goes back to the original thumbnail. Video thumbnail previewing on hover will always have priority over Preview panel playback.

For more information on video thumbnail previews, check out Preview dynamic media files in Adobe Bridge.

Note:

If you face performance issues with video workflows, check the recommended system requirements for Bridge on both Mac and Win.

Encode in Adobe Media Encoder

You can easily select your video assets in Bridge and send them to Adobe Media Encoder directly where the selected assets are queued up for encoding or stitching together.

Follow these quick steps to create your queue or stitched video in Media Encoder directly from Bridge:

  1. Select your videos in Bridge in the order you want. To rearrange your videos in a particular order, choose Sort Manually from the path bar above the Content panel. 
  2. With your videos selected, go to Tools >  Media Encoder > Add to Encoder Queue / Stitch Clips Together.
    1. Add to Encoder Queue: Add video clips to the encoder queue from Bridge and select the required encoding option for each file separately in Adobe Media Encoder. In Media Encoder, these assets are queued for encoding. To add clips to encoder queue in Media Encoder, you can also select the videos in Bridge and cmd-click/right-click to open contextual options and choose Place > In Adobe Media Encoder
    2. Stitch Clips Together: Stitch your video clips from Bridge together into one file. You can further rearrange video clips in Media Encoder before you start processing the queue. In Media Encoder, these assets are queued for encoding to be outputted as a single stitched clip.
Encode in Adobe Media Encoder

For more information, check out Work with Adobe Media Encoder.

Edit in Adobe Premiere Pro

You can easily select your video assets in Bridge and take them to Adobe Premiere Pro to create a sequence for further editing.

Follow these quick steps to create your edit sequence in Premiere Pro directly from Bridge:

  1. Select your videos in Bridge in the order you want. To rearrange your videos in a particular order, choose the Sort Manually option from the path bar above the Content panel. 
  2. With your videos selected, go to Tools > Premiere Pro > Edit (Create a sequence)

To add assets to a new project in Premiere Pro, you can select the videos in Bridge and cmd-click/right-click to open contextual options. Choose Place > In Adobe Premiere Pro

Edit in Adobe Premiere Pro

For more information, check out Work with Adobe Premiere Pro.

Resize images to fit or fill

With this release, you can adjust the size for your image to be exported based on whether you want to 'Fit' or 'Fill' a target rectangle area. Once you define the width and height of the target rectangle, you can also specify the resolution if the target width and height are in inches or cms. The Width Height option is for the target rectangle where your image output can either fit or fill.

Follow these easy steps to resize your image for export:

  1. Select assets from the Content panel that you wish to resize before export.
  2. Drag and drop the selected assets from the Content panel to Custom Export or a user-created export preset in the Export panel.
  3. In the Export dialog that opens, select Image Size > Resize to. You can also enable the Don't enlarge option to make sure your image doesn't get enlarged on exporting. By default, Don't enlarge is enabled for Fit and disabled for Fill.
    1. On selecting Fit, you can fit your image to resize on the basis of Long edge, Short edge, or Width Height.
      • Long Edge: You can manually change the Dimension and Resolution before you export your images.
      • Short Edge: You can manually change the Dimension and Resolution before you export your images.
      • Width Height: You can manually change the Width, Height, and Resolution before you export your images. When you select Width/Height as your Fit option, your image is resized as per a target rectangle.
    2. On selecting Fill, you can resize on the basis of the Width Height of the target rectangle. You can also view image thumbnails under Resize To having the original and new sizes of the images mentioned below each thumbnail.
    3. You can specify the Resolution of your image in Pixels/inch or Pixels/cm and Dimension metrics in pixels/inches/cm.

You can also see a preview of the images beside the resize options to quickly view your applied changes for Width/Height options.

Resize images to fit or fill

For more information, check out Asset conversion using the Export panel.

Reorder export presets

In the Export panel, you can easily drag export presets to arrange them in the desired order for easy access. The order of your presets remains unchanged across default or custom workspaces in Bridge. Also, the order of presets is unchanged on the next launch of Bridge. By default, new presets are added to the bottom of the preset list in the Export panel.

Rearrange export presets

For more information, check out Asset conversion using the Export panel.

Other enhancements

Single key ratings and labels

You can now easily toggle between ratings/labels and file navigation in Adobe Bridge. By default, the Use Ctrl/Cmd for Ratings and Labels option is enabled. Once disabled, apply labels and ratings to your assets in the Control panel using single numeric keys without holding down the Ctrl/Cmd keys. 

You can access the single key ratings and labels option from any of the following locations:

  • Use Ctrl/Cmd for Labels & Ratings checkbox at the bottom of the Content panel. 
  • Label > Use Ctrl/Cmd for shortcuts
  • Edit > Preferences > Labels and Ratings > Keyboard Option > Use Ctrl/Cmd to Apply Labels and Ratings

When you enable this option, you can use 0-9 numeric keys for file navigation. 

Single key ratings and labels

For more information, check out Adobe Bridge workspace.

Improved preview quality

With this release, Bridge automatically generates high-quality previews for your assets almost instantaneous. The default preview options are, Preview size > High Quality and Preview Generation > Always Generate. Users who currently use "100% previews" or "Monitor size previews" can try this new default option and check the preview quality in the Full screen mode and in the Preview panel. The thumbnail menu option includes the "Monitor Size" preview option which can be accessed in the Preferences dialog (Preferences > Advanced) as in the previous versions.

Improved preview quality

Note:

It is not recommended to work with Monitor Size Previews or 100% Previews unless your workflow requires even higher quality previews. These options need CPU intensive processes to render much higher quality previews.

For more information, check out Adjust Adobe Bridge Content panel display.

Delete 100% previews

With this release, you can now selectively delete your 100% preview renditions stored in the app cache. This is helpful if your workflow requires you to generate 100% Previews.

To generate 100% previews, click the thumbnail quality () icon in the upper-right corner of the content panel and select 100% Previews as your Preview Generation option. The 100% preview renditions get stored in the app cache, taking up some of your disk space.

To delete 100% previews, go to Edit > Preferences > Cache Management > Purge 100% Previews in Cache.

Delete 100% previews

For more information, check out Work with the Adobe Bridge cache.

Improved cache size limit slider

Under Edit > Preferences > Cache, you can now set the maximum amount of disk space to be used for cache in gigabytes using the Cache Size slider.

Improved cache slider

For more information, check out Work with the Adobe Bridge cache.

Default migration of preferences

When installing on another machine, reinstalling, or upgrading your Bridge version, you can see a dialog to locate and import preferences from the previous version of your Bridge. 

With this release, Workspaces, Keywords, Collections, Export presets, Metadata templates, and Favorites will always be imported when a new Bridge version is installed on your device.

Onboarding dialog

With this release, enjoy improved discoverability of new features with easy navigation and animated content in the Onboarding dialog when launching the app for the first time.

To watch the onboarding dialog again, go to Help > What's New.

Fixed issues

Find fixes to customer-reported issues in Fixed issues | Bridge.