Aktuelle Versionshinweise
Aktuelle Version: 9.2.17
Adobe Sign for Dynamics – Video
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Häufige Fragen

  1. Melden Sie sich bei MS Dynamics an.

  2. Navigieren Sie zu Einstellungen > Anpassung.

    Navigieren Sie zu „Anpassen“.
  3. Klicken Sie auf die Option System anpassen.

    System anpassen
  4. Klicken Sie im linken Navigationsbereich auf die gewünschte benutzerdefinierte Entität.
    Beispiel: Yukti_test.

  5. Um die Felder und Steuerelemente anzuzeigen, klicken Sie auf den Namen der Entität.

  6. Navigieren Sie zu Formulare und klicken Sie dann auf den Link Informationen für den Typ Hauptformular.

    Zuordnen des Hauptformulartyps
  7. Fügen Sie ein neues Feld hinzu und geben Sie einen Namen für das Feld ein.

    Neues Feld hinzufügen
  8. Speichern und schließen Sie die Seite.

  9. Ziehen Sie das Feld per Drag-and-Drop in die Entität und speichern und veröffentlichen Sie alle Anpassungen. 

    Ziehen des Felds in die Entität

  1. Melden Sie sich bei MS Dynamics an.

  2. Navigieren Sie zu Einstellungen > Anpassung.

    Navigation zu „Anpassen“
  3. Klicken Sie auf die Option System anpassen.

    System anpassen
  4. Klicken Sie im linken Navigationsbereich auf die gewünschte benutzerdefinierte Entität.

    Beispiel: Kunde.

  5. Um die Felder und Steuerelemente anzuzeigen, klicken Sie auf den Namen der Entität.

  6. Kopieren Sie den Wert aus dem Feld Name (beispielsweise new_customer). 
    Hierbei handelt es sich um den internen Systemnamen Ihrer benutzerdefinierten Entität.

    Kopieren des Namenswerts
  7. Navigieren Sie in der benutzerdefinierten Entität zur Option 1:n-Beziehungen.
    Klicken Sie auf die Schaltfläche Neue 1:n-Beziehung.

    1:n
  8. Erstellen Sie die Beziehung:

    1. Wählen Sie die Vereinbarung im Feld Verknüpfte Entität aus.
      Der Name wird in „{entityName}_adobe_agreement“ geändert.
    2. Fügen Sie den Namen der benutzerdefinierten Entität, zum Beispiel „new_customer“, in das Feld „Anzeigename“ ein.
      Der Wert des Feldes „Name“ ändert sich in „new_“ + {entityName} + „Id“. (new_new_customerID).
    Neue Beziehung

        c. Klicken Sie auf „Speichern und schließen“.
            Das Beziehungsfenster wird geschlossen.

        d. Klicken Sie auf der Seite „1:n-Beziehungen“ auf die Option „Alle Anpassungen veröffentlichen“.

    1:n-Beziehungen

Es gibt ein bekanntes Problem für On Premise-CRM-Umgebungen, die über mehrere Server verfügen (CRM befindet sich auf einem Server und DB auf einem anderen) und deren SPN nicht korrekt konfiguriert ist. 

Dies führt dazu, dass die Seite Verwaltungseinstellungen leer angezeigt wird.

Die beste Lösung für dieses Problem besteht darin, sich zur Unterstützung bei der korrekten Konfiguration des SPN an den Microsoft Dynamics-Support zu wenden.

Eine kurze Übersicht über die SPN-Konfiguration finden Sie hier.

 

Problemumgehung für das Problem in den meisten Umgebungen:

  • Laden Sie das Microsoft Dynamics CRM SDK herunter.
  • Führen Sie MicrosoftDynamics365SDK.exe aus.
  • Suchen Sie das Plug-in-Registrierungstool und führen Sie es aus. (SDK\Tools\PluginRegistration)
  • Verbinden Sie das Plug-in-Registrierungstool mit Ihrer Dynamics-Instanz (klicken Sie hier für Anweisungen).
  • Durchsuchen Sie die AdobeSign-Übersicht.
  • Geben Sie für den Isolationsmodus Keine an.
  • Klicken Sie anschließend auf die Schaltfläche Ausgewählte Plug-ins aktualisieren.
Isolationsmodus angeben

Wenn diese Problemumgehung nicht funktioniert, wenden Sie sich an den Microsoft CRM-Support, um die SPN für Ihre Umgebung untersuchen zu lassen.

Sobald das SPN-Problem behoben ist, kann die Einstellung für den Isolationsmodus wieder auf Sandbox geändert werden.

Ein Absender erhält beim Senden eines Datensatzes zum Unterschreiben den folgenden Fehler. Der Fehler tritt auf, wenn der Vereinbarungsdatensatz erstellt wird.

Geschäftsprozessfehler

Der Fehler wird angezeigt, wenn der Absender zu weiteren Optionen wechselt und dann auf „Zum Unterschreiben senden“ klickt. Das Problem tritt nur in einer Produktionsumgebung auf, in der Anwendungssicherheit (F5) und Lastausgleich eingerichtet sind.

Antwort:

Wenn die verwaltete Lösung für das Adobe Sign in CRM importiert wird, werden die zugehörigen Plug-in-Bibliotheken im Isolationsmodus „Sandbox“ registriert. Dies führt zu Problemen in Produktionsumgebungen. Aktualisieren Sie den Wert manuell auf „Kein“.

Wie kann die Vorlage für die Funktion „Bericht zum Unterschreiben senden“ verwendet werden? Wenn Sie die Funktion verwenden, wird die neue Vereinbarung als „Neue Vereinbarung“ ohne Meldung angezeigt und es sind keine Vereinbarungsoptionen festgelegt. Anders ausgedrückt: Gibt es eine Möglichkeit, der Funktion „Bericht zum Unterschreiben senden“ eine Vorlage zuzuweisen?

Antwort:

Dies wird nicht unterstützt.

Die Funktion „Bericht zum Unterschreiben senden“ ist in Versionen 5 und 6 eine Ad-hoc-Funktion, d. h., Sie müssen zum Zieldatensatz wechseln und den Bericht manuell senden.

Problem:

Beim Importieren von Microsoft Dynamics v6 werden die folgenden Fehler angezeigt:

Fehler:

  • „Fehler beim Importieren der Lösung „Adobe Sign“
  • SQL Server-Fehler. Wiederholen Sie den Vorgang. Besteht das Problem weiterhin, durchsuchen Sie die Microsoft Dynamics CRM-Community nach Lösungen, oder wenden Sie sich an den Microsoft Dynamics CRM-Administrator in Ihrer Organisation. Sie können auch den Microsoft-Support kontaktieren.“

Ursache:

Der Fehler während der Aktualisierung der Lösung verweist auf den SQL-Serverfehler, was bedeutet, dass die CRM-DB-Verbindung überlastet oder der SQL-Server in einem fehlerhaften Zustand ist.

 

Auflösung:

  1. Der CRM-Administrator sollte das Ereignisprotokoll der CRM-Serveranwendung überprüfen, um festzustellen, ob dort ein anderer Fehler auftritt, der auf SQL-Serverprobleme hindeuten könnte.
  2. Löschen Sie den Volltextindex manuell in den adobe_agreementBase- und adobe_agreementtemplateBase-Tabellen im SQL-Server.