Note sulla versione corrente
Versione corrente: 9.2.17


Domande frequenti

  1. Accedi a MS Dynamics.

  2. Passa a Impostazioni > Personalizzazione.

    Passa a Personalizza.
  3. Fai clic sull’opzione Personalizza il sistema.

    Personalizza il sistema
  4. Nel riquadro di navigazione a sinistra, fai clic su sull’entità personalizzata desiderata.
    Ad esempio, Yukti_test.

  5. Per visualizzare i campi e i controlli, fai clic sul nome dell’entità.

  6. Passa a Forms, quindi fai clic sul collegamento Informazioni associato al tipo di modulo Principale.

    Associare il tipo di modulo principale
  7. Aggiungi un nuovo campo e immetti il nome del campo.

    Aggiungere un nuovo campo
  8. Salva e chiudi.

  9. Trascina il campo nell’Entità, quindi salva e pubblica le personalizzazioni. 

    Trascinare il campo nell’entità

  1. Accedi a MS Dynamics.

  2. Passa a Impostazioni > Personalizzazione.

    Passare a Personalizzazione
  3. Fai clic sull’opzione Personalizza il sistema.

    Personalizza il sistema
  4. Nel riquadro di navigazione a sinistra, fai clic su sull’entità personalizzata desiderata.

    Ad esempio, Cliente.

  5. Per visualizzare i campi e i controlli, fai clic sul nome dell’entità.

  6. Copia il valore del campo Nome (ad esempio, nuovo_cliente).
    Questo valore corrisponde al nome di sistema interno dell’entità personalizzata.

    Copiare il valore Nome
  7. Passa all’opzione Relazioni 1:N, sotto l’entità personalizzata.
    Fai clic sul pulsante Nuova relazione uno a molti.

    Uno a molti
  8. Crea la nuova relazione:

    1. Scegli Accordo dal campo Entità correlata.
      Il campo Nome cambia per mostrare {entityName}_adobe_agreement.
    2. Incolla il nome dell’entità personalizzata, ad esempio new_customer, nel campo Nome visualizzato.
      Il valore del campo Nome diventa “new_” + {entityName} + “Id”. (new_new_customerID).
    Nuova relazione

        c. Fai clic su salva e chiudi.
            La finestra Relazione si chiude.

        d. Fai clic su Pubblica tutte le personalizzazioni, nella parte superiore della pagina Relazione 1:N.

    Relazioni uno a molti

Si può verificare un errore noto in ambienti CRM locali con più server (CRM in un server e DB in un altro) se il relativo SPN non è configurato correttamente. 

A causa di tale errore, la pagina Impostazioni amministrazione risulta vuota.

Se riscontri questo problema, contatta il supporto di Microsoft Dynamics e richiedi assistenza per la configurazione corretta dell’SPN.

Qui puoi trovare una breve panoramica della configurazione SPN.

 

Soluzione al problema per la maggior parte degli ambienti:

  • Scarica l’SDK di Microsoft Dynamics CRM.
  • Esegui MicrosoftDynamics365SDK.exe.
  • Trova ed esegui Plugin Registration Tool (SDK\Tools\PluginRegistration)
  • Collega Plugin Registration Tool alla tua istanza di Dynamics (fai clic qui per accedere alle istruzioni).
  • Sfoglia l’assembly AdobeSign.
  • Per Modalità di isolamento, specifica Nessuno.
  • Al termine, fai clic sul pulsante Aggiorna plug-in selezionati.
Specificare la modalità di isolamento

Se questa soluzione non risolve il problema, contatta il supporto di Microsoft CRM per richiedere assistenza in merito all’SPN per il tuo l’ambiente.

Una volta risolto il problema SPN, l’impostazione Modalità di isolamento può essere impostata di nuovo su Sandbox.

Un mittente riceve il seguente errore durante l’invio di record per la firma. L’errore si verifica quando il record dell’accordo viene creato.

Errore di processo di business

L’errore viene visualizzato quando il mittente passa ad Altre opzioni e fa clic su Invia per firma. Il problema si verifica solo in un ambiente di produzione in cui sono impostati la protezione dell’applicazione (F5) e i servizi di bilanciamento del carico.

Risposta:

Quando la soluzione gestita per Adobe Sign viene importata in CRM, le librerie plug-in associate vengono registrate nella modalità di isolamento Sandbox. Questo provoca problemi negli ambienti di produzione. Imposta manualmente la modalità di isolamento su “Nessuno”.

Come si può aggiornare il modello per la funzione Invia report per firma? Quando si usa questa funzione, l’accordo visualizzato presenta la dicitura “Nuovo accordo” senza alcun messaggio e non è impostata alcuna opzione per l’accordo. In altre parole, come è possibile assegnare un modello alla funzionalità Invia report per firma?

Risposta:

Questa funzione non è supportata.

In entrambe le versioni v5 e v6, Invia report per firma è una funzionalità ad-hoc, pertanto è necessario impostare il record ed eseguire manualmente l’invio del report.

Problema:

Quando si importa Microsoft Dynamics v6, si verificano i seguenti errori:

Errori:

  • “Importazione della soluzione Adobe Sign non riuscita”
  • “Errore di SQL Server. Riprova questa azione. Se il problema persiste, cerca una soluzione nella Community di Microsoft Dynamics CRM o contatta l’amministratore di Microsoft Dynamics CRM dell’organizzazione. In alternativa, contatta il Supporto tecnico Microsoft.”

Causa:

L’errore durante l’aggiornamento della soluzione indica che si tratta di un errore SQL Server, per via di un sovraccarico di traffico nella connessione DB di CRM o perché il server SQL si trova in uno stato non valido.

 

Soluzione:

  1. L’amministratore di CRM dovrebbe controllare il registro degli eventi applicazione del server CRM per capire se sono presenti altri errori riconducibili a problemi del server SQL.
  2. Rilascia manualmente l’indice fulltext nelle tabelle adobe_agreementBase e adobe_agreementtemplateBase nel server SQL.