在运行时共享库资源

关于运行时共享库资源

共享库资源允许在某个 FLA 文件中使用来自其他 FLA 文件的资源。在下列情况下此功能非常有用:

  • 当多个 FLA 文件需要使用同一图稿或其他资源时。

  • 当设计人员和开发人员希望能够在单独的 FLA 文件中为一个联合项目编辑图稿和 ActionScript 代码时。

共享库资源按以下方式工作:

  • 对于运行时共享 资源,源文档的资源是以外部文件的形式链接到目标文档中的。运行时资源在文档播放期间(即在运行时)加载到目标文档中。在创作目标文档时,包含共享资源的源文档并不需要在本地网络上。为了让共享资源在运行时可供目标文档使用,源文档必须发布到 URL 上。

处理运行时共享资源

使用运行时共享库资源需要两个步骤:首先,源文档的作者在源文档中定义共享资源并输入该资源的标识符字符串和源文档将要发布到的 URL(仅 HTTP 或 HTTPS)

然后,目标文档的作者在目标文档中定义一个共享资源,并输入一个与源文档的那些共享资源相同的标识符字符串和 URL。或者,目标文档作者可以把共享资源从发布的源文档拖到目标文档库中。在“发布”设置中设置的 ActionScript 版本必须与源文档中的版本匹配。

在上述任何一种方案下,源文档都必须发布到指定的 URL,使共享资源可供目标文档使用。

在源文档中定义运行时共享资源

若要定义源文档中资源的共享属性,并使该资源能够链接到目标文档以供访问,请使用“元件属性”对话框或“链接属性”对话框。

  1. 在源文档打开时,选择“窗口”>“库”:
  2. 请执行下列操作之一:
    • 在“库”面板中选择一个影片剪辑、按钮或图形元件,然后从“库面板”菜单中选择“属性”。单击“高级”。

    • 选择一个字体元件、声音或位图,然后从“库面板”菜单中选择“链接”。

  3. 对于“链接”,选择“为运行时共享导出”,使该资源可以链接到目标文档。
  4. 为元件输入一个标识符。不要包含空格。这是 Animate 在链接到目标文档时用于标识资源的名称。

    注意:

    Animate 还使用链接标识符来标识在 ActionScript 中用作对象的影片剪辑或按钮。 

  5. 输入将要张贴包含共享资源的 SWF 文件的 URL 并单击“确定”。

    发布 SWF 文件时,您必须将 SWF 文件发布到指定的 URL 上,这样共享资源才可供目标文档使用。

可以通过输入共享资源的 URL 或将资源拖动到目标文档来链接到共享资源。

  1. 在目标文档中,选择“窗口”>“库”。
  2. 请执行下列操作之一:
    • 在“库”面板中选择影片剪辑、按钮、图形元件、位图或声音,然后从“库面板”菜单中选择“属性”。单击“高级”。

    • 选择一个字体元件,然后从“库面板”菜单中选择“链接”。

  3. 要进行“链接”,选择“为运行时共享导入”,链接到源文档中的资源。
  4. 输入元件、位图或声音的标识符,这些标识符须与源文档中该元件使用的标识符相同。不要包含空格。
  5. 输入张贴了包含共享资源的 SWF 源文件的 URL,然后单击“确定”。
  1. 在目标文档中,请执行下列操作之一:
    • 选择“文件”>“打开”。

    • 选择“文件”>“导入”>“打开外部库”。

  2. 选择源文档并单击“打开”。
  3. 将共享资源从源文档“库”面板拖入目标文档中的“库”面板或舞台上。

关闭目标文档中的元件共享

  1. 在目标文档中,从“库”面板中选择链接的元件,然后执行下列操作之一:
    • 如果该资源是影片剪辑、按钮或图形元件,请从“库面板”菜单中选择“属性”。

    • 如果该资源是字体元件,请从“库面板”菜单中选择“链接”。

  2. 取消选择“为运行时共享导入”,然后单击“确定”。

在创作时共享库资源

在创建时共享资源具有以下好处:

  • 可以避免在多个 FLA 文件中使用资源的多余副本。例如,如果为 Web 浏览器、iOS 和 Android 分别开发一个 FLA 文件,则可以在这 3 个文件之间共享资源。

  • 当在一个 FLA 文件中编辑共享资源时,如果打开使用该资源的其他 FLA 文件并取得焦点,更改将反映到这些文件中。

在创作过程中可以通过两种方式共享库资源:

  • 通过从另一 FLA 文件中的元件链接到外部 FLA 文件中的元件,使用外部 FLA 文件中的元件。

  • 在属于“项目”面板中同一 Animate 项目的 FLA 文件之间共享元件。有关使用“项目”面板的信息,请参阅处理 Animate 项目

通过链接到单独 FLA 文件中的元件进行共享的工作方式如下:

  • 对于创作期间的共享资源,可以用本地网络上任何其他 FLA 文件中的任何可用元件来更新或替换正在创作的 FLA 文件中的任何元件。

  • 在创作文档时更新目标文档中的元件。

  • 目标文档中的元件保留了原始名称和属性,但其内容会被更新或替换为所选元件的内容。

使用“项目”面板共享资源的工作方式如下:

  • 在“项目”面板中创建一个项目,并在该项目中创建一个 FLA 文件。

  • 在该 FLA 文件中,通过在“库”面板中选中每个项目的共享复选框,可指定希望将哪些元件与其他文件共享。

  • 在项目中创建第二个 FLA 文件。

  • 在舞台上从第一个 FLA 文件复制图层、帧或项目,并将其粘贴到第二个文件。

  • Animate 将粘贴元素中的共享库项目移动到项目文件夹中一个名为 AuthortimeSharedAssets.FLA 的单独文件中。

以下资源类型可在项目中共享:

资源类型

自身是否可共享?

在影片剪辑内部是否可共享?

影片剪辑元件

图形元件

按钮元件

字体元件

FLV 视频

嵌入式视频

声音(任何格式)

位图(任何格式)

编译剪辑 (SWC)

组件(基于元件)

更新或替换共享元件

可以用在本地网络可访问的 FLA 文件中的任何其他元件更新或替换文档中的影片剪辑、按钮或图形元件。目标影片中该元件的原始名称和属性都会被保留,但元件的内容会被您选择的元件的内容替换。选定元件使用的所有资源也会复制到目标文档中。

  1. 在文档打开的情况下,在“库”面板中选择影片剪辑、按钮或图形元件,然后从“选项”菜单面板中选择“属性”。
  2. 如果“元件属性”对话框的“链接”和“源”区域没有显示,则单击“高级”。
  3. 要选择新的 FLA 文件,单击“浏览”。
  4. 定位到包含元件(用于更新或替换在“库”面板中选定的元件)的 FLA 文件,然后单击“打开”。
  5. 定位到一个元件,然后单击“确定”。
  6. 请执行下列操作之一:
    • 在“元件属性”对话框中的“源”下,选择“总是在发布前更新”并单击“确定”。

    • 在“元件属性”对话框中的“创作时共享”下,选择“自动更新”并单击“确定”。

定义在项目中共享的资源

通过在项目中的 FLA 文件之间共享资源,可以只在一个文件中编辑资源,然后看到这些更改反映到使用该资源的其他 FLA 文件中。

  1. 创建一个 Animate 项目。 

  2. 在项目的 FLA 文件中,对于希望与该项目中的其他 FLA 文件共享的每个库资源,执行以下操作之一:

    • 打开“库”面板,并选择资源名称旁边的“链接”复选框。

    • 在“库”面板中选择资源的情况下,从“选项”菜单面板中选择“属性”,然后单击“与项目共享”按钮。

  3. 在时间轴或舞台上,复制包含共享资源的图层、帧或舞台项目。

  4. 在同一项目的单独 FLA 文件中,将图层、帧或舞台项目粘贴到同一项目中的单独 FLA 文件中。

视频和教程

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略