用户指南 取消(C)

在 Animate 中使用多种文件类型

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

有关 Animate 文件

在 Animate 中,您可以处理各种文件类型,每种文件类型的用途各不相同:

  • FLA 文件是在 Animate 中使用的主要文件,其中包含 Animate 文档的基本媒体、时间轴和脚本信息。媒体对象是组成 Animate 文档内容的图形、文本、声音和视频对象。时间轴用于告诉 Animate 应何时将特定媒体对象显示在舞台上。您可以将 ActionScript® 代码添加到 Animate 文档中,以便更好地控制文档的行为并使文档对用户交互做出响应。

  • 未压缩的 XFL 文件与 FLA 文件类似。XFL 文件和同一文件夹中的其他关联文件只是 FLA 文件的等效格式。通过此格式,多组用户可以更方便地同时处理同一个 Animate 项目的不同元件。有关详细信息,请参阅使用未压缩的 XFL 文件

  • SWF 文件(FLA 文件的编译版本)是在网页上显示的文件。当您发布 FLA 文件时,Animate 将创建一个 SWF 文件。

    Animate SWF 文件格式是其他应用程序所支持的一种开放标准。有关 Animate 文件格式的详细信息,请参阅 www.adobe.com/go/flashplayer_cn

  • AS 文件是 ActionScript 文件,您可以使用这些文件将部分或全部 ActionScript 代码放置在 FLA 文件之外,这对于代码组织和有多人参与开发 Animate 内容不同部分的项目很有帮助。

  • SWC 文件包含可重用的 Animate 组件。每个 SWC 文件都包含一个已编译的影片剪辑、ActionScript 代码以及组件所要求的任何其他资源。 注意:不能将 SWC 文件导入 Animate。
  • ASC 文件是用于存储 ActionScript 的文件,ActionScript 将在运行 Adobe Media Server 的计算机上执行。这些文件可以实现与 SWF 文件中的 ActionScript 结合使用的服务器端逻辑。 注意:Animate 不支持 ASC 文件。
  • JSFL 文件是 JavaScript 文件,可用来向 Animate 创作工具添加新功能。
  • APR 文件可以让您将画布发布模板与其发布配置文件设置捆绑在一起。此后,任何链接到发布配置文件的新资源都会绑定而且共享。有关更多信息,请参阅发布设置

 

Animate 是什么?

Adobe

以下教程演示了如何使用 Animate/Flash Pro 使用。

使用其他 Adobe 应用程序

Animate 可以使用其他 Adobe® 应用程序来实现广泛的创意工作流程。您可以将 Illustrator® 和 Photoshop® 文件直接导入 Animate 中。您还可以在 Animate 中创建视频,然后在 Adobe® Premiere® Pro 或 After Effects® 中进行编辑,或者从这些应用程序中将视频导入 Animate 中。发布 SWF 文件时,可以使用 Dreamweaver® 将内容嵌入网页,然后在 Dreamweaver 中直接启动 Animate 来编辑这些内容。

打开 XFL 文件

从 Animate 开始,XFL 是所创建的 FLA 文件的内部格式。在 Animate 中保存文件时,默认格式是 FLA,但文件的内部格式是 XFL。

其他 Adobe® 应用程序(例如 After Effects®)可以导出 XFL 格式的文件。这些文件的文件扩展名是 XFL,而不是 FLA。InDesign® 可直接以 FLA 格式导出在内部为 XFL 格式的文件。这样,就可以首先在 After Effects 或 InDesign 中处理项目,然后在 Animate 中继续进行处理。

可以按与打开 FLA 文件相同的方式,在 Animate 中打开和处理 XFL 文件。在 Animate 中打开 XFL 文件后,可以将该文件另存为 FLA 文件或另存为未压缩的 XFL 文件。

在 Animate 中打开 XFL 文件:

  1. 在其他 Adobe® 应用程序(如 InDesign 或 After Effects)中,将您完成的工作导出为 XFL 文件。

    该应用程序在 XFL 文件中保存原始文件的所有图层和对象。

  2. 在 Animate 中,选择“文件”>“打开”,然后导航到 XFL 文件。单击“打开”。

    XFL 文件按与 FLA 文件相同的方式在 Animate 中打开。原始文件的所有图层都显示在时间轴中,且原始对象显示在“库”面板中。

    现在可以正常处理文件了。

  3. 若要保存文件,请选择“文件”>“保存”。

    Animate 会提示您在“另存为”对话框中为新的 FLA 文件指定名称。

  4. 键入名称,然后保存 FLA 文件。

使用未压缩的 XFL 文件

从 Animate 开始,您可以选择使用未压缩 XFL 格式的 Animate 文件。这种格式允许您查看构成 Animate 文件的每个单独的部分(即子文件)。这些部分包括:

  • 全面描述 Animate 文件的 XML 文件。

  • 描述每个库元件的各个 XML 文件。

  • 包含发布设置、移动设置及其他设置的其他 XML 文件。

  • 包含 Animate 文件使用的外部资源(如位图文件)的文件夹。

使用未压缩的 XFL 格式,您可以让不同的人各自使用 Animate 文件的各个部分。您还可以使用源控制系统管理对未压缩的 XFL 文件中的每个子文件所做的更改。将这些功能协作,可以使多个设计人员和开发人员在大型项目上更加轻松地合作。

使用 XFL 文件的实时更新

未压缩 XFL 文档的可编辑资源是实时更新的,因此在 Animate 中打开未压缩的 XFL 文档后,您可以编辑其中的任何库资源。如果资源编辑是在其他应用程序中完成的,您对资源的更改将反映在 Animate 中。

要在其他应用程序中编辑未压缩 XFL 文档中的资源,请执行下列操作:

  1. 以未压缩的 XFL 格式保存 Animate 文档。

  2. 在适当的编辑器中(例如 Photoshop),从“未压缩的 XFL 文档”的 LIBRARY 文件夹中打开要编辑的资源。

  3. 编辑资源并保存更改。

  4. 返回 Animate。

    该资源的更新将立即在 Animate 中反映出来。

使用 Animate 编辑 Dreamweaver 中的 SWF 文件

如果 Animate 和 Dreamweaver 都已安装,可以在 Dreamweaver 文档中选择一个 SWF 文件,然后使用 Animate 编辑该文件。Animate 并不直接编辑 SWF 文件,而是编辑源文档(FLA 文件)然后重新导出 SWF 文件。

  1. 在 Dreamweaver 中,打开“属性”检查器(“窗口”>“属性”)。
  2. 在 Dreamweaver 文档中,执行下列操作之一:
    • 单击 SWF 文件占位符以选中它,然后在“属性”检查器中单击“编辑”。

    • 右键单击 (Windows) 或者按住 Control 单击 (Macintosh) SWF 文件的占位符,然后从上下文菜单中选择“使用 Animate 编辑”。

      Dreamweaver 将焦点切换到 Animate,Animate 将尝试定位到所选 SWF 文件的 Animate 创作文件 (FLA)。如果 Animate 无法找到相应的 Animate 创作文件,则会提示您定位到该文件。

      如果 FLA 文件或 SWF 文件已被锁定,请在 Dreamweaver 中取出该文件。

  3. 在 Animate 中,编辑该 FLA 文件。“Animate 文档”窗口会指示您正在 Dreamweaver 内修改文件。

  4. 在完成编辑后,单击“完成”。

    Animate 将更新 FLA 文件并将其重新导出为 SWF 文件,然后关闭该文件,将焦点返回到 Dreamweaver 文档。

    若要更新 SWF 文件并保持 Animate 打开,请在 Animate 中选择“文件”>“用于 Dreamweaver 的更新”。

  5. 若要在文档中查看更新后的文件,请在 Dreamweaver 的“属性”检查器中单击“播放”,或者按 F12 在浏览器窗口中预览页面。

创建新文档

您可以在 Animate 中创建新的文档或打开以前保存的文档,也可以在工作时打开新的窗口。可以设置新建文档或现有文档的属性。

使用任意方法为动画选择目标时,Animate 都能提供预设格式。 从屏幕顶部的选项卡(如“角色动画”、“社交”、“游戏”、“教育”、“广告”、“Web”和“高级”)中选择目标。

为每个目标选择相应的预设,然后单击“创建”即可开始创建动画。您可以在左窗格中查看最近使用的资源。示例资源在启动屏幕的底部提供。

新建文档

  1. 选择“文件”>“新建”

    新建文档
    新建文档

  2. 从屏幕顶部的选项卡(如“角色动画”、“社交”、“游戏”、“教育”、“广告”、“Web”和“高级”)中选择目标。

  3. 为每个目标选择相应的预设,然后单击“创建”

    此外,还可以选择文档设置。请参阅设置新建文档或现有文档的属性

在 Animate 中使用各种文档类型

将文档转换为各种类型,例如 HTML 5、WegGl、GLTF、360 度、全景等等。只需单击两次鼠标,即可转到 Animate。想要使用各种选项转换您的视频以便在不同平台上显示?在本示例结尾观看教程并按照这些步骤操作。

  1. “主页”页面中,单击 “高级”选项卡。

  2. 查看将文档用于各个不同平台的选项。

  3. 单击“文件”>“转换为”选择所需选项。

如何在 Animate 中使用文档类型

观看视频,详细了解有关各功能特性的信息。

从模板新建文档

  1. 选择“文件”>“从模板新建”

    从模板新建对话框
    从模板新建对话框

  2. 从“类别”列表中选择一个类别,从“类别项”列表中选择一个文档,然后单击“确定”。可以选择 Animate 自带的标准模板,也可以选择您曾经保存的模板。

打开现有文档

  1. 选择“文件”>“打开”

  2. 在“打开”对话框中,定位到文件或在“转到”框中输入文件的路径。
  3. 单击“打开”。

在打开多个文档时查看文档

打开多个文档时,“文档”窗口顶部的选项卡会标识所打开的各个文档,允许您在它们之间轻松导航。只有在“文档”窗口中最大化各文档后,才会显示选项卡。

  1. 单击要查看的文档的选项卡。

    默认情况下,选项卡按文档创建顺序排列。可以通过拖动文档选项卡来更改它们的顺序。

为当前文档打开一个新的窗口

  1. 选择“窗口”>“重制窗口”。

设置新建文档或现有文档的属性

  1. 在文档打开的情况下,选择“修改”>“文档”。

    此时将显示“文档设置”对话框。

  2. 若要设置“舞台尺寸”,请执行下列操作之一:
    • 若要指定舞台大小(以像素为单位),请在“宽”和“高”框中输入值。最小为 1 x 1 像素;最大为 2880 x 2880 像素。

    • 若要将“舞台尺寸”与舞台内容使用的间距量精确对应,请选择“匹配: 内容”选项。

    • 若要将舞台大小设置为最大的可用打印区域,请选择“匹配: 打印机”。此区域的大小是纸张大小减去“页面设置”对话框 (Windows) 或“打印边距”对话框 (Macintosh) 的“页边界”区域中当前选定边距之后的剩余区域。

    • 若要将舞台大小设置为默认大小(550 x 400 像素),请选择“匹配: 默认值”。

  3. 要指定帧速率,请使用“帧速率”选项输入帧速率。

    帧速率

  4. 若要调整舞台上 3D 对象的位置和方向,以保持其相对于舞台边缘的外观,请选择“调整 3D 透视角度以保留当前舞台投影”。

    仅当更改舞台大小时此选项才可用。

  5. (仅限 CS5.5)若要相对于舞台大小的更改自动缩放舞台内容,请选择“用舞台缩放内容”。

    仅当更改舞台大小时此选项才可用。您可以在“首选参数”中选择是否缩放锁定和隐藏图层中的内容。有关详细信息,请参阅设置常规首选参数

  6. 若要指定显示在工作区的标尺的度量单位,请从“标尺单位”菜单中选择一个选项。(此设置还确定了在“信息”面板中使用的单位。)
  7. 要设置文档的背景色,请单击“背景色”样本,然后从调色板中选择颜色。
  8. 要指定“帧频”,请输入每秒显示的动画帧的数量。

    对于大多数计算机显示的动画,特别是网站中播放的动画,8 fps 到 15 fps 就足够了。更改帧速率时,新的帧速率将变成新文档的默认值。

  9. (仅限 CS5.5)要以指定的时间间隔自动保存文档,请选择“自动保存”选项并指定保存的时间间隔(分钟数)。
  10. 请执行下列操作之一:
    • 若要将新设置仅应用于当前文档,请单击“确定”。

    • 要将这些新设置用作所有新文档的默认属性,请单击“设为默认值”。

使用属性检查器更改文档属性

  1. 单击舞台外部的工作区,以取消选择舞台上的所有对象。属性检查器中将显示文档属性。要打开属性检查器,请选择(“窗口”>“属性”)。
  2. (仅限 CS5.5)在“发布”部分,选择文档的 Flash Player 版本和 ActionScript 版本。要访问其他“发布”设置,请单击“发布设置”按钮。

  3. 在“属性”部分中,对于 FPS(每秒帧数),请输入每秒播放的动画帧的数量。
  4. 要更改舞台大小,请输入舞台的宽度和高度值。
  5. 要选择舞台的背景色,请单击“舞台”属性旁边的颜色样本,然后从调色板中选择颜色。
  6. 要编辑其他文档属性,请单击“大小”属性旁边的“编辑”按钮。有关所有文档属性的更多信息,请参阅为新文档或现有文档设置属性

Animate CC 非常方便易用,且允许用户使用其各种组件。想要了解如何使用 Animate 的基本界面和工具?在本示例结尾观看教程并按照这些步骤操作。

向文档中添加 XMP 元数据

可以在 FLA 文件中包含可扩展元数据平台 (XMP) 数据,例如标题、作者、描述、版权等。XMP 是一种某些其他 Adobe® 应用程序能够理解的元数据格式。可以在 Animate 和 Adobe® Bridge 中查看元数据。有关 XMP 元数据的详细信息,请参阅 Bridge 帮助中的“元数据和关键字”

Adobe Animate 不支持 32 位 Bridge。

嵌入元数据可改善基于 Web 的搜索引擎的功能,以便在搜索 Animate 内容时返回有意义的结果。搜索元数据基于 XMP(可扩展元数据平台)规范,并以 W3C 兼容的格式存储在 FLA 文件中。

文件的元数据包含有关文件的内容、版权状态、出处及历史记录的信息。在“文件信息”对话框中,可以查看和编辑当前文件的元数据。

根据所选文件的不同,可能会显示以下类型的元数据:

描述

包含作者、标题、版权和其他信息。

IPTC

显示可编辑的元数据。您可以在文件中添加字幕以及版权信息。IPTC Core 是 IPTC(国际出版电信协会)于 2004 年 10 月批准的规范。它与早期 IPTC(前身是 IIM)的不同之处在于,新增了一些属性,更改了一些属性名称并删除了一些属性。

摄像头数据 (Exif)

显示由数字摄像头分配的信息,包括在获取图像时所用的摄像头设置。

视频数据

显示视频文件的元数据,包括像素高宽比、场景和快照。

音频数据

显示音频文件的元数据,包括艺术家、专辑、曲目编号和流派。

Mobile SWF

列出有关 SWF 文件的信息,包括标题、作者、描述和版权。

历史记录

使用 Photoshop 记录对图像所做的更改。

:必须在 Photoshop 中启用历史记录日志首选参数,才能将该日志与文件的元数据一起保存。

Version Cue

列出任意 Version Cue 文件版本信息。

DICOM

显示有关用医学数字图像通讯 (DICOM) 格式保存的图像的信息。

若要添加元数据,请执行下列操作:

  1. 选择“文件”>“文件信息”。
  2. 在显示的“文件信息”对话框中,输入要包含的元数据。可以随时在 FLA 文件中添加或删除元数据。

保存 Animate 文档

可以用当前的名称和位置或其他名称或位置保存 Animate FLA 文档。

如果文档包含未保存的更改,则文档标题栏、应用程序标题栏和文档选项卡中的文档名称后会出现一个星号 (*)。保存文档时星号即会消失。

以默认的 FLA 格式保存 Animate 文档

  1. 请执行下列操作之一:
    • 要覆盖磁盘上的当前版本,请选择“文件”>“保存”。

    • 要将文档保存到不同的位置和/或用不同的名称保存文档,或者要压缩文档,请选择“文件”>“另存为”。

  2. 如果选择“另存为”,或者以前从未保存过该文档,请输入文件名和位置。
  3. 单击“保存”。

以未压缩的 XFL 格式保存文档

  1. 选择“文件”>“另存为”。
  2. 从“另存为类型”菜单中,选择“Animate 未压缩文档 (*xfl)”。

  3. 为文件选择名称和位置,然后单击“保存”。

还原到上次保存的文档版本

  1. 选择“文件”>“还原”。

将文档另存为模板

  1. 选择“文件”>“另存为模板”。
  2. 在“另存为模板”对话框的“名称”框中输入模板的名称。
  3. 从“类别”弹出菜单中选择一种类别或输入一个名称,以便创建新类别。
  4. 在“描述”框中输入模板说明(最多 255 个字符),然后单击“确定”。

    在“新建文档”对话框中选择该模板时,会显示此说明。

    要删除保存的模板,请定位到以下文件夹之一,并从包含模板 FLA 文件的类别文件夹中删除该文件。

    • Windows 10 - C:\Users\<用户名>\AppData\Local\Adobe\<版本号>\<app_locale>\Configuration\Templates\
    • 在 Mac OS 中 - <硬盘>/Users/<用户名>/Library/Application Support/Adobe/Flash CS5/<语言>/Configuration/Templates/

在退出 Animate 时保存文档

  1. 选择“文件”>“退出”(Windows) 或“Animate”>“退出 Animate”(Macintosh)。

  2. 如果打开的文档包含未保存的更改,Animate 会提示您保存或放弃每个文档的更改。

    • 单击“是”保存更改并关闭文档。

    • 单击“否”关闭文档,不保存更改。

打印 Animate 文档(Flash Professional 中已弃用)

若要预览和编辑文档,可打印 Adobe Animate 文档中的帧,也可以通过查看器指定可以从 Flash Player 中打印的帧。

打印 Animate 文档中的帧时,可以使用“打印”对话框,指定要打印的场景或帧的范围和打印份数。在 Windows 中,“页面设置”对话框可以指定纸张大小、方向和各种打印选项,包括边距设置以及是否每一页都要打印所有的帧。在 Macintosh 中,这些选项分布在“页面设置”和“打印边距”对话框中。

两个操作系统上的“打印”和“页面设置”对话框都是标准的,而且它们的外观取决于选择的打印机驱动程序。

  1. 选择“文件”>“页面设置”(Windows) 或“文件”>“打印边距”(Macintosh)。
  2. 设置页面边距。对两个操作系统均选择“居中”选项,以便在页面的中间打印帧。
  3. 在“帧”菜单中,选择是打印文档中的所有帧,还是只打印每个场景的第一帧。
  4. 在“布局”菜单中,选择以下某个选项:

    实际大小

    按照帧的完全大小打印。在“缩放”中输入一个用来缩小或放大所打印帧的值。

    缩放到页面大小

    缩小或放大每个帧,使其填充页面的整个打印区域。

    记事本

    在一个页面上打印几个缩略图。可以选择“方框”、“网格”、“空白”。在“帧”框中输入每一页中缩略图的数量。在“帧边距”框中设置缩略图之间的间隔,然后选择“标签帧”以将帧标签打印为缩略图。

  5. 若要打印帧,请选择“文件”>“打印”。

使用帧标签禁用打印

若不想打印主时间轴中的任何帧,则可以将其中一个帧标记为 ! #p 以使整个 SWF 文件都不可打印。将某个帧标记为 ! #p 会禁用(变暗)Flash Player 上下文菜单中的“打印”命令。您也可删除 Flash Player 上下文菜单。

即使禁用从 Flash Player 中打印的功能,用户仍可以用浏览器的打印命令打印帧。因为该命令是浏览器的功能,所以不能用 Animate 控制或禁用它。

禁用 Flash Player 上下文菜单中的打印

  1. 打开或激活要发布的 Animate 文档(FLA 文件)。

  2. 选择主时间轴中的第一个关键帧。
  3. 选择“窗口”>“属性”以查看“属性”检查器。
  4. 在属性检查器中,对“帧标签”输入 ! #p 以指定该帧不可打印。

    只需指定一个 ! #p 标签即可禁用(变暗)上下文菜单中的“打印”命令。

    您也可以选择一个空白帧(而非关键帧),并将其标记为 #p。

通过删除 Flash Player 的上下文菜单禁用打印

  1. 打开或激活要发布的 Animate 文档(FLA 文件)。

  2. 选择“文件”>“发布设置”。
  3. 选择“HTML”选项卡,取消选择“显示菜单”,然后单击“确定”。

打印帧时指定打印区域

  1. 打开包含要打印帧的 Animate 文档(FLA 文件)。

  2. 选择未指定为使用 #p 帧标签进行打印的帧,该帧应位于与标记为 #p 的帧相同的层上。

    为方便起见,可选择标记为 #p 的帧后面的一帧。

  3. 在舞台中,创建所需打印区域大小的形状。若要使用某个帧的边框,可选择这样的帧,它具有适合打印区域大小的对象。
  4. 选择时间轴中的帧,其中包含要用于边框的形状。
  5. 在属性检查器中(“窗口”>“属性”),为“帧标签”输入 #b 以将所选的形状指定为打印区域的边框。

    每个时间轴只允许使用一个 #b 帧标签。这个选项与用打印动作选择影片边框选项一样。

更改打印的背景色

可以打印在“文档属性”对话框中设置的背景色。在要打印的时间轴的最低层上放置一个有颜色的对象,可以只更改要打印的帧的背景色。

  1. 在要打印的时间轴的最低层上放置一个覆盖舞台的填充形状。
  2. 选择该形状,然后选择“修改”>“文档”。为打印背景选择一种颜色。

    该动作将改变整个文档的背景色,包括影片剪辑和所加载 SWF 文件的背景色。

  3. 请执行下列操作之一:
    • 要用这种颜色作为文档的打印背景色,请指定要打印放置了形状的帧。

    • 若要对非打印帧保持不同的背景色,请重复步骤 2 和步骤 3。然后在所有未指定为要打印的帧中,将形状放在时间轴的最低层。

使用 Flash Player 上下文菜单中的“打印”命令可以打印任何 Animate SWF 文件中的帧。

上下文菜单的“打印”命令无法打印透明或色彩效果,也无法打印其他影片剪辑中的帧;要获得更多高级打印功能,请使用 PrintJob 对象或 print() 函数。

  1. 打开文档。

    该命令使用舞台作为打印区域或使用指定的边框来打印标记为 #p 的帧。

    如果没有具体指定要打印哪些帧,则将打印文档主时间轴中的所有帧。

  2. 选择“文件”>“发布预览”>“默认”,或者按下 F12 在浏览器中查看 Animate 内容。

  3. 在浏览器窗口中的 Animate 内容中右键单击鼠标 (Windows) 或按住 Control 单击鼠标 (Macintosh),以显示 Flash Player 的上下文菜单。

  4. 从 Flash Player 的上下文菜单中选择“打印”,以显示“打印”对话框。
  5. 在 Windows 中,选择打印范围以选定要打印哪些帧。
  6. 在 Macintosh 中,在“打印”对话框中选择要打印的页面。
  7. 根据打印机属性选择其他打印选项。
  8. 单击“确定”(Windows) 或“打印”(Macintosh)。

从上下文菜单中进行打印不会影响对 PrintJob 对象的调用。

Adobe 徽标

登录到您的帐户