Adobe Captivate allows you to quickly record software simulations in Demo, Assessment, and Training modes.

Assets and samples

The procedures in this document require you to use assets such as images and sample Adobe Captivate project files. You can choose to use your own assets and samples. However, it is recommended that you download and extract the following zip file to your computer:

Create software simulation projects

Captivate allows you to simultaneously create software simulations in all the three available modes:

  • Demo: Demonstrate a software procedure. The user is not required to perform any action.
  • Assessment: Test the user's knowledge of a procedure. Only inform the user if the step was incorrectly carried out.
  • Training: Guide a user through a software procedure. The user is required to perform the steps in a procedure but with guidance at every step.

Let's create a short software simulation of the steps required to create a new PowerPoint presentation. We will simultaneously create the simulations in the three available modes.

  1. When you open Captivate, in the New tab, click Software Simulation and then click Create.

    software_simulationstartup
  2. The dialog box provides you with the options to record the demo. Choose the following options:

    • Application
    • In the drop-down list choose PowerPoint
    • Ensure that Application window is selected
    • Ensure that the Demo, Assessment, and Training checkboxes are selected
    software_simulationsettings
  3. Click Record.

    After the counter counts down to 1, the PowerPoint application comes to the foreground.

  4. Perform the following steps in PowerPoint:

    1. Click File.
    2. Click New.
    3. Choose a theme.
    4. In the dialog box, click Create.
  5. To end your simulation:

    • On Windows, click the End key on your keyboard
    • On MAC, click the Captivate icon in the top bar

    As soon as you end your simulation, Captivate comes to the foreground again.

    A new project is created for each of the simulation modes:

    • untitled_demo1.cptx
    • untitled_assessment1.cptx
    • untitled_training1.cptx

    To see the difference between the three projects that Captivate has created for us, let's preview them.

  6. In the toolbar, click Preview and then choose Project to preview each of the projects.

Demo: As the simulation progresses, the pointer moves across the screen. The area around the clicked part of the screen is highlighted. Also, text captions display indicators as the area is clicked. The simulation without any user intervention.

Training: You need to perform each screen task. In our project, the first screen task is to click File. The simulation will wait until you perform this task. If you hover the pointer over the File menu, a hint is displayed. If you click elsewhere on the screen, a failure caption tells you where you need to click. When you click the correct location, the simulation progresses to the next step.

Assessment: You need to perform each screen task. In our project, the first screen task is to click File. The simulation will wait until you perform this task. Because this is an assessment mode, you are not provided with hints if you hover the pointer over the File menu. If you click elsewhere on the screen, a failure caption tells you where you need to click. When you click the correct location, the preview progresses to the next step.

 

For more information on this topic, see How to record software simulations in Adobe Captivate.

 

Insert software simulations in existing projects

In the previous section, we created software simulation projects from scratch. However, you can also insert software simulations at any point within an existing project.

Let's insert a short software simulation in Demo mode of the steps required to create a new PowerPoint presentation.

  1. Open the project in which you want to insert the software simulation.

    Or create a new blank project.

  2. In the toolbar, click Slides and choose Software Simulation.

  3. In the Record Additional Slides dialog box, choose the slide after which you want to insert the software simulation and click OK.

  4. The dialog box provides you with the options to record the demo. Choose the following options:

    • In the drop-down list choose PowerPoint
    • In the Mode drop-down list, ensure that the Demo mode is selected
    software_simulationinsertstartup
  5. Click Record.

    After the counter counts down to 1, the PowerPoint application comes to the foreground.

  6. Perform the following steps in PowerPoint:

    1. Click File.
    2. Click New.
    3. Choose a theme.
    4. In the dialog box, click Create.
  7. To end your simulation:

    • On Windows, click the End key on your keyboard
    • On MAC, click the Captivate icon in the top bar

    As soon as you end your simulation, Captivate comes to the foreground again.

  8. In the toolbar, click Preview and then choose Project.

Manage slide timing

When you create a software simulation, Captivate creates a project that uses slides and objects that can be easily manipulated.

You can rearrange the slides, insert slides between the steps in a simulation, you can edit the properties of objects, and change the hints and error captions that are displayed. In a Demo project, you can even change the path of a mouse.

Besides the above editing changes, you can also use Captivate's timing feature to adjust the timing on a slide.

  1. In the downloaded files folder, navigate to the samples subfolder and open:

    create-software-simulation-demo.cptx

    注意:

    It is not mandatory that you download the project file that ships with this tutorial. You can still follow along with the steps in this procedure. However, you will need to create a Demo software simulation project Captivate.

  2. Navigate to the following slide in the Demo:

    software_simulationeditslide
  3. Let's quickly preview this slide.

    In the toolbar, click Preview and then choose Play Slide.

    As you step through the simulation of an application while creating a software simulation, Captivate sets the time for which a slide is displayed to the user.

  4. Currently the caption on the slide is: Select the Atlas item.

    Change the caption to the following:

    PowerPoint displays the available themes that you can apply to the new presentation. Let’s use the Atlas theme for our presentation.
    Select the Atlas theme.

  5. After making changes to the text caption, let's again check the slide.

    In the toolbar, click Preview and then choose Play Slide.

    Notice, that the preview duration is the same as in step 2 above. However, since we have changed the contents in the text caption, we need to increase the duration for which the slide is displayed to users.

    Let's use Captivate's Timeline panel to adjust the timeline for this slide and the object on the slide.

  6. In the Window menu, choose Timeline.

    timeline_menu

    The Timeline panel displays the timeline for the current slide:

    software_simulationtimeline

    Let's quickly discuss how each of these objects is represented on the timeline:

    Mouse: Appears on the slide after about half a second and will continue to be displayed on the slide for the remainder of the slide duration (3s).

    Text_Caption_3: Displayed on the slide for its entire duration.

    Highlight_Box_3: Displayed on the slide for its entire duration.

    The Timeline is not just informational. You can change the time duration for any of the objects on a slide. You can even change the time duration for the slide itself.

    Let's change the time duration of the slide to 8 seconds. That should be enough time for the user to read the updated caption.

  7. In the Timeline panel, hover the pointer over right edge of the slide duration.

    software_simulationtimeline-withcursor

    The cursor changes into a double-sided arrow that allows you to slide the timeline to the right (to increase the duration) or to the left (to reduce the duration).

  8. Drag the slide duration to the 7 second mark on the timeline.

    software_simulationtimeline-7s-1

    Notice however, that the duration for the objects on the slide remain the same.

    Let's increase the duration for the text caption and the highlight box to the full duration of the slide.

  9. To select multiple objects in the Timeline, keeping the Ctrl key pressed, click Text_Caption_3 and Highlight_Box_3.

  10. Hover the pointer over the right edge of the selected object and when the cursor changes into a double-sided arrow, drag the edge to the end of the slide.

    software_simulationtimeline-7s-2

    Finally, we need to adjust the timeline for the mouse. The pointer needs to be displayed until the end of the slide duration. However, we also need to ensure that it displays for the same duration (3s) as previously. So, let's not increase the duration for the mouse. Let's move it to the end of the slide duration.

  11. Select the mouse object in the timeline and drag it to the end of the slide.

    software_simulationtimeline-7s-3

Let's preview the procedure we completed.

In the toolbar, click Preview and then choose Project.

Notice how the slide that we changed above now remains for longer. Also, the mouse appears on the screen later.

The timeline is a useful tool when you want to make changes to the content on a slide in a software simulation project.

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略