在任务间移动内容 (InDesign)

InDesign 用户可以在现有任务间移动内容,也可以从“任务”面板的“未指定的 InCopy 内容”部分移动内容。您也可以创建新任务并将内容移至该任务中。

  1. 存储 InDesign 文档。
  2. 在“任务”面板中,单击任务名称左侧的箭头以显示任务内容。
  3. 在任务中选择一个项目。
  4. 执行以下操作之一:
    • 将内容从一个任务拖动到另一个任务。

    • 要将内容移动到现有任务中,请从“任务”面板菜单中选择“添加到任务”,然后选择所需的任务。

    • 要在移动内容时创建新任务,请从“任务”面板菜单中选择“添加到任务”>“新建”,然后在“新建任务”对话框中指定选项。

  5. 从“任务”面板菜单中选择“更新全部任务”。

注意:

如果任务列表很短,您可能更愿意将内容项目从“未指定的 InCopy 内容”部分拖动到任务中或反之。

删除任务 (InDesign)

  1. 在“任务”面板中,选择一个或多个任务,然后在面板菜单中选择“删除任务”。

删除任务过程完成以下操作:

  • 从文档中删除任务数据。

  • 从文件系统中删除任务文件。

  • 从列表中删除任务名称。

  • 将所有 InCopy 内容移动至“任务”面板中“未指定的 InCopy 内容”部分。

注意:

如果在 InDesign 中删除某一任务时 InCopy 用户已打开此任务,此 InCopy 用户会收到一条警告信息,通知此任务已被删除。但是,内容文件不会被删除,并且可被更新而不会丢失所做的更改。

如果您从磁盘中移动或删除了一个任务文件,然后又打开了用于创建该任务文件的 InDesign 文档,则 InDesign 将不知道该任务文件的位置。这时您需要重新创建此任务文件,以便 InDesign 可以找到它。

在原始位置重新创建任务文件

  1. 在“任务”面板中,执行以下操作之一:
    • 选择缺失的任务(它仍将列在此面板中)并从面板菜单中选择“更新选定的任务”。

    • 从面板菜单中选择“更新全部任务”。

更改任务位置

  1. 要在新位置重新创建此任务文件,请在“任务”面板中执行以下操作之一:
    • 选择此任务并从面板菜单中选择“更改任务位置”。为新文件指定位置和名称。

    • 双击此任务的名称。在“任务选项”对话框中,单击“更改”并为新文件指定位置和名称。

纠正错误

如果您操作有误,您可以放弃自上次执行“存储”命令以来所做的更改,并从文件系统中恢复内容。

由于在您存储 InDesign 文档时 InDesign 会自动存储每个可编辑的 InCopy 内容文件,因此“取消注销”命令只恢复自上次更改文档以来的版本。

  1. 执行以下操作之一:
    • 要还原最近的更改,请选择“编辑”>“还原 [动作]”。

    • 要还原自您从上次存储文档以来所做的所有更改,请选择“文件”>“恢复内容”。

    • 要还原自上次存储的版本以来所做的更改并删除锁定文件,请在“任务”面板中选择内容,然后从面板菜单中选择“取消注销”。此操作将使内容成为只读内容,可供其他用户注销。

覆盖锁定文件 (InDesign)

用户执行动作后,可能不会立即意识到这些动作会对工作流程中的其他人有何影响,也可能无意中导致发生内容状态和所有权之间出现冲突的情况。如有必要,InDesign 用户可通过取消链接由其他用户注销的锁定文件并对该文件进行控制来解决冲突。取消链接文件时会将内容存储在 InDesign 文档中,但不再与 InCopy 共享该内容。

如有必要(例如,因生产截止日期的限制),InDesign 用户可以通过取消链接内容文件从受管理的工作流程和“链接”面板中将内容文件删除。如果您要使内容重新可供编辑,您必须使用其他文件名将其重新导出为 InCopy 内容。这可以确保旧的锁定文件不会妨碍用户编辑此文件。

注意:

取消链接您自己注销的文件时会将其从工作流程中删除,并将锁定文件从磁盘中删除。您可以重新导出内容并覆盖此文件名,而不会引发冲突。

  1. 要取消链接 InCopy 内容文件,请在“链接”面板中选择所需文件(.icml 或 .incx 扩展名),然后从面板菜单中选择“取消链接”。取消链接操作会将内容嵌入到文档中,并删除指向磁盘上的 InCopy 文件的链接。

要重新链接文件,请选择“编辑”>“还原取消链接”。

注意:

取消链接的方法还有删除框架,或使用 InDesign“链接”面板将一个内容文件重新链接至另一个文件。也可以在“任务”面板中选择文章,然后将其拖到废纸篓图标上。

将 InCopy 文件置入 InDesign 文档中

尽管典型的工作流程是从 InDesign 中开始,即在 InDesign 中定义基本版面以及文本和图形占位符,然后将它们导出至 InCopy。但也可以选择另一种工作流程的开始方法,即通过使用“文件”>“置入”命令置入 InDesign 中的独立 InCopy 内容文件(.icml 或 .incx)开始。

将 InCopy 内容文件置入到 InDesign 文档中时,请注意以下依赖性:

样式

如果 InCopy 文本文件应用了样式,则这些样式将被添加到文档的 InDesign 样式列表中。如果出现样式名称冲突,InDesign 会用其现有样式优先选项导入的样式。

版面

您可以在 InDesign 中为内容创建基本版面几何形状,然后创建文本和样式或从文字处理应用程序中导入文本和样式。(置入到 InCopy 中的文本文件是嵌入在 InCopy 文档中的,不链接到任何外部文件。)

置入/复制

如果您多次置入某一 InCopy 内容文件,则每个内容实例都会显示在“InDesign 链接”面板中,但它们只作为一个内容文件受管理。对于内容文件的任何精确副本来说也是如此(不论通过何种方式复制)。

注意:

如果您复制并粘贴受管理的 InCopy 内容文件的部分(而非全部)文本,结果会产生一个新的内容文件,此文件不连接到原文件,并且不链接到任何外部文件(InCopy 或其他)。原来的部分和粘贴的部分可以被相互独立地编辑。

更新/管理

一旦 InDesign 文档中存在受管理内容文件的多个实例,则这些实例的行为就像在两个应用程序中打开它们时的行为一样。例如,注销内容文件的一个实例会锁定所有其他实例,以使您只可以编辑注销的实例。在这种情况下,您需要使用相应的“更新”命令来刷新该内容的其他(打开的)实例。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略