用户指南 取消(C)

管理图形链接

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
      7. Capture 扩展
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. InDesign 中的 Capture 扩展
      4. 脚本
注意:

语言公正:我们将从 InDesign 2022(版本 17.0)起替换掉非包容性的语言,以反映 Adobe 包容性的核心价值观。我们在英语、丹麦语、匈牙利语、西班牙语、意大利语、巴西语、葡萄牙语和日语等语言的帮助文章中,将所有“Master page”均替换为“Parent page”。

关于链接和嵌入的图形

置入图形时,将在版面中看到它采用屏幕分辨率的版本,这有助于您查看和定位该图形。但实际图形文件可能已链接嵌入

  • 链接的图稿虽然连接到文档,但仍与文档保持独立,因而得到的文档较小。您可以使用变换工具和效果来修改链接的图稿;但是,不能在图稿中选择和编辑单个组件。可以多次使用链接的图形,而不会显著增加文档的大小;也可以一次更新所有链接。当导出或打印时,将检索原始图形,并按照原始图形的完全分辨率创建最终输出。

  • 嵌入的图稿将按照完全分辨率复制到文档中,因而得到的文档较大。可以控制版本和根据需要更新文件;一旦嵌入了图稿,文档便必须自行实现嵌入图稿的版本控制和更新。

若要确定图稿是链接的还是嵌入的,或将图稿从一种状态更改为另一种状态,请使用“链接”面板。

如果置入的位图图像不大于 48K,InDesign 将自动嵌入该图像的完全分辨率版本,而非版面中的屏幕分辨率版本。InDesign 将这些图像显示在“链接”面板中,以便您控制版本及根据需要来更新文件;不过,实现最佳输出效果并不一定需要使用链接。

注意:

如果将文档移动到其他文件夹或磁盘(例如,将它提供给服务提供商),请务必一并移动链接的图形文件,这些图形并未存储在文档内。可以使用“印前检查”和“打包”功能自动复制所有相关文件。

链接面板概述

“链接”面板中列出了文档中置入的所有文件。其中包括本地文件(位于磁盘上)和在服务器上管理的资源。但是,从 Internet Explorer 中的某个网站粘贴而来的文件并不显示在此面板中。

在 InCopy 中,“链接”面板还可以显示链接的文章。当您在“链接”面板中选中一个链接的文章时,“链接信息”部分会显示这些信息,例如:附注数量、管理状态以及修订状态。

“链接”面板

A. “类别”列 B. 显示/隐藏链接信息 C. “已修改一个或多个实例”图标 D. “已修改”图标 E. “缺失的链接”图标 F. “嵌入的链接”图标 

同一个图形在文档中出现多次时,其链接将合并到“链接”面板中一个明显的三角形下。如果链接的 EPS 图形或 InDesign 文档包含链接,那么这些链接也会合并到那个明显的三角形下。

可以通过以下任何方式,将链接的文件显示在“链接”面板中:

最新

最新文件的“状态”列中是空白的。

已修改

此图标意味着磁盘上的文件版本比文档中的版本新。例如,如果将一个 Photoshop 图形导入 InDesign,然后您或其他用户在 Photoshop 中编辑并存储该原始图形,那么便会显示此图标。

修改图形时,如果更新它的一个或多个实例,但其他实例保持不变,“已修改”图标将变得略有不同。

缺失

图形不再位于导入时的位置,但仍存在于某个地方。如果导入文件后,将原始文件删除或移至另一个文件夹或服务器,则可能会出现缺失链接的情况。在找到其原始文件前,无法知道缺失的文件是否是最新版本。如果在显示此图标的状态下打印或导出文档,则文件可能无法以全分辨率打印或导出。

嵌入

嵌入链接文件的内容会导致该链接的管理操作暂停。如果选定链接当前处于“正在编辑”操作中,则不能使用此选项。取消嵌入文件,就会恢复对相应链接的管理操作。

如果链接对象未显示在特定文档页面上,则会通过下列代码指示该对象的显示位置:PB(粘贴板)、PP(主页)、OV(溢流文本)和 HT(隐藏文本)。

有关使用“链接”面板的视频教程,请参阅 www.adobe.com/go/lrvid4027_id_cn

InDesign Secrets 在通过“链接”面板节省时间中提供了一份有关“链接”面板提示和技巧的视频广播。

  • 要显示“链接”面板,请选择“窗口”>“链接”。每个链接文件和自动嵌入的文件都通过名称来标识。
  • 要选择并查看链接的图形,可以在“链接”面板中选择相关链接,然后单击“转到链接”按钮 ;在“页面”栏中单击该链接的页码;或在“链接”面板菜单中选择“转到链接”。InDesign 以选定的图形为中心来显示内容。要查看隐藏对象,请显示图层(如果该隐藏对象为定位对象,则显示条件)。
  • 要展开或折叠嵌套链接,请单击链接左侧的三角形图标。同一图形在文档中出现多次,或者链接的 EPS 图形或 InDesign 文档包含链接时,便会形成嵌套链接。
  • 要对面板中的链接排序,请单击“链接”面板顶部的相应类别标题,便会按该类别排序。再次单击该类别可反转排序顺序。例如,如果单击“页面”类别,则链接将按从第一页到最后一页的顺序显示。如果再次单击“页面”,则链接将按从最后一页到第一页的顺序排序。使用“面板选项”向“链接”面板添加栏。

您可以在“链接”面板中显示其他类别(如“创建日期”和“图层”),以显示有关图形的更多信息。对于每个类别,您可以确定该信息是否显示为“链接”面板及“链接”面板底部“链接信息”部分中的一栏。

  1. 从“链接”面板菜单中选择“面板选项”。
  2. 选中“显示栏”下面的复选框,以在“链接”面板中添加栏。

    Folder 0 是包含链接文件的文件夹,Folder 1 是包含 Folder 0 的文件夹,依此类推。

  3. 选中“在链接信息中显示”下面的复选框,以在“链接”面板底部的“链接信息”部分中显示信息。
  4. 单击“确定”。

通过选择栏并将其拖动到另一位置,可以更改栏的顺序。拖动栏边界可更改栏宽。单击类别标题可按该类别对链接进行升序排序。再次单击可按降序排序。

  1. 从“链接”面板菜单中选择“面板选项”。
  2. 对于“行大小”,选择“小行”、“常规行”或“大行”。
  3. 对于“缩览图”,确定是否在“名称”栏和“链接”面板底部的“链接信息”部分中显示图形的缩览图表示形式。
  4. 单击“确定”。

“链接”面板的“链接信息”部分会列出有关所选链接文件的信息。

注意:

要更改“链接”面板“链接信息”部分中显示的信息,请从“链接”面板菜单中选择“面板选项”,然后选中“在链接信息中显示”栏中的复选框。

  1. 双击链接,或选择链接并单击“显示/隐藏链接信息”图标,此三角形图标显示在面板的左侧。

如果链接的或嵌入的文件包含元数据,则可以使用“链接”面板查看元数据。您无法编辑或替换与链接文件关联的元数据。

  1. 在“链接”面板中选择一个文件,然后从面板菜单中选择“实用程序”>“XMP 文件信息”

将图像嵌入文档中

可以将文件嵌入(或存储)到文档中,而不是链接到已置入文档的文件上。嵌入文件时,将断开指向原始文件的链接。如果没有链接,当原始文件发生更改时,“链接”面板不会向您发出警告,并且您将无法自动更新相应文件。

嵌入文件会增加文档文件的大小。

嵌入链接的文件

  1. 在“链接”面板中选择一个文件。
  2. 执行以下操作之一:
    • 在“链接”面板菜单中选择“嵌入链接”。

    • 如果该文件有多个实例,请在“链接”面板菜单中选择“嵌入 [文件名] 的所有实例”。如果只嵌入一个实例,请选择该实例,然后选择“嵌入链接”。

文件将保留在“链接”面板中,并标记有嵌入的链接图标

注意:

对于显示在“链接”面板中的文本文件,请在“链接”面板菜单中选择“取消链接”。嵌入文本文件后,它的名称将从“链接”面板中删除。

取消嵌入链接的文件

  1. 在“链接”面板中选择一个或多个嵌入的文件。
  2. 执行以下操作之一:
    • 从“链接”面板菜单中选择“取消嵌入链接”。如果该文件有多个实例,请在“链接”面板菜单中选择“取消嵌入 [文件名] 的所有实例”。

    • 单击“重新链接”按钮 ,或在“链接”面板菜单中选择“重新链接”。

  3. 选择将文件链接到原始文件,或链接到 InDesign 根据文档中存储的嵌入数据创建的文件夹。

更新、恢复和替换链接

使用“链接”面板检查任一链接的状态,或使用更新文件或替代文件替换文件。

更新或重新建立(重新链接)文件链接时,将保留 InDesign 中已执行的所有变换,前提是在“文件处理”首选项中选中了“重新链接时保留图像尺寸”。例如,如果导入一个正方形图形并将其旋转 30°,然后将其重新链接到一个未旋转的图形,InDesign 会将后者旋转 30°,以便匹配要替换的图形的版面。

注意:

置入的 EPS 文件可能包含 OPI 链接,这些链接将显示在“链接”面板中。OPI 链接的重新链接对象只能是 EPS 文件创建者初始希望链接的文件,否则,可能导致字体下载和分色出现问题。

选择如何缩放重新链接的图形

通过重新链接操作将一个图形替换成另外一个源文件时,可以保持被替换文件的图像尺寸不变,也可以按实际尺寸显示引入的文件。

  1. 选择“编辑”>“首选项”>“文件处理”(Windows),或“InDesign”>“首选项”>“文件处理”(Mac OS)。

  2. 如果希望图像的显示尺寸与被替换的图像相同,请选择“重新链接时保留图像尺寸”。如果取消选择此选项,重新链接的图像将按其实际尺寸显示。

InDesign 首先会在文件夹(当前会话中已经重新链接了该文件夹中的另一个文件)中查找缺失的链接。接下来,InDesign 会在文档所在的同一文件夹中查找链接。如果仍未找到,则会在该文档的上级文件夹中查找。

经过修改的链接也称为“过时”链接。

  1. 在“链接”面板中,执行以下操作之一:
    • 要更新特定链接,请选择一个或多个标记有“修改的链接”图标  的链接。然后单击“更新链接”按钮 ,或从“链接”面板菜单中选择“更新链接”。

    • 要更新所有经过修改的链接,请从“链接”面板菜单中选择“更新所有链接”,或选择某个经过修改的链接,然后按住 Alt (Windows) 或 Option (Mac OS) 键并单击“更新链接”按钮。

    • 若同一图形链接在文档中出现多次,而您只想更新其中一个链接,请仅选择该子链接,然后选择“更新链接”。如果选择“父”链接,可以更新指向已修改图形的所有链接。

  1. 在“链接”面板中选择任一链接,然后单击“重新链接”按钮 ,或从“链接”面板菜单中选择“重新链接”。如果选择了多个实例的“父”链接,请从“链接”面板菜单中选择“重新链接 [Filename] 的所有实例”。

    在受管理的文章中,重新链接是禁用的,直到注销该文章。

  2. 如果希望 InDesign 在文件夹中搜索与其他缺失的链接文件同名的文件,请在出现的对话框中选择“在此文件夹中搜索缺失的链接”。如果未选择此选项,则仅重新链接所选图像。
  3. 选择“显示导入选项”,控制新源文件的导入方式。
  4. 找到并双击新的源文件。
  5. 如果单击了“显示导入选项”选项,请选择导入选项。(请参阅图形的导入选项。)
  1. 要恢复缺失链接,请在“链接”面板中选择任何标记有缺失链接图标   的链接,然后单击“重新链接”按钮  
  2. 在出现的对话框中,选择“在此文件夹中搜索缺失的链接”,以重新链接指定文件夹中显示的所有缺失文件。找到并双击一个文件。

默认情况下,InDesign 会在您打开文档时检查缺失的链接并尝试解析它们。首选项中有两个选项可以让 InDesign 在您打开文档时自动检查并查找缺失的链接。

打开文档前检查链接

如果关闭此选项,InDesign 将立即打开文档,且链接保持挂起状态,直到确定它们的状态是最新、缺失还是已修改。如果打开此选项,InDesign 将检查已修改或缺失的链接。

打开文档前查找缺失链接

如果关闭此选项,InDesign 则不会尝试解析缺失的链接。如果链接影响到服务器的性能,或是发生异常链接,您可能希望关闭此选项。如果关闭了“打开文档前检查链接”,此选项将灰显。

搜索缺失的链接

使用“搜索缺失的链接”命令可搜索并解析文档中的缺失链接。如果关闭了首选项中在打开文档时检查缺失链接的那个选项,而现在发现了缺失的链接,可以使用此命令帮助解决问题。如果存储图像的服务器是在打开文档之后装入的,也会用到此命令。

  • 要更改链接设置,请打开“首选项”对话框的“文件处理”部分,并确定“打开文档前检查链接”和“打开文档前查找缺失链接”两个选项是否已选中。
  • 要让 InDesign 尝试解析缺失的链接,请从“链接”面板菜单中选择“实用程序”>“搜索缺失的链接”。

    如果文档不包含缺失链接,此命令将灰显。

  1. 在“首选项”对话框中,选择“文件处理”。
  2. 从“默认重新链接文件夹”菜单中选择以下选项之一,然后单击“确定”:

    最近使用的重新链接文件夹

    此选项显示的最近使用的文件夹是您在重新链接时选择的文件夹,这与 InDesign CS3 的行为相同。

    原始链接文件夹

    此选项显示链接文件的原始位置,这与 InDesign CS2 和更早版本的行为相同。

通过“将链接复制到”命令,可以将图形文件复制到另一个文件夹,然后将链接重定向到所复制的文件。在将文件移动到另一驱动器(例如将文件从 DVD 移动到硬盘驱动器)时,此命令尤为有用。

  1. 选择指向要复制的文件的链接,然后从“链接”面板菜单中选择“实用程序”>“将链接复制到”。
  2. 指定复制链接文件的目标文件夹,然后选择“选择”(Windows/Mac OS)。

使用“重新链接到文件夹”命令时,目标文件夹可以包含与过期链接同名的文件。例如,如果当前链接指向低分辨率图像,则可以指定包含高分辨率图像的其他文件夹。可以为文件指定其他扩展名,例如可以将链接从 .jpg 更改为 .tiff。

在受管理的 InCopy 文章中,“重新链接到文件夹”命令是灰显的,直到注销该文章。

  1. 在“链接”面板中选择一个或多个链接。
  2. 从“链接”面板菜单中选择“重新链接到文件夹”。
  3. 指定新文件夹的位置。
  4. 要使用其他扩展名,请选择“匹配相同文件名及此扩展名”,然后指定新扩展名(如 AI、TIFF 或 PSD)。
  5. 单击“选择”(Windows/Mac OS)。

使用“重新链接文件扩展名”命令,可以根据文件扩展名来替换图像。例如,如果文档中有多张 JPEG 图像,您可以将这些图像替换为 PSD 文件。具有不同扩展名的文件必须与要替换的链接文件位于同一文件夹中。

  1. 请确保具有不同文件扩展名的文件与原始文件位于同一文件夹中。
  2. 在“链接”面板中选择一个或多个链接。
  3. 从“链接”面板菜单中选择“重新链接文件扩展名”。
  4. 指定要替换选定文件的文件扩展名,然后单击“重新链接”。

使用置入命令替换导入的文件

  1. 执行以下操作之一:
    • 要替换图形框架的内容(如导入的图形),请使用“选择”工具 选择框架。

      要替换图形框架的内容(如导入的图形),请使用“位置”工具选择所需图像。

    • 要替换文本框架的内容,请使用“文字”工具单击文本框架,置入一个插入点,然后选择“编辑”>“全选”

  2. 选择“文件”>“置入”。
  3. 找到新文件并选择它。
  4. 确保选中了“替换所选项目”,然后单击“打开”。
  5. 单击“打开”。

您可以复制链接图像的完整路径,也可以复制平台样式路径。如果复制图像的完整路径,可以让团队成员知道图形的位置。例如,可以复制完整路径,然后将其粘贴到电子邮件中。如果复制平台路径,对于脚本编写或在数据合并中指定图像字段有很大帮助。

  1. 在“链接”面板中选择一个链接。
  2. 从“链接”面板菜单中选择“复制信息”>“复制完整路径”或“复制平台样式路径”。
  3. 粘贴该路径。

编辑原始图稿

通过使用“编辑原稿”命令,您可以在创建图形的应用程序中打开大多数图形,以便在必要时对其进行修改。存储原始文件之后,将使用新版本更新链接该文件的文档。

注意:

在 InDesign 中,如果您注销并选择受管理的图形框架(已导出到 InCopy 的图形框架)而不是图形本身,则图形将在 InCopy 中打开。

使用默认应用程序编辑原始图稿

默认情况下,InDesign 依靠操作系统来确定用于打开原始文件的应用程序。

  1. 在页面上或“链接”面板中选择一张或多张图像。
  2. 执行以下操作之一:
    • 在“链接”面板中,单击“编辑原稿”按钮 

    • 选择“编辑”>“编辑原稿”。

  3. 在原始应用程序中进行更改后,存储文件。

使用其他应用程序编辑原始图稿

  1. 选择图像。
  2. 选择“编辑”>“编辑工具”,然后指定将用于打开文件的应用程序。如果没有显示该应用程序,请选择“其他”,浏览并找到该应用程序。
Adobe 徽标

登录到您的帐户