Adobe Media Encoder 使用现有预设或自定义设置来编码和转码不同视频和音频格式的媒体文件。

编码过程

要对视频或音频项目进行编码,请将项目添加到 Adobe Media Encoder 中的编码队列。选择现有编码预设或创建您自己的自定义设置。您可以指示应用程序在您将项目添加到队列后开始编码,或者让应用程序等到您决定开始编码时再开始。您可以使用 Adobe Media Encoder 执行以下操作:

  • 将项目添加到编码队列:将视频或音频文件拖入 Adobe Media Encoder 中的队列面板。有关更多信息,请参阅将项目导入到编码队列
  • 使用预设对项目进行编码:从队列中含有项目的“格式”和“预设”下拉列表中选择格式和预设。或者从预设浏览器选择一个预设并拖动到“队列”中的任何项。有关更多信息,请参阅使用预设进行编码
  • 使用自定义设置对项目进行编码:在队列面板中选择所需项目,然后选择“编辑”>“导出设置”,或者单击队列中列出的“格式”和“预设”,然后选择您的设置。有关更多信息,请参阅使用自定义设置进行编码

要在指定的持续时间后自动开始对队列中的项目进行编码,请选择“空闲时间超过后面的设定时自动启动队列”。在“首选项”对话框中设置空闲状态的所需持续时间。

首选项
首选项

启用倒计时后,将在“编码”面板中显示倒计时。有关更多信息,请参阅首选项

编码倒计时
编码倒计时

将项目导入到编码队列

要将视频或音频文件添加到编码队列中,请执行以下操作之一:

  • 将一个或多个文件从桌面或媒体浏览器拖动到“队列”面板中。
  • 单击“队列”面板中的“添加源”按钮,然后选择一个或多个文件。
  • 双击“队列”面板中打开的区域,然后选择一个或多个文件。

从 Premiere Pro 导入

要添加 Adobe Premiere Pro 序列,请执行以下操作之一:

  • 在媒体浏览器中的 Adobe Premiere Pro 项目中导航,然后单击序列并拖动到队列中。
  • 选择“文件”>“添加 Premiere Pro 序列”,选择一个 Premiere Pro 项目,然后从该项目选择一个或多个序列。
  • 单击一个序列并从 Adobe Premiere Pro 的“项目”面板拖动到“队列”面板中。
  • 单击一个 Premiere Pro 项目并从桌面拖动到“队列”面板中。

从 After Effects 导入

要添加 Adobe After Effects 合成,请执行以下操作之一:

  • 在媒体浏览器中的 Adobe After Effects 项目内导航,并将合成拖放到“队列”面板中。
  • 选择“文件”>“添加 After Effects 合成”,选择一个 After Effects 项目,然后从该项目中选择一个合成。
  • 单击一个合成并从 After Effects 中的“项目”面板拖动到“队列”面板中。
  • 单击一个 After Effects 项目并从桌面拖动到“队列”面板中。

停止编码

要停止编码,请执行以下操作之一:

  • 要停止对当前项目的编码,请选择“文件”>“停止当前项目”。Adobe Media Encoder 继续编码队列中的其余项。
  • 要停止对队列中所有项目的编码,请选择“文件”>“停止队列”

拼接剪辑

在添加到队列时可将多个媒体文件合并到单个文件中。要将媒体文件拼接在一起,请执行以下操作:

  1. 选择“文件”>“添加源”,或单击“队列”面板中的“添加源”按钮 。将打开文件资产管理器。

  2. 选择要拼接在一起的资源。

  3. 选中“将剪辑拼接在一起”复选框。

    将剪辑拼接在一起
    将剪辑拼接在一起
  4. 单击“打开”,将拼接的剪辑添加到队列。

或者,选择要拼接的剪辑。将它们拖到“队列”面板上,然后在选项“拖放到此处,将剪辑拼接在一起”的顶部松开。

拖放到此处,将剪辑拼接在一起
拖放到此处,将剪辑拼接在一起

拼接的剪辑将载入到队列中。要查看单个剪辑,请单击“显示源”。默认情况下,剪辑按字母顺序排序。您可以根据自己的喜好重新排列它们。

所拼接剪辑的名称会自动设置为序列中的第一个剪辑。要更改剪辑的名称,请单击该名称。有关更多信息,请参阅使用 Adobe Media Encoder 将剪辑拼接在一起

注意:

拼接剪辑遵循媒体浏览器中设置的入点和出点。但是,一旦将源添加到拼接剪辑中,则无法编辑源的持续时间。

标识编码队列中的缺失项

在开始编码之前,可以标识队列中包含缺失项目的项目。此过程有助于您在编码之前确认并修复问题。存在缺失项的源或输出旁会显示警告状态。要查看与此问题相关联的错误摘要,请将鼠标悬停在图标上。

在以下情况下,Adobe Media Encoder 会显示警告图标

  • Premiere Pro 项目包含脱机媒体。在此情况下,Adobe Media Encoder 会使用代理媒体代替缺失的媒体集合。如果没有代理,则会使用一个图形,显示消息“媒体脱机”。
  • Premiere Pro 项目中缺少部分字体。
  • Premiere Pro 项目中缺少部分效果。
  • 叠加效果中缺少部分文件。
错误摘要
错误摘要

解释编码队列中的项目

当 Adobe Media Encoder 导入视频资产时,它将尝试确定视频资产的帧速率、像素长宽比、场序和 alpha 通道。如果 Adobe Media Encoder 对于这些特性的确定有误,您可以手动指定正确的解释。

  1. 选择编码队列中的一个或多个视频项目。

  2. 执行以下操作之一:

    • 选择“文件”>“解释素材”
    • 右键单击文件,然后选择“解释素材”
  3. 选择适当的解释设置。

解释素材
解释素材

注意:

如果选择的资产不是视频资产或图像资产,则“解释素材”选项将不可用。

使用预设或自定义设置进行编码

使用预设进行编码

预设
A. 格式 B. 预设 C. 目标 
  1. 将项目添加到“队列”面板。有关信息,请参阅将项目导入到编码队列

  2. 通过单击格式(A) 的文本来打开包含支持的文件格式的“格式”弹出窗口,选择一种与输出设备兼容的格式。

  3. 通过单击预设(B) 的文本来打开包含行业标准预设的“预设”弹出窗口,选择与输出设备兼容的预设。有关更多信息,请参阅为 Media Encoder 创建自定义预设

    或者将预设从预设浏览器拖放到“队列”中。

    应用预设
    应用预设
  4. 通过单击输出(C) 的文本,然后在“另存为”对话框中查找您的导出所在的目录或文件夹,选择导出的位置。单击“保存”

  5. “启动队列”按钮。

即会按照您想要的格式、使用所选预设并在您所选择的位置,开始对您的文件进行编码。在文件经过编码后,单击输出文件路径以打开包含编码文件的文件夹。

输出文件
A. 编码后的输出文件 B. 编码前的输出文件 

注意:

在编码过程中,如果想要暂停该编码过程,请再次单击“启动队列”按钮。

使用自定设置进行编码

要使用自定义设置进行编码,请执行以下操作:

  1. 将项目添加到“队列”面板。有关信息,请参阅将项目导入到编码队列

  2. 通过执行以下操作之一打开“导出设置”对话框:

    • 在队列面板中,为显示格式、预设和输出文件路径的文本选择项目的行,然后选择“编辑”>“导出设置”
    • 右键单击显示格式、预设和输出文件路径文件的文本的行,然后选择“导出设置”
    • 单击“格式”“预设”名称以打开“导出设置”对话框。
  3. 设置导出选项,然后单击“确定”。有关更多信息,请参阅 Media Encoder 导出设置参考

  4. 关闭“导出设置”对话框后,单击“启动队列”开始对您的文件进行编码。

注意:

要在编码过程中获得最佳性能,请关闭“编码”面板。您可以使用“队列”面板中的进度条来查看编码过程的状态。

您可以在“导出设置”对话框中,执行以下任何一项操作:

  • “格式”菜单中选择视频、音频或静止图像格式。有关更多信息,请参阅可用于导出的文件格式

  • “预设”菜单中选择一种编码预设。

  • 选择“导出视频”和/或“导出音频”

  • 指定编码前选项,包括裁剪、修剪。有关更多信息,请参阅“导出设置”对话框

  • 设置用于 XMP 元数据导出的选项。有关更多信息,请参阅导出和精简 XMP 元数据

  • 选择“使用最高渲染品质”“以最大位深度渲染”

  • 选择“使用帧混合”

  • 通过单击“导出设置”对话框右上角部分的“输出名称”旁边的下划线文本并输入文件名和位置,指定编码文件的文件名和位置。如果未指定文件名,Adobe Media Encoder 将会使用源视频剪辑的文件名。

注意:

如果将格式设置为“P2 影片”,则用户分配的文件名不适用。因此,Adobe Media Encoder 为此类编码提供了六个字符的字母数字名称。“输出名称”会保存到剪辑的元数据中,并且在 Adobe Premiere Pro 中显示为剪辑名称。

您可以指定目标文件夹,以用来保存含有源视频剪辑的文件夹相关的编码文件。当指定目标文件夹时,请确保指定的目标文件夹存在。如果指定的文件夹不存在,系统会显示错误消息,提示您由于找不到文件夹而无法将文件编码。

保存编码队列

您退出 Adobe Media Encoder 时,编码队列和编码设置将自动保存。当用户开始编码过程时,同时会自动保存编码队列。

要手动保存编码队列,请选择“文件”>“保存队列”

注意:

如果希望在关闭并重新启动 Adobe Media Encoder 后,完成的已编码项目仍然保留在队列里,请取消选中“首选项”>“退出时将队列中已完成的文件删除”复选框。

更改多个源的输出文件路径

请按照以下步骤更改多个输出的输出文件路径(同时):

  1. 按住 Shift 键并单击,在队列中选择多个源。

  2. 在当前选择项中单击一个源的“输出文件”的文本。

  3. “选择输出文件夹”对话框中选择一条路径,然后单击“选择”

所选输出将指向新目录,但保留其唯一的输出文件名。

监视文件夹

您可以配置 Adobe Media Encoder 在名为监视文件夹的特定文件夹中查找文件。Adobe Media Encoder 会自动对位于监视文件夹中的文件进行编码。当 Adobe Media Encoder 在监视文件夹中找到视频或音频文件时,它会使用分配给该文件夹的编码设置对该文件进行编码。然后,它会将编码文件导出到监视文件夹内创建的输出文件夹。

Adobe Media Encoder 使用监视文件夹自动执行媒体文件排队和渲染过程。通过使用不同的格式或预设添加不同的输出实例,可以创建源的多个版本。

“监视文件夹”面板
“监视文件夹”面板

Adobe Media Encoder 中的“监视文件夹”面板可用于添加和管理文件夹。您可以通过下列操作中的一项来添加监视文件夹:

  • 选择“文件”>“添加监视文件夹”,并选择文件夹。
  • 双击“监视文件夹”面板的空白区域并选择文件夹。
  • 在资源管理器 (Windows) 或 Finder (Mac OS) 中创建文件夹,然后将其拖动到“监视文件夹”面板。

由监视文件夹添加到编码队列中的项目将在您启动队列时随着队列中的其他项目一起编码。

注意:

如果您选中了“空闲时间超过后面的设定时自动启动队列”首选项,而且监视文件夹在编码队列中添加了一个项目,当指定的时间过去后,编码将开始。

使“自动对监视文件夹进行编码”复选框保持选中状态,以便在项目添加到监视文件夹时自动对项目进行编码。

使用监视文件夹以多种格式创建输出

使用监视文件夹,您可以通过单个操作生成多个输出。例如,您想要在每次转码视频资产时都生成 AVI 影片和 JPEG 缩览图图像。

要通过单个用户操作创建这些文件,请执行以下步骤:

  1. 使用名为“My_WatchFolder”的文件资产管理器 (Windows) 或 Finder (macOS) 创建文件夹。

  2. 通过单击“添加文件夹”按钮创建监视文件夹,然后导航到刚刚创建的名为“My_Watchfolder”的文件夹。

    • 单击“格式”,然后从弹出菜单中选择“MPEG4”作为格式。
    • 单击“预设”,然后从“预设”弹出菜单中选择所需的设置。
    导出设置
    导出设置
    • 单击“输出文件夹”。选择想要生成输出的位置。
  3. 就像在步骤 2 中一样,创建也指向文件夹“My_Watchfolder”的“监视文件夹”项目。

    • 单击“格式”,然后从弹出菜单中选择“AVI”作为格式。
    • 单击“预设”,然后从“预设”弹出菜单中选择所需的设置。
    • 单击“输出文件夹”。选择想要生成输出的位置。
  4. 就像在步骤 2 和步骤 3 中一样,创建也指向文件夹“My_Watchfolder”的“监视文件夹”项目。

    • 单击“格式”,然后从弹出菜单中选择“JPEG”作为格式。
    • 单击“预设”,然后从“预设”弹出菜单中选择所需的设置。
    • 单击“输出文件夹”。选择想要生成输出的位置。
  5. 单击源文件并拖动到“My_WatchFolder”中,然后单击“启动队列”按钮。如果启用了“自动对监视文件夹进行编码”,则编码过程会自动开始。

完成后,每个文件都位于预期的输出位置。

删除、复制和跳过编码队列中的项目

删除、复制和跳过编码队列中的项目
删除、复制和跳过编码队列中的项目

从编码队列中移除项目

要从编码队列中移除项目,请执行以下操作:

  1. 选择要从编码队列中移除的项目。

  2. 执行以下操作之一:

    • 右键单击文件,然后选择“移除”按钮。
    • 选择“编辑”>“清除”,或按 Delete 键。
    • 选择“是”以确认移除。(选中“不再询问”可避免每次从队列中移除项目时都出现确认窗口)

复制编码队列中的项目

要复制编码队列中的项目,请执行以下操作:

  1. 选择要从编码队列中复制的项目。

  2. 执行以下操作之一:

    • 右键单击该文件,然后选择“复制”
    • 单击“复制”按钮,选择“编辑”>“复制”
    • Ctrl+ D (Windows) 或 Command+ D (macOS)

跳过编码队列中的项目

要跳过编码队列中的项目,请执行以下操作:

  1. 选择要在编码队列中跳过的项目。

  2. 执行以下操作之一:

    • 选择“编辑”>“跳过所选项目”
    • 右键单击该文件,然后选择“跳过所选项目”

重置编码队列中项目的状态

要重置编码队列中文件的状态,请执行以下操作:

  1. 在编码队列中选择要重置为“就绪”状态的项目。

  2. 执行以下操作之一:

    • 选择“编辑”>“重置状态”。
    • 右键单击该文件,然后选择“编辑”>“重置状态”

监视编码进度

在对某个项目进行编码时,编码队列的“状态”列将提供每个项目的状态。Adobe Media Encoder 可同时对来自单个源的多个输出进行编码。但是,源文件按照它们在队列中的顺序依次处理。

进行编码时,您可以在应用程序中继续工作。可以添加、删除或重新排序队列或监视文件夹中的项目。但是,无法编辑当前正在编码的输出。

  • “就绪”
    该项目处于编码队列中,但尚未进行编码。可以从队列中删除始终以及目前未进行编码的文件。
  • “完成”
    该项目已成功编码。
  • “已停止”
    在对项目进行编码时用户取消了编码过程。
  • “失败”
    Adobe Media Encoder 在尝试对指定项目编码时遇到了错误。
  • “跳过”
    用户可以跳过一个或多个所选文件。选择文件之后,请选择“编辑”>“跳过所选项目”。

编码完成时可听见的警报(成功,但有错误)

Adobe Media Encoder 具有可听见的警报。“队列”中的编码完成时,会播放可听见的警报。如果检测到任何错误情况,则会发出不同的警报声。如果不想听到这些警告,可以在首选项中禁用这些警告。

首选项
首选项

显示日志

要查看带有错误消息的工具提示,请将鼠标悬停在状态图标上。要打开编码已成功完成、停止或失败的任何项目的日志,请单击状态。

显示日志
显示日志

并行编码

Adobe Media Encoder 按顺序编码所有源,但并行编码某个源的所有输出。它用于同时导出同一源的多个格式,但不能同时用于导出不同的源。

并行编码
并行编码

注意:

默认情况下开启并行编码。要禁用并行编码,请选择“编辑”>“首选项”,然后取消选中“启用并行编码”

同时编码多个输出时,“编码”面板将显示每个编码输出的缩略图预览、进度条和完成时间估算。

在某些情况下,导出设置要求输出以序列形式编码,而不是以并行模式。此种情况下,在临时序列编码完成之后,队列返回到平行编码。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略