Note:

Looking for information pertaining to the current version of Photoshop? See Photoshop plug-ins troubleshooting.

What's covered

Use this document to identify problematic plug-ins in Adobe Photoshop CS5 or CS4. This document also provides instructions for restoring the default set of Photoshop CS5 or CS4 plug-ins.

Plug-ins are software modules that extend the capabilities of Photoshop. For example, some plug-ins enable you to apply special effects to images, while others enable you to open or save various image file formats.

When you installed Photoshop, many plug-ins were installed automatically. If you subsequently installed any third-party plug-ins -- plug-ins from a publisher other than Adobe -- and if you are troubleshooting unexpected behavior in Photoshop, then a third-party plug-in may be causing the problem.

A plug-in can cause a problem in Photoshop for any of these reasons:

  • The plug-in was designed for a different version of Photoshop and is not compatible with Photoshop CS5 or CS4.
  • The plug-in was installed incompletely or incorrectly.
  • More than one version of the same plug-in is installed.
  • A plug-in file has become damaged.

Some of the steps in this document have different instructions for the 32-bit and 64-bit editions of your Windows operating system. If you do not know which edition of Windows you are using, see "Determine whether your computer is running a 32-bit or a 64-bit edition of Windows" (TechNote kb407673).

Note: To troubleshoot issues with the Adobe Camera Raw plug-in, see "Unable to open camera raw file in Photoshop or Photoshop Elements" (TechNote kb407110).

Troubleshoot the Additional Plug-Ins Folder

If you have not enabled the Additional Plug-Ins Folder option then skip this section.



To determine whether Photoshop is loading a problematic plug-in from the Additional Plug-Ins Folder:

  1. Start Photoshop.
  2. Choose Photoshop > Preferences > Plug-Ins (Mac OS) or Choose Edit > Preferences > Plug-Ins (Windows).
  3. In the Preferences dialog, deselect Additional Plug-Ins Folder.
  4. Click OK.
  5. Restart Photoshop for the change to take effect.
  6. Try to re-create the problem.

If the problem recurs, then a plug-in in the Additional Plug-Ins Folder is not the cause. Re-enable the Additional Plug-Ins Folder option.

If the problem does not recur, then a plug-in in the Additional Plug-Ins Folder is the cause. To identify the problematic plug-in:

  1. Choose Edit > Preferences > Plug-Ins on Windows or Photoshop > Preferences > Plug-Ins on Mac OS.
  2. In the Preferences dialog, select Additional Plug-Ins Folder. Note the location of this folder.
  3. Click OK.
  4. Close Photoshop.
  5. Navigate to the location of the Additional Plug-Ins Folder, which you noted in Step 2.
  6. Move one plug-in from the Additional Plug-Ins Folder to a temporary location (for example, a new folder on your Desktop).
  7. Start Photoshop and then try to re-create the problem.
  8. Do one of the following:
    • If the problem recurs, then repeat Steps 4 through 7.
    • If the problem does not recur, then the plug-in that you last moved out of the Additional Plug-Ins Folder is the cause. Leave this plug-in out of your Additional Plug-Ins Folder and then contact its publisher for support or for information about an updated version of the plug-in. Restore all of the other third-party plug-ins that you previously moved out of the Additional Plug-Ins Folder.

Troubleshoot installed third-party plug-ins

If you have never installed any third-party plug-ins for Photoshop, then skip this section.

To complete the steps in this section, you must know all of the third-party plug-ins that you have installed for Photoshop CS5 or CS4. If you do not have this information, then open Photoshop, choose Help > System Info, and make a list of the plug-ins whose publisher is not Adobe Systems. System Info will also tell you which plug-ins are 32-bit and which ones did not load.

To determine whether Photoshop is loading a problematic third-party plug-in:

  1. Close Photoshop.
  2. Remove or disable all third-party plug-ins. Use one or more of these methods:
    • Move third-party plug-ins from Photoshop's plug-in folders to a temporary location that is outside of Photoshop's plug-ins folders (for example, to a new folder on your Desktop).
    • Rename each third-party plug-in file so that the file name begins with a tilde (~). Photoshop does not load files whose name begins with a tilde.
    • Follow the removal instructions provided by each plug-in's publisher.
    Note: See Additional Information below for the locations of the Photoshop plug-in folders.
  3. Start Photoshop and then try to re-create the problem.

If the problem recurs, then an installed third-party plug-in is not causing the problem. Close Photoshop and reinstall or re-enable all of the third-party plug-ins that you removed or disabled. Skip the remaining steps in this section.

If the problem does not recur, then a third-party plug-in is causing the problem. To identify the problematic plug-in:

  1. Close Photoshop.
  2. Reinstall or re-enable one of the third-party plug-ins that you removed or disabled.
  3. Start Photoshop and then try to re-create the problem.
  4. Do one of the following:
    • If the problem does not recur, then repeat Steps 1 through 3.
    • If the problem recurs, then the plug-in that you last reinstalled or re-enabled is causing the problem. Remove or disable this plug-in and then contact its publisher for support or for information about an updated version of the plug-in. Reinstall or re-enable the other third-party plug-ins that you removed or disabled.

Restore the default set of Photoshop CS5 or CS4 plug-ins

Important: After you complete this section, do the following additional tasks:

  • Reinstall any third-party plug-ins and optional Photoshop plug-ins that you previously installed and wish to continue using. (If you have enabled the Additional Plug-Ins Folder option, however, then the plug-ins in that folder are not affected and will not need to be reinstalled.)
  • Install all available updates to Photoshop and its supporting components such as Camera Raw, including the 11.0.1 update to Photoshop and the latest compatible version of the Camera Raw plug-in. To install these updates go to http://www.adobe.com/downloads/updates/.

Windows

To restore the default plug-ins on a 32-bit edition of Windows:

  1. Close all applications.
  2. In Windows Explorer, navigate to C:\Program Files\Adobe\Adobe Photoshop CS5 or CS4 (or to your custom installation location). Move the Plug-Ins folder to a temporary location (for example, a new folder on your Desktop).
  3. Navigate to C:\Program Files\Common Files\Adobe\Plug-Ins. Move the CS5 folder (or CS4 folder) to a temporary location.
  4. Start the installer for Photoshop CS5 or CS4 or your edition of Adobe Creative Suite.

    • If you purchased boxed software, then insert the installation disc into your computer's optical drive. (If the installer does not start automatically, then navigate in Windows Explorer to the Adobe CS5 or CS4 folder on the installation disc and double-click Setup.)
    • If you purchased downloadable software from the Adobe Online Store, then double-click the installer that you downloaded. (If you no longer have the downloaded installer, then log into your account at https://www.adobe.com/account/my-products-services.html to download the installer.)
  5. In the installer window, select Adobe Photoshop CS5 or CS4 in the list of Installed Products.
  6. (Optional) Deselect all other components besides Photoshop, if this option is available.
  7. Click Install. Follow the on-screen instructions.

To restore the default plug-ins on a 64-bit edition of Windows:

  1. Close all applications.
  2. In Windows Explorer, navigate to C:\Program Files\Adobe\Adobe Photoshop CS5 or CS4 (or to your custom installation location). Move the Plug-Ins folder to a temporary location (for example, a new folder on your Desktop).
  3. Navigate to C:\Program Files\Common Files\Adobe\Plug-Ins. Move the CS5 or CS4 folder to a temporary location.
  4. Navigate to C:\Program Files (x86)\Adobe\Adobe Photoshop CS5 or CS4. Move the Plug-Ins folder to a temporary location.
  5. Navigate to C:\Program Files (x86)\Common Files\Adobe\Plug-Ins. Move the CS5 or CS4 folder to a temporary location.
  6. Start the installer for Photoshop CS5 or CS4 or your edition of Adobe Creative Suite.

    • If you purchased boxed software, then insert the installation disc into your computer's optical drive. (If the installer does not start automatically, then navigate in Windows Explorer to the Adobe CS5 or CS4 folder on the installation disc and double-click Setup.)
    • If you purchased downloadable software from the Adobe Online Store, then double-click the installer that you downloaded. (If you no longer have the downloaded installer, then log into your account at www.adobe.com/account to download the installer.)
  7. In the installer window, select Adobe Photoshop CS5 or CS4 (64-bit) and Adobe Photoshop CS4 in the list of Installed Products.
  8. (Optional) Deselect all other components besides Photoshop, if this option is available.
  9. Click Install. Follow the on-screen instructions.

 Mac OS

To restore the default plug-ins on Mac OS:

Close all applications.

  1. In the Finder, navigate to Applications/Adobe Photoshop CS5 or CS4 (or to your custom installation location). Move the Plug-Ins folder to a temporary location (for example, a new folder on your Desktop).
  2. Start the installer for Photoshop CS5 or CS4 or your edition of Adobe Creative Suite.
  3. If you purchased boxed software, then insert the installation disc into your computer's optical drive. (If the installer does not start automatically, then navigate in the Finder to the Adobe CS5 or CS4 folder on the installation disc and double-click Setup.)
  4. If you purchased downloadable software from the Adobe Online Store, then double-click the installer that you downloaded. (If you no longer have the downloaded installer, then log into your account at www.adobe.com/membership to download the installer.)
  5. In the installer window, select Adobe Photoshop CS5 or CS4 in the list of Installed Products.
  6. (Optional) Deselect all other components besides Photoshop.
  7. Click Install. Follow the on-screen instructions.

Additional Information

Third-party plug-ins may be installed in one or more of the following locations:

  • The Photoshop Plug-Ins folder, or to a sub-folder within the Photoshop Plug-Ins folder. (Most third-party plug-ins are installed in this location.)
  • Third-party plug-ins may also be installed in a custom location and then loaded into Photoshop by enabling the Additional Plug-Ins Folder option in the preferences.

Windows

If you installed Photoshop to the default location: C:/Program Files/Adobe/Adobe Photoshop CS5 or CS4, 

then the Photoshop Plug-Ins folder is located here: C:/Program Files/Adobe/Adobe Photoshop CS5 or CS4/Plug-Ins.



Note: If you are using a 64-bit edition of Windows, then there are two editions of Photoshop installed on your computer: a 32-bit edition and a 64-bit edition.

The default location of the Plug-ins folder for the 32-bit edition is

C:/Program Files (x86)/Adobe/Adobe Photoshop CS5 or CS4/Plug-Ins.

The default location of the Plug-Ins folder for the 64-bit edition is

C:/Program Files/Adobe/Adobe Photoshop CS5 or CS4/Plug-Ins.

Additionally, there is a Common Plug-Ins folder for the Camera Raw plug-in, which is shared by Photoshop, Bridge and Photoshop Elements.

It is located at C:/Program Files/Common Files/Adobe/Plug-Ins/CS5 or CS4.



Note: If you are using a 64-bit edition of Windows, then there is a separate Common Plug-Ins folder for 32-bit plug-ins at

C:/Program Files (x86)/Common Files/Adobe/Plug-Ins/CS5 or CS4.

Mac OS X

If you installed Photoshop to the default location: Applications/Adobe Photoshop CS5 or CS,

then the Photoshop Plug-Ins folder is located here: Applications/Adobe Photoshop CS5 or CS4/Plug-Ins.

Photoshop CS5 will install a single Universal application that can run both 32-bit and 64-bit modes for all installs. Photoshop checks the chipset of the computer and sets the default bit mode appropriately, 64- bit when possible.  



To use 32-bit plug-ins when you are running Photoshop CS5 in 64-bit mode:

1.  Select the Applications/Adobe Photoshop CS5/Adobe Photoshop CS5.app file.

2.  Choose File > Get Info 

3. Select Open in 32-bit mode

4. Reopen Photoshop.

Additionally, there is a Common Plug-Ins folder for the Camera Raw plug-in, which is shared by Photoshop, Bridge and Photoshop Elements.

It is located at Hard Drive/Library/Application Support/Adobe/Plug-Ins/CS5or CS4/File Formats. 

 Photoshop CS5 Optional Plugins

You can download the optional plug-ins for Photoshop CS5 from these locations: 

For Mac OS: http://www.adobe.com/support/downloads/detail.jsp?ftpID=4687 

For Windows: http://www.adobe.com/support/downloads/detail.jsp?ftpID=4688 

To read about their changes from Photoshop CS4 and compatibliity with 32- and 64-bit systems refer to "Plug-in changes in Photoshop CS5" (TechNote kb82824)

 

 

 

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy