Doplněk Adobe Acrobat PDFMaker (tlačítko Převést do Adobe PDF na pruhu nástrojů/kartě tohoto doplňku) slouží k vytváření souborů PDF z aplikací Microsoft Office. Tato funkce je nainstalována ve verzích Acrobat Professional a Standard.

  • V systému MS Office2003 a dřívějších verzích využívá doplněk PDFMaker k vytvoření souboru jazyka PostScript tiskárnu Adobe PDF. Následně se tiskárna Adobe PDF spojí s aplikací Adobe Acrobat Distiller a vytvoří soubor PDF.
  • V systému MS Office 2007, 2010, 2016 a 365 používá doplněk PDFMaker k převodu dokumentu Microsoft Office na formát PDF knihovnu AdobePDF.
  • Aplikaci Acrobat Distiller a tiskárnu Adobe PDF lze k tvorbě souborů PDF také použít samostatně.

V tomto dokumentu naleznete postupy řešení potíží při vytváření souborů PDF z aplikací systému Office pomocí doplňku Acrobat PDFMaker. Tento dokument sice obsahuje informace o řešení potíží v souboru Microsoft Word, ale většinu těchto postupů můžete využít také u aplikací Microsoft PowerPoint a Microsoft Excel.

 

V aplikacích sady Office 2016 nebo služby Office 365 v systému Windows není k dispozici pás karet aplikace Acrobat

Týká se to verzí aplikací Word, Excel a PowerPoint ze sady Office 2016 nebo služby Office 365.

Pokuste se problém odstranit provedením následujících kroků:  

  1. Pravým tlačítkem myši klikněte na ikonu aplikace Word a vyberte příkaz Spustit jako správce.

    Jestliže se zobrazí výzva nástroje Řízení uživatelských účtů, klikněte na tlačítko Ano.

  2. Otevřete prázdný dokument – vyberte šablonu Prázdný dokument. Případně můžete otevřít existující dokument aplikace Word.

  3. V nabídce Soubor vyberte příkaz Možnosti. Zobrazí se dialogové okno Možnosti aplikace Word.

  4. V seznamu možností vyberte možnost Doplňky. V rozevíracím seznamu Spravovat vyberte položku Doplňky modelu COM a potom klikněte na tlačítko Přejít.

    Doplňky aplikace Word
  5. V dialogovém okně Doplňky modelu COM zaškrtněte políčko u doplňku Acrobat PDFMaker modelu COM pro sadu Office (pokud není zaškrtnuto) a potom klikněte na tlačítko OK.

    Doplněk PDFMaker modelu COM pro sadu Office

Selhání sady Office 2016 a balíčku služeb Office 365 při práci s doplňkem PDFMaker v systému Windows

Po únorové aktualizaci sady Office 2016 dochází k selhání sady Office 2016 a balíčku služeb Office 365 při práci s doplňkem PDFMaker v systému Windows.

Společnost Adobe spolupracuje se společností Microsoft na vyřešení tohoto problému v nejkratším možném čase. Alternativní řešení k vytvoření souborů PDF naleznete zde.

Kontrola kompatibility aplikace Acrobat se systémem Microsoft Office

Před aplikací postupů řešení potíží se ujistěte, zda je verze aplikace Acrobat, kterou používáte, kompatibilní s verzí systému Office ve vašem zařízení. Další informace naleznete v článku Kompatibilita webových prohlížečů a aplikací PDFMaker | Acrobat, Reader.

Řešení potíží s aplikací Acrobat Distiller a tiskárnou Adobe PDF (platné pouze při práci s doplňkem PDFMaker v systému MS Office 2003 nebo dřívější)

Doplněk PDFMaker (v systému MS Office 2003 a dřívější) používá k převodu dokumentů aplikace Word tiskárnu Adobe PDF, která využívá aplikaci Acrobat Distiller. Při řešení potíží tedy nejprve zkontrolujte, zda aplikace Acrobat Distiller funguje správně:

Vytvoření souboru PDF z aplikace Word pomocí tiskárny Adobe PDF 

  1. Otevřete dokument pomocí aplikace Word a zvolte možnost Soubor > Tisk.
  2. V nabídce s názvy tiskáren zvolte tiskárnu Adobe PDF a klikněte na tlačítko OK.

Vytvoření souboru PDF pomocí aplikace Acrobat Distiller

Poznámka: Při použití tohoto způsobu nejsou podporovány rozšířené funkce doplňku PDFMaker, například zachování odkazů a struktury dokumentu.

  1. Otevřete dokument aplikace Word a zvolte možnost Soubor > Tisk.
  2. V dialogu Tisk vyberte tiskárnu s podporou jazyka PostScript (například tiskárnu Adobe PDF), vyberte možnost Tisk do souboru a klikněte na tlačítko OK.

    Bude vytvořen soubor jazyka PostScript (PS nebo PRN).

    Poznámka: Pokud nemáte tiskárnu s podporou jazyka PostScript, můžete z webu společnosti Adobe stáhnout ovladač tiskárny s podporou tohoto jazyka. Po instalaci ovladače dokončete krok 2. Pokud vyberete tiskárnu Adobe PDF, zrušte výběr možnosti zajišťující, že písma nebudou odeslána do tiskárny Adobe PDF, a vytvořte soubor jazyka PostScript.

  3. V aplikaci Acrobat zvolte možnost Další volby > Acrobat Distiller.
  4. V seznamu Výchozí nastavení zvolte nastavení (nebo ponechte výchozí nastavení).
  5. Zvolte možnost Soubor > Otevřít a v nabídce Typ souborů zvolte možnost Všechny soubory, vyberte vytvořený soubor PS nebo PRN a poté klikněte na možnost Otevřít.
  6. Zadejte název a umístění PDF souboru a pak klikněte na Uložit.
  7. Otevřete soubor messages.log v následující složce systému Windows (NT, 2000, XP, Vista, 7): %AppData%\Adobe\Acrobat\Distiller [název verze]

  8. V tomto souboru vyhledejte informace pro řešení potíží:

    • Pokud v souboru naleznete informace, proč nemohla aplikace Acrobat Distiller vytvořit soubor PDF, vyhledejte pomocí textového pole pro vyhledávání na stránkách nápovědy a podpory k aplikaci Adobe související dokumenty. Pokud je například v souboru zaznamenána chyba jazyka PostScript, vyřešte potíže podle doporučení v článku Řešení chyb jazyka PostScript.
    • Pokud v souboru nejsou uvedeny důvody, proč nemohla aplikace Acrobat Distiller vytvořit soubor PDF, vytvořte dokument aplikace Word, který obsahuje pouze pár slov. Poté zkuste z tohoto dokumentu vytvořit soubor PDF pomocí tiskárny Adobe PDF a aplikace Acrobat Distiller:
    • Pokud z nového dokumentu můžete vytvořit soubor PDF, problém se zřejmě vztahuje k doplňku PDFMaker. Přejděte k části Řešení potíží s doplňkem Acrobat PDFMaker.
    • Pokud soubor PDF z nového dokumentu vytvořit nemůžete, použijte jiný soubor z jiné aplikace. Poté zkuste vytvořit soubor PDF pomocí aplikace Acrobat Distiller. Pokud problém přetrvává i u souboru z jiné aplikace, přeinstalujte aplikaci Acrobat Distiller. Pokud se potíže u souboru z jiné aplikace nevyskytnou, vyřešte daný problém pomocí dokumentů uvedených v části Související obsah. Nebo vyhledejte informace v nápovědě k aplikaci Adobe. Pokud potřebujete další pomoc, kontaktujte technickou podporu pro produkt Acrobat.

Řešení potíží s doplňkem Acrobat PDFMaker

Pokud lze vytvořit soubor PDF pomocí tiskárny Adobe PDF nebo aplikace Acrobat Distiller, ale nikoli pomocí doplňku Acrobat PDFMaker, problém zřejmě způsobuje funkce Acrobat PDFMaker. Chcete-li určit, zda některá z těchto funkcí způsobuje dané potíže, funkce zakažte. Poté zkuste vytvořit soubor PDF:

  1. V dokumentu aplikace Word zvolte možnost Adobe PDF > Změnit nastavení převodu.
  2. V nabídce Nastavení převodu zvolte položku Nejmenší velikost souboru.
  3. Klikněte na kartu Word a poté zrušte výběr všech možností.
  4. Klikněte na kartu Záložky a poté zrušte výběr všech možností záložek.
  5. Klikněte na kartu Zabezpečení a poté zrušte výběr všech možností zabezpečení.
  6. Klikněte na tlačítko OK.
  7. Zkuste vytvořit soubor PDF:
  • Pokud se vytvoření nezdaří, přejděte k části Řešení potíží specifických pro dokument.
  • Pokud soubor PDF vytvoříte, určete, které funkce způsobily daný problém: Povolte funkci a zkuste vytvořit soubor PDF. Tento postup opakujte, až se znovu vyskytne daný problém. Poté vytvořte dokument aplikace Word, který obsahuje pouze pár slov. Poté zkuste z tohoto dokumentu vytvořit soubor PDF pomocí stejných nastavení doplňku Acrobat PDFMaker:
  • Pokud z nového dokumentu můžete vytvořit soubor PDF, problém se týká daného dokumentu. Přejděte k části Řešení potíží specifických pro dokument.
  • Pokud soubor PDF z nového dokumentu vytvořit nemůžete, problém je způsoben funkcí, která byla naposledy povolena. Přeinstalujte doplněk Acrobat PDFMaker. Pokud problém přetrvává, kontaktujte podporu produktu Acrobat

Řešení potíží specifických pro dokument

Pokud zjistíte, že se problém vztahuje ke konkrétnímu dokumentu, postupujte při řešení potíží podle následujících pokynů.

Povolení pouze funkcí doplňku Acrobat PDFMaker, které daný dokument používá

Pokud například dokument obsahuje pouze styly nadpisů Nadpis 1 a Nadpis 2, zakažte v dialogu doplňku Acrobat PDFMaker ostatní styly nadpisů.

Přepnutí na zobrazení Normální v dokumentu aplikace Word a vytvoření souboru PDF pomocí doplňku Acrobat PDFMaker

Další vytvoření dokumentu aplikace Word k odstranění problémů

Proveďte jeden nebo více z následujících úkonů:

  • Zkopírujte a vložte obsah dokumentu aplikace Word do nového dokumentu a poté vytvořte soubor PDF.
  • Vyberte všechen text v dokumentu, změňte písmo a poté dokument uložte s novým názvem. Dokument aplikace Word přepíše soubor a odstraní prvky, které nejsou kompatibilní s doplňkem Acrobat PDFMaker. Po uložení můžete v dokumentu nastavit požadované písmo.
  • Pokud byl dokument vytvořen v jiné verzi aplikace Word, než jakou jste použili k vytvoření souboru PDF, proveďte v něm drobnou změnu. Poté jej uložte s novým názvem. Aplikace Word bude nucena dokument přepsat a mohou se tak odstranit prvky, které nejsou kompatibilní s doplňkem Acrobat PDFMaker.

Nové vytvoření vlastních stylů nadpisů v dokumentu a vytvoření souboru PDF

Identifikace nekompatibilních prvků v dokumentu

  1. Vytvořte dokument aplikace Word.
  2. Zkopírujte polovinu původního souboru aplikace Word do nového dokumentu aplikace Word.
  3. Nový dokument aplikace Word převeďte pomocí doplňku PDFMaker do formátu PDF.
  • Pokud se problém vyskytne znovu, nachází se v dokumentu aplikace Word nekompatibilní prvek. Chcete-li tento prvek dohledat, opakujte kroky 1 až 3 a zkopírujte polovinu druhého dokumentu aplikace Word do nového dokumentu aplikace Word.
  • Pokud k potížím nedojde, nekompatibilní prvek se vyskytuje v původním dokumentu aplikace Word. Chcete-li problém přesně určit, opakujte kroky 1 až 3 a zkopírujte druhou polovinu původního dokumentu aplikace Word do nového dokumentu aplikace Word. Pokud se obě poloviny dokumentu převedou bez problémů, zavřete ostatní spuštěné programy včetně aplikace Office. Odstraňte soubory TMP, které jsou často umístěny ve složce s dočasnými soubory systému Windows.

Přeinstalace programů

Odstraňte aplikaci Acrobat a systém Office nebo všechny aplikace specifické pro tento systém (Word, PowerPoint nebo Excel). Přeinstalujte systém Office nebo aplikace specifické pro tento systém a poté přeinstalujte aplikaci Acrobat.

Aplikaci Acrobat odstraňte pomocí ovládacích panelů Přidat nebo odebrat programy. Pokyny k odstranění systému Office naleznete v dokumentaci k systému Office nebo kontaktujte společnost Microsoft.

Zrušení ochrany chráněného dokumentu aplikace Word

Pokyny ke zrušení ochrany naleznete v dokumentaci k aplikaci Word nebo kontaktujte společnost Microsoft. 

Řešení potíží s dalšími makry v aplikaci Microsoft Word

Problémy se mohou vyskytnout při použití doplňku PDFMaker s jinými makry, například s programy ke kontrole přítomnosti virů nebo s faxovým softwarem. Pokud nelze problémy vyřešit nebo se vyskytnou problémy s doplňkem PDFMaker po instalaci maker třetích stran, vyřešte potíže pomocí jiných maker. Mezi nekompatibilní makra patří Duden Korrektor Plus 2.0, ViaVoice 10 a dřívější verze, Personal Translator 2002 Office Plus, OfficeReady Stuffit, Leuchter Informatic AG WordPlus a GoldMine Link to Word.

Pokud chcete zjistit, zda je doplněk PDFMaker nekompatibilní s jiným makrem, postupně odstraňujte nebo deaktivujte další makra. Další informace naleznete v příslušném odkazu níže. Poté zkuste pomocí doplňku PDFMaker dokument znovu převést na formát PDF. Pokud se problém nevyskytne, kontaktujte výrobce daného makra.

Řešení potíží s aplikací Microsoft Word

Níže uvedené kroky uvádějí informace převzaté z článků znalostní báze společnosti Microsoft:

Podrobnosti o řešení potíží s aplikací Microsoft Word naleznete v příslušném článku na webu společnosti Microsoft.

Spuštění aplikace Word pomocí přepínače /a a ruční přidání doplňku PDFMaker

Díky přepínači /a spustíte aplikaci Word a zabráníte automatickému načtení doplňků a globálních šablon (včetně šablony Normální). Přepínač /a také uzamkne soubory nastavení, které nebude možné při použití tohoto přepínače číst ani upravit.

Poznámka: Změny předvoleb, vlastního nastavení nebo maker provedené v průběhu relace aplikace Word spuštěné přepínačem /a nebudou po ukončení této aplikace uloženy.

Postup spuštění aplikace Word pomocí přepínače /a:

  1. Ukončete všechny programy.
  2. V nabídce Start klikněte na příkaz Spustit.
  3. V dialogu Spustit zadejte příkaz winword.exe /a.
  4. Klikněte na tlačítko OK. Dialog se zavře a spustí se aplikace Word.

Ruční načtení doplňku PDFMaker (pouze u aplikace Acrobat 6.x):

  1. Ukončete všechny programy.
  2. Vyberte možnost Nástroje > Šablony a doplňky.
  3. Vyberte doplněk PDFMaker.dot (nikoli PDFMakerA.dot) a klikněte na tlačítko OK.

    Zobrazí se ikona doplňku PDFMaker.

Pro aplikaci Acrobat 7.x, 8.x, 9.x, X (podle příslušné aplikace) 

Ruční načtení doplňku PDFMaker (MS Word 2003 nebo dřívější):

  1. Ukončete všechny programy.
  2. Vyberte možnost Nástroje > Vlastní a klikněte na kartu Příkazy.
  3. Na panelu Kategorie klikněte na možnost Nástroje.
  4. Přetáhněte možnost Doplňky modelu COM z panelu Příkazy do nabídky Nástroje a podržte stisknuté tlačítko myši. Po zobrazení příkazů nabídky Nástroje přetáhněte možnost Doplňky modelu COM pod položku Vlastní a poté uvolněte tlačítko myši.
  5. Klikněte na možnost Zavřít.
  6. V nabídce Nástroje klikněte na možnost Doplňky modelu COM.
  7. Klikněte na možnost Přidat, vyhledejte doplněk (doplněk PDFMaker se nachází v umístění [cesta instalace aplikace Acrobat]\PDFMaker\Office\PDFMOfficeAddIn.dll) a klikněte na tlačítko OK.

  8. Stisknutím klávesové zkratky Alt+F11 spusťte editor Visual Basic Editor.
  9. Stisknutím klávesové zkratky Ctrl+G spusťte příkazové podokno editoru Visual Basic Editor.
  10. Chcete-li spustit doplněk PDFMaker v aplikaci Word, zadejte řetězec Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True. Zavřete editor Visual Basic Editor.
  11. Ověřte, zda se nyní nabídka aplikace Adobe PDF zobrazí vpravo od nápovědy pruhu nabídek aplikace Microsoft Word.

Ruční načtení doplňku PDFMaker (MS Word 2007 a 2010):

  1. Ukončete všechny programy.
  2. Klikněte na tlačítko Microsoft Office a poté na tlačítko Možnosti aplikace Word.

  3. Klikněte na část Doplňky.

  4. V seznamu Správa vyberte možnost Doplňky modelu COM a poté klikněte na tlačítko Přejít.

  5. Pokud je doplněk modelu COM Acrobat PDFMaker uveden v seznamu a vybrán v dialogu Doplňky modelu COM, postupujte podle následujících pokynů. Pokud tomu tak není, přejděte ke kroku 6.

  6. Kliknutím zrušte výběr zaškrtávacího políčka doplňku modelu COM Acrobat PDFMaker.

  7. Kliknutím na tlačítko OK zavřete dialog Doplňky modelu COM.

  8. Zopakujte kroky 1 až 3 a poté kliknutím vyberte doplněk modelu COM Acrobat PDFMaker nebo zaškrtněte jeho políčko v dialogu Doplňky modelu COM.

  9. Ověřte, zda se na pásu karet aplikace MS Word zobrazí karta aplikace Acrobat.

  10. Pokud NENÍ doplněk modelu COM Acrobat PDFMaker uveden v dialogu Doplňky modelu COM, pokračujte podle kroků 7 až 10 v části Ruční načtení doplňku PDFMaker (MS Word 2003 nebo dřívější)

Vytvoření testovacího dokumentu aplikace Word a spuštění doplňku PDFMaker: 

  1. Do dokumentu aplikace Word vepište text.
  2. Zvolte možnost Soubor > Uložit a uložte testovací dokument na počítači.
  3. Klikněte na možnost Převést do Adobe PDF.

Pokud se problém vyřešil použitím přepínače /a ke spuštění aplikace Word, odeberte všechny komponenty, které se při spuštění aplikace Word načtou. Tyto komponenty odebírejte po jedné v pořadí, ve kterém se zobrazují v aplikaci Word. Při spuštění aplikace Word se načtou následující komponenty:

  • automatická makra aplikace Word,
  • globální šablona (Normal.dot),
  • doplňky (WLL),
  • šablony ve složce Po spuštění aplikace Word a složkách Po spuštění systému Office,
  • doplňky modelu COM,
  • datový klíč aplikace Word v registru systému Windows,
  • klíč možností v registru systému Windows,
  • automatická makra aplikace Word.

Poznámka: Další informace o řešení potíží se spuštěním aplikace Word naleznete v následujících službách pro podporu společnosti Microsoft:

Přejmenování souboru šablony Normal.dot

Postup přejmenování souboru globální šablony naleznete v části Globální šablona (Normal.dotm nebo Normal.dot) článku podpory společnosti Microsoft s názvem Obnovení uživatelských možností a nastavení registru v aplikaci Word. Článek naleznete v dolní části stránky.

Důležité informace: Po dokončení těchto kroků nepoužívejte k restartování aplikace Word přepínač /a.

Pokud se problém vyřeší po přejmenování globální šablony, byl způsoben poškozenou šablonou Normal.dot. Někdy je nutné změnit některé nastavení, aby se obnovily možnosti. Pokud obsahuje přejmenovaný soubor Normal.dot vlastní nastavení, například styly, makra nebo položky automatického textu, které nelze snadno znovu vytvořit, zkuste pomocí dialogu Organizátor toto vlastní nastavení zkopírovat ze starého souboru Normal.dot do nového souboru Normal.dot.

Další informace o používání dialogu Organizátor získáte po provedení těchto kroků:

  1. Spusťte aplikaci Word.
  2. Zvolte možnost Nápověda > Nápověda aplikace Microsoft Word.
  3. V pomocníku Office nebo průvodci odpověďmi zadejte možnost Organizátor.

  4. Klikněte na možnost Hledat a zkontrolujte vyhledaná témata.

Pokud jste problém nevyřešili, použijte místo nové globální šablony starou šablonu, tedy Normal.dot. Chcete-li použít starou šablonu Normal.dot, přejmenujte novou šablonu Normal.dot zpět na Normal.dot. Pokud potíže s doplňkem PDFMaker přetrvají i po vyzkoušení postupů z tohoto dokumentu, kontaktujte podporu produktu Acrobat.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online