Problém: Chyba „Správa licencí pro tento produkt přestala fungovat“

Poznámka:

Tento článek se týká verze Creative Suite 5.5 a starších.

Zobrazuje se při pokusu o spuštění aplikace Adobe chybová zpráva „Správa licencí pro tento produkt přestala fungovat“? Pokud ano, zkuste problém odstranit pomocí řešení na této stránce.

Řešení

Důležitá poznámka: Řešení níže provádějte v uvedeném pořadí. Nepokračujte k dalšímu řešení, pokud jste problém vyřešili pomocí předchozího řešení. Po provedení některých řešení můžete být vyzváni k opětovnému zadání údajů o licenci nebo aktivaci produktu. Také je možné, že zkušební verze softwaru Adobe se nepodaří spustit.

Řešení 1: Aktualizace licenční služby

  1. Ukončete všechny aplikace Adobe.
  2. Stáhněte si nástrojAdobe Licensing Repair Tool.

  3. Spusťte aktualizaci licenční služby:

    1. Extrahujte soubor LicenseRecovery109.zip.

      Důležitá poznámka: K extrahování obsahu komprimovaného souboru použijte nástroj, jako například WinZip.
    2. Dvakrát klikněte na soubor LicenseRecover.exe.
  4. Postupujte podle pokynů na obrazovce.
  5. Spusťte aplikaci Adobe.

    Důležitá poznámka: Oprava se vztahuje na produkty Creative Suite 3 a 4, aplikaci Acrobat 8 a 9, aplikaci Photoshop Elements 6, 7 a 8, aplikaci Director a sadu Adobe Technical Communication Suite. Pokud se vám na první pokus nepodařilo problém vyřešit, spusťte opravu znovu a po výzvě zadejte volbu 0. V případě, že problém přetrvává i po druhém pokusu o opravu, přejděte k řešení 2.

Řešení 2: Nastavení ručního spouštění služby FLEXnet Licensing Service a následné spuštění služby

  1. Klepněte na nabídku Start > Ovládací panely.
  2. Dvakrát klikněte na ikonu Nástroje pro správu.
  3. Dvakrát klikněte na ikonu Služby.
  4. Dvojitým kliknutím na službu FLEXnet Licensing Service otevřete dialogové okno Vlastnosti.
  5. V nabídce Typ spouštění vyberte možnost Ručně.
  6. Klikněte na tlačítko Použít.
  7. Spusťte službu kliknutím na tlačítko Spustit v části Stav služby.
  8. Klikněte na tlačítko Použít a pak na tlačítko OK.
  9. Zavřete všechna otevřená dialogová okna.
  10. Spusťte aplikaci Adobe.
 

Poznámka: Pokud se při pokusu o spuštění služby FLEXnet Licensing Service zobrazí chyba „Chyba 5, přístup byl odepřen“, postupujte takto:

  1. V nabídce Start klikněte na příkaz Spustit a zadejte services.msc.
  2. Dvakrát klikněte na službu FLEXnet Licensing Service.
  3. Klikněte na kartu Přihlášení a v nabídce Účet pro přihlášení vyberte možnost Tento účet a zadejte údaje o účtu.
  4. Klikněte na tlačítko OK a zavřete okno Služby.
  5. Restartujte počítač a znovu postupujte podle řešení 2.

Řešení 3: Přejmenování složky FLEXnet

Přejmenujte složku FLEXnet v následujícím umístění na FLEXnetold:

  • V systému Windows XP:
    C:\Documents and Settings\All Users\Data aplikací\FLEXnet
  • V systému Windows Vista nebo Windows 7:
    C:\ProgramData\FLEXnet folder

Důležitá poznámka: Odstraněním tohoto souboru ukončíte všechny aktivní zkušební verze produktů Adobe a přijdete o zbývající dny zkušební doby.

 

Řešení 4: Obnovení oprávnění ke složce FLEXnet.

Ukončete všechny aplikace Adobe. Složka FLEXnet obsahuje všechna data licencí nainstalovaných aplikací Adobe. Úprava oprávnění k souborům ve složce FLEXnet může umožnit správný zápis licenčních údajů.Podle pokynů pro váš operační systém níže upravte oprávnění ke složce FLEXnet (která obsahuje data licenční služby).

Poznámka: K tomuto řešení potřebujete mít v počítači oprávnění správce. V systému Windows XP se přihlaste pomocí účtu správce. V systému Windows 7 nebo Vista zadejte pověření správce.

V systému Windows XP Professional

  1. Klepněte na nabídku Start > Ovládací panely.
  2. Dvakrát klikněte na ikonu Možnosti složky a pak klikněte na kartu Zobrazení.
  3. V části Upřesnit nastavení zrušte výběr možnosti Použít zjednodušené sdílení souborů (doporučeno).
  4. Klikněte na tlačítko OK.
  5. V okně Průzkumníku ve složce Ovládací panely klikněte do panelu adresy, zadejte %ALLUSERSPROFILE%\Data aplikací a stiskněte Enter.
  6. Pravým tlačítkem klikněte na složku FLEXnet a pak klikněte na příkaz Vlastnosti.
  7. V části Atributy zrušte výběr možnosti Jen pro čtení.
  8. Klikněte na tlačítko Použít a pak kliknutím na tlačítko OK zavřete dialogové okno Potvrdit změnu atributů.
  9. Klikněte na kartu Zabezpečení.
  10. Ujistěte se, že jsou v seznamu uvedeny skupiny Administrators a System a oprávnění jsou nastavena na úplné řízení.
  11. Klikněte na tlačítko Upřesnit.
  12. Vyberte možnost Nahradit položky oprávnění ve všech podřízených objektech zde zobrazenými položkami platnými pro podřízený objekt.
  13. Klikněte na kartu Vlastník.
  14. Vyberte skupinu Administrators.
  15. Vyberte možnost Nahradit vlastníka v podřízených kontejnerech a objektech.
  16. Klikněte na tlačítko OK a pak v dialogovém okně Zabezpečení klikněte na tlačítko Ano.
  17. Kliknutím na tlačítko OK zavřete dialogové okno FLEXnet – vlastnosti.
  18. Spusťte aplikaci Adobe.
 

V systému Windows XP Home

  1. Restartujte počítač v nouzovém režimu.
    1. Restartujte systém Windows.
    2. Před spuštěním systému Windows stiskněte klávesu F8 (ve chvíli, kdy je zobrazena zpráva jako například Upřesnění možností spuštění).
    3. Z nabídky možností spuštění vyberte možnost Nouzový režim.

      • Pokud není v pravém horním rohu pracovní plochy zobrazen nápis Nouzový režim, opakujte kroky 1.1 až 1.3.
      • Pokud je v pravém horním rohu pracovní plochy zobrazen nápis Nouzový režim, přihlaste se jako správce místního počítače.
    4. Jestliže se zobrazí dialogové okno s informací, že systém Windows je spuštěn v nouzovém režimu, klikněte na tlačítko OK.
  2. Klepněte na nabídku Start > Ovládací panely.
  3. Dvakrát klikněte na ikonu Možnosti složky a pak klikněte na kartu Zobrazení.
  4. V části Upřesnit nastavení zrušte výběr možnosti Použít zjednodušené sdílení souborů (doporučeno).
  5. Klikněte na tlačítko OK.
  6. V okně Průzkumníku ve složce Ovládací panely klikněte do panelu adresy, zadejte %ALLUSERSPROFILE%\Data aplikací a stiskněte Enter.
  7. Pravým tlačítkem klikněte na složku FLEXnet a pak klikněte na příkaz Vlastnosti.
  8. V části Atributy zrušte výběr možnosti Jen pro čtení.
  9. Klikněte na tlačítko Použít a pak kliknutím na tlačítko OK zavřete dialogové okno Potvrdit změnu atributů.
  10. Klikněte na kartu Zabezpečení.
  11. Ujistěte se, že jsou v seznamu uvedeny skupiny Administrators a System a oprávnění jsou nastavena na úplné řízení.
  12. Klikněte na tlačítko Upřesnit.
  13. Klikněte na kartu Vlastník.
  14. Vyberte skupinu Administrators.
  15. Vyberte možnost Nahradit vlastníka v podřízených kontejnerech a objektech.
  16. Klikněte na tlačítko Použít a pak klikněte na kartu Oprávnění.
  17. Vyberte možnost Nahradit položky oprávnění ve všech podřízených objektech zde zobrazenými položkami platnými pro podřízený objekt.
  18. Klikněte na tlačítko OK a pak v dialogovém okně Zabezpečení klikněte na tlačítko Ano.
  19. Kliknutím na tlačítko OK zavřete dialogové okno FLEXnet – vlastnosti.
  20. Spusťte aplikaci Adobe.
 

V systému Windows 7 nebo Windows Vista

  1. V nabídce Start klikněte na položku Počítač.
  2. V nabídce Uspořádat klikněte na příkaz Možnosti složky a hledání a pak klikněte na kartu Zobrazení.
  3. V části Upřesnit nastavení zrušte výběr možnosti Používat průvodce sdílením (doporučeno).
  4. Klikněte na tlačítko OK.
  5. V okně Průzkumníku ve složce Počítač klikněte do panelu adresy, zadejte %ALLUSERSPROFILE% a stiskněte Enter.
  6. Pravým tlačítkem klikněte na složku FLEXnet a pak klikněte na příkaz Vlastnosti.
  7. V části Atributy zrušte výběr možnosti Jen pro čtení.
  8. Klikněte na tlačítko Použít a pak kliknutím na tlačítko OK zavřete dialogové okno Potvrdit změnu atributů.
  9. Klikněte na kartu Zabezpečení.
  10. Ujistěte se, že jsou v seznamu uvedeny skupiny Administrators a System a oprávnění jsou nastavena na úplné řízení. Jestliže tomu tak není, postupujte následovně:
    1. Klepněte na možnost Upravit.
    2. Pokud se zobrazí výzva ke zvýšení úrovně oprávnění nástroje Řízení uživatelských účtů, přijměte ji podle zobrazených pokynů.
    3. Proveďte potřebné změny.
  11. Klikněte na tlačítko Upřesnit.
  12. Klikněte na kartu Vlastník.
  13. Klikněte na tlačítko Upravit, a pokud se zobrazí výzva ke zvýšení úrovně oprávnění nástroje Řízení uživatelských účtů, přijměte ji.
  14. V části Změnit vlastníka na klikněte na skupinu Administrators.
  15. Vyberte možnost Nahradit vlastníka v podřízených kontejnerech a objektech.
  16. Klikněte na tlačítko Použít a pak klikněte na kartu Oprávnění.
  17. Klikněte na tlačítko Upravit, a pokud se zobrazí výzva ke zvýšení úrovně oprávnění nástroje Řízení uživatelských účtů, přijměte ji.
  18. Vyberte možnost Nahradit položky oprávnění ve všech podřízených objektech zde zobrazenými položkami platnými pro podřízený objekt.
  19. Klikněte na tlačítko OK a pak na tlačítko Ano.
  20. Klikněte na tlačítko OK a pak v dialogovém okně Zabezpečení systému Windows klikněte na tlačítko OK.
  21. Kliknutím na tlačítko OK zavřete dialogové okno Upřesnit nastavení otevřené z dialogového okna FLEXnet.
  22. Kliknutím na tlačítko OK zavřete dialogové okno FLEXnet – vlastnosti.
  23. Spusťte aplikaci Adobe.
 

Řešení 5: Obnovení oprávnění ke složce Adobe PCD 

Postupujte podle pokynů v řešení 4, ale použijte je u této složky:

C:/Program Files/Common Files/Adobe PCD

Řešení 6: Odstranění žurnálového souboru SQLite

Žurnálový soubor existuje pouze za určitých podmínek, pokud klient přistupuje k databázovému souboru a jsou povoleny určité volby. V případě, že tento soubor neexistuje, pokračujte dalším řešením.

  1. V Průzkumníku přejděte do složky \Program Files\Common Files\Adobe\Adobe PCD\cache.
  2. Obsahuje-li soubor cache.db-journal, odstraňte jej.
  3. Spusťte aplikaci Adobe.

Řešení 7 (pouze systém Vista): Synchronizace virtualizovaných a nevirtualizovaných souborů PCD a caps

Jsou-li v počítači aplikace podporující systém Vista i aplikace nepodporující systém Vista, může dojít k desynchronizaci souborů ve složce C:\Program Files a virtuálním úložišti. Synchronizujte soubory podle následujícího postupu:

  1. Ukončete všechny aplikace Adobe.
  2. Z umístění C:\Program Files (x86)\Common Files\Adobe zkopírujte složku „Adobe PCD“.
  3. Vložte ji do umístění C:\Users\[jméno uživatele]\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe.
  4. Pokud se zobrazí dotaz, zda chcete nahradit nebo sloučit stávající soubory, klikněte na tlačítko Ano. V následujícím dialogovém okně vyberte možnost Kopírovat a nahradit pro všechny soubory.
  5. Znovu spusťte aplikaci.
  6. Pokud problém přetrvává, opakujte stejný postup u složky „caps“ uložené ve stejném umístění a zkopírujte ji do stejného nového umístění.

Poznámka: Po tomto řešení může daná aplikace i jiné aplikace Adobe vyžadovat opětovné zadání sériového čísla.

Případně můžete složky ve virtuálním úložišti přejmenovat nebo odstranit a pak aplikaci znovu spustit:

  1. Ukončete všechny aplikace Adobe.
  2. Přejděte do umístění C:\Users\[jméno uživatele]\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe.
  3. Přejmenujte složku Adobe PCD, například na AdobeoldPCD, nebo ji odstraňte.
  4. Spusťte danou aplikaci.
  5. Pokud problém přetrvává, opakujte stejný postup u složky caps.

Pokud výše uvedené kroky problém nevyřeší, odstraňte klíč registru virtual store\Adobe:

  1. Ukončete všechny aplikace Adobe.
  2. Přihlaste se k systému Windows jako správce.
  3. V nabídce Start zvolte možnosti Všechny programy > Příslušenství > Spustit a zadejte regedit.
  4. V dialogovém okně Řízení uživatelských účtů klikněte na tlačítko Pokračovat.
  5. V nabídce Soubor klikněte na příkaz Exportovat a vytvořte záložní kopii registru. Zadejte název záložního souboru a uložte jej do umístění, které si zapamatujte.
  6. Pravým tlačítkem klikněte na položku HKEY_LOCAL_MACHINE > SOFTWARE > Classes > VirtualStore > MACHINE > SOFTWARE > Adobe.
  7. Vyberte možnost Odstranit. Ukončete Editor registru.
  8. Spusťte danou aplikaci.

Poznámka: Po tomto řešení může daná aplikace i jiné aplikace Adobe vyžadovat opětovné zadání sériového čísla.

Řešení 8: Přeinstalace

Upozornění: U tohoto řešení je potřeba úplně odinstalovat a znovu nainstalovat veškerý software Adobe CS3 a CS4 a také aplikace Acrobat 8 a 9. K instalaci softwaru Adobe jsou potřeba oprávnění správce. Před provedením kroků níže se přihlaste k účtu správce. Další informace najdete v dokumentaci k operačnímu systému.

  1. Klepněte na nabídku Start > Ovládací panely.
  2. Dvakrát klikněte na položku Programy a funkce (Windows 7/Vista) nebo na ikonu Přidat nebo odebrat programy (Windows XP).
  3. Vyberte příslušný produkt Adobe a klikněte na tlačítko Změnit nebo odebrat.
  4. Podle pokynů na obrazovce software odinstalujte.
  5. Opakujte kroky 3 a 4 u všech zbývajících produktů Adobe CS3/CS4 a Acrobat 8/9.
  6. Odstraňte následující složky:
    C:\Program Files\Common Files\Adobe\Adobe PCD
    C:\Program Files\Common Files\Adobe\caps
    C:\Program Files\Common Files\Adobe\backup

  7. V nabídce Start klikněte příkaz Vypnout, vyberte možnost Restartovat a pak klikněte na tlačítko OK.
  8. Nainstalujte produkty Adobe z původních médií.
  9. Spusťte produkty Adobe.

Řešení 9: Technická podpora společnosti Adobe

Technická podpora společnosti Adobe může na základě protokolů z počítače zjistit další informace o chybě. Pokud se vám pomocí informací uvedených v tomto dokumentu nepodařilo problém vyřešit, obraťte se na technickou podporu společnosti Adobe.

Další informace

Tuto chybu může způsobit řada okolností, například:

  • Pokud k chybě dojde ihned po instalaci, je v některých případech potřeba aktualizovat určitou komponentu, aby byla kompatibilní s operačním systémem. Případně může komponenta vyžadovat mírně odlišnou konfiguraci systému.
  • Pokud se aplikaci podařilo alespoň jednou spustit nebo pokud byla používána často, souvisí problém pravděpodobně se systémovým prostředkem. (Může se jednat například o nedostatek paměti, nedostatek místa na disku nebo souběžné spouštění několika programů.) V důsledku může dojít k dočasnému selhání licenčního systému nebo k poškození trvalých dat o licenci.
  • Pokud byl proces instalace přerušen, nemusí licenční systém fungovat správně.
  • Pokud jste dříve používali předběžnou verzi programu, je možné, že máte dočasné sériové číslo s nastaveným vypršením platnosti. V takovém případě se podívejte do tématu Chyba „Platnost licence tohoto produktu vypršela“ | CS4, CS5.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online