Naučte se odeslat a publikovat web Adobe Muse do hostingové služby třetí strany pomocí FTP, SFTP nebo FTPS.

Poznámka:

Do aplikace Adobe Muse již nejsou přidávány žádné další funkce a 26. března 2020 bude její podpora ukončena. Podrobnější informace a možnosti asistence naleznete na stránce Ukončení životnosti aplikace Adobe Muse.

Tento článek popisuje používání FTP (File Transfer Protocol) k publikování webu Adobe Muse do poskytovatele webhostingu třetí strany.

Postup publikování do služby Adobe Business Catalyst místo do poskytovatele třetí strany najdete v článku Publikování prvního webu aplikace Muse.

Co je to FTP?

FTP (File Transfer Protocol) je metoda přenosu (odesílání či stahování) souborů po Internetu. Pomocí FTP můžete odeslat soubory exportované z aplikace Adobe Muse do vzdáleného serveru hostujícího vaše webové stránky. Další informace o FTP najdete na stránce File Transfer Protocol.

SFTP

SFTP neboli „SSH File Transfer Protocol“ (či také Secure File Transfer Protocol) je protokol FTP chráněný pomocí SSH (Secure Shell) a přenášený přes zabezpečené připojení. Další informace o SFTP najdete na stránce SSH File Transfer Protocol.

FTPS

FTPS (též FTP-ES, FTP-SSL nebo FTP Secure) je rozšíření protokolu FTP, které přidává podporu kryptografických protokolů Transport Layer Security (TLS) a Secure Sockets Layer (SSL). Informace o protokolu FTPS si můžete zobrazit kliknutím na odkaz FTPS.

Nastavení webhostingu

Webhosting je internetová hostingová služba umožňující uživatelům zpřístupnit svůj web prostřednictvím sítě WWW (World Wide Web). Poskytovatelé webhostingu jsou společnosti nabízející klientům prostor na serverech.

Jako uživatel aplikace Adobe Muse musíte nejprve vytvořit účet u poskytovatele webhostingu. Mezi oblíbené poskytovatele webhostingu patří:

Zadejte do online hledání výraz „webhosting“ a projděte si nabízené možnosti, porovnejte ceny a najděte plán hostingu, který nejlépe odpovídá vašim požadavkům.

Po vytvoření účtu online vám poskytovatel hostingu předá informace pro přihlášení pomocí FTP (označované také jako pověřovací údaje), které budete potřebovat pro přístup do serveru pomocí FTP. Jedná se obvykle o následující informace:

Hostitel FTP

je webová adresa serveru hostujícího vaše webové stránky. Může být stejná jako název domény vašeho webu (například vášweb.com), ale často je odlišná (například ftp.vášweb.com). Může se dokonce jednat o číselnou IP adresu, například 152.16.274.1. Té se také říká server FTP.

Webový adresář

je složka na serveru FTP, do které je nutné nahrát soubory vašeho webu. U některých poskytovatelů hostingu může být prázdná. Webový adresář je nejčastěji public_html. Běžně se také může jednat o www nebo httpdocs. Říká se mu také kořenový adresář webu nebo adresář hostitele.

Číslo portu

jedinečně identifikuje IP adresu hostitele. Někdy je také uvedeno číslo portu. FTP používá ve výchozím nastavení port číslo 21. Číslo portu si poznamenejte pouze v případě, že se jedná o jinou hodnotu než 21.

Používání funkce Odeslat do hostitele FTP

Jakmile máte k dispozici informace pro přihlášení do FTP, můžete publikovat svůj web Adobe Muse:

  1. Zvolte Soubor > Odeslat do hostitele FTP.

    Vyberte možnost Odeslat do hostitele FTP
    Vyberte možnost Odeslat do hostitele FTP.

  2. Do jednotlivých polí zadejte následující informace a klikněte na tlačítko Další.

    Server FTP

    tak, jak uvedl poskytovatel hostingu. Server FTP může být název domény (např. google.com) nebo IP adresa. Do tohoto pole nezadávejte webový adresář. Pokud server používá jiný port než výchozí (21), je nutné na konec zadat středník a číslo portu. Například ftp.vášweb.com:3341

    Uživatelské jméno a heslo

    pro váš hostingový účet. Uživatelské jméno a heslo jsou specifické pro adresu FTP zadanou v poli Server FTP. Tyto přihlašovací údaje nejsou vaše Adobe ID.

    Ukládání pověřovacích údajů

    umožňuje bezpečné uložení přihlašovacích informací do FTP a automatické připojení k FTP serveru při dalších relacích. Uložené pověřovací údaje také umožňují aplikaci Adobe Muse provádět automatickou kontrolu změn provedených pomocí úprav v prohlížeči při každém otevření nějakého souboru webu Adobe Muse.

    Pokud nevyberete možnost Ukládání pověřovacích údajů, zobrazí se při synchronizaci s živou verzí okno FTP. Může to také způsobit selhání synchronizace.

    Metoda

    Zadejte metodu protokolu pro přenos souboru:
    • Automatická detekce: Aplikace Adobe Muse automaticky zjistí způsob nejbezpečnějšího publikování dostupný pro vašeho poskytovatele hostingu.
    • FTP
    • SFTP
    • FTP přes SSL/TLS (implicitní šifrování)
    • FTP přes SSL/TLS (explicitní šifrování)

    Režim

    Zadejte režim protokolu pro přenos souboru: Rozšířený pasivní (EPSV) nebo Pasivní (PASV).

    Do jednotlivých polí zadejte pověřovací údaje pro váš hostingový účet
    Do jednotlivých polí zadejte pověřovací údaje pro váš hostingový účet.

  3. V dialogu Odeslat do hostitele FTP zadejte následující informace:

    • Adresa URL webu: Adresu URL vašeho webu. Tj. adresa zadávaná do prohlížeče pro přechod na domovskou stránku vašeho webu (např. www.vášweb.com). Neuvádějte název stránky index.html.
    • Složka na serveru: Webový adresář poskytnutý poskytovatelem hostingu. Název složky nebo cesta závisejí na poskytovateli hostingu. Většina platforem obecně používá složku public_html. Složka ale závisí na cestě ke kořenové složce nebo podsložce vašeho serveru. Toto pole může být předem vyplněné. V tomto případě zkontrolujte, jestli obsah pole Složka odpovídá informacím dodaným vaším poskytovatelem hostingu.
    • Odeslat: Rozbalovací nabídka umožňující výběr, jestli chcete odeslat všechny stránky svého webu nebo pouze upravené stránky. Při prvním odeslání souborů musíte vybrat možnost Odeslat všechny stránky.
    Zadejte název domény svého webu
    Zadejte název domény svého webu
  4. Kliknutím na tlačítko OK zahájíte odesílání webu do poskytovatele webhostingu třetí strany. 

    Okamžitě se zobrazí průběh odesílání.

    Průběh odeslání do FTP v aplikaci Adobe Muse
    Průběh odeslání do FTP

Pokud se zobrazí varování, že aplikace Adobe Muse nemůže ověřit asociaci mezi zadanou doménou a serverem FTP a složkou, zkontrolujte hodnoty zadané do těchto polí. Toto varování se ale může zobrazit i v případě, že jste svůj hostingový účet právě vytvořili a doména ještě nebyla zaregistrována. V takovém případě můžete toto varování ignorovat.

Aplikace Adobe Muse zahájí generování a odesílání souborů webu do serveru FTP. Po dokončení tohoto procesu zobrazí aplikace Adobe Muse zprávu o dokončení odesílání. Publikovaný web se automaticky otevře v novém okně prohlížeče.

Dialogové okno označující úspěšné odeslání do FTP v aplikaci Adobe Muse
Dialogové okno označující úspěšné odeslání do FTP

Používání externího klienta FTP

Někteří poskytovatelé hostingu vyžadují, abyste při odesílání webů používali FTPS a SFTP. Od aktualizace z října 2014 podporuje funkce FTP zabudovaná do aplikace Adobe Muse FTPS nebo SFTP.

Případně můžete k odeslání webů pomocí FTPS nebo SFTP použít klienty FTP třetích stran. K dispozici máte mnoho klientů FTP (bezplatných i placených). Následující stručný seznam obsahuje několik populárních klientů FTP:

Používání externího klienta FTP je proces o dvou krocích. Nejprve musíte exportovat web Adobe Muse do nějakého umístění ve svém počítači. Potom použijete externího klienta FTP k odeslání exportovaných souborů webu.
 
Následující odstavce podrobněji popisují tyto dva kroky.

Export webu ve formátu HTML

Až budete připraveni publikovat web vytvořený v aplikaci Adobe Muse, exportujte tento web ve formátu HTML. Po exportu do formátu HTML se nebudou vykreslovat některé prvky stránky vyžadující živé připojení. Například obsah iframe s absolutními adresami URL, který lze vložit pomocí nabídky Objekt > Vložit HTML.

  1. Zvolte příkaz Soubor > Exportovat jako HTML.

  2. Do zobrazeného pole zadejte název domény. Jedná se o adresu URL vašeho webu, tj. adresu zadávanou do prohlížeče pro přechod na domovskou stránku vašeho webu (například www.vášweb.com). Neuvádějte název stránky index.html.

    Zvolte požadovanou složku, do které chcete uložit exportované soubory
    Zvolte požadovanou složku, do které chcete uložit exportované soubory.

  3. Klikněte na ikonu složky a procházením vyberte složku ve svém počítači, do které chcete exportovat soubory webu. Klikněte na tlačítko OK.

    Přejmenujte soubor index.html na index.htm.

Odeslání souborů webu pomocí aplikace FileZilla

Před odesláním webu si připravte informace o serveru FTP, portu, uživatelském jménu FTP a heslu. Musíte také znát cílovou složku, do které chcete svůj web umístit.

I když jsou níže uvedené kroky specifické pro aplikaci FileZilla, lze je přizpůsobit i pro ostatní klienty FTP.

  1. V horní části zadejte své pověřovací údaje FTP a klikněte na tlačítko Quickconnect. Pokud váš poskytovatel hostingu používá jiný port než výchozí port (21), zadejte také číslo portu.

    Připojení k serveru FTP pomocí aplikace FileZilla
    Připojení k serveru FTP pomocí aplikace FileZilla

  2. Po připojení přejděte na levém panelu (pod textem Local Site) do složky, do které jste exportovali soubory svého webu. Na pravém panelu (pod textem Remote Site) přejděte do webového adresáře.

  3. Vyberte všechny exportované soubory webu (na levém spodním panelu) a přetáhněte je do pravého spodního panelu.

    Pokud se zobrazí zpráva „target file already exists“ (cílový soubor již existuje), zvolte možnost „Overwrite if source newer“ (Přepsat, pokud je zdroj novější). Můžete také zaškrtnout políčko „Always use this action“ (Vždy použít tuto akci).

    Odesílání do serveru FTP pomocí aplikace FileZilla
    Odesílání do serveru FTP pomocí aplikace FileZilla

Časté dotazy

Zkuste svůj web odeslat pomocí bezplatného klienta FTP, jako je například FileZilla.

Chyba 530 se zobrazí v případě problému s přístupem. Při řešení této chyby postupujte následovně:

  • Ověřte správnost zadaných přihlašovacích údajů FTP.
  • Pokud jsou přihlašovací údaje v pořádku, zkuste odeslat soubory pomocí nástroje třetí strany, například FileZilla. Pokud se vám podaří soubory úspěšně odeslat, požádejte svého poskytovatele hostingu o dodání správných přihlašovacích údajů.
  • Zkontrolujte, jestli máte oprávnění pro přístup k aktualizaci souboru .htaccess v hostingu.
  • Ověřte, jestli jste v dialogu Připojit k serveru FTP zvolili jako režim FTP možnost PASV (Soubor > Odeslat do hostitele FTP).

Chyby 553 a 550 jsou dvě různé chyby týkající se ochrany souboru .htaccess před aktualizací. Tyto chyby se zobrazí v případě, že nelze aktualizovat soubor .htaccess. Chcete-li tento problém vyřešit, obraťte se na svého poskytovatele služeb.

Jako alternativní postup můžete použít příkaz Soubor > Odeslat do hostitele FTP, a poté soubory odeslat na server pomocí externího klientu FTP.

Zavolejte poskytovatele hostingu a ověřte, jestli máte správné přihlašovací údaje. Pokud se po ověření a zadání přihlašovacích údajů tato chyba zobrazí znovu, můžete ji buď ignorovat, nebo opravit. Pokud budete chybu ignorovat, bude sice možné odeslat soubory do hostitele FTP, ale k webu nebude možné přistupovat. Z tohoto důvodu doporučujeme tuto chybu nejprve vyřešit.

Pokud se tato chyba zobrazí při odesílání do FTP, znamená to, že vaše doména neukazuje na správnou složku. V dialogu pro odeslání do FTP zkontrolujte, jestli je údaj v poli Název domény správný. Zadaný název domény se musí shodovat s adresou URL domovské stránky vašeho webu. 

Musíte rovněž zajistit, aby zadaný název domény ukazoval na kořenovou složku (například public_html), do které jsou, nebo po dokončení odesílání budou, odeslané vaše soubory. Pokud nahrajete web do podřízené složky vaší domény, musí mít název domény formát <mujweb.cz/podsložka>.

Po ověření a opravení případných nepřesností se pokuste odeslání zopakovat. Pokud se bude tato chyba zobrazovat i nadále, obraťte se na poskytovatele hostingu a ověřte, jestli jsou správně nakonfigurovány název domény, oprávněný server a další nastavení, včetně portů.

Kdykoli dojde k otevření webu pomocí nově aktualizované aplikace Adobe Muse, dojde nejprve k regenerování funkce Publikovat/Exportovat/Odeslat a k odeslání všech souborů. Důvodem je, že aktualizace pravděpodobně vyvolala změny ve vygenerovaném kódu a souborech.

Mezi změny patří:

  • Opravy chyb, nové funkce nebo vylepšení výkonu v souborech HTML/CSS/JavaScript
  • Změny v pojmenování souborů (jaké názvy souborů jsou vhodné pro web, přiřazování jedinečných názvů konfliktním souborům, atd.)
  • Opravy chyb nebo vylepšení změny velikosti obrazů (převzorkování) nebo kódování (komprese formátu JPEG nebo PNG)
  • Změny v generování kódu eliminující potřebu obrazů (tj. převod většiny použití vrženého stínu z obrazů generovaných aplikací Muse na vlastnosti CSS3 nebo totéž pro otáčení položek na mobilních zařízeních, atd.)

Po prvním publikování by při následných operacích publikování/exportu/odeslání stejného souboru .muse mělo opět proběhnout odeslání pouze změněných souborů (za předpokladu, že soubor .muse byl uložen po otevření v aktualizaci).

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online