Learn how to create, move, modify, convert, rename, and edit catalogs in Adobe Elements Organizer.

About catalogs

A catalog is a file in which Elements Organizer maintains information about imported media. When you import media, basic info such as filename and location are updated in the file. As you keep working on the file in Elements Organizer, the file is further updated to reflect those changes.

When you move your media files along with the catalog to another computer or another version of Elements Organizer, all that information is retained. For more information about moving catalog from one computer to another, see Backup or restore catalogs.

The catalog file contains the following information:

  • The path and name of the media file.

  • The path and filename of any associated audio file.

  • The path, filename, and volume name of the original, full-resolution file (if the original file is stored offline on a CD or DVD).

  • The path and filename of the original, unedited file (if the file has been edited).

  • The name of any camera or scanner associated with the batch of imported media files.

  • Captions you’ve added to a media file.

  • Notes you’ve added to a media file.

  • The media type—that is, whether it’s a photo, video files, audio clip, or project.

  • The date and time the media file was created and whether its date is completely or only partially known.

  • Keyword tags that have been applied to the media file.

  • Albums in which the media file is included.

  • The media file’s history: whether it is printed on a local printer, exported, shared over e‑mail or online, sent to online photo-finishing services. The history also shows whether the media file was received from an online source, and what batch it was imported in (including import date and time).

  • Edits that have been applied to the media file (such as rotation, cropping, and fixing red eye).

  • The pixel dimensions of any photos and video files.

  • Project settings (project type, whether captions are displayed, showing page numbers, and so on).

  • Metadata including pixel dimensions, EXIF, copyright, IPTC information, and file format information.

Create a catalog

When you import media into Photoshop Elements, they are added to a default catalog. If you choose to use this default catalog file for all your media, you do not have to do anything else.

However, there are times when you want to create multiple catalogs. For example, you want to create separate catalogs for photos of your workplace and photos of your family.

  1. Do one of the following:

    • Select File > Manage Catalogs.
    • Press Ctrl+Shift+C (Windows) or Command+Shift+C (Mac OS).
    Catalog manager
    Catalog Manager (Windows OS)
  2. Do one of the following:

    • To choose a preset location for the catalog, select Catalogs Accessible By All Users (Windows only) or Catalogs Accessible By The Current User.

    Note:

    The Catalog Accessible by All Users and Catalog Accessible by the Current User options are not available in the Windows Application Store version of Photoshop Elements.
    The Windows Application Store version has only two options—Default Catalog Location and Custom Location.

    • To select a custom location, choose Custom Location, and click Browse. Browse to the location on your computer for the catalog file.
  3. Click New.

  4. Type a name for the catalog in the Enter a Name for the New Catalog dialog box.

  5. Click OK.

Locating the catalog file

 

To view the location of the catalog file, click Help > System Info.

The location of the catalog file currently open on your computer is listed under Current Catalog >Catalog Location.

 

System info

Open a catalog

  1. Do one of the following:

    • Select File > Manage Catalogs.
    • Press Ctrl+Shift+C (Windows) or Command+Shift+C (Mac OS).
    Catalog manager
    Catalog Manager (Windows OS)
  2. Select the catalog from the list in the Catalog Manager dialog box.
  3. Click Open.

    Note:

    (Mac OS) You cannot access catalogs on a shared network.

Moving or modifying media files

Because Elements Organizer contains references to files, avoid moving or modifying them outside of the software. If you move or alter the file outside of Elements Organizer, you are prompted to reconnect to the file. For more information about reconnecting the missing files, see Reconnect missing files in a catalog.

Use the following suggestions to move or modify files associated with a catalog.

Moving files

Move the files in your catalog with the Move command.

  1. Select media files in the Media view.

  2. Do one of the following:

    • Select File > Move.
    • Press Ctrl+Shift+V (Windows) or Command+Shift+V (Mac OS).
  3. Click Browse and select a new location for the media files.

  4. Click OK.

Note:

You cannot copy or move media files from one catalog to another catalog.

Renaming files

Rename the files in your catalog with the Rename command. You can use this command to rename multiple photos with a common base name.

  1. Select media files in the Media view.

  2. Do one of the following:

    • Select File > Rename.
    • Press Ctrl+Shift+N (Windows) or Command+Shift+N (Mac OS).
  3. Do one of the following:

    • If you have selected one media file, enter the new name for the media file and click OK.
    • If you have selected multiple media files, enter a common base name for the media files and click OK. For example, if you have selected five photos and the common base name is Birthday, the photos are renamed as Birthday-1, Birthday-2, Birthday-3, and so on.

Deleting files

Always remove the media files from the catalog using Delete from Catalog. If you’ve deleted a media file from your computer, it still appears in the Media view with missing icon. 

To remove a media file from your catalog, select the media file and press Delete button or click Edit > Delete from Catalog. You can choose if you want to remove the media file only from the catalog or from the hard disk too.

Editing files

You can launch Photoshop Elements or Adobe Premiere Elements from Elements Organizer to edit your media files. 

To edit the media file, select Edit > Edit with [Application name] command. For example, Edit with Photoshop Elements Editor.

Using this command also allows you to change the filename and file type (for example, from BMP to JPEG) without causing a missing file error. If necessary, update the thumbnails when you’re finished editing.

  1. Do one of the following:

    • (Windows) Select Edit > Preferences > Editing.
    • (Mac OS) Select Elements OrganizerPreferences Editing.
  2. Select from the following available options:

    • Use a Supplementary Editing Application: Select this option to choose any other application for editing.
    • Show Photoshop Elements Editor options only: Select this option to choose Photoshop Elements as editing application.
    • Show Premiere Elements Editor options only: Select this option to choose Premiere Elements as editing application.
    • Show options for both Editors: Select this option to choose Photoshop Elements and Premiere Elements as editing application.

     

  3. Click OK.

Use (convert) a catalog of a previous version

When you open Elements Organizer for the first time after installation, you are prompted to convert catalogs from previous versions. When you click Yes, catalogs from the previous version are converted and renamed.

If you have not converted catalogs earlier, use the following procedure to convert catalogs from previous versions.

Note:

Adobe recommends that you take a backup of your previous catalog. For more information about backup, see Backup or restore catalogs.

  1. In the latest version of Elements Organizer, do one of the following:

    • Select File > Manage Catalogs.
    • Press Ctrl+Shift+C (Windows) or Command+Shift+C (Mac OS).
    Catalog manager
    Catalog Manager (Windows OS)
  2. Click Convert.

  3. Select the catalog from the list that is displayed.

  4. Click Done.

Notes for users upgrading their catalogs to Photoshop Elements

Enhancements to the user interface and changes to supported file formats need changes to the catalog conversion process as well. The following table helps you upgrade your catalog smoothly to Photoshop Elements.

Item

Post migration to Photoshop Elements

People tags

You can locate photos with People tags in the People panel of the Media view, or in the People view. Generic icons are used for People tags.

To view the People panel in the Media view, select View > People Recognition.

Photos in sub categories are moved to the Groups section of the People view. In the People view, click the People > Group slider to view them.

Events tag

Renamed to Events (Tags)

Places tag

Renamed to Places (Tags)

Smart Albums

You can locate Smart Albums under Saved Searches.

Unsupported file formats

The following file formats are skipped during file conversion: PDF, Filmstrip (FLM), Wireless BMP (WBM, WBMP), PCX, Targa (TGA, VDA, ICB, VST), Photoshop RAW (RAW), PICT File, PCT, PICT), Scitex CT (SCT), Photoshop EPS (EPS), EPS TIFF Preview (EPS), Generic EPS (AI3, AI4, AI5, AI6, AI7, AI8, PS, EPS.AI, EPSF, EPSP, .amr

Unsupported album templates

Default album template is used for the online album.

Rename a catalog

  1. Close Photoshop Elements Editor and Adobe Premiere Elements.
  2. In Elements Organizer, do one of the following:

    • Select File > Manage Catalogs.
    • Press Ctrl+Shift+C (Windows) or Command+Shift+C (Mac OS).
    Catalog manager
    Catalog Manager (Windows OS)
  3. In Elements Organizer, select File > Manage Catalogs.

  4. In the Catalog Manager dialog box, select the name of a catalog from the list.
  5. Click Rename

  6. Type the new name, and click OK.

Delete a catalog

You can delete a catalog only if there is more than one catalog associated with Elements Organizer. If you have one catalog and want to delete it, create another catalog before you proceed to delete the current catalog.

  1. Close Photoshop Elements Editor and Adobe Premiere Elements.
  2. In Elements organizer, do one of the following:

    • Select File > Manage Catalogs.
    • Press Ctrl+Shift+C (Windows) or Command+Shift+C (Mac OS).
    Catalog manager
    Catalog Manager (Windows OS)
  3. Ensure that more than one catalog is listed in the Catalog Manager dialog box. Create a catalog if necessary. For more information, see Create a catalog.

  4. In the Catalog Manager dialog box, select the catalog that you want to remove.

  5. Click Remove and then click Yes.

Optimize catalog size

Optimizing a catalog helps reduce its size. Therefore, the time taken to open and work with files in a catalog is reduced.

  1. Close Photoshop Elements Editor and Adobe Premiere Elements.
  2. In Elements Organizer, do one of the following:

    • Select File > Manage Catalogs.
    • Press Ctrl+Shift+C (Windows) or Command+Shift+C (Mac OS).
    Catalog manager
    Catalog Manager (Windows OS)
  3. In the Catalog Manager, select the catalog you want to optimize.
  4. Click Optimize.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy