Acerca de los archivos de Animate

En Animate, puede trabajar con distintos tipos de archivos, según la finalidad de cada uno:

  • Los archivos FLA, los principales en Animate, contienen la información básica de medios, línea de tiempo y scripts de un documento de Animate. Los objetos multimedia son los objetos gráficos, de texto, de sonido y vídeo que conforman el contenido del documento de Animate. La línea de tiempo permite indicar a Animate cuándo deben aparecer objetos multimedia específicos en el escenario. Se puede añadir código ActionScript® a documentos de Animate para controlar mejor su comportamiento y conseguir que respondan a las acciones del usuario.

  • Los archivos XFL sin comprimir son parecidos a los archivos FLA. Un archivo XFL (y el resto de archivos asociados dentro de la misma carpeta) simplemente son el equivalente sin comprimir de un archivo FLA. Este formato facilita a los grupos de usuarios trabajar en distintos elementos de un proyecto de Animate al mismo tiempo. Para obtener más información, consulte Trabajo con archivos XFL sin comprimir.

  • Los archivos SWF, las versiones compiladas de los archivos FLA, son los archivos que se visualizan en una página web. Cuando se publica un archivo FLA, Animate crea un archivo SWF.

    El formato SWF de Animate es un estándar abierto que admiten otras aplicaciones. Para obtener más información sobre los formatos de archivo de Animate, consulte www.adobe.com/go/flashplayer_es.

  • Los archivos AS son archivos de ActionScript: se pueden utilizar para mantener una parte o la totalidad del código ActionScript fuera de los archivos FLA, lo que resulta de gran utilidad para la organización del código y en los proyectos en los que colaboran distintas personas en distintas partes del contenido de Animate.

  • Los archivos SWC contienen los componentes reutilizables de Animate. Cada archivo SWC incluye un clip de película compilado, código ActionScript y cualquier otro activo que requiera el componente. Nota: Los archivos SWC no se pueden importar en Animate.
  • Los archivos ASC se utilizan para almacenar código ActionScript que se ejecutará en un equipo con Adobe Media Server. Estos archivos ofrecen la capacidad de implementar lógica del servidor que funciona en combinación con ActionScript en un archivo SWF. Nota: Los archivos ASC no se admiten en Animate CC.
  • Los archivos JSFL son archivos JavaScript que se pueden utilizar para añadir nuevas funciones a la herramienta de edición de Animate.
  • Los archivos APR permiten empaquetar la plantilla de publicación de Canvas junto con su correspondiente configuración de perfil de publicación. Es más, también se empaquetan y comparten todos los nuevos activos vinculados a un perfil de publicación. Para obtener más información, consulte Configuración de publicación.

 

 

¿Qué es Animate CC?

¿Qué es Animate CC?
Adobe

Los siguientes vídeos y tutoriales adicionales muestran el trabajo con Animate/Flash Pro. Algunos vídeos pueden ser de Flash CS3 o CS4, pero siguen siendo útiles en Flash Pro CS5.

Utilización con otras aplicaciones de Adobe

Animate se puede utilizar con otras aplicaciones de Adobe® con el fin de proporcionar una amplia gama de flujos de trabajo creativos. Los archivos de Illustrator® y Photoshop® se pueden importar directamente a Animate. También se puede crear vídeo en Animate y editarlo en Adobe® Premiere® Pro o After Effects®, o importar vídeo de cualquiera de estas aplicaciones a Animate. Al publicar archivos SWF, se puede utilizar Dreamweaver® para incorporar dicho contenido a las páginas Web e iniciar Animate directamente desde Dreamweaver para editarlo.

Apertura de archivos XFL

Comenzando con Animate CC, XFL es el formato interno de los archivos FLA que se crean. Cuando se guarda un archivo en Animate, el formato predeterminado es FLA, pero el formato interno del archivo es XFL.

Otras aplicaciones de Adobe® como, por ejemplo, After Effects® pueden exportar archivos en formato XFL. Estos archivos tienen la extensión XFL en lugar de FLA. InDesign® puede exportar directamente en formato FLA, que internamente es XFL. Esto permite al usuario trabajar en un proyecto en After Effects o InDesign en primer lugar y seguir trabajando con él después en Animate.

Puede abrir archivos XFL y trabajar con ellos en Animate del mismo modo que con los archivos FLA. Cuando abre un archivo XFL en Animate, puede guardarlo posteriormente como un archivo FLA o como un archivo XFL sin comprimir.

En los siguientes tutoriales de vídeo se muestra la exportación desde InDesign y AfterEffects a Animate mediante XFL y FLA:

Para abrir un archivo XFL en Animate:

  1. En otra aplicación de Adobe®, como InDesign o After Effects, exporte su trabajo como archivo XFL.

    La aplicación conserva todas las capas y los objetos del archivo original en el archivo XFL.

  2. En Animate, seleccione Archivo > Abrir y busque el archivo XFL. Haga clic en Abrir.

    El archivo XFL se abre en Animate del mismo modo que lo haría un archivo FLA. Todas las capas del archivo original se muestran en la línea de tiempo y los objetos originales aparecen en el panel Biblioteca.

    Ahora puede seguir trabajando con el archivo normalmente.

  3. Para guardar el archivo, seleccione Archivo > Guardar.

    Animate indica que asigne un nombre al nuevo archivo FLA en el cuadro de diálogo Guardar como.

  4. Indique un nombre y guarde el archivo FLA.

Trabajo con archivos XFL sin comprimir

Si se comienza con Animate CC, se puede optar por trabajar con archivos de Animate en formato XFL sin comprimir. Este formato permite ver cada una de las partes independientes, o archivos secundarios, que conforman el archivo de Animate. Estas partes incluyen:

  • Un archivo XML que describe el archivo Animate en su totalidad.

  • Archivos XML independientes que describen todos los símbolos de biblioteca.

  • Archivos XML adicionales que contienen valores de configuración de publicación, valores configuración móvil, etc.

  • Carpetas que contienen activos externos, como archivos de mapa de bits, utilizados por el archivo de Animate.

Trabajando con el formato XFL sin comprimir, se puede permitir que cada parte del archivo de Animate se trabaje de forma independiente por parte de usuarios diferentes. También se puede utilizar un sistema de control de origen para administrar los cambios realizados en cada archivo secundario del archivo XFL sin comprimir. Asimismo, estas capacidades permiten una colaboración mucho más sencilla en proyectos de mayor tamaño en los que intervienen varios diseñadores y desarrolladores.

Uso de la actualización activa con archivos XFL

Con la actualización activa de los activos editables para documentos XFL sin comprimir, es posible editar un activo de biblioteca desde un documento XFL sin comprimir mientras que el documento está abierto en Animate. Los cambios realizados en el activo se reflejan en Animate cuando la edición del activo finaliza en otra aplicación.

Para editar un activo desde un documento XFL sin comprimir en otra aplicación:

  1. Guarde un documento de Animate en formato XFL sin comprimir.

  2. En un editor adecuado, como Photoshop, abra el activo que desee editar en la carpeta LIBRARY del documento XFL sin comprimir.

  3. Edite el activo y guarde los cambios.

  4. Vuelva a Animate.

    La actualización del activo se refleja en Animate de forma inmediata.

Editar un archivo SWF desde Dreamweaver en Animate 

Si tiene Animate y Dreamweaver instalados, puede seleccionar un archivo SWF en un documento de Dreamweaver y utilizar Animate para editarlo. Animate no edita el archivo SWF directamente, sino que edita el documento de origen (el archivo FLA) y, a continuación, vuelve a exportar el archivo SWF.

  1. En Dreamweaver, abra el inspector de propiedades (Ventana > Propiedades).
  2. En el documento de Dreamweaver, siga uno de estos procedimientos:
    • Haga clic en el marcador de posición del archivo SWF para seleccionarlo y, a continuación, en el inspector de propiedades, haga clic en Editar.

    • Haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el marcador de posición del archivo SWF y seleccione Editar con Animate en el menú contextual.

      Dreamweaver cambia el enfoque a Animate y Animate intenta localizar el archivo de creación Animate (FLA) correspondiente al archivo SWF seleccionado. Si Animate no encontrase el archivo de creación Animate, le solicitaría que indicase su ubicación.

      Nota: Si el archivo FLA o el archivo SWF están bloqueados, desproteja el archivo en Dreamweaver.

  3. En Animate, edite el archivo FLA. La ventana de documento de Animate indicará que está modificando el archivo desde Dreamweaver.

  4. Cuando haya terminado de hacer cambios, haga clic en Listo.

    Animate actualiza el archivo FLA, vuelve a exportarlo como archivo SWF, se cierra y devuelve el enfoque al documento de Dreamweaver.

    Nota:

    Para actualizar el archivo SWF y mantener Animate abierto, en Animate seleccione Archivo > Actualizar para Dreamweaver.

  5. Para ver el archivo actualizado en el documento, haga clic en Reproducir en el inspector de propiedades de Dreamweaver o pulse F12 para realizar una previsualización de su página en una ventana de navegador.
  1. Inicie Animate.

  2. En la pantalla principal de Animate, seleccione Crear nuevo > Archivo de Animate (móvil).

  3. En Device Central, seleccione una versión del reproductor y una versión de ActionScript.
  4. Seleccione un tipo de contenido.
  5. En la lista de dispositivos disponibles, seleccione un único dispositivo de destino o varios dispositivos (o bien seleccione un grupo de dispositivos o un dispositivo único en la lista Conjuntos de dispositivos).
  6. Haga clic en Crear.
  7. Añada contenido al nuevo documento de Animate.

  8. Para probar el documento, seleccione Control > Probar.

Creación de un documento nuevo

Puede crear un documento nuevo o abrir uno que se haya guardado anteriormente en Animate, y puede abrir una ventana nueva mientras trabaja. Puede definir las propiedades para documentos nuevos o existentes.

Creación de un documento nuevo

  1. Seleccione Archivo > Nuevo.
  2. En la ficha General, seleccione el tipo de documento de Animate que quiera crear.

  3. Realice uno de los siguientes pasos:

Creación de un documento nuevo utilizando una plantilla

  1. Seleccione Archivo > Nuevo.
  2. Haga clic en la ficha Plantillas.
  3. Seleccione una categoría de la lista Categoría, elija un documento de la lista Elementos de la categoría y haga clic en Aceptar. Puede elegir plantillas estándar que incluye Animate o una plantilla que ya haya guardado.

Apertura de un documento existente

  1. Seleccione Archivo > Abrir.
  2. En el cuadro de diálogo Abrir, busque el archivo o introduzca la ruta del mismo en el cuadro de texto Ir a.
  3. Haga clic en Abrir.

Visualización de un documento cuando hay varios documentos abiertos

Cuando se abren varios documentos, las fichas situadas en la parte superior de la ventana Documento identifican los documentos abiertos y permiten cambiar de documento fácilmente. Las fichas solo se muestran cuando los documentos están maximizados en la ventana Documento.

  • Haga clic en la ficha del documento que desea visualizar.

    De forma predeterminada, las fichas se muestran en el orden de creación de los documentos. Las fichas del documento se pueden arrastrar para cambiarlas de posición.

Apertura de una nueva ventana para el documento actual

  • Seleccione Ventana > Duplicar ventana.

Definición de propiedades para un documento nuevo o existente

  1. Con el documento abierto, seleccione Modificar > Documento.

    Aparecerá el cuadro de diálogo Configuración del documento.

  2. Para configurar las dimensiones del escenario, haga lo siguiente:
    • Para especificar el tamaño del escenario en píxeles, introduzca los valores en los cuadros de texto Anchura y Altura. El tamaño mínimo es de 1 x 1 píxel; el tamaño máximo es de 2.880 x 2.880 píxeles.

    • Para hacer coincidir el tamaño del escenario con la cantidad exacta de espacio utilizada por el contenido del escenario, seleccione la opción Coincidir contenido.

    • Para establecer el tamaño del escenario en el área de impresión máxima disponible, seleccione Coincidir impresora. Esta área queda determinada por el tamaño del papel menos los márgenes seleccionados en el área Márgenes del cuadro de diálogo Configurar página (Windows) o del cuadro de diálogo Márgenes de impresión (Macintosh).

    • Para establecer el tamaño del escenario en su tamaño predeterminado (550 x 400 píxeles), seleccione Coincidir predeterminado.

  3. Para ajustar la posición y la orientación de objetos 3D en el escenario y mantener su aspecto relativo a los bordes del escenario, seleccione Ajustar ángulo de perspectiva 3D para conservar proyección actual del escenario.

    Esta opción solo está disponible si se cambia el tamaño del escenario.

  4. (Sólo CS5.5) Para escalar automáticamente el contenido del escenario relativo al cambio en el tamaño del escenario, seleccione Escalar contenido con escenario.

    Esta opción solo está disponible si se cambia el tamaño del escenario. Puede elegir escalar contenido en capas bloqueadas y ocultas en las preferencias. Para obtener más información, consulte Preferencias generales.

  5. Para especificar la unidad de medida de las reglas que aparecen en el área de trabajo, seleccione una opción en el menú Unidades de regla. (Esta opción determina también las unidades que se van a utilizar en el panel Información.)
  6. Para establecer el color de fondo del documento, haga clic en el control Color de fondo y seleccione un color de la paleta.
  7. En la sección Velocidad de fotogramas, introduzca el número de fotogramas de animación que deben mostrarse cada segundo.

    Para la mayoría de las animaciones que se muestran en los equipos, especialmente las que se reproducen desde un sitio web, basta con una velocidad de entre 8 fotogramas por segundo (fps) y 15 fps. Cuando se cambia la velocidad de fotogramas, la nueva velocidad pasa a ser el valor predeterminado para los documentos nuevos.

  8. (Solo CS5.5) Para guardar automáticamente el documento en intervalos de tiempo concretos, seleccione la opción de guardado automático y especifique el número de minutos que quiere que transcurran entre cada operación de guardado.
  9. Realice uno de los siguientes pasos:
    • Para aplicar la nueva configuración solo al documento activo, haga clic en Aceptar.

    • Para hacer que los valores nuevos sean las propiedades predeterminadas de todos los documentos nuevos, haga clic en Establecer como valor predeterminado.

Cambio de propiedades de documentos mediante el inspector de propiedades

  1. Haga clic en el área de trabajo fuera del escenario para anular la selección de todos los objetos del escenario. Las propiedades del documento se muestran en el inspector de propiedades. Para abrir el inspector de propiedades, seleccione (Ventana > Propiedades).
  2. (Sólo CS5.5) En la sección de publicación, seleccione una versión de Flash Player y una versión de ActionScript para su documento. Para acceder a ajustes adicionales de publicación, haga clic en el botón Configuración de publicación. Para obtener más información, consulte Configuración de publicación.

  3. En la sección Propiedades, en FPS (fotogramas por segundo), introduzca el número de fotogramas de animación que se reproducirán cada segundo.
  4. Para cambiar el tamaño del escenario, introduzca valores para la anchura y la altura del escenario.
  5. Para seleccionar un color de fondo para el escenario, haga clic en la paleta de colores situada junto a la propiedad Stage y seleccione un color.
  6. Para editar las propiedades adicionales del documento, haga clic en el botón Editar situado junto a las propiedades de tamaño. Para obtener más información sobre todas las propiedades del documento, consulte Definición de propiedades para un documento nuevo o existente.

Cómo añadir metadatos XMP a un documento

Es posible incluir datos XMP (Extensible Metadata Platform) en los archivos FLA, tales como el título, el autor, la descripción, los derechos de autor, etc. XMP es un formato de metadatos que pueden identificar otras aplicaciones de Adobe®. Los metadatos se pueden ver en Animate y en Adobe® Bridge. Para obtener más información sobre metadatos XMP, consulte Metadata and Keywords (Metadatos y palabras clave) en la ayuda de Bridge.

Nota: No se admite Bridge de 32 bits en Adobe Animate CC.

La incorporación de metadatos facilita a los motores de búsqueda basados en la web la devolución de resultados comprensibles para el contenido de Animate. Los metadatos de búsqueda se basan en XMP (Extensible Metadata Platform) y se almacenan en el archivo FLA con un formato compatible con W3C.

Los metadatos de un archivo contienen información sobre el contenido, estado de los derechos de autor, origen e historial del archivo. En el cuadro de diálogo Información de archivo, puede ver y editar los metadatos para el archivo actual.

Dependiendo del archivo seleccionado, pueden aparecer los siguientes tipos de metadatos:

Descripción

Contiene autor, título, derechos de autor y otra información.

IPTC

Muestra los metadatos modificables. Puede añadir rótulos a los archivos, así como información de derechos de autor. IPTC Core es una especificación que fue aprobada por el Consejo internacional de telecomunicaciones de prensa (IPTC, International Press Telecommunications Council) en octubre de 2004. Difiere del antiguo IPTC (IIM) en que se añadieron nuevas propiedades, se modificaron algunos nombres de propiedades y se eliminaron algunas de ellas.

Datos de cámara (Exif)

Muestra información asignada mediante cámaras digitales, incluyendo la configuración de cámara utilizada cuando se tomó la imagen.

Datos de vídeo

Muestra metadatos para archivos de vídeo, incluyendo proporción de aspecto de píxeles, escena y toma.

Datos de audio

Muestra metadatos para archivos de audio, incluyendo artista, álbum, número de pista y género.

SWF móvil

Incluye información sobre archivos SWF, incluyendo título, autor, descripción y derechos de autor.

Historial

Conserva un registro de los cambios realizados en las imágenes con Photoshop.

Nota: se debe activar en Photoshop la preferencia de registro de historial para que el registro se guarde con los metadatos del archivo.

Version Cue

Incluye cualquier información de la versión de archivo de la referencia de versión.

DICOM

Muestra información sobre las imágenes guardadas en formato DICOM (Digital Imaging and Communications in Medicine).

Para agregar metadatos:

  1. Elija Archivo > Información de archivo.
  2. En el cuadro de diálogo Información de archivo que aparece, introduzca los metadatos que desee incluir. Se puede agregar o quitar metadatos del archivo FLA en cualquier momento.

Guardar documentos de Animate

Puede guardar un documento FLA de Animate con su nombre y ubicación actuales, o bien utilizar un nombre o una ubicación diferentes.

Si un documento contiene cambios sin guardar, aparece un asterisco (*) detrás del nombre del documento en la barra de título del documento, la barra de título de la aplicación y la ficha del documento. El asterisco se quita al guardar el documento.

Guardar un documento de Animate en el formato FLA predeterminado

  1. Realice uno de los siguientes pasos:
    • Para sobrescribir la versión actual existente en el disco, seleccione Archivo > Guardar.

    • Para guardar el documento en una ubicación distinta o con otro nombre, o para comprimir el documento, seleccione Archivo > Guardar como.

  2. Si ha seleccionado Guardar como o si el documento no se ha guardado nunca, introduzca el nombre y la ubicación del archivo.
  3. Haga clic en Guardar.

Almacenamiento de un documento en formato XFL sin comprimir

  1. Elija Archivo > Guardar como.
  2. En el menú Guardar como tipo, elija Documento de Animate CC no comprimido (*xfl).

  3. Seleccione un nombre y la ubicación del archivo y haga clic en Guardar.

Recuperación de la última versión guardada de un documento

  • Seleccione Archivo > Descartar cambios.

Almacenamiento de un documento como una plantilla

  1. Seleccione Archivo > Guardar como plantilla.
  2. En el cuadro de diálogo Guardar como plantilla, escriba un nombre para la plantilla en el cuadro de texto Nombre.
  3. Seleccione una categoría en el menú emergente Categoría o escriba un nombre si desea crear una categoría nueva.
  4. Escriba una descripción de la plantilla en el cuadro de texto Descripción (255 caracteres como máximo) y haga clic en Aceptar.

    La descripción se muestra al seleccionar la plantilla en el cuadro de diálogo Nuevo documento.

    Para eliminar la plantilla guardada, acceda a una de las siguientes carpetas y elimine el archivo de plantilla FLA de la carpeta de la categoría que lo contenga.

    • Windows XP - C:\Documents and Settings\<nombreusuario>\Local Settings\Application Data\Adobe\Flash CS5\es_ES\Configuration\Templates\

    • Windows Vista and 7 - C:\Users\<nombreusuario>\AppData\Local\Adobe\Flash CS5\<idioma>\Configuration\Templates\

    • Mac OS - <HD>/Users/<nombreusuario>/Library/Application Support/Adobe/Flash CS5/<idioma>/Configuration/Templates/

Almacenamiento de un documento en formato Animate CC

  1. Seleccione Archivo > Guardar como.
  2. Introduzca el nombre y la ubicación del archivo.
  3. Seleccione Documento de Animate CC en el menú emergente Formato y haga clic en Guardar.

    Nota:

    Si aparece un mensaje de alerta que indica que se eliminará contenido si usa el formato Animate CC y desea continuar, haga clic en Guardar como Animate CC. Esto se puede producir cuando el documento contiene características que solo están disponibles en Animate CC. Animate no conserva estas características cuando se guarda el documento en Animate CC.

Almacenamiento de documentos al salir de Animate

  1. Seleccione Archivo > Salir (Windows) o Animate > Salir de Animate (Macintosh).

  2. Si tiene documentos abiertos con cambios sin guardar, Animate solicitará que guarde o descarte los cambios realizados en cada documento.

    • Haga clic en Sí para guardar los cambios y cerrar el documento.

    • Haga clic en No para cerrar el documento sin guardar los cambios.

Impresión de documentos de Animate (ya no se usa en Flash Professional CC)

Para previsualizar y editar sus documentos, imprima fotogramas de documentos de Adobe Animate o especifique los fotogramas que se podrán imprimir desde Flash Player con un visor.

Para imprimir los fotogramas de un documento de Animate, en el cuadro de diálogo Imprimir especifique el intervalo de escenas y fotogramas, así como el número de copias que desea imprimir. En Windows, el cuadro de diálogo Configurar página especifica el tamaño del papel, la orientación y otras opciones de impresión (como los márgenes o si se deben imprimir todos los fotogramas de cada página). En Macintosh, estas opciones se distribuyen entre los cuadros de diálogo Configurar página y Márgenes de impresión.

Los cuadros de diálogo Imprimir y Configurar página suelen ser estándar en los sistemas operativos y dependen del controlador de impresora seleccionado.

  1. Seleccione Archivo > Configurar página (Windows) o Archivo > Márgenes de impresión (Macintosh).
  2. Establezca los márgenes de la página. Seleccione ambas opciones en Centrar para imprimir el fotograma en el centro de la página.
  3. En el menú Fotogramas, seleccione si desea imprimir todos los fotogramas del documento o solo el primer fotograma de cada escena.
  4. En el menú Diseño, seleccione alguna de las opciones siguientes:

    Tamaño real

    Imprime el fotograma a tamaño completo. Introduzca un valor en Escala para reducir o aumentar el tamaño del fotograma impreso.

    Ajustar en una página

    Reduce o agranda cada fotograma para que llene el área de impresión de la página.

    Guión

    Imprime varias miniaturas en una página. Puede elegir entre Cuadros, Cuadrícula o Vacío. Introduzca el número de miniaturas por página en el cuadro Fotogramas. Establezca el espacio entre las miniaturas en el cuadro Margen de cuadro y seleccione Etiquetar fotogramas para imprimir las etiquetas de los fotogramas como una miniatura.

  5. Para imprimir fotogramas, seleccione Archivo > Imprimir.

Utilización de etiquetas de fotograma para desactivar la impresión

Si desea que no se imprima ningún fotograma de la línea de tiempo principal, etiquete un fotograma como !#p para que no se pueda imprimir ningún elemento del archivo SWF. Al etiquetar el fotograma como !p# se atenúa el comando Imprimir del menú contextual de Flash Player. También se puede eliminar el menú contextual de Flash Player.

Si se desactiva la impresión de Flash Player, el usuario igualmente podrá imprimir fotogramas mediante el comando Imprimir del navegador. Debido a que este comando es una función del navegador, no se puede controlar ni desactivar mediante Animate.

Desactivación de la impresión desde el menú contextual de Flash Player

  1. Abra o active el documento de Animate (archivo FLA) que desea publicar.

  2. Seleccione el primer fotograma clave de la línea de tiempo principal.
  3. Seleccione Ventana > Propiedades para ver el inspector de propiedades.
  4. En el inspector de propiedades, escriba !#p en Etiqueta de fotograma para especificar que el fotograma no se puede imprimir.

    Especifique solo una etiqueta !#p para atenuar el comando Imprimir del menú contextual.

    Nota:

    también puede seleccionar un fotograma vacío (no un fotograma clave) y etiquetarlo como #p.

Desactivación de la impresión eliminando el menú contextual de Flash Player

  1. Abra o active el documento de Animate (archivo FLA) que desea publicar.

  2. Seleccione Archivo > Configuración de publicación.
  3. Seleccione la ficha HTML y anule la selección de Mostrar menú. Haga clic en Aceptar.

Especificación de un área de impresión al imprimir fotogramas

  1. Abra el documento de Animate (FLA) que contiene los fotogramas que desea definir como imprimibles.

  2. Seleccione un fotograma que no se haya especificado para imprimirse con una etiqueta de fotograma #p que se encuentre en la misma capa que el fotograma etiquetado como #p.

    Para organizar el trabajo, puede seleccionar el fotograma posterior al que está etiquetado como #p.

  3. Cree una forma en el escenario con el tamaño del área de impresión deseado. Puede seleccionar un fotograma con cualquier objeto con el tamaño de área de impresión adecuado para utilizar un recuadro de delimitación.
  4. Seleccione el fotograma de la línea de tiempo que contiene la forma que desea utilizar como recuadro de delimitación.
  5. En el inspector de propiedades (Ventana > Propiedades) introduzca #b en Etiqueta de fotograma para indicar que la forma seleccionada se debe utilizar como recuadro de delimitación para el área de impresión.

    Solo puede introducir una etiqueta de fotograma #b por cada línea de tiempo. Esta opción equivale a seleccionar la opción de recuadro de delimitación Película con la acción Print.

Cambio del color de fondo impreso

Puede imprimir el color de fondo establecido en el cuadro de diálogo Propiedades del documento. Puede cambiar el color de fondo únicamente para los fotogramas que se van a imprimir colocando un objeto coloreado en la capa inferior de la línea de tiempo que se está imprimiendo.

  1. Coloque una capa rellena que cubra el escenario en la capa inferior de la línea de tiempo que se va a imprimir.
  2. Seleccione la forma y elija Modificar > Documento. Seleccione un color para el fondo de impresión.

    Esta acción cambia el color de fondo de todo el documento, incluido el de los clips de película y los archivos SWF cargados.

  3. Realice uno de los siguientes pasos:
    • Para imprimir dicho color como fondo del documento, designe el fotograma en el que colocó la forma para imprimirlo.

    • Para mantener un color de fondo diferente para los fotogramas que no se pueden imprimir, repita los pasos 2 y 3. A continuación, coloque la forma en la capa inferior de la línea de tiempo en todos los fotogramas que no se pueden imprimir.

Puede utilizar el comando Imprimir del menú contextual de Flash Player para imprimir fotogramas desde cualquier archivo SWF de Animate.

El comando Imprimir del menú contextual no puede imprimir transparencias ni efectos de color, ni tampoco puede imprimir fotogramas desde otros clips de película; para capacidades de impresión más avanzadas, utilice el objeto PrintJob o la función print().

  1. Abra el documento.

    El comando imprime los fotogramas con la etiqueta #p utilizando el escenario como área de impresión o el recuadro de delimitación especificado.

    Si no ha designado los fotogramas específicos que desea imprimir, se imprimirán todos los fotogramas de la línea de tiempo principal del documento.

  2. Seleccione Archivo > Vista previa de publicación > Predeterminado o presione la tecla F12 para ver el contenido de Animate en un navegador.

  3. Con el botón derecho del ratón (Windows) o con la tecla Control presionada (Macintosh), haga clic en el contenido de Animate en la ventana del navegador para mostrar el menú contextual de Flash Player.

  4. Elija Imprimir en el menú contextual de Flash Player para mostrar el cuadro de diálogo Imprimir.
  5. En Windows, seleccione el intervalo de impresión para seleccionar los fotogramas que se van a imprimir.
  6. En Macintosh, en el cuadro de diálogo Imprimir, seleccione las páginas que desea imprimir.
  7. Seleccione otras opciones de impresión, en función de las propiedades de la impresora.
  8. Haga clic en Aceptar (Windows) o Imprimir (Macintosh).

Nota:

la impresión desde el menú contextual no interactúa con las llamadas al objeto PrintJob.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea