Interface Overview

Lean about the main interface of Adobe Substance 3D Painter and how to navigate it.

Substance Painter Interface Overview
Substance 3D Painter interface divided in parts to present its main components.

  1. Tools & Plugins Toolbars
  2. Main Menu & Contextual Toolbar
  3. 3D and 2D Viewport
  4. Asset Panel
  5. Texture Set List
  6. Layer Stack & Texture Set Settings
  7. Properties
  8. Dock Toolbar

Tools and Plugins Toolbars

Find painting tools and helpful plugins.

Paint tools

Select a paint layer or mask to use the paint tools. 

Icon

Name

Description

Paint

The Paint tool lets you apply brush strokes on the surface of the 3D Mesh.

Eraser

The Eraser tool lets you remove or hide any existing painting present on the surface of the 3D Mesh.

Projection

The Projection tool lets you apply a material on the surface of the 3D Mesh by painting it over the viewport. The material is projected from the camera's point of view.

Polygon Fill

The Polygon Fill tools lets you create masks based on the mesh properties such as its polygon faces or its UV unwrapping.

Smudge

The Smudge tool lets you stretch, smear, blur, or mix any existing painting.

Clone

The Clone tool lets you duplicate or clone any existing painting to another part of the 3D Mesh surface.

Material Picker

The Material Picker lets you extract material information from the surface of the 3D Mesh.

Plugins

Painter includes several default plugins to help speed up your workflow. 

Icon Name Description
Send to… 
Use this to quickly send your mesh and material to other Adobe Substance 3D applications 
3D Community assets On the 3D community assets platform you can find hundreds of community created assets like materials, filters, textures, and brushes to help your workflow.
  3D Marketplace
In the 3D marketplace you can find hundreds of high-quality assets created by the Adobe Substance 3D team. 

Resource updater 
New versions of Painter often include updates to assets like materials and filters. When you open a file made with an old version of Painter, you may have to update some of the assets in that file. Use the resource updater to update your assets to the latest versions. 

Main Menu

Create, open, and save a project.

The Main menu presents you a few different categories and functions:

Menu Name

Content

File

The File menu lets you create New Projects and Save existing projects. It also lets you Import resources and Export textures of your project.

Edit

The Edit menu lets you quickly Undo and Redo actions. It also lets you access the current project settings and the general settings.

Mode

The mode menu lets you switch the interface of Substance Painter. Each mode has a dedicated purpose:

  • Painting lets you paint over the 3D mesh and manipulate the layer stack.
  • Rendering (Iray) lets you create higher-quality, more realistic renders of your current project.

 

Window

The window menu lets you choose which parts of the Substance Painter interface to show or hide. You can also use the toolbar menu to hide some toolbars. Here you can also reset the interface back to its default state.

Viewport        

The viewport menu lets you change the rendering mode of the 3D and 2D Viewports.

Plugins

The plugins menu lists all the available plugins that are loaded by Substance Painter at startup. You can find more plugins on Substance Share.

Help

The help menu regroups various actions. From links to the documentation to the classic about window. You can use this menu to report bugs and read the scripting and shader documentation.  

Contextual Toolbar

Modify the current brush or tool.

Content of the toolbar when a Paint tool is selected.
Content of the toolbar when a Paint tool is selected.

Content of the toolbar when a fill layer is selected with the setting set to UV projection mode.
Content of the toolbar when a fill layer is selected with the setting set to UV projection mode.

Content of the toolbar when a fill layer is selected with the setting set to a 3D projection mode.
Content of the toolbar when a fill layer is selected with the setting set to a 3D projection mode.

In addition to the various tool settings and functions, the Contextual Toolbar lets you control the display of the viewports, such as:

  • Hide excluded geometry: Can be used to hide geometry with the geometry mask

  • Pause engine computation: Pauses texture updates 

  • Viewport mode: 3D only, 2D only or both side by side

  • Camera projection mode: Perspective or Orthographic

  • Camera rotation mode: Constrained (2 axes) or free (3 axes)

  • Render mode: Shortcut to change to rendering mode with Iray. 

Contextual Toolbar for viewport settings.
Contextual Toolbar for viewport settings.

3D and 2D Viewports

Paint and view your 3D Mesh.

3D and 2D viewports side by side
3D and 2D viewports side by side

The 3D viewport displays your 3D mesh and the 2D viewport shows the mesh UVs.  Both viewports show the textures and materials applied to your mesh, and you can paint directly on the mesh or on the mesh UVs.

At the top of the viewport are dropdowns that you can use to display different channels or mesh maps. By default these dropdowns are set to material, which shows the 3D mesh with realistic lighting. Select another option from the dropdown to see that channel or mesh map without lighting. 

Asset Panel

Manage your painting resources.

Asset panel window showing the Smart Materials
Asset panel window showing the Smart Materials

The asset panel holds the assets that you can use in the layer stack to create textures and materials:

  • With the dropdown, you can filter assets to only see assets belonging to the current project or to a specific library.

  • Type any keyword in the search to find a specific asset.

  • Use the asset icons to filter by asset type.

asset panel

The asset panel holds the following asset types:

  • Materials

  • Smart materials

  • Smart Masks

  • Filters

  • Brushes

  • Alphas

  • Textures

  • Environments

Nota:

You can import new assets in a few ways:

  • Drag-and-drop files into Painter.

  • Click the Import resources button at the bottom right of the asset panel window.

  • Use File > Import resources.

Texture Set List

Displays all Materials IDs of the 3D mesh.

The texture sets are listed in the texture set list panel.

Painter creates a separate texture set for each material ID of an imported mesh. Every texture set has its own layer stack. Click a texture set in the texture set list to switch between layer stacks. From the texture set list you can also turn off visibility of a texture set. 

Layer Stack

Manage and organize your painting layers.

Example of a Layer Stack with folders and fill layers.
Example of a Layer Stack with folders and fill layers.

Add layers to the layer stack to build up your material. Each layer in the layer stack can hold information like brush strokes, textures, and effects. The layer stack combines this information to create the textures on your 3D mesh. 

With the layer stack you can hide and unhide layers, group layers, and adjust layers' blending mode and opacity for each channel.

Properties

Modify brush, tool, and layer properties.

Example of different types of properties

The properties window changes depending on your current selection or tool. Clicking on a layer will display its properties. Paint Layers will show the Tool parameters while Fill layers will display the Fill properties. Other advanced methods, such as Layer Instancing, can also display information in this window.

Dock Toolbar

Access any additional windows.

The dock toolbar on the right of the screen contains all the closed windows.
The dock toolbar contains all the collapsed/closed windows.

When you close a panel it is docked in the toolbar on the right of the Painter window. To open a panel again, click the panel's icon. Click and drag opened panels to rearrange your workspace. 

Nota:

In case you want to restore the interface back to its default state, you can use the Edit > Reset UI action from the main menu.

What's Next?

You now know all about the interface of Substance 3D Painter. Next, you can try to create your first project.

Have a question or an idea?

If you have a question to ask, come and participate in the Substance 3D Painter community. We would love to hear from you. 

You can also share your ideas of new features with us!

Logotipo de Adobe

Inicia sesión en tu cuenta