Create a results report

You can capture the results of a preflight inspection in various types of reports. You can capture the results in a text file, an XML file, or a single PDF file. A PDF report can include just an overview or detailed information presented in different ways.

A PDF report includes information about the document and problem objects in layers, which you turn on or off in the Layers navigation pane.

Note:

You can also create an inventory of all objects and resources used in the PDF.

Create a report of preflight results

  1. In the Results panel of the Preflight dialog box, click Create Report, or choose Create Report from the Options menu.
  2. Specify a name and location for the report. The suffix “_report” is automatically added to the report name.
  3. Select the type of report, and click Save.

Report types

PDF Report

Creates a summary of problems accompanied by details that are shown using transparent masks, comments, or layers for each problem object.

Overview

Condenses the preflight results into a short document that includes applied fixups, a results summary, and document information.

Details

Reports additional information about each problem object—for example, where the object is located on the page. Problems Highlighted By Transparent Masks places a colored mask, similar to a Photoshop mask, over areas to make the problem areas stand out. You can change the mask color using Preflight preferences. Problems Highlighted By Comments inserts preflight results as comments. Problems Highlighted By Layers shows the file separated into layers of mismatches or found objects according to the criteria used in the profile itself. Another layer calledOther Objects includes objects that have nothing to do with the profile used.

XML Report

Produces a structured report for workflow systems that can interpret and process the preflight results. For details, contact your print service provider.

Text Report

Produces a report in plain text format, with each line indented according to the hierarchy in the Preflight Results dialog box. You can open the report in a text editor.

Hide or show layers in a PDF report

  1. In the navigation pane for the PDF report, click the Layers button  to open the Layers panel.
  2. In the Layers panel, expand the report and click the square to the left of a layer name to hide or show the layer.

About inventory reports

An inventory report shows resources used in a PDF, including color spaces, images, patterns, shadings, metadata, and fonts and glyphs in each font family. Related information is grouped together and arranged on a PDF page so that you can scan and locate items. You can run an inventory report before or after you run a preflight inspection. Unlike a preflight results report, which provides only the information requested by checks in the selected profile, an inventory report does not filter the PDF content. Together, a preflight inspection report and an inventory report can help you identify and fix problems.

The information in an inventory report can be useful when you perform tasks such as these:

  • Exploring files that seem unusual, such as those created by an unknown application, or files with slow screen redraw or copy-and-paste actions that don’t work.

  • Examining processing issues, such as failure to print correctly, or problems encountered during color conversion, imposition, placement on an InDesign page, and so on.

  • Identifying aspects of a PDF that are not ideal, such as the inadvertent embedding of a font because of an unnoticed space character on a master page, or cropped images with extraneous image data, or objects that are not of the expected type (such as type or vector objects converted to images or merged with an image).

  • Providing additional information about an object besides its presence. For example, by locating a spot color in the inventory report, you can determine whether it is used by itself or in combination with other colorants, such as in a duotone image. Or you can determine which glyphs in a font are embedded, what they look like, and which character they are supposed to represent. This information can help you resolve a missing-glyph error.

  • Exploring XMP metadata embedded with the file, such as its author, resolution, color space, copyright, and keywords applied to it. This information is stored in a standardized way using the Extensible Metadata Platform (XMP) standard.

Create an inventory of PDF content

  1. In the Preflight dialog box, choose Create Inventory from the Options menu.
  2. Select the types of objects and resources you want included in the inventory. In addition to fonts, colors, images, and so on, you can include the following information:

    Form XObjects

    Objects that are referenced within a PDF. For example, if a PDF contains many occurrences of the same object, it exists as a single resource that is referenced many times.

    Include XMP Metadata

    Includes information embedded in the PDF that can be used by an XMP-enabled application or device in the workflow. This information can include meaningful descriptions and titles, searchable keywords, the author’s name, and copyright information. If you select Include Advanced Fields, you can include the fields and structures used for storing the metadata using namespaces and properties. This advanced information appears as a text-based tree view of all the XMP data in the PDF, both for the document as well as for those images in the PDF for which XMP metadata is present.

    Note:

    You can also view the metadata for the PDF document as a whole in the Document Properties dialog box. Choose File > Properties, click the Description tab, and then click Additional Metadata. To see the advanced fields, click Advanced from the list on the left.  

  3. (Optional) Save the report.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy