疑難排解儲存檔案時發生的問題

在 Illustrator 儲存檔案時遇到問題嗎? 以下提供一些您可以嘗試疑難排解的步驟。

如果系統回報 .ai 檔案損壞,請嘗試按照以下解決方式恢復受影響的檔案內容:

解決方法

步驟 

以其他檔案格式儲存檔案

  • 將 .ai 檔案變更為其他格式 (.svg、.png、.jpg),然後嘗試再次儲存檔案。
  • 將檔案儲存為 Post-Script (PS) 格式
    1. 選擇「檔案 > 列印」
    2. 指定所需列印設定。
    3. 「印表機」選單中選擇「Adobe PostScript 檔案」,然後按一下「儲存」
    4. 輸入包含 .ps 副檔名 (例如 Filename.ps) 的檔案名稱,然後按一下「確定」(Windows) 或「儲存」(macOS)。
    5. 在 Illustrator 中開啟 PostScript 檔案,然後嘗試將檔案儲存為 .ai 格式。

注意: 若要執行此解決方法,您必須安裝 PostScript 印表機驅動程式。如需了解如何在 Windows 安裝 Postscript 印表機,請參閱 Windows 說明頁面。

將內容拷貝到新的 檔案中

  • 移除圖稿中不需要的項目,例如孤立控制點、未上色物件以及空白文字路徑。選擇「物件 > 路徑 > 清理」
  • 在新檔案中保留圖稿中的圖層。在「圖層面板 > 更多選項」中選擇「 貼上記住圖層」。
  • 選取圖層並選擇「編輯 > 複製」
  • 選擇「檔案 > 開新檔案」,建立新檔案。
  • 在新檔案中,選擇「編輯 > 貼至上層」,以便將圖稿貼上到頁面上的正確位置。

找出並移除損毀的元件

若要判斷物件是否損毀,請從新檔案中刪除該物件,然後儲存並重新開啟檔案。 

  • 找出損毀的圖樣、漸層或自訂顏色
    • 選擇「編輯  > 全選」,然後將填色和筆畫變更為印刷黑色。
    • 如果新檔案不再出現問題,請在原始檔案中重新建立圖樣、漸層或特別色。
      注意: 您可能會遺失透明度和圖層資訊。
  • 刪除損壞的色票、自訂顏色、顏色群組、筆刷、符號或樣式
    從「色票」面板選單、「筆刷」面板選單、「符號」面板選單和「樣式」面板選單中選擇「 選取所有未使用項目」,然後按下「刪除」
  • 將損壞的文字物件轉換為外框或變更字體
    • 選擇「物件 > 解除鎖定所有項目」
    • 選擇「編輯 > 全選」
    • 選擇「文字 > 字體」,然後選擇未在文件中使用的字體。
      注意: 若要避免文字物件未來受到損毀,請從原始磁碟重新安裝有問題的字體。

問題尚未解決嗎?

  • 如果仍然無法解決問題,請先重新儲存或重新建立在原始檔案中使用的圖形、範本和自訂顏色,然後在 Illustrator 重新建立檔案。 
  • 也許您遭遇的是其他檔案相關問題,例如與記憶體、存取權限、網路、卸除式媒體相關的問題。如要進一步了解此問題,請參閱「識別檔案問題並進行疑難排解」 一文。

加入對話

Ask the community

如果您想提出問題或分享心得,請加入並參與 Adobe Illustrator 社群。我們很樂意聽取您的意見。

Adobe 標誌

登入您的帳戶