Projects

A Character Animator project is a collection of puppets, scenes, and supporting items (for example, artwork and audio files). You can create separate projects to organize related work, such as for an episode of a cartoon or for a specific client. Each project is stored on disk as a separate folder.

Create and open projects

The default project Character Animator Project is located in your user Documents/Adobe/Character Animator/Preview (Mac) or Documents\Adobe\Character Animator\Preview (Win) folder. You can switch to a different project at any time. When Character Animator launches, it reopens the recent project you had closed so you can continue your work. If the current project cannot be found, it reopens or recreates the default project.

Create a project

Choose File > New Project. Specify the location and name for the project, and click Save. A project folder with the default project file (.chproj file) both using the name specified, are created.

Megjegyzés:

As you work in a project, Character Animator is continually creating and updating files in the project’s folder on disk. Avoid creating and working on projects located in folders actively synced or backed up.

Open a project

Choose File > Open Project (Ctrl+O), select the Ch project (.chproj), then click Open.

Open a recent project

Choose the project from the File > Open Recent submenu. The current project is the first one listed.

Locate the current project on disk

To show and select the current project’s folder on disk, choose File > Reveal Project in Explorer (Windows) or File > Reveal Project in Finder (Mac OS).

Import contents of another project

You can import the contents of another project and reuse its scenes and puppets in the current project.

To import a project’s contents:

  • Choose File > Import, then select the .chproj file in that project’s folder.

A new folder is created in the Project panel, and a copy of that project’s contents are placed in the folder.

If the source media (artwork and audio) files are originally in the imported project’s Ch Media folder (or one of its subfolders) on disk, copies of those files are added to the current project’s Ch Media folder. These files are added in a Gathered Media subfolder.

If the source files existed outside of the project folder, the imported items reference their current location instead of making a copy.

Supported import file formats

JPEG and PNG support for puppets and cycles

  • Single JPEG (*.jpg or *.jpeg) and PNG file can be imported as single-layered puppets (click File > Import). 
  • JPEG and PNG image sequences can be imported as cycles (click File > Import Cycle).

EPS and SVG format support for puppet artwork

Puppet artwork in EPS (.eps) and SVG (.svg or .svgz) formats are supported in Character Animator. As these formats are vector-based, the Render as Vector option and the Wiggler behavior can be applied to them.

Megjegyzés:

Older versions of the EPS and SVG file formats might not be able to retain the full layer hierarchy, so some parts might appear flattened in the Puppet panel.

Megjegyzés:

If you are exporting from Adobe Animate, ensure you enable the Optimize for Character Animator checkbox to retain layer structure and layer names.

Using Adobe Animate scenes as cycles (SVG sequences)

To export Adobe Animate artwork cycles in SVG format for use in Character Animator, follow these steps:

  1. Open the scene in the Adobe Animate document.

  2. Choose File > Export > Export Movie. The Export Movie dialog box opens. Set the Save as type to SVG Sequence (*.svg)

  3. Enable the Optimize for Character Animator checkbox and click OK.

    Optimise for import in Character Animator

The published .svg file can then be imported into Character Animator as a cycle.

Illustrator (vector artwork) rasterization

Use the Resolution property in the Puppet section of the Properties panel to control the maximum quality of the vector artwork when it is rasterized. The default is set to 200%. It can be increased to up to 400%. Reduce it to a draft (50%) or low (100%) resolution if scaling down and to preserve more memory.

Megjegyzés:

Scenes sent through Dynamic Link to After Effects, Premiere Pro, or Adobe Media Encoder are rasterized. If you want to scale up the footage in those other applications, use a larger scene size in Character Animator to retain details.

Supported audio file formats

Use .mp3, .wav, and .aif audio files to import for your Character Animator project.

Organize project items

Within the current project, you can rearrange project items in the Project panel into different folders to suit your needs. 

You can sort the items in the Project panel by name or type. Click a column heading to toggle sorting direction.

Add a folder

To add a folder, choose File > New Folder, type the name for the folder, then press Enter or click away from the text field.

A new folder is created at the same level as the outermost selected project item, or inside the selected folder.

To duplicate artwork, puppet, and audio in the Project panel, select the item that you want to duplicate and choose Edit > Duplicate.

Remove a folder

To remove a folder, select it, then choose Edit > Delete (Delete or Backspace).

Move items between folders

To move items between folders, select the items, then drag them into a different folder.

Rename a project item

To rename a project item (puppet, scene, folder, and so on), select it, and press Enter. To save changes, type the new name and press Enter, or click away from the text field. Press Esc instead to cancel your edits.

Megjegyzés:

Dragging an item into a folder containing another item of the same name causes the dragged item to be renamed. Renaming an item to match an existing item in the same folder is disallowed— a red ‘x’ appears next to the text field. Hover the pointer above the ‘x’ to show the error message.

Delete an item

To delete an item, select it, then press Delete or Backspace or choose Edit > Delete.

Locate imported files on disk

To locate imported files on disk, context + right-click a puppet, artwork, or audio item in the Project panel. Now choose Reveal in Finder (Mac) /Explorer (Windows) from the context menu. For puppets, the artwork file for the bottom-most layer is revealed.

Copy imported artwork and audio files into a project

To gather copies of imported artwork and audio files into the project folder for easier project sharing, choose File > Copy Media Files into Project Folder. The files are copied into the Gathered Media subfolder of the project’s Ch Media folder. The files in the original locations are not deleted.

Undo and redo

Character Animator provides unlimited undo and redo, even between Character Animator sessions. Your Character Animator project saves changes automatically.

Undo or redo changes

To undo or redo changes, do either of the following:

  • Choose Edit > Undo Action (Command/Ctrl+Z) or Redo Action (Shift+Command/Ctrl+Z).
  • Select the action from the History panel (Window > History).

Clear undo history

To clear the undo history, choose File > Clear History, then click Clear History.

Save Project Version

Use project versions to remember a specific state of a project. Create these markers in a project’s history and recall them later to restore the state of your project. Versions let you keep track of different variations of a project all within the same project.

Megjegyzés:

You cannot undo creating, renaming, or deleting a project version as that would affect project history. Also, clearing history (File > Clear History menu command) deletes all project history versions.

Using project versions

    • To create a new version for the current state, choose File > Save Project Version. You can also create a project version using the shortcut Ctrl+S (Windows) / Command+S (macOS).
    • Alternatively, click Save New Version button in the History panel.
    • To provide a custom name for the version, choose File > Save Named Project Version (Command+Option+S / Ctrl+Alt+S).

    A new version appears in the top section of the History panel with a solid document icon. Hover over the version to display the exact date and time of its creation.

    Project versions
    History panel showing project versions and the Save New Version button

    The default name of each new project version is based on the most recently named project version in history, or “Version n” if there was no previous or custom name used, but you can rename project versions anytime.

  1. To restore project history to a version’s state, click the version.

    Megjegyzés:

    If the Scene panel is not showing the expected results, try clicking the Refresh Scene button in the panel.

  2. To rename a project version, right-click the project version and choose the Rename command or, if the version is selected, press Return (macOS) or Enter (Windows). Change the name, then press Return/Enter.

  3. To delete a project version, either right-click the version and choose the Delete command or hover over it and then click the 'x' button.

    Tip: You don’t have to select a version (and restore project history to that state) to rename or delete it.

Auto-save versions

The following actions create Auto-save versions:

  • If you undo a few operations and then to do some new operation (for example, create a folder), the previous redoable operations no longer appear in the current undo/redo history. An auto-save versions is created for the previous state of the project, and is named as the last state plus the number of redoable operations. For example, 'Record Performance + 5 redos'.
  • If you select a project version with a history state that isn‘t within the current undo/redo history, an auto-save version  is created for the previous state of the project, named as the last state plus the number of redoable operations (if any). For example, Set Scale to 80 or Set Scale to 75 + 1 redo.
  • When you delete a project version, an auto-save version  is created. The auto-save version is named after the deleted project version ,  and shows when the project version was originally created and later deleted below the auto-save version's name.
  • When you open a project, an auto-save versions is created for the state of the project at the time it was opened.

View Auto-save versions

Select the Show Auto-saved versions option from the History panel menu. Deselect to show manually created versions.

Show auto bookmarks option
Show auto-save versions

Auto-saved versions appear with outlined document icons to differentiate them from manually created versions. The most recent Auto-saved version appears at the bottom of the list. You can restore, rename, and delete auto-saved versions. Renaming an auto-save versions. makes it a regular version, and switches the top section of the History panel to view it.

Create a copy of a project

You can save your project under a new name to easily experiment with changes or to save different versions of your work.

To save the project under a new name, choose File > Save As, then specify the new location and name for the project. The saved project contains copies of the puppets, scenes, and recordings, including artwork and audio files that had been previously saved in the Ch Media subfolder. Character Animator does not copy any files that were outside of the project’s folder and the history is cleared.

More like this

Adobe logó

Bejelentkezés a fiókba