Létrehozhat hivatkozásokat, hogy amikor Adobe PDF vagy SWF formátumba exportál az InDesign programban, az olvasók a hivatkozásra kattintva a dokumentum más részeire, más dokumentumokba vagy webhelyekre ugorhassanak. Az InCopy programban exportált hivatkozások nem aktívak az exportált PDF vagy SWF dokumentumban.

A forrás egy hivatkozással ellátott szöveg, szövegkeret vagy grafikakeret. A hivatkozás célja az URL, fájl, e-mail cím, oldal, szerkesztőpont vagy megosztott rendeltetési hely, amelyre a hivatkozással ugrani lehet. Egy forrásból csak egy célra lehet ugrani, de akárhány forrásból lehet egy célra ugrani.

A forrás egy hivatkozással ellátott szöveg vagy grafika. A hivatkozás célja az az URL, fájl, e-mail cím, oldal, szerkesztőpont vagy megosztott rendeltetési hely, amelyre a hivatkozással ugrani lehet. Egy forrásból csak egy célra lehet ugrani, de akárhány forrásból lehet egy célra ugrani.

Megjegyzés:

Ha azt szeretné, hogy a program a célszövegből generálja a forrásszöveget, akkor hivatkozás hozzáadása helyett egy kereszthivatkozást szúrjon be. Lásd: Kereszthivatkozások.

dy_00
Hyperlinks

A. Hyperlink source B. List of hyperlinks in the current document C. Hyperlink status icons 
  • Válassza az Ablak menü Interaktív elemének Hivatkozás parancsát.
  • Válassza az Ablak menü Hivatkozás parancsát.
  • Válassza az Ablak menü Szöveg és táblázatok elemének Kereszthivatkozások parancsát.
  1. Válassza a Hivatkozások panel menüjének Rendezés parancsát, majd válasszon az alábbi lehetőségek közül:

    Manuálisan

    A dokumentumhoz való hozzáadás sorrendjének megfelelően jeleníti meg a hivatkozásokat.

    Név szerint

    Betűrendben jeleníti meg a hivatkozásokat.

    Típus szerint

    Hasonlóság szerint csoportosítva jeleníti meg a hivatkozásokat.

  1. Válassza a Hivatkozások panel menüjének Kis panelsorok parancsát.

Oldalakra, URL-ekre, szövegek szerkesztőpontjaira, e-mail címekre és fájlokra mutató hivatkozásokat hozhat létre. Más dokumentum oldalaira és a szövegrészeinek szerkesztőpontjaira mutató hivatkozások létrehozásakor ügyeljen arra, hogy azonos mappába legyenek exportálva a fájlok.

Megjegyzés:

A hivatkozások megjeleníthetők, illetve elrejthetők a Nézet > Extrák > Hivatkozások megjelenítése (Hivatkozások elrejtése) beállítással.

Megjegyzés:

Az exportált Adobe PDF fájlok akkor tartalmazzák a hivatkozásokat, ha az Adobe PDF exportálása párbeszédpanelen be van jelölve a Hivatkozások négyzet. Az exportált SWF fájlok akkor tartalmazzák a hivatkozásokat, ha az SWF exportálása párbeszédpanelen be van jelölve a Hivatkozásokkal együtt négyzet.

Több különböző módon is készíthet URL-ekre mutató hivatkozásokat. Az URL megadásakor tetszőleges érvényes internetes erőforrás-protokoll használható: http://, file://, ftp:// és mailto://.

Megjegyzés:

Érdemes saját karakterstílust létrehozni a hivatkozásokhoz. A hivatkozások gyakran jelennek meg aláhúzott kék szövegként.

  1. Jelölje ki a hivatkozás forrásává teendő szöveget, keretet vagy grafikát. Kijelölheti például a „Látogasson el az Adobe webhelyére” szövegrészt.
  2. A Hivatkozás panelen az alábbi módszerekkel készíthet URL-re mutató hivatkozásokat:
    • Az URL szövegablakba írja vagy másolja be az URL nevet (például http://www.adobe.com), majd válassza az Új hivatkozást a Hivatkozások panelen. Jelölje ki a kívánt URL-t a Hivatkozás helye listában, adja meg a megjelenési beállításokat, majd kattintson az OK gombra.

    • Ha ki van jelölve valamelyik URL a dokumentumban, akkor válassza a Hivatkozás panel menüjének Új csatolás URL-ből parancsát. Kattintson duplán a hivatkozásra a Hivatkozások panelen, válasszon egy URL-t a Hivatkozás helye listából, állítsa be a megjelenést, majd kattintson az OK gombra.

    • Jelölje ki valamelyik korábban hozzáadott URL-t az URL-ek listájáról. A hivatkozás megjelenése megegyezik az előző URL megjelenésével.

    • Válassza a Hivatkozás panel menüjének Új hivatkozás parancsát. Jelölje ki a kívánt URL-t a Hivatkozás helye listában, adja meg a megjelenési beállításokat, majd kattintson az OK gombra.

Megjegyzés:

Ha az exportált PDF fájlban nem működne az URL hivatkozás, akkor lehet, hogy a hivatkozás egy „megosztott rendeltetési hely”. Kattintson duplán a hivatkozásra a Hivatkozások panelen, válasszon egy URL-t a Hivatkozás helye listából, szüntesse meg a „megosztott rendeltetési hely” kijelölését, majd kattintson az OK gombra.

Fájlra mutató hivatkozás létrehozásakor az exportált PDF vagy SWF fájlban szereplő hivatkozásra való kattintás hatására a fájl a saját alkalmazásában nyílik meg (a .doc fájlok pl. a Microsoft Word alkalmazásban).

Ügyeljen arra, hogy a célként megadott fájl minden olyan felhasználó számára legyen elérhető, aki megnyitja az exportált PDF, illetve SWF fájlt. Ha például egy munkatársának küldi az exportált PDF fájlt, akkor ne a saját merevlemez-meghajtóján, hanem egy megosztott kiszolgálón található fájlt adjon meg.

  1. Jelölje ki a hivatkozás forrásává teendő szöveget, keretet vagy grafikát.
  2. Válassza a Hivatkozások panel menüjének Új hivatkozás parancsát, vagy kattintson a Hivatkozások panel alján található Új hivatkozás létrehozása gombra.
  3. Válassza az Új hivatkozás párbeszédpanelen látható Hivatkozás helye listában a Fájl lehetőséget.
  4. Adja meg az elérési utat az Elérési út mezőben, vagy kattintson a mappát ábrázoló gombra, keresse meg a kívánt fájlt, majd kattintson duplán annak nevére.
  5. Akkor válassza a „megosztott rendeltetési hely” beállítást, ha a fájlt könnyen újrahasználhatóvá kívánja tenni a Hivatkozások panelen való eltárolással.
  6. Adja meg a hivatkozás forrásának megjelenését, majd kattintson az OK gombra.
  1. Jelölje ki a hivatkozás forrásává teendő szöveget, keretet vagy grafikát.
  2. Válassza a Hivatkozások panel menüjének Új hivatkozás parancsát, vagy kattintson a Hivatkozások panel alján található Új hivatkozás létrehozása gombra.
  3. Válassza az Új hivatkozás párbeszédpanelen látható Hivatkozás helye listában az E-mail lehetőséget.
  4. A Cím mezőben adja meg az e-mail címet (pl. felhasználónév@vállalat.com).
  5. A Tárgysor mezőben adja meg az e-mail üzenet Tárgy mezőjében feltüntetni kívánt szöveget.
  6. Ha későbbi felhasználás céljából szeretné a Hivatkozások panelen tárolni az e-mail üzenetet, akkor jelölje be a Megosztott hivatkozás rendeltetési hely lehetőség mellett látható négyzetet.
  7. Adja meg a hivatkozás forrásának megjelenését, majd kattintson az OK gombra.

A cél előzetes létrehozása nélkül is létrehozhat oldalakra mutató hivatkozásokat. Oldal cél létrehozásával azonban megadhatja az oldalszámot és a megtekintési beállításokat.

  1. Jelölje ki a hivatkozás forrásává teendő szöveget, keretet vagy grafikát.
  2. Válassza a Hivatkozások panel menüjének Új hivatkozás parancsát, vagy kattintson a Hivatkozások panel alján található Új hivatkozás létrehozása gombra.
  3. Válassza az Új hivatkozás párbeszédpanelen látható Hivatkozás helye listában az Oldal lehetőséget.
  4. A Dokumentum mezőben jelölje ki a célt tartalmazó dokumentumot. A menüben megjelenik minden mentett nyitott dokumentum. Ha nincs nyitva a keresett dokumentum, a Tallózás gombra kattintva keresse meg a fájlt, és kattintson a Megnyitás gombra.
  5. Az Oldal mezőben adja meg annak az oldalnak a számát, melyre ugrani szeretne.
  6. A Nagyítás/kicsinyítés beállítása mezőben az alábbi módszerek valamelyikével válassza ki a célként megadott lap nézetének állapotát:
    • Válassza a Rögzített lehetőséget a hivatkozás létrehozásakor érvényes nagyítási szint és oldalpozíció megjelenítéséhez.

    • A Nézet igazítása lehetőséget választva a jelenlegi oldal látható része jelenik meg célként.

    • Az Ablakhoz igazítás lehetőséget választva a jelenlegi lap a célablakban jelenik meg.

    • A Szélesség igazítása vagy a Magasság igazítása lehetőséget választva a célablak a jelenlegi oldal szélességével vagy magasságával jelenik meg.

    • A Látható rész igazítása lehetőséget választva az oldal úgy jelenik meg, hogy a szöveg és a képek vízszintesen elférjenek az ablakban, ami rendszerint azt jelenti, hogy a margók nem jelennek meg.

    • Válassza a Nagyítás megtartása elemet, ha azt szeretné, hogy a célablak ugyanolyan nagyítással jelenjen meg, amit a felhasználó használ, amikor a hivatkozásra kattint.

  7. Adja meg a megjelenés beállításait, majd kattintson az OK gombra.

A hivatkozások célpontját csak akkor kötelező létrehozni, ha szerkesztőpontra mutató hivatkozást vagy kereszthivatkozást készít. A szerkesztőpont kijelölt szövegrészre, illetve a beszúrási pont helyére mutathat. Ezt követően hozhatja létre a hivatkozás célpontjára mutató hivatkozást, illetve kereszthivatkozást. Az oldalakra és az URL-ekre mutató hivatkozások esetén is létrehozhatja a hivatkozások célpontját, de azoknál nem kötelező azt megadni.

A hivatkozások létrehozott céljai nem láthatók a Hivatkozás panelen, azok a hivatkozások létrehozásakor és szerkesztésekor megjelenő párbeszédpanelen láthatók.

  1. Szerkesztőpont létrehozásakor a Szöveg eszközzel helyezze a kívánt helyre a beszúrási pontot, vagy jelölje ki azt a szövegtartományt, amelyet szerkesztőpontként szeretne használni.

    A digitális eredeti másolat szövege nem lehet szerkesztőpontcél.

  2. Kattintson a Hivatkozás panel menüjének Új hivatkozási cél parancsára.
  3. A Típus listában jelölje ki a Szerkesztőpont elemet. Adja meg a szerkesztőpont nevét, majd kattintson az OK gombra.
  4. Hajtsa végre a megfelelő műveletet, majd kattintson az OK gombra:
    • A Típus listában jelölje ki a Szerkesztőpont elemet. Adja meg a szerkesztőpont nevét.

    • A Típus listában jelölje ki az Oldal elemet. Adja meg annak az oldalnak a számát, melyre ugrani szeretne, valamint adja meg a Nagyítás/kicsinyítés beállítása mező értékét. Adja meg az oldal nevét, vagy a Szerkesztőpont neve és oldalszám négyzet bejelölésével hagyja, hogy a program nevezze el automatikusan a célt a megadott oldalszám és nagyítási/kicsinyítési beállítás alapján.

    • A Típus listában jelölje ki az URL elemet. Írjon vagy illesszen be egy URL-címet (például: http://www.adobe.com). Minden érvényes internetes erőforrás-protokoll használható: http://, file://, ftp:// és mailto://.

  1. Jelölje ki a hivatkozás forrásává teendő szöveget, keretet vagy grafikát.
  2. Válassza a Hivatkozások panel menüjének Új hivatkozás parancsát, vagy kattintson a Hivatkozások panel alján található Új hivatkozás létrehozása gombra.
  3. A Hivatkozás helye listában jelölje ki a Szerkesztőpont elemet.
  4. A Dokumentum mezőben jelölje ki a célt tartalmazó dokumentumot. A menüben megjelenik minden mentett nyitott dokumentum. Ha nincs nyitva a keresett dokumentum, a Tallózás gombra kattintva keresse meg a fájlt, és kattintson a Megnyitás gombra.
  5. A Szerkesztőpont listában jelölje ki a szerkesztőpont számára létrehozott célt.
  6. Adja meg a hivatkozás megjelenési beállításait, majd kattintson az OK gombra.

Ha a Hivatkozás helye listában a Megosztott rendeltetési hely lehetőséget választja a hivatkozás létrehozásakor, akkor tetszőleges, névvel ellátott célt megadhat a hivatkozás céljaként. A cél akkor minősül elnevezett célnak, ha egy URL-re, fájlra vagy e-mail címre mutató hivatkozás létrehozásakor az URL szövegmezőben megad egy URL-t, illetve ha bejelöli a Megosztott hivatkozás rendeltetési hely lehetőség mellett látható négyzetet.

  1. Jelölje ki a hivatkozás forrásává teendő szöveget, keretet vagy grafikát.
  2. Válassza a Hivatkozások panel menüjének Új hivatkozás parancsát, vagy kattintson a Hivatkozások panel alján található Új hivatkozás létrehozása gombra.
  3. Válassza az Új hivatkozás párbeszédpanelen látható Hivatkozás helye listában a Megosztott rendeltetési hely lehetőséget.
  4. A Dokumentum mezőben jelölje ki a célt tartalmazó dokumentumot. A menüben megjelenik minden mentett nyitott dokumentum. Ha nincs nyitva a keresett dokumentum, a Tallózás gombra kattintva keresse meg a fájlt, és kattintson a Megnyitás gombra.
  5. Válasszon egy célt a Név menüből.
  6. Adja meg a hivatkozás megjelenési beállításait, majd kattintson az OK gombra.

Ezekkel a beállításokkal határozhatja meg az exportált PDF, illetve SWF fájlokban szereplő hivatkozások és kereszthivatkozások forrásának megjelenését. Ezek a megjelenítési beállítások az InDesign dokumentumban is megjelennek a Nézet > Extrák > Hivatkozások megjelenítése beállítás hatására.

Karakterstílus

Itt választhatja ki a hivatkozás forrásának karakterstílusát. A Karakterstílus beállítás csak akkor választható el, ha kijelölt szövegrész a hivatkozás forrása; ha kijelölt keret vagy grafika a hivatkozás forrása, akkor nem használható.

Kereszthivatkozás beszúrása esetén a kereszthivatkozás formátumának szerkesztésekor is alkalmazhatja a kívánt karakterstílust. Adott formátumon belüli építőelemeket is elláthat karakterstílusokkal. Lásd Kereszthivatkozásokhoz való formátumok használata.

Szöveg

A Látható téglalap és a Láthatatlan téglalap beállítás közül választhat.

Kiemelés

A Negatív, a Körvonal, a Belső sarok és a Nincs beállítás közül választhat. Ezekkel a beállításokkal határozhatja meg a PDF, illetve SWF fájlokban szereplő hivatkozások megjelenését arra az esetre, amikor azokra kattintanak.

Szín

Itt választhatja ki a hivatkozás látható téglalapjának színét.

Szélesség

A Vékony, a Közepes és a Vastag beállítás valamelyikének kiválasztásával adhatja meg a hivatkozás téglalapjának vastagságát.

Stílus

A Folytonos és a Szaggatott beállítás valamelyikének kiválasztásával adhatja meg a hivatkozás téglalapjának megjelenését.

Megkereshetők és átalakítható hivatkozássá a dokumentumban az URL-ek (például „www.adobe.com”).

  1. Válassza a Hivatkozások panelmenü „URL-ek hivatkozássá alakítása” elemét.
  2. Adja meg, hogy az URL-ek hivatkozássá alakításának hatóköre a teljes dokumentum, az aktuális szövegegység vagy az aktuális kijelölés legyen.
  3. A hivatkozások karakterstílusa a Karakterstílus menü listájából választható ki.
  4. Végezze el az alábbi műveletek egyikét, majd kattintson a Kész gombra.
    • Kattintson a Keresés gombra a következő URL kereséséhez.

    • Kattintson az Átalakítás gombra az aktuális URL hivatkozássá alakításához.

    • Kattintson az Összes átalakítása gombra az összes URL hivatkozássá alakításához.

A Hivatkozások panelen szerkesztheti, törölheti, visszaállíthatja és megkeresheti a hivatkozásokat. Az InCopy programban csak akkor kezelheti a hivatkozásokat, ha a szövegegység ki van véve szerkesztésre.

  1. A Hivatkozások panelen kattintson duplán a szerkesztendő elemre.
  2. Tetszése szerint módosítsa a hivatkozást a Hivatkozás szerkesztése párbeszédpanelen, majd kattintson az OK gombra.

Megjegyzés:

URL-re mutató hivatkozás módosításához jelölje ki a hivatkozást, módosítsa az URL-t az URL szövegmezőben, majd nyomja le az Enter vagy a tabulátor billentyűt.

Ha eltávolít egy hivatkozást, a forrásszöveg vagy -grafika megmarad.

  1. Jelölje ki az eltávolítandó elemet vagy elemeket a Hivatkozások panelen, majd kattintson a panel alján található Törlés gombra.

Ha átnevezi a hivatkozás forrását, az más néven jelenik majd meg a Hivatkozások panelen.

  1. Jelölje ki a hivatkozást a Hivatkozások panelen.
  2. Válassza a Hivatkozások panel menüjének Hivatkozás átnevezése parancsát, majd adja meg az új nevet.
  1. Nyissa meg a célt tartalmazó dokumentumot.
  2. Kattintson a Hivatkozások panel menüjének Hivatkozási cél beállításai parancsára.
  3. A Cél mezőben jelölje ki a szerkesztendő cél nevét.
  4. Tegye a következők egyikét:
    • Kattintson a Szerkesztés gombra, és hajtsa végre a célon szükséges módosításokat.

    • A Törlés gombra kattintva törölje a célt.

  5. Ha befejezte a cél szerkesztését vagy törlését, kattintson az OK gombra.
  1. Jelölje ki az új hivatkozási forrásként használandó szövegtartományt, szövegkeretet vagy grafikakeretet. További szövegrészt is kijelölhet például a forrás számára.
  2. Jelölje ki a hivatkozást a Hivatkozások panelen.
  3. Tegye a következők egyikét:
    • Kattintson a Hivatkozások panel menüjének Hivatkozás alaphelyzetbe állítása parancsára.

    • A külső dokumentumokra mutató hivatkozások frissítéséhez kattintson a Hivatkozások panel menüjének Hivatkozás frissítése parancsára.

  • Egy hivatkozás vagy kereszthivatkozás forrásának megkereséséhez jelölje ki azt az elemet a Hivatkozások panelen, amelyet meg szeretne keresni. Kattintson a Hivatkozások panel menüjének Ugrás a forrásra parancsára. Ekkor kijelölődik a szöveg vagy a keret.
  • Egy hivatkozás vagy kereszthivatkozás céljának megkereséséhez jelölje ki azt az elemet a Hivatkozások panelen, amelyet meg szeretne keresni. Válassza a Hivatkozások panel menüjének Ugrás a célra parancsát.

Ha az elem egy URL-cél, az InDesign elindítja a webböngészőt (vagy átvált rá) a cél megjelenítéséhez. Ha az elem szerkesztőpont vagy oldalcél, az InDesign odaugrik.

Hivatkozásokat tartalmazó Microsoft Word dokumentum InDesign dokumentumba importálásakor esetenként téglalap, illetve keret jelenik meg a hivatkozás URL-je (pl. www.adobe.com) körül. Az InDesign dokumentum örökli a Word_R0_G0_B255 nevű, kék színmintát. A dokumentum örököl ezenkívül egy Hivatkozás nevű karakterstílust, amely aláhúzást és kék színt határoz meg a szövegnek.

A keret eltávolításához kattintson a hivatkozásra a Hivatkozások panelen. A Megjelenés alatt válassza ki a Láthatatlan téglalap beállítást a Típus listában, majd kattintson az OK gombra.

Felmerülhet az igény az importált színminta törlésére. Amikor ezt megteszi, kicserélheti azt egy másik színmintára. Lásd: Egyedi színminták törlése

Megjegyzés:

A formátum öröklődésének megakadályozása céljából a Word dokumentum InDesign dokumentumba helyezése előtt érdemes a Word dokumentum URL címeihez tartozó hivatkozásokat törölni. Lásd a Word dokumentációját. Egy másik lehetőség az importálást megelőzően létrehozni az InDesign alkalmazásban egy Hivatkozás nevű karakterstílust. A Word dokumentum importálásakor alapértelmezés szerint az ilyen nevű stílus kerül felhasználásra.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat