Issue

When you export an InDesign document to PDF with downsampling enabled, the export might fail with the message, "PDF Export Failed."

Reason

This is typically caused by placing images, or graphics that contain images, and scaling them down significantly. This causes their effective resolution to increase. For example, a 600 dpi image scaled to 50% has an effective resolution of 1200dpi. But placing a large, high resolution image without scaling could also require more than the available memory, depending on your system configuration and state, and the downsampling settings.

Additionaly, the issue is also caused by corrupted pages or links and various others.

 

Solution

Solution 1: Downsample the images after export using Acrobat.

  1. Choose File > Export and select PDF as your format, choose a location and click Save.
  2. In the Export PDF dialog box, disable the image downsampling options.
  3. Open the resulting PDF in Acrobat.
  4. Choose Advanced > PDF Optimizer.
  5. Set the downsampling options you desire in the Image Settings pane.
  6. Disable any other options that are not needed.
  7. Click OK and choose the name and location to save the file.

Solution 2: Downsample the images prior to export using Photoshop (or another photo editing tool).

  1. Context-click on the image in the layout, or the links panel, and choose Edit Original.
  2. Once the image has opened in Photoshop, choose Image > Image size.
  3. Ensure that Resample Image, and Constrain Proportions are enable.
  4. Adjust the document size values to the needs of your layout.
  5. If the image resolution is larger than what is required by your final output, adjust the value here.
  6. Save and close the image.
  7. Return to InDesign.
  8. Update the link, if necessary. 

Solution 3: Binary sorting of the document

Binary sorting of the document helps in eliminating the issue coherently.

  1. Export a single page or group of pages at time.

  2. Locate the corrupted page or link.

Solution 4: Move the document into a new file

  1. Move pages using Move Pages command:
    Choose Layout > Pages > Move Pages, or choose Move Pages from the Pages panel menu.

  2. Specify the page or pages you want to move.

  3. For Destination, choose where you want to move the pages, and specify a page if necessary.

  4. Click OK.

     

Solution 5: Save the file as an IDML

  1. Go to File> Save As> IDML and click Save.

  2. Export the IDML file. 

  3. Check if the Export functions without any error.