Adobe InDesign CC 2015.4 Release | June 2016

Cleaner and bigger UI

Users often complain about eye strain after using InDesign for a long time, mostly due to small UI elements in InDesign. With this release, the following areas have been enhanced:

  • More than 100 panels have been redesigned in InDesign by increasing the:
    • Size of various controls in panels.
    • Font size.
    • Inter-spacing between controls (both vertical and horizontal).
  • More than 500 dialogs have been redesigned by increasing the height of UI controls.
Panels and dialogs now look bigger, cleaner, and less cluttered.

Improved stability while working with network files

Users often work on documents that are on network locations. Earlier, when network connectivity was lost, InDesign used to perform a protective shutdown to protect the document from corruption. Users could no longer continue working on the document. However, with network locations becoming more common, more users are running into this issue.

In this release, for network documents smaller than 100 MB, if connectivity is lost, InDesign continues to function normally.

For more information, see  Save documents.

GPU performance and Animated Zoom (Mac only)

InDesign can now significantly improve the rendering performance of documents on your Mac, by utilizing the GPU of your computer.

GPU acceleration is available only on supported Mac machines that have a GPU card with a minimum 1 GB of dedicated VRAM.

The enhanced performance from using the GPU powers features like Animated Zoom.

For more information, see GPU Performance enhancements.

Sorting Swatches

New options are available to sort swatches in the Swatches panel. You can sort swatches by the following:
  • Name
  • Color Values
For more information, see Sort swatches.

Accessibility enhancement (Export Interactive PDF)

The Export to Interactive PDF dialog has been modified to make it more organized. Various options have been categorized and arranged in tabs.

Also, a new accessibility option is now available under the Advanced tab while exporting to Adobe PDF (Interactive). 

  • Language: Choose the document language for the exported PDF.
For more information, see Export to interactive PDF options.
Accessibility in interactive PDF
Accessibility options

Read-only libraries

  • While inviting others to collaborate on a Library, authors can mark the Library as Can View, to indicate that it is in read-only mode. The person with whom a Library is shared in read- only mode can use the assets from this Library but will not be able to add or modify any assets.
  • Whenever the author updates the content of the Library, users who have read-only access get the updated content.

Better integration with Adobe Stock

In-app purchase for Adobe Stock images

When you search for an image on Adobe Stock via CC Libraries panel and place it in your document, you now have a shopping cart icon that enables you to initiate the purchase process right from the asset.

Additionally, the Links panel also displays a shopping cart icon next to un-licensed Adobe stock images placed in your layout. Clicking the cart icon also initiates the purchasing process.

Open-in from Adobe Stock

While searching for an asset on Adobe Stock, in addition to downloading the asset to your Desktop or CC Library, you can directly place the asset in your document.

  • If there is an open document with a frame selected, the Stock asset is added to the frame.
  • If there is an open document with no frame selected, a new frame is created and the Stock asset is added to the frame.
  • If no document is open, a blank document is created in the default format and the Stock asset is added in a new frame.

Start and Recent Files workspaces

Now available in all languages

When you launch InDesign or when you close all InDesign documents, a new Start workspace is displayed. You have convenient access to your recently used files, CC Libraries, and Presets with the Start workspace. You can open the New Document and Open dialogs using the regular shortcuts Ctrl/Cmd + N or Ctrl/Cmd + O.

If you have a document open, you can view the most recent files that you have worked on using the Recent Files workspace (Ctrl/Cmd + O, or Window > Workspace > Recent Files.).

Note: The above Recent Files workspace functionality is switched off by default. To switch on this functionliaty, see the Workspace Basics article.

For more information on the new workspaces, see the article on the new workspaces.

For InDesign-specific information, see the Workspace Basics article.

Publish Online and Creative Cloud for enterprise enablement

  • Publish Online is no longer a technology preview feature.
  • Publish online is now available for enterprise users as well.
  • Support for kerberos proxy has now been enabled.

For more information, see Publish Online.

Adobe InDesign CC 2015.3 Release | March 2016

Publish Online (Technology Preview) enhancements

  • All-new design for the Publish Online Options dialog box. The dialog is now more elegant and less cluttered.
  • Option to hide the Share and Embed button from the published document.
  • Support behind a proxy wall for Publish Online and other Creative Cloud services.
    Note: Kerberos proxy is not supported

For more information, see Publish Online.

Style Override Highlighter

Use the Style Override Highlighter to identify all the paragraph and/or character style overrides applied in your document. You can enable the Style Override Highlighter widget in the Paragraph Styles or Character Styles panel.

For more information, see Highlight character and paragraph style overrides.

Accessibility enhancement

New accessibility options are now available under the Advanced tab while exporting to Adobe PDF (Print). 

  • Display Title: Choose what to display in the title bar of Acrobat when it opens your PDF.
  • Language: Choose the document language for the exported PDF.
Accessibility enhancement
Accessibility options

Save As dialog box retains the default location of the original document

When you opened a document from a previous version of InDesign and saved it in a new version, the default folder location displayed in the Save As dialog was different from the original location of the document. You had to manually navigate to the location of the document to save it. With this release, the default location opened in the Save As dialog will be the location from where the original document was opened.

Adobe InDesign CC 2015.2 Release | November 2015

Publish Online (Technology Preview) enhancements

Now, re-publish edited documents to the same URL or publish a different document to any existing URL. Or, embed your document on any website or blog using the embed code provided. Track views and unique readers in Analytics section of File -> Web Dashboard. Also, allow your users to download the document as a PDF (print). You can also make use of an Advanced setting of specifying a PDF Preset to customize the PDF downloaded by the document viewers.

When you use the embed code for a published document, you can choose the start page of the document. So if a user clicks the embedded link on a web page, your document will open on the selected page number.

For more information, see the article on Publish Online.

Create layouts with the Touch workspace

Design production-ready layouts on-the-go using the new Touch Workspace optimized for your Microsoft Surface Pro, or any Windows 8 (or higher) Touch device. Use intuitive touch gestures to create objects, text boxes, and more with the new InDesign Touch workspace Drawing tool. Include creative assets like images from your Creative Cloud Libraries.

InDesign Touch workspace
The new InDesign Touch workspace Drawing tools

What's more - you can easily switch back to a traditional workspace at any point in time to leverage the full collection of InDesign tools and features.

For a quick tutorial on how you can use the new Touch workspace to comp layouts in a jiffy with simple gestures, see Comp layouts in a touch environment.

For more information, see the article on Touch workspace.

Start and Recent Files workspaces

When you launch InDesign or when you close all InDesign documents, a new Start workspace is displayed. You have convenient access to your recently used files, CC Libraries, and Presets with the Start workspace. You can open the New Document and Open dialogs using the regular shortcuts Ctrl/Cmd + N or Ctrl/Cmd + O.

If you have a document open, you can view the most recent files that you have worked on using the Recent Files workspace (Ctrl/Cmd + O, or Window > Workspace > Recent Files.).

Note: The above Recent Files workspace functionality is switched off by default. To switch on this functionliaty, see the Workspace Basics article.

For more information on the new workspaces, see the article on the new workspaces.

For InDesign-specific information, see the Workspace Basics article.

Work with glyphs more easily

With the latest OpenType enhancements, apply alternate glyphs for a specific character, and convert text to true fractions, directly from an in-context menu.

in-context menu
Apply glyphs using an in-context menu

Plus, search for a glyph in the Glyphs panel by name, by unicode or GID value, or by the specific character.

Glyphs panel
The Glyphs panel

For a quick tutorial on how you can access special font properties of OpenType fonts for greater typographic control, see Work with glyphs more easily.

For more information, see the article on Glyphs and special characters.

Enhancements to Creative Cloud Libraries

Add selected group to CC Library

Add multiple assets from the following CC library categories to a document or the corresponding panel:

  • Colors
  • Character Styles
  • Paragraph Styles
  • Graphics

Right-click on the selected assets and choose the appropriate option from the right-click menu to add them to a document or the corresponding panel.

Add Color theme as a group

Now add the Color themes from the CC Libraries as a color group in the Swatches panel.

Add multi-selected CC library assets

Now right-click on multi-selected assets from the following CC library categories and choose the appropriate option from the right-click menu to add them to a document or the corresponding panel:

  • Colors
  • Character Styles
  • Paragraph Styles
  • Graphics

Searching for assets in your Creative Cloud libraries

Just choose whether to search the current library or all libraries, and then type your search criteria. The results appear in the CC Libraries panel.

Search Adobe Stock from CC Libraries Panel

You’ll see the same search results in the CC Libraries panel that you see on the Adobe Stock website. Download a preview or license an image. 

Edit Original

You can now edit images and graphics that are in your CC Library, no matter which Adobe application they are created in. Simply double-click (or right-click and choose Edit) any image or vector
illustration, and Illustrator will launch with the asset opened for editing. Make your changes, then Save and the asset is updated in your CC Library, so the updated version is available in any Adobe application.

For more information, see the article on Creative Cloud Libraries.

Adobe InDesign CC 2015.1 Release | August 2015

Publish Online (Technology Preview)

The Publish Online technology preview feature now allows you to share the online documents on social networks like Facebook and Twitter or over email with a single click. Your documents can also be embedded on any website or blog using the embed code provided on clicking the embed option on the viewing layout.

The Publish Online technology preview feature now allows you to share the online documents on social networks like Facebook and Twitter or over email with a single click. Your documents can also be embedded on any website or blog using the embed code provided on clicking the embed option on the viewing layout.

Publish Online preview feature
Share online documents using the Publish Online preview feature

Publish Online also includes the following enhancements:

Multiple page spread

Now, if you create an InDesign document that contains spreads with more than two pages, the published document will display multiple pages on a spread in the same way as they are displayed in InDesign

Publish documents with multiple page sizes

Now you can publish documents that contain pages with different sizes. The published document will now maintain the size of individual pages and display the content on the pages appropriately.

Text hyperlinks

Hyperlinks created on text are now supported in published document. InDesign will maintain all types of hyperlinks in the published document:

  • URLs
  • Emails
  • Page destinations
  • TOC markers
  • Index markers
  • Cross references

Image resolution

The image resolution of the published output now supports 96 PPI and is the default value for better quality images in the output.

Mobile & Tablet experience The mobile viewing experience of published InDesign documents has been improved.

  • Smoother page transitions with swipe gesture improvements.
  • Share dialog displays on the full screen
  • Mobile optimized layout of thumbnails for better viewing and accessibility.

The tablet view includes an easy-to-use scrollable thumbnail view.

Mobile and tablet views
Mobile and tablet views


For more information, see the article on Publish Online.

Adobe InDesign CC 2015 Release | June 2015

Mercury Performance Improvements

Everyday tasks are faster thanks to performance enhancements in InDesign. You’ll notice a difference when you zoom or scroll in your documents, and when InDesign generates page thumbnails in the Pages panel.

Publish Online (Technology Preview)

Publish Online is a new technology preview for CC members. With Publish Online, you can repurpose your documents by effortlessly publishing them online. With one click, you can publish a digital version that works on all devices, in any modern browser, without the need to install a plugin. Just provide the document URL to anyone to view the document in a beautiful, yet simple, online reading experience, on any device, and on any platform. You can even share the published document on Facebook.

Publish Online new technology preview
The Publish Online new technology preview

These published documents can be viewed with full fidelity directly on a desktop or tablet web browser with a delightful viewing experience, without requiring any plug-ins.

Full fidelity
View published documents with full fidelity on a desktop or tablet

For an even richer user experience, you can also add buttons, slideshows, animation, audio, and video using the interactive authoring features of InDesign CC.

For more information, see the article on Publish Online.

Enhancements to Creative Cloud Libraries

You can now add the following InDesign categories to your CC libraries:

  • Character styles
  • Paragraph styles
  • Color themes

Note:

In the previous release of InDesign, the CC Libraries feature included the Text Styles category. This category is now renamed to Character Styles. So, if you have created Text Styles in a CC Library, these will now be available under the Character Styles category.

Paragraph and character styles

Now add paragraph and character styles from your documents to the new CC Libraries Paragraph and Character Styles category, respectively.

Simply select the text in your document on which the paragraph or character style is applied and click the Add Paragraph Style or Add Character Style icons in the CC Libraries panel.

Paragraph Styles category
Paragraph Styles category

Character Styles category
Character Styles category


And add one or more character or paragraph styles from the Character or Paragraph Styles panel to the current CC Library by selecting the styles and clicking the new Add to CC Libraries icon.

Add Character Styles to the CC Library
Click to add Character Styles to the CC Library

Add Paragraph Styles to the CC Library
Click to add Paragraph Styles to the CC Library


When you create a new character or paragraph style in InDesign, you can add it directly to a CC Library. Simply, check the Add to CC Library option and select the CC Library.

Add a new Character Style to the CC Library
Add a new Character Style to the CC Library

Add a new Paragraph Style to the CC Library
Add a new Paragraph Style to the CC Library


If you use a character or paragraph style from a CC Library in a document, the style will then be available in the Character Styles or Paragraph Styles panel.

Color Themes

Color themes picked using the Color Themes tool can now be directly added to the CC Libraries Color Themes category.

CC Libraries Color Themes category
Click to add color themes to the CC Libraries Color Themes category

Color swatches

Now add one or more color swatches from the Swatches panel to the selected CC Library by choosing the colors and clicking the new Add to CC Libraries icon.

CC Libraries icon to add color swatches
Click the new Add to CC Libraries icon to add color swatches


When you create a new color swatch in InDesign, you can add it directly to a CC Library. Check the Add to CC Library option and select the CC Library.

New color swatch to a CC Library
Add a new color swatch to a CC Library


Linked Assets with CC Libraries

Graphic assets from CC Libraries (created in other applications such as Illustrator and PhotoShop) can now be placed as linked or copied objects in InDesign.

If a linked object is updated in the CC Library, the update is reflected in the InDesign document. However, in the case of copied objects, updates to the objects in the CC Library are not reflected in the document.

Place linked or copied objects
Place linked or copied objects in InDesign


The links to these placed graphics from CC Libraries will be displayed in the Links panel.

 Links panel
The Links panel


For more information, see the article on Creative Cloud Libraries.

Paragraph shading

New in this release of InDesign CC  

Add colorful highlights that travel with the text on the page. InDesign's new Paragraph Shading feature provides you with the capability to create a shade (or color) behind a paragraph.

You can even shade paragraphs within non-rectangular text frames.

Paragraph Shading
Shade paragraphs in non-rectangular text frames


Use paragraph shading in the final document to draw reader’s attention (focus) to a paragraph. Or in document review workflows as a means to highlight a specific paragraph.

Paragraph shading to focus a viewer's attention
Use paragraph shading to focus a viewer's attention

The benefit of using paragraph shading is that since the paragraph shading is applied on text, the shading will move or resize as the text is moved or resized.

For more information, see the article on Create a shade (or color) behind a paragraph.

Images in Table Cells

New in this release of InDesign CC  

Now when you place an image in a table, InDesign considers the cell an image frame. All frame and fitting options apply, making it much easier to create tables that include both text and graphics. You can drag or drop images into table cells, or place them using the content collector.

 Add graphics to a table
Place an image in a table cell

Images can be placed inside empty cells by simply dropping them on the cells with the placegun or the content collector.

For more information, see the article on Add graphics to a table.

Adobe Stock

New in this release of InDesign CC  

Adobe Stock is a new service that sells millions of high-quality, royalty-free photos, illustrations, and graphics.

Adobe Stock service
Adobe Stock service

You can launch Adobe Stock from within InDesign and then search for photos, illustrations, and vectors.

When you've found the asset that you need, you can then download it to your desktop or a selected InDesign CC Library.

When the CC Library is syncd with the new Adobe Stock assets, you can then include these in your InDesign documents.

For more information, see the article on Using Adobe Stock.

The Export Adobe PDF dialog now includes the following Acrobat view and layout default for PDFs exported from InDesign:

Acrobat view
The Export PDF dialog Acrobat view default

In the View drop-down list, choose the PDF view options:


Dialog Layout default
The Export PDF dialog Layout default

Note:

Until InDesign CC 2014, these view options were only available in the Export to Interactive PDF dialog.

For more information, see the article on General options for PDFs.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy