What's covered
Learn how to solve problems that can occur when you print or export to PDF from InDesign.
On this page

    Work through the tasks in this document in order, stopping when you've solved your problem.

    You can also find known printing and exporting issues and solutions at https://helpx.adobe.com/indesign.html.

    When attempting to resolve a printing or exporting issue, the first step is to determine the conditions under which the problem occurs. For example, was the error a one-time problem, or can it be reproduced
    consistently when printing or exporting all documents, some documents, or a specific document? The steps and tests below help you define how and when your issue occurs so that you can find a solution.

    1. Restart your computer.

    If the error doesn't recur, a temporary communication problem, low system resources, or other temporary environmental factors could have caused it. If you can print or export without problems after you first restart the computer, but the error occurs again later, troubleshoot the problem at the system level.

    2. Turn your printer off and on.

    If the error doesn't recur, an issue with the printer's memory could have caused the problem. If the error recurs, move on to step 3.

    3. Create a new sample document.

    If you can successfully print or export a new document, but not the original document, troubleshoot the problem at the document level.

    4. Print or export using a different application.

    If you can print from another application (e.g., WordPad, TextEdit), or export/save as a PDF from another application (e.g., Illustrator, Photoshop), troubleshoot the problem at the application level.

    5. Print to a different printer.

    If another printer is available, try printing the document to that printer. If that works, then make sure that the original printer is turned on and is online. Remove and reconnect the printer cables, and then run a self-test on the printer to check for mechanical failure or damaged cables. If none of these steps identifies the problem, troubleshoot the problem at the system level.

    6. Use a different method to create the PDF file.

    • If your issue occurs when exporting to PDF from InDesign to Acrobat Standard, Pro, or Pro Extended, try printing to Adobe PDF Printer. (If you're using Mac OS v10.6 or later with Acrobat 9, see Acrobat 9 Save As Adobe PDF support.)
    • If your issue occurs when you use the Print function to create your PDF file, choose File > Export to PDF instead.


    If the error doesn't occur when you print or export a new document, the original document's print or export settings could be invalid, an object or font used in the document could be damaged, or the structure of the document could be damaged. Try one or more of the following steps.


    Depending on which printer you use, locations of settings may vary and may be different from what's listed in the following procedures. Check your printer documentation.   

    1. Export to IDML (InDesign CS4 and later) or INX (InDesign CS3 and earlier).

    The document may be damaged. Damaged documents may occur after being converted from a previous version of InDesign or from a QuarkXPress document. Exporting to InDesign Markup Language (IDML) or InDesign Interchange format (INX) can eliminate problematic data.

    2. (PostScript printers only) Enable PostScript error handling.

    1. Choose File > Print.
    2. Click the Setup button.
    3. If the following dialog appears, click OK: "If the desired print setting is available in InDesign's Print dialog box, please set it there to avoid printing conflicts."
    4. Right-click the printer and choose Properties.
    5. In the General tab, click Printing Preferences.
    6. Click Advanced.
    7. Expand Document Options and then expand PostScript Options. If Send PostScript Error Handler is not set to Yes, click it and choose Yes from the pop-up menu.
    Mac OS X
    1. Choose File > Print.
    2. Click the printer.
    3. Choose Error Handling from the menu below the Presets menu.
    4. Select Print Detailed Report, and then click Print.

    If a PostScript error is causing the problem, the PostScript error handler prints a page with error information. See Troubleshoot PostScript errors.

    3. Exclude graphics from the document.

    Exclude graphics when you print the document
    1. Choose File > Print.
    2. Click Graphics, and then choose None from the Send Data menu.
    3. Click Print.
    Exclude graphics when you export the document
    1. Choose File > Export and select Adobe PDF (Print) as the format or "Save as type."
    2. Choose a location and click Save.
    3. Click Advanced, and then select all three Omit for OPI check boxes: EPS, PDF, and Bitmap.
    4. Change the PDF standard to None to allow exclusion of images.
    5. Click Export.

    If the document prints or exports successfully, one or more of the graphic elements on the page could be damaged. Remove 50% of the graphics by deleting pages, or graphic frames on a single page. Then, print or export the document after each change to determine whether a damaged graphic in the group removed is causing the error. If the document prints or exports after a change, revert the change and remove the other 50% of remaining pages or graphics. Confirm that the error recurs, then delete 50% again, and so on. Once you identify graphics that consistently produce the error, delete and replace them. You may need to reexport a graphic from the application in which you created it.

    A successful print job without the graphics can also indicate inadequate printer memory. Symptoms include fonts being substituted, missing graphics, or incomplete printouts. Try printing in ranges of pages, or simplify the publication to see if it prints with fewer graphics. Or try printing at a lower resolution.


    If the document contains only graphical elements, then you receive a blank page when you print only if the option to print blank pages is enabled in InDesign. Select Print Blank Pages in the General section of the Print dialog box.

    4. Exclude or minimize fonts.

    Exclude fonts when you print
    1. Choose File > Print.
    2. Click Graphics.
    3. In the Fonts section, choose None from the Download menu.
    4. Click Print.
    Minimize fonts when you export to PDF

    You can't exclude fonts when exporting, but you can minimize the number of fonts used.

    1. Choose Type > Find Font.
    2. In the Fonts in Document list, click the first font, then hold the Shift key and click the last font to select all the fonts in the list.
    3. In the Replace With: Font Family list, choose a font that you know works in other documents, such as Arial or Verdana.
    4. Click Change All.
    5. Click Done.
    6. Choose File > Export and select Adobe PDF (Print) as the format.
    7. Choose a location and click Save.
    8. Click Export.

    If the document successfully prints or exports, the problem could be related to one of the fonts used in the document. If the document uses a large number of fonts, excluding the fonts makes the document less complex. Save the document as a new name, and then test the fonts one at a time to determine if they are damaged. If a font consistently demonstrates a problem, check for multiple active instances of the font, or download the font from the manufacturer again to ensure the font isn't corrupted.

    To view the status of links, choose Window > Links. Unlink or relink any files in which the filename is preceded with a question mark or other symbol. For more information about InDesign links, see Managing graphics links.

    6. Disable settings.

    Sometimes errors are a result of a particular function in the print or export process, as it is handling some specific content in the document. Eliminate as many of these types of settings as possible. If
    eliminating settings resolves the issue, enable them again in groups to isolate the problem to a particular setting.


    Depending on which printer you're using, some of the settings may be unavailable.

    Choose File > Print to open the Print dialog box. Then change the following settings in the following panes:

    General pane
    • Set copies to 1.
    • Select Pages to disable Spreads.
    • Clear Print Master Pages, Print Non-printing Objects, and Print Visible Guides and Baseline Grids.
    • Set print layers to Visible & Printable Layers.
    Setup pane
    • Set paper size to Defined by Driver.
    • Set scale width and height to 100%.
    • Disable Thumbnails and Tile.
    Marks and Bleed pane
    • Disable Marks, Bleed, and Slug.
    Output pane
    • Set color to Composite Leave Unchanged.
    • Disable Trapping, Text as Black, and Simulate Overprint.
    • In the Ink Manager, disable Ink Aliasing.
    Graphics pane
    • Set images to Send Data to None or All.
    • Set fonts to Download to None or All.
    • Set PostScript to Level 2.
    • Set data format to ASCII.
    Color Management pane
    • Set color handling to Let PostScript Printer Determine Colors.
    • Enable Preserve CMYK Numbers.
    Pages panel (outside the Print dialog box)

    Select all the pages, right-click, and then choose Page Attributes > Spread Flattening > None (Ignore Transparency).

    7. Troubleshoot plug-ins.

    Remove third-party plug-ins from the InDesign Plug-ins folder, and then restart InDesign. If the problem recurs, move the plug-ins back to the InDesign Plug-ins folder. If the problem doesn't recur, identify conflicting plug-ins:

    1. Choose Help > Configure Plug-Ins (Windows) or InDesign > Configure Plug-Ins (Mac OS).
    2. Select All Plug-Ins for the Set and then clear all the options in the Display section except Third Party. Create a list of these plug-ins.
    3. Quit InDesign and move these plug-ins out of the Plug-in folder:
      • Windows: /Program Files/Adobe/Adobe InDesign [Version]/Plug-Ins
      • Mac OS: /Applications/Adobe InDesign [Version]/Plug-Ins
    4. Restart InDesign and try to re-create the problem.
      • If the problem doesn't recur, repeat steps 3 and 4, adding some third-party plug-ins back to the Plug-Ins folder.
      • If the problem recurs, contact the developer of the plug-in you last moved to inquire about an update.

    For more information, see Troubleshoot InDesign third-party plug-ins.

    8. Print or export from a new user account.

    Sometimes user accounts can become corrupted and prevent an application from reading or writing to certain files and folders. Create a new user account (don't delete your original one), log in to the new account, and try to print or export the document again.


    Choose Start > Control Panel > User Accounts.

    Mac OS X

    Choose Apple menu > System Preferences > Users & Groups.

    9. Determine if the document is damaged.


    If you receive an error when printing any InDesign document, try one or more of the following tasks to identify the cause of an application-level problem.

    1. Re-create your InDesign preference files.

    When InDesign is behaving erratically, deleting preferences (also referred to as “trashing preferences” or “removing preferences”) and re-creating them often solves the problem.

    There are two ways to re-create preferences:

    • Automatically: This method quickly deletes your current preference files and then regenerates a new set of default preference files. However, any custom settings you may have had are lost.


    • Manually: If you don't want to lose your custom settings, rename your current preference files before regenerating a new set of default preference files. That way, if new preferences don't solve your print or export problem, you have a backup of your original preference files (including any custom settings), which you can use to replace the new preference files.
    Re-create InDesign preference files automatically

    Re-creating InDesign preference files deletes previous preference data, including any custom settings. If you don't want to lose your custom settings, re-create your preference files manually.

    1. Quit InDesign.
    2. Relaunch InDesign and immediately hold down the appropriate keys for your OS:
      • Mac OS: Control+Option+Command+Shift
      • Windows: Control+Alt+Shift
    3. A dialog box appears, asking if you want to delete InDesign preference files. Click Yes. InDesign launches with regenerated default preferences.
    Re-create InDesign preference files manually

    Rename the two preference files (e.g., change "InDesign SavedData" to "InDesign SavedData backup," and "InDesign Defaults" to "InDesign Defaults backup"). The preference files are located here:

    • Mac OS X

      InDesign Defaults: 

      Users/[user]/Library/Preferences/Adobe InDesign/Version [version]/[language]/InDesign Defaults

    InDesign SavedData:

    Users/[user]/Library/Caches/Adobe InDesign/Version [version]/[language]/InDesign SavedData

    • Windows XP

      InDesign Defaults:

      /Documents and Settings/[user]/Application Data/Adobe/InDesign/Version [version]/InDesign Defaults

    Hidden by default. Learn how to show hidden files.

    InDesign SavedData:

    /Documents and Settings/[user]/Local Settings/Application Data/Adobe/InDesign/Version[version]/Caches/InDesign SavedData

    • Windows 7 and 8

    InDesign Defaults:

    C:\Users\DC-work\AppData\Roaming\Adobe\InDesign\Version 11.0\[language]\InDesign Defaults

    Hidden by default. Learn how to show hidden files.

    InDesign SavedData:

    /Users/[user]/AppData/Local/Adobe/InDesign/Version[version]/[language]/Caches/InDesign SavedData

    Restart InDesign. InDesign creates a new set of default preference files.

    If your print or export problem persists, then you can restore your original preferences by renaming your old preference files back to their original names: InDesign SavedData and InDesign Defaults.

    2. (Windows only) Make sure your printer driver is up-to-date.

    Install the most recent driver for your printer:

    3. (Windows, PostScript printer only) Optimize PostScript for speed.

    1. Choose File > Print.
    2. Click Setup, select a printer, click Preferences, and then click Advanced.
    3. Expand Document Options, and then expand PostScript Options.
    4. Choose PostScript Output Option.
    5. Choose Optimize for Speed from the pop-up menu, and then click OK.
    6. Click OK and then click Print.

    4. Disable page protection in your printer.

    See the documentation included with the printer for instructions on how to disable this feature.

    5. Connect your computer to the printer.

    If the problem occurs when you print over a network, connect the computer directly to the printer and try printing again.

    If you can't connect directly to the printer, save the document as a PostScript file. Using the command prompt on a computer that can be connected directly to a printer, send the file to the printer. 

    6. Save as PDF to a local hard drive.

    If the problem occurs when you export as PDF to a network location, try saving as PDF to a local hard drive.

    Network instability or premissions issues can cause problems when exporting to mounted network volumes. If you can export the file to a local drive, but not a network location, ask your IT department to investigate the problem.

    Resolve problems printing to a PostScript printer

    If you're experiencing problems printing to a PostScript printer, try one or more of the following tasks. Print after each task.

    1. Use an updated printer driver.

    Download the latest PostScript printer driver for Mac or Windows.


    If you use a network printer, you could be using a printer driver that's compatible with the print server's operating system but not with your computer's operating system. To install a printer driver that's compatible with your operating system, reconfigure the network printer using the Add Printer wizard. See Install a printer driver that is compatible with your operating system.

    2. Use an updated PPD file.

    A PostScript Printer Description (PPD) file describes the capabilities of a PostScript printer for settings such as margins, color, and resolution. Incorrect or outdated PPD files can increase print times. Configure your printer with the PPD file that the printer manufacturer recommends.

    To get a PPD file, contact the printer manufacturer or download it from the Adobe website.

    3. (Windows only) Set up the printer to output optimized PostScript code.

    For Windows 7:

    1. Choose Start > Devices and Printers.
    2. Right-click and choose Printing Preferences > Advanced.
    3. Expand the document options, and then expand the PostScript options.
    4. Set the PostScript output option to Optimize For Portability.
    4. Create more free disk space.

    Make sure that plenty of free hard disk space is available. Try to keep at least 10 percent of your total hard disk space free. To create more space, search for and delete temporary (.tmp) files from your computer, and clear the disk cache that your web browser uses. For instructions about clearing the disk cache, see the documentation for your browser.

    To learn other ways to free up disk space, see the documentation for your OS (e.g., Tips to free up drive space on your PC for Windows, or Increase disk space for Mac OS).

    5. Print from a local printer.

    If you print to a network printer, try printing the file from a computer that is connected directly to a local printer. If the file prints correctly, network-related issues could be the cause of your problem. Contact the network administrator for assistance.

    6. (Windows only) Install a printer driver that is compatible with your operating system.

    If you use a network printer, then install a printer driver that is compatible with your operating system. Print servers don't always provide drivers for operating systems running on client computers. So, you could be using a printer driver that is appropriate for the print server's operating system but not for your computer's operating system.

    For Windows 7:

    1. Choose Start > Devices and Printers.
    2. Click Add a Printer.
    3. Select Add a Local Printer.
    4. Choose Create a New Port > Local Port > Next.
    5. Enter the port name (e.g., \\[printservername]\[printername]) and click OK.
    6. Follow the onscreen instructions to install a driver that matches the brand and model of your network printer.

    Resolve problems printing to a non-PostScript printer

    If you have problems printing to a non-PostScript printer, try one or more of the following tasks. Print after each task.


    Some of these solutions require you to change the printer driver properties. The locations for specific properties vary by printer and by printer driver. Contact the printer manufacturer or refer to the printer documentation for more information.

    1. Print as bitmap.
    1. Choose File > Print.
    2. Ensure you have a non-PostScript printer selected, then select the Advanced pane.
    3. Select the Print as Bitmap checkbox and select an appropriate resolution for your printer.
    2. Ensure that the printer has enough memory.

    To print at 300 dpi, the printer should have at least 2 MB of available RAM. To print at 600 dpi, the printer should have at least 4–6 MB of RAM. For instructions on determining available printer memory, see the printer documentation.

    3. Use the printer's PostScript mode, if available.

    For details, see the printer documentation.

    4. (Windows only) Switch to a standard SVGA driver.

    Switch to the standard Windows SVGA driver to determine if your third-party video driver causes the problem. If the error doesn't occur when you use the standard SVGA driver, then contact the video card manufacturer for an updated driver. If you already use the current version, then try using a different video resolution (e.g., 1024 x 768 instead of something higher).

    If you can't get anything to print or export as PDF from any application, contact Apple Technical Support, Microsoft Technical Support, or the printer manufacturer. Always check the physical connection between the printer and the computer before calling, as the solution could be as simple as reconnecting a loose cable.

    Also, consider what has changed on the system recently that could be affecting the printing or exporting process. For example, have you performed any of the following tasks lately?

    • Updated your hardware, or added or removed hardware components
    • Added, updated, or deleted software
    • Installed or deleted fonts
    • Connected to a network
    • Cleaned up or erased files from the hard drive
    • Encountered random system errors, or errors in other applications

    Often, a change to the system directly corresponds to the appearance of a printing problem. Keep a record of changes made to the system as a resource for troubleshooting printing and other problems.

    Back to top