Place Excel Files

InDesign includes a filter for importing Excel files. The Spreadsheet Import Filter imports only text and not the graphic representation of the worksheet (that is, charts, graphs, borders), giving you the most flexibility for arranging the data in a layout.

InDesign CS2 includes the following filters for importing Excel files:

  Import Filter File name Import Formats
InDesign CS2 for Windows Reader for Excel Reader for Excel.smrd Excel 97Excel 98Excel 2000Excel 2002Excel 2003Excel X
InDesign CS2 for Mac OS Reader for Excel Reader for Excel Excel 97Excel 98Excel 2000Excel 2002Excel 2003Excel 2004Excel X

InDesign CS and 2.x include the following filters for importing Excel files:

  Import Filter Filename Import Formats
InDesign CS and 2.x for Windows Reader for Excel Reader for Excel.smrd Excel 97Excel 98Excel 2000Excel 2002Excel X
InDesign CS and 2.x for Mac OS Reader for Excel Reader for Excel Excel 97Excel 98Excel 2000Excel 2002Excel X

Note: These filters work across platforms with Excel files. For example, you can import an Excel 2000 spreadsheet into InDesign for Mac OS, even though Excel 2000 is not available in Mac OS.

To import an Excel file into InDesign:

1. Save the Excel spreadsheet in a format supported by InDesign. (See the chart above for compatible formats.) Close the Excel file.

2. In InDesign, open the destination document.

3. Choose File > Place and navigate to the Excel file.

4. If you are placing a worksheet, leave the Cell Range field blank to import the entire sheet or, to import a selected range of cells, do one of the following:

-- Enter the upper left and lower right cell labels separated by a colon (for example, B3:H17).

-- Enter a named range or choose a named range from the Cell Range pop-up menu.

5. Select any text import options you want to use. For detailed information on these options, see "Microsoft Excel Import Options" in InDesign Help.

6. Click Place.

Unsupported items and features

The following items and features aren't supported by the InDesign import filters:

2003, 2004 Excel 2000, 2002,X Excel 97-98 Excel 4.0-7.0
Document propertiesNotesExcel drawingsObjectsOutlinesPatternsFile protection Named stylesSplit screensFreeze panesCenter across selectionUnwrapped text Manual page breaksHorizontal fillHeaders and footersPage numbersInserted or Paste Special objectsMacrosModulesDialogsCommentsText boxesConditional formattingShrink to fit Center across selectionChartsCommentsConditional formattingDialogsDocument propertiesExcel drawingsFreeze panesHeaders and FootersHorizontal fillInserted or Paste Special ObjectsJustified textManual page breaksMacrosModulesNamed stylesNotesOutlinesPage numbersPatternsPictures or GraphicsObjectsProtections (password protected files are not imported)Shrink to fitSplit screensText boxesWrap text Background colorsBordersCenter across selectionChartsCommentsConditional formattingDialogsDocument PropertiesExcel drawingsFreeze panesHeaders and footersHidden textHorizontal fillsHyperlinksJustified textLocked/unlocked cellsMacrosManual page breaksModulesNamed stylesNotesObjectsOrientationOutlinesPage numbersPatternsPictures or graphicsProtectionsShadingShrink to fitSplit screensSubscriptsSuperscriptsText boxesVertical alignmentsVertical textWrap text Center across selectionChartsDialogsExcel drawingsFreeze panesHidden textHorizontal fillLocked/unlocked cellsJustified textMacrosModulesNamed stylesNotes ObjectsOutlinesPage breaksPatternsPictures or graphicsProtectionsSplit screensSubscriptsSuperscriptsText boxesVertical alignmentsVertical textWrap text

For further information on what can and can't be imported, see the Filters ReadMe.pdf file in the InDesign application folder.

Import Excel files as PDF files

Because InDesign doesn't import formatting in spreadsheet files, you can convert an Excel spreadsheet file to PDF, and then place the PDF file into InDesign.

Note: To make a PDF file from an Excel file, you should use Adobe Acrobat Distiller, which isn't included with InDesign. To purchase Adobe Acrobat (which includes Distiller), visit the Adobe website at www.adobe.com .

Copy or drag Excel charts into InDesign CS2 documents

You can copy and paste--or drag--an Excel chart to an InDesign CS2 document as a vector graphic. To do so, start InDesign and Excel, and open each of the files side by side. Select the chart in Excel. Then, either copy it in Excel and paste it in InDesign, or drag it directly to the InDesign document.

Import Excel charts or graphs as EPS files

Use Adobe Illustrator to save an EPS version of Excel chart or graph, and then import the EPS file in InDesign:

1. In Excel, select the chart or graph and choose Edit > Copy.

2. Start Illustrator.

3. Choose File > New to create a new document, select the appropriate Color Mode setting, and then click OK.

4. Choose Edit > Paste.

5. Choose File > Save As.

6. Choose Illustrator EPS (eps) from the Format pop-up menu.

7. Name the file, and then click Save.

8. In InDesign, choose File > Place to import the EPS file in your document.

Availablility of Excel/Lotus: Mac OS Windows Excel 4.0 Y Y Excel 5.0 Y Y Excel 95 Y Y Excel 97 N Y Excel 98 Y N Lotus 1-2-3 N YInDesign

Additional Information

321537 : Pages blank or missing in PDF file created from Excel workbook with Acrobat product (4.0 or later for Windows)

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy