La funzione di aggancio vi permette di allineare automaticamente gli elementi tra di loro. In Animate è possibile allineare gli oggetti sullo stage in tre modi:

  • L’opzione Aggancia agli oggetti consente di agganciare gli oggetti direttamente ad altri oggetti lungo i bordi.
  • L’opzione Aggancia ai pixel consente di agganciare gli oggetti direttamente a singoli pixel o linee di pixel sullo stage.
  • L’opzione Allinea agganciato consente di agganciare gli oggetti in base a una tolleranza di aggancio specificata, ossia a un limite preimpostato tra i diversi oggetti o tra gli oggetti e il bordo dello stage.
  • L’opzione Aggancia bitmap a pixel allinea le bitmap ai pixel più vicini in fase di creazione, in modo da renderle più nitide nell’output finale.

Nota: potete anche agganciare alla griglia e alle guide.

 

Attivare o disattivare l'aggancio agli oggetti

Per attivare la funzione di aggancio agli oggetti, utilizzate il modificatore Aggancia agli oggetti dello strumento Selezione o il comando Aggancia agli oggetti del menu Visualizza.

Se il modificatore Aggancia agli oggetti per lo strumento Selezione è attivo, quando si trascina un elemento sotto il puntatore viene visualizzato un piccolo anello nero. L'anello da piccolo diventa grande quando l'oggetto si trova entro la distanza di aggancio di un altro oggetto.

  1. Selezionate Visualizza > Aggancio > Aggancia agli oggetti. Accanto al comando, quando è attivato, appare un segno di spunta.

    Quando spostate o rimodellate un oggetto, la posizione dello strumento Selezione sull'oggetto fornisce il punto di riferimento per l'anello di agganciamento. Ad esempio, se spostate una forma piena trascinandola vicino al centro, il punto centrale si aggancia ad altri oggetti. Ciò è particolarmente utile per l'aggancio di forme a tracciati di movimento per l'animazione.

    Nota:

    per un migliore controllo del posizionamento di un oggetto durante l'aggancio, iniziate a trascinare da un punto centrale o d'angolo.

Aggancia bitmap a pixel

Per attivare l’aggancio delle bitmap, utilizzate il comando Aggancia bitmap a pixel, nel menu Visualizza. Le bitmap saranno inserite in posizioni con valori di coordinate interi (senza decimali).

  1. Selezionate Visualizza > Aggancio > Aggancia bitmap a pixel.

  2. Un segno di spunta accanto a questa opzione indica che la funzione è attivata. Se la spunta è disattivata, potete inserire le bitmap in qualsiasi posizione.

    Aggancia bitmap a pixel in fase di creazione

Regolare le tolleranze di aggancio agli oggetti

  1. Selezionate Modifica > Preferenze (Windows) o Animate > Preferenze (Macintosh), quindi fate clic su Disegno.

  2. Nelle impostazioni Disegno, regolare l'impostazione Collega linee.

Usare l'aggancio ai pixel

Per attivare la funzione di aggancio ai pixel, utilizzate il comando Aggancia a pixel nel menu Visualizza. Se l'opzione Aggancia a pixel è attiva, quando l'ingrandimento della visualizzazione è impostato su un valore pari a 400% o superiore viene visualizzata una griglia di pixel. La griglia mostra i singoli pixel che appariranno nell'applicazione Animate. Quando create o spostate un oggetto, questo è agganciato alla griglia di pixel.

Se create una forma i cui bordi ricadono tra i limiti dei pixel, ad esempio se utilizzate un tratto con una larghezza decimale (ad es. 3,5 pixel), l'opzione Aggancia a pixel esegue l'aggancio ai limiti dei pixel, non al bordo della forma.

  • Per attivare o disattivare l'aggancio automatico ai pixel, selezionate Visualizza > Aggancio > Aggancia a pixel. Se l'ingrandimento è impostato su un valore pari a 400% o superiore, viene visualizzata una griglia. Accanto al comando, quando è attivato, appare un segno di spunta.

  • Per attivare o disattivare temporaneamente l'aggancio ai pixel, premete il tasto C. Quando rilasciate il tasto C, l'aggancio ai pixel torna allo stato selezionato con Visualizza > Aggancio > Aggancia a pixel.

  • Per nascondere temporaneamente la griglia di pixel, premete il tasto X. Quando rilasciate il tasto X, la griglia di pixel viene nuovamente visualizzata.

 

Modifica aggancio

Quando selezionate le impostazioni di allineamento dell'aggancio, potete impostare la tolleranza di aggancio tra i bordi orizzontale o verticale degli oggetti oppure tra i bordi degli oggetti e il bordo dello stage. Potete anche attivare l'allineamento dell'aggancio tra i centri orizzontale e verticale degli oggetti. Tutte le impostazioni per l'allineamento dell'aggancio sono misurate in pixel.

  1. Selezionate Visualizza > Aggancio > Modifica Allinea agganciato.
  2. Nella finestra di dialogo Modifica aggancio, selezionate i tipi di oggetti a cui volete agganciare gli elementi. Selezionate Salva predefiniti per salvare le impostazioni specificate nel file .fla. Le impostazioni salvate nel documento attivo vengono mantenute nel nuovo documento.

    Modifica aggancio

    Nella finestra di dialogo Modifica aggancio, selezionate i tipi di oggetti a cui volete agganciare gli elementi.
  3. Fate clic sul pulsante Avanzate e selezionate le opzioni seguenti:
    • Per impostare la tolleranza di aggancio tra gli oggetti e il bordo dello stage, immettete un valore in Bordo stage.

    • Per impostare la tolleranza di aggancio tra i bordi orizzontale o verticale degli oggetti, immettete un valore in Orizzontale, Verticale o in entrambi.

    • Per attivare Allineamento centrato orizzontale o Allineamento centrato verticale, selezionate una o entrambe le opzioni.

Attivare Allinea agganciato

Con l'allineamento dell'aggancio attivato, quando l'oggetto trascinato si posiziona alla distanza stabilita dalla tolleranza di aggancio specificata, sullo stage vengono visualizzate delle linee punteggiate. Ad esempio, se impostate la tolleranza di aggancio Orizzontale su 18 pixel, ossia l'impostazione predefinita, viene visualizzata una linea punteggiata lungo il bordo dell'oggetto che state trascinando quando questo si trova a una distanza di esattamente 18 pixel da un altro oggetto. Se attivate l'opzione Allineamento centrato orizzontale, viene visualizzata una linea punteggiata lungo i vertici del centro orizzontale dei due oggetti quando i vertici risultano allineati con precisione.

  1. Selezionate Visualizza > Aggancio > Allinea agganciato. Accanto al comando, quando è attivato, appare un segno di spunta.

Creare un livello guida

Per agevolare l'allineamento degli oggetti nelle operazioni di disegno, create dei livelli guida e allineate gli oggetti presenti sugli altri livelli a quelli creati sui livelli guida. I livelli guida non vengono esportati né visualizzati in un file SWF pubblicato. Potete assegnare la funzione di livello guida a qualsiasi livello, che viene contrassegnato da un'icona a forma di guida a sinistra del nome.

  1. Selezionate il livello e fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) e scegliete Guida dal menu di scelta rapida. Per convertire nuovamente il livello in un livello normale, selezionate di nuovo Guida.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online