참고:

After Effects CS6의 OpenGL 기능은 이전 버전의 OpenGL 기능과 다릅니다. 이 문서는 After Effects CS4 ~ CS5.5에만 해당됩니다. After Effects CS6 GPU 기능에 대한 자세한 내용은 이 비디오를 참조하십시오.

이 문서는 After Effects를 사용하는 동안 발생하는 OpenGL 관련 문제를 해결하는 데 도움이 될 수 있습니다. OpenGL 문제는 다음을 비롯한(이에 국한되지 않음) 다양한 방식으로 나타날 수 있습니다.

  • Adobe After Effects를 시작하면 충돌하거나 오류 없이 닫힙니다.
  • 시간 표시줄을 문지르거나, 구성을 미리 보거나 렌더링할 때 충돌하거나 중단됩니다.
  • OpenGL 미리 보기를 사용하도록 설정한 상태에서 효과 설정을 변경하면 충돌합니다.
  • OpenGL 미리 보기를 사용하거나 사용하지 않도록 설정하면 충돌하거나 중단됩니다.
  • 구성 창을 다시 그리는 데 다소 시간이 소요됩니다.
  • 가공물 또는 "가비지" 픽셀 블록이 구성 창에 그려집니다.
  • 구성 창은 OpenGL 미리 보기를 켰을 때와 껐을 때 다르게 그려집니다.
  • 다음 중 하나와 같은 오류 메시지가 표시됩니다.

    "After Effects 경고: OpenGL 명령을 처리하는 동안 문제가 발생했습니다."

    "'0x00fe1940'의 명령이 '0x000000000'에서 메모리를 참조했습니다. 이 메모리를 '읽을 수 없습니다."

    "AE_OpenGL: 그림자 맵을 생성하지 못했습니다(5065::0)."

    "이 구성이 OpenGL 하드웨어에 비해 너무 복잡합니다."

    "After Effects 오류: AE_OpenGL: 텍스처 만들기 오류. (5065 :: 0)"

OpenGL용 After Effects에서 미리 보기 기본 설정을 구성하는 방법과 OpenGL로 렌더링할 수 있는 After Effects의 기능 목록에 대해서는 After Effects 도움말의 OpenGL로 렌더링을 참조하십시오.

이 문서를 최대한 활용하려면 작업을 순서대로 수행하십시오. 오류나 다른 문제를 포함하여 수행하는 작업과 각각의 결과를 기록하십시오. Adobe 기술 지원에서는 사용자가 전화를 하는 경우 이 정보를 사용하여 더 나은 지원을 제공할 수 있습니다.

이 문서의 일부 절차를 수행하려면 관리자 권한으로 로그온해야 합니다.

Windows의 경우 해당 프로시저 중 일부에서는 숨겨진 파일 및 숨겨진 폴더를 찾아야 합니다. 일부 프로시저에서는 확장자를 포함하는 전체 파일 이름으로 파일을 찾아야 합니다(예: example_filename.ini). 기본적으로 Windows 탐색기는 인식되는 숨겨진 파일, 숨겨진 폴더, 파일 확장자를 보여주지 않습니다. 자세한 내용은 Windows의 숨겨진 파일 및 폴더 표시를 참조하십시오.

Windows Vista의 경우 이 문서에서 제어판을 언급하는 단계가 클래식 보기와 관련이 있습니다. 제어판을 클래식 보기로 전환하는 내용과 여러 다른 일반적인 OS 절차에 대한 자세한 내용은 일반적인 OS 절차를 참조하십시오.

이러한 작업은 OpenGL의 일반적인 문제 대부분을 해결하는 데 도움이 될 수 있습니다. 다음 작업을 수행하기 전에 개인 파일(예: 사용자가 만든 After Effects 파일)을 모두 백업하십시오. 시스템 오류가 발생하여 메모리를 새로 고친 후에는 항상 컴퓨터를 다시 시작하십시오. 다시 시작하지 않고 작업을 계속하면 컴퓨터에서 문제가 더 복잡해질 수 있습니다.

1. After Effects를 최신 버전으로 업데이트

업데이트를 확인하려면 [도움말] > [After Effects의 업데이트]를 선택합니다.

2. 컴퓨터 시스템이 After Effects의 최소 요구 사항에 맞는지 확인하십시오.

After Effects의 시스템 요구 사항 목록에 대해서는 Adobe After Effects 시스템 요구 사항 페이지를 참조하십시오.

3. 비디오 카드 및 드라이버가 OpenGL 요구 사항을 충족하는지 확인하십시오.

After Effects에서 OpenGL을 사용하려면 OpenGL 2.0을 지원하는 OpenGL 카드가 있어야 합니다.

카드가 지원하는 OpenGL 버전을 확인하려면 [미리 보기] 기본 설정에서 [OpenGL 정보] 단추를 클릭합니다. Mac OS에서 [After Effects] > [기본 설정] > [미리 보기]를 선택합니다. Windows에서 [편집] > [기본 설정] > [미리 보기]를 선택합니다.

지원되는 OpenGL 하드웨어에 대한 자세한 내용은 GPU(CUDA, OpenGL) 기능을 참조하십시오.

최신 비디오 카드 드라이버는 카드의 OpenGL 기능을 향상할 수 있습니다. 아래의 비디오 카드 드라이버 업데이트를 참조하십시오.

4. OpenGL을 사용하지 않도록 설정하여 문제의 원인인지 여부를 확인합니다.

OpenGL 미리 보기를 사용하지 않도록 설정하려면:

  1. [After Effects] > [기본 설정] > [미리 보기(Mac OS)] 또는 [편집] > [기본 설정] > [미리 보기(Windows)]를 선택합니다.
  2. [OpenGL 사용] 옵션을 선택 취소합니다.

참고: OpenGL은 After Effects의 일부 기능을 지원하지 않으며 OpenGL 미리 보기를 사용할 때와 소프트웨어에서 렌더링되는 미리 보기를 사용할 때 구성 모양이 다를 수 있습니다. OpenGL이 지원하는 기능 목록에 대해서는 After Effects 도움말의 [렌더링 및 내보내기] 섹션에서 OpenGL로 렌더링을 참조하십시오.

5. After Effects 플러그인 폴더에서 OpenGL 플러그인을 제거합니다.

OpenGL이 문제의 원인인지 여부를 확인하려면 OpenGL 플러그인을 제거한 후 After Effects를 다시 시작합니다.

OpenGL 플러그인을 제거하려면:

  1. After Effects 종료.
  2. Mac OS: Applications/Adobe After Effects CS4/Plug-ins/Extensions 폴더에서 바탕 화면으로 AE_OpenGL.plugin 파일을 드래그합니다.

    Windows: C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Plug-ins\Extensions 폴더에서 바탕 화면으로 AE_OpenGL.AEX 파일을 드래그합니다.
  3. After Effects를 다시 시작합니다.

문제가 재발하면 OpenGL이 원인이 아닌 것입니다. OpenGL 플러그인을 원래 위치로 다시 드래그합니다. 문제가 재발하지 않으면 문제의 원인이 OpenGL인 것입니다. 아래의 비디오 카드 드라이버 업데이트를 참조하십시오.

6. 비디오 카드 드라이버 업데이트

많은 OpenGL 문제나 충돌은 비디오 카드 드라이버를 업데이트하면 해결됩니다. 대부분의 비디오 카드 제조업체는 소프트웨어 드라이버를 자주 업데이트합니다. 최근 업데이트된 비디오 카드 드라이버가 없는 경우 비디오 카드 제조업체에 업데이트된 드라이버에 대해 문의하거나 제조업체 웹 사이트에서 다운로드하십시오.

7. After Effects를 다시 시작하고 충돌을 유발한 동작을 테스트합니다. (Windows에만 해당)

Windows의 OpenGL 문제로 인한 충돌이 발생한 후에 After Effects CS4는 [DLL 주소 공간 조각화 방지] 기본 설정을 자동으로 사용하지 않도록 설정합니다. 이 기본 설정은 After Effects가 좀 더 많은 인접 RAM에 액세스할 수 있도록 하지만 일부 OpenGL 드라이버와는 호환되지 않습니다.

[편집] > [기본 설정] > [메모리 및 캐시]로 이동하여 [DLL 주소 공간 조각화 방지] 기본 설정을 사용하거나 사용하지 않도록 설정할 수 있습니다.

OpenGL 또는 메모리 관련 충돌이 발생하는 경우가 아니면 이 기본 설정을 사용 가능 상태로 두십시오. OpenGL 문제 때문에 이 기본 설정을 사용하지 않도록 설정하고 나중에 비디오 카드 드라이버를 업데이트하는 경우 이 기본 설정을 다시 사용하도록 설정하십시오. 그런 후 문제를 다시 테스트합니다.

8. [텍스처 메모리] 기본 설정을 최적화합니다.

After Effects에서 너무 많은 비디오 텍스처 메모리를 사용하려고 하면 충돌 또는 OpenGL 오류가 발생할 수 있습니다. 텍스처 메모리는 비디오 카드의 RAM(VRAM) 크기입니다.

After Effects에서 [텍스처 메모리] 기본 설정을 지정하십시오.

  1. 최적의 [텍스처 메모리] 설정을 계산하려면 설치된 총 VRAM에 80%를 곱합니다.
  2. After Effects에서 [After Effects] > [기본 설정] > [미리 보기(Mac OS)] 또는 [편집] > [기본 설정] > [미리 보기(Windows)]를 선택합니다.
  3. [OpenGL 정보]를 클릭합니다.
  4. 1단계에서 계산한 값을 입력하고 [확인]을 클릭합니다.

텍스처 메모리의 이상적인 값은 비디오 카드에 있는 VRAM의 80%입니다. (여러 개의 비디오 카드를 사용하는 경우 [OpenGL 정보] 대화 상자에서 식별된 비디오 카드에 대한 VRAM의 80%를 계산하십시오.) After Effects의 [텍스트 메모리] 기본 설정이 VRAM의 80%보다 크게 설정되어 있으면 비디오 카드에서 사용자 인터페이스 또는 기타 작업을 처리할 만큼 충분한 VRAM이 남아 있지 않을 수 있습니다. (예를 들어 전체 화면이 흰색으로 바뀔 수 있습니다.) 값이 80%보다 작게 설정되면 After Effects의 OpenGL 미리 보기가 프레임을 처리하는 데 더 오래 걸릴 수 있습니다.

비디오 카드의 VRAM 크기 확인에 대한 자세한 내용은 Mac OS 도움말 또는 Windows 도움말을 참조하십시오.

9. 이미지 캐시 및 비디오 메모리를 비웁니다.

After Effects의 구성 창에 가공물 또는 "가비지"(잘못된 픽셀 블록)가 표시되면 비디오 메모리(VRAM)가 꽉 찼거나, 조각화되었거나, 손상된 것일 수 있습니다. 이미지 캐시 및 비디오 메모리를 비워 VRAM을 빈 상태로 만든 후 After Effects에서 구성 미리 보기를 다시 작성하도록 합니다.

이미지 캐시 내용을 비우려면 [편집] > [제거] > [이미지 캐시]를 선택합니다.

비디오 메모리를 비우려면 [편집] > [제거] > [비디오 메모리]를 선택합니다.

참고: OpenGL(또는 Windows의 Direct3D)을 사용하는 일부 화면 보호기를 After Effects 실행 중에 활성화하면 비디오 메모리가 손상될 수 있습니다. 화면 보호기를 끈 후에 구성 창에서 이미지 손상 문제가 자주 발생하는 경우 화면 보호기를 변경하거나 사용하지 않도록 설정합니다.

10. 비디오 카드의 색상 설정을 최고(32비트)(Windows) 또는 수백만(Mac OS)으로 변경합니다.

비디오 카드 또는 디스플레이 설정 변경에 대한 자세한 내용은 Mac OS 도움말 또는 Windows 도움말을 참조하십시오.

11. 비디오 카드의 고급 기능을 사용하지 않도록 설정합니다. (Windows에만 해당)

대부분의 디스플레이 카드 드라이버에는 카드의 고급 기능에 액세스할 수 있도록 하는 유틸리티가 포함되어 있습니다. 특히, 앤티 앨리어싱 및 16비트 모드 기능이 OpenGL과 충돌하고 After Effects 충돌을 야기할 수 있습니다. 카드의 고급 기능을 기본값으로 설정하고 앤티 앨리어싱 및 16비트 모드 옵션을 사용하지 않도록 설정합니다.

Nvidia 카드를 사용해서 여러 대의 모니터를 사용하는 경우 [다중 모니터] 설정을 "호환 가능"으로 설정합니다.

해당 고급 기능 액세스 방법에 대해서는 비디오 카드 설명서 또는 제조업체 웹 사이트를 참조하십시오.

12. 단일 모니터를 사용합니다.

여러 대의 모니터를 사용하고 있으며 After Effects의 OpenGL에서 문제가 발생하는 경우 다음을 시도하십시오.

  • After Effects 응용 프로그램 창 또는 [구성] 패널을 보조 모니터에 표시한 경우 해당 창을 기본 모니터로 이동합니다.
  • 한 대를 제외한 나머지 모니터의 연결을 끊습니다.
  • 여러 개의 디스플레이 카드를 사용하고 있으면 하나를 제외한 모든 디스플레이 카드를 제거합니다. OpenGL에서 최상의 결과를 얻으려면 1개의 듀얼 헤드 디스플레이 카드를 사용하십시오.

13. 시작 스크립트 폴더에 [OpenGL 텍스처 크기 감소] 스크립트를 배치합니다.

[OpenGL 텍스처 크기 감소] 스크립트는 After Effects에서 사용하는 텍스처 메모리 크기를 줄이고 이전 비디오 카드에 대해 보다 나은 호환성을 제공할 수 있습니다.

시작 스크립트 폴더에 [OpenGL 텍스처 크기 감소] 스크립트를 배치합니다.

  1. After Effects 스크립트 폴더로 이동합니다.

    Mac OS: Applications/Adobe After Effects CS4/Scripts

    Windows: C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Scripts
  2. Reduce OpenGL Texture Size.jsx 파일을 (지원) 폴더에서 시작 폴더로 이동합니다.

최신 비디오 카드는 컴퓨터의 OpenGL 기능을 향상하며, 스크립트를 사용하지 않아도 되게 합니다. 새 카드 및 해당 드라이버를 설치한 후에 [OpenGL 텍스처 크기 감소] 스크립트를 (지원) 폴더로 다시 이동합니다. 그런 후 After Effects 기본 설정을 원래대로 복원합니다.

14. After Effects 기본 설정을 원래대로 복원합니다.

After Effects 기본 설정 파일을 다시 만들어 손상된 OpenGL 기본 설정으로 인한 문제를 없앱니다.

Effects 기본 설정 파일을 다시 만들려면 After Effects를 다시 시작합니다. 응용 프로그램이 시작되는 동안 Ctrl+Alt+Shift(Windows) 또는 Command+Option+Shift(Mac OS)를 누릅니다.

15. Adobe 기술 지원에 문의

위의 단계로도 After Effects 오류나 중단 문제가 해결되지 않으면 Adobe 기술 지원 서비스에 문의하십시오. Adobe 지원에서 지원 옵션을 찾을 수 있습니다.

 

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책