Creating actions

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and Adobe services
    1. Photoshop and Adobe Stock
    2. Creative Cloud Libraries
    3. Creative Cloud Libraries in Photoshop
    4. Grid and guides
    5. Creating actions
    6. Undo and history
    7. Default keyboard shortcuts
    8. Touch capabilities and customizable workspaces
    9. Use the Touch Bar with Photoshop
    10. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export cloud documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. System requirements 1.x | Photoshop on the iPad
    23. System requirements 2.x | Photoshop on the iPad
    24. Edit your image size
    25. Livestream as you create in Photoshop on the iPad
    26. Correct imperfections with the Healing Brush
    27. Create brushes in Capture and use them in Photoshop
  5. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud doc sync logs
    8. Share access and edit your cloud documents
  6. Workspace
    1. Workspace basics
    2. Create documents
    3. Use the Touch Bar with Photoshop
    4. Microsoft Dial support in Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Quickly share your creations
    13. Place Photoshop images in other applications
    14. Preferences
    15. Default keyboard shortcuts
    16. Rulers
    17. Show or hide non-printing Extras
    18. Specify columns for an image
    19. Undo and history
    20. Panels and menus
    21. Place files
    22. Position elements with snapping
    23. Position with the Ruler tool
    24. Presets
    25. Customize keyboard shortcuts
    26. Grid and guides
  7. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Export files in Photoshop
    4. Device Preview
    5. Copy CSS from layers
    6. Slice web pages
    7. HTML options for slices
    8. Modify slice layout
    9. Work with web graphics
    10. Create web photo galleries
  8. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  9. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  10. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  11. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  12. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  13. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  14. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  15. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Fill and stroke selections, layers, and paths
    14. Draw with the Pen tools
    15. Create patterns
    16. Generate a pattern using the Pattern Maker
    17. Manage paths
    18. Manage pattern libraries and presets
    19. Draw or paint with a graphics tablet
    20. Create textured brushes
    21. Add dynamic elements to brushes
    22. Gradient
    23. Paint stylized strokes with the Art History Brush
    24. Paint with a pattern
    25. Sync presets on multiple devices
  16. Text
    1. Work with OpenType SVG fonts
    2. Format characters
    3. Format paragraphs
    4. How to create type effects
    5. Edit text
    6. Line and character spacing
    7. Arabic and Hebrew type
    8. Fonts
    9. Troubleshoot fonts
    10. Asian type
    11. Create type
    12. Text Engine error using Type tool in Photoshop | Windows 8
    13. World-Ready composer for Asian Scripts
    14. How to add and edit text in Photoshop
  17. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  18. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  19. Saving and exporting
    1. Save files in graphics formats
    2. Save your files in Photoshop
    3. File formats
    4. Save and export video and animations
    5. Save PDF files
    6. Digimarc copyright protection
  20. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  21. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  22. 3D and technical imaging
    1. Creative Cloud 3D Animation (Preview)
    2. Print 3D objects
    3. 3D painting
    4. 3D panel enhancements | Photoshop
    5. Essential 3D concepts and tools
    6. 3D rendering and saving
    7. Create 3D objects and animations
    8. Image stacks
    9. 3D workflow
    10. Measurement
    11. DICOM files
    12. Photoshop and MATLAB
    13. Count objects in an image
    14. Combine and convert 3D objects
    15. 3D texture editing
    16. Adjust HDR exposure and toning
    17. 3D panel settings
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors

For tasks you perform frequently, you can easily record a number of actions to help you work more efficiently.

Guidelines for recording actions

Keep in mind the following guidelines when recording actions:

  • You can record most—but not all—commands in an action.

  • You can record operations that you perform with the Marquee, Move, Polygon, Lasso, Magic Wand, Crop, Slice, Magic Eraser, Gradient, Paint Bucket, Type, Shape, Notes, Eyedropper, and Color Sampler tools—as well as those that you perform in the History, Swatches, Color, Paths, Channels, Layers, Styles, and Actions panels.

  • Results depend on file and program setting variables, such as the active layer and the foreground color. For example, a 3‑pixel Gaussian blur won’t create the same effect on a 72‑ppi file as on a 144‑ppi file. Nor will Color Balance work on a grayscale file.

  • When you record actions that include specifying settings in dialog boxes and panels, the action will reflect the settings in effect at the time of the recording. If you change a setting in a dialog box or panel while recording an action, the changed value is recorded.

Pastaba:

Most dialog boxes retain the settings specified at the previous use. Check carefully that those are the values you want to record.

  • Modal operations and tools—as well as tools that record position—use the units currently specified for the ruler. A modal operation or tool is one that requires you to press Enter or Return to apply its effect, such as transforming or cropping. Tools that record position include the Marquee, Slice, Gradient, Magic Wand, Lasso, Shape, Path, Eyedropper, and Notes tools.
Pastaba:

If you record an action that will be played on files of different sizes, set the ruler units to percentages. As a result, the action will always play back in the same relative position in the image.

  • You can record the Play command listed on the Actions panel menu to cause one action to play another.

Record an action

When you create a new action, the commands and tools you use are added to the action until you stop recording.

Pastaba:

To guard against mistakes, work in a copy: At the beginning of the action before applying other commands, record the File > Save As command and select As A Copy. Alternatively, you can click the New Snapshot button on the History panel to make a snapshot of the image before recording the action.  

  1. Open a file.
  2. In the Actions panel, click the Create New Action button  , or choose New Action from the Actions panel menu.
  3. Enter an action name, select an action set, and set additional options:

    Function Key

    Assigns a keyboard shortcut to the action. You can choose any combination of a function key, the Ctrl key (Windows) or Command key (Mac OS), and the Shift key (for example, Ctrl+Shift+F3), with these exceptions: In Windows, you cannot use the F1 key, nor can you use F4 or F6 with the Ctrl key.

    Pastaba:

    If you assign an action the same shortcut that is used for a command, the shortcut will apply the action rather than the command.

    Color

    Assigns a color for display in Button mode.

  4. Click Begin Recording. The Begin Recording button in the Actions panel turns red  .
    Pastaba:

    When recording the Save As command, do not change the filename. If you enter a new filename, that new name is recorded and used each time you run the action. Before saving, if you navigate to a different folder, you can specify a different location without having to specify a filename.

  5. Perform the operations and commands you want to record.

    Not all tasks in actions can be recorded directly; however, you can insert most nonrecordable tasks using commands in the Actions panel menu.

  6. To stop recording, either click the Stop Playing/Recording button, or choose Stop Recording from the Actions panel menu, or press the Esc key.

Pastaba:

To resume recording in the same action, choose Start Recording from the Actions panel menu.

Record a path

The Insert Path command lets you include a complex path (a path created with a pen tool or pasted from Adobe Illustrator) as part of an action. When the action is played back, the work path is set to the recorded path. You can insert a path when recording an action or after it has been recorded.

  1. Do one of the following:
    • Start recording an action.

    • Select an action’s name to record a path at the end of the action.

    • Select a command to record a path after the command.

  2. Select an existing path from the Paths panel.
  3. Choose Insert Path from the Actions panel menu.

If you record multiple Insert Path commands in a single action, each path replaces the previous one in the target file. To add multiple paths, record a Save Path command using the Paths panel after recording each Insert Path command.

Pastaba:

Playing actions that insert complex paths may require significant amounts of memory. If you encounter problems, increase the amount of memory available to Photoshop.

Insert a stop

You can include stops in an action that let you perform a task that cannot be recorded (for example, using a painting tool). After you complete the task, click the Play button in the Actions panel to complete the action.

You can also display a short message when the action reaches the stop as a reminder of what needs to be done before continuing with the action. You can include a Continue button in the message box in case no other task needs to be done.

  1. Choose where to insert the stop by doing one of the following:
    • Select an action’s name to insert a stop at the end of the action.

    • Select a command to insert a stop after the command.

  2. Choose Insert Stop from the Actions panel menu.
  3. Type the message you want to appear.
  4. If you want the option to continue the action without stopping, select Allow Continue.
  5. Click OK.
Pastaba:

You can insert a stop when recording an action or after it has been recorded.

Change settings when playing an action

By default, actions are completed using the values specified when they were originally recorded. If you want to change the settings for a command within an action, you can insert a modal control. A modal control pauses an action so that you can specify values in a dialog box or use a modal tool. (A modal tool requires pressing Enter or Return to apply its effect—once you press Enter or Return, the action resumes its tasks.)

A modal control is indicated by a dialog box icon  to the left of a command, action, or set in the Actions panel. A red dialog box icon  indicates an action or set in which some, but not all, commands are modal. You can’t set a modal control in Button mode.

  1. Do one of the following:
    • To enable a modal control for a command within an action, click the box to the left of the command name. Click again to disable the modal control.

    • To enable or disable modal controls for all commands in an action, click the box to the left of the action name.

    • To enable or disable modal controls for all actions in a set, click the box to the left of the set name.

Exclude commands from an action

You can exclude commands that you don’t want to play as part of a recorded action. You can’t exclude commands in Button mode.

  1. If necessary, expand the listing of commands in the action by clicking the triangle to the left of the action name in the Actions panel.
  2. Do one of the following:
    • To exclude a single command, click to clear the check mark to the left of the command name. Click again to include the command.

    • To exclude or include all commands or actions in an action or set, click the check mark to the left of the action or set name.

    • To exclude or include all commands except the selected command, Alt-click (Windows) or Option-click (Mac OS) its check mark.

      To indicate that some of the commands within the action are excluded, the check mark of the parent action turns red.

Insert a non-recordable menu command

You cannot record the painting and toning tools, tool options, View commands, and Window commands. However, you can insert many non-recordable commands into an action using the Insert Menu Item command.

You can insert a command when recording an action, or after it has been recorded. An inserted command doesn’t execute until the action is played, so the file remains unchanged when the command is inserted. No values for the command are recorded in the action. If the command opens a dialog box, the dialog box appears during playback, and the action pauses until you click OK or Cancel.

Pastaba:

When you use the Insert Menu Item command to insert a command that opens a dialog box, you cannot disable the modal control in the Actions panel.

  1. Choose where to insert the menu item:
    • Select an action’s name to insert the item at the end of the action.

    • Select a command to insert the item at the end of the command.

  2. Choose Insert Menu Item from the Actions panel menu.
  3. With the Insert Menu Item dialog box open, choose a command from its menu.
  4. Click OK.

Edit and rerecord actions

You can tweak the settings of any specific command within an action, add commands to an existing action, or step through an entire action and change any or all settings.

Overwrite a single command

  1. In the Actions panel, double-click the command.
  2. Enter the new values, and click OK.

Add commands to an action

  1. Do one of the following:
    • Select the action name to insert a new command at the end of the action.

    • Select a command in the action to insert a command after it.

  2. Click the Begin Recording button, or choose Start Recording from the Actions panel menu.
  3. Record the additional commands.
  4. When finished, click the Stop Playing/Recording button in the Actions panel or choose Stop Recording from the panel menu.

Rearrange commands within an action

  1. In the Actions panel, drag a command to its new location within the same or another action. When the highlighted line appears in the desired position, release the mouse button.

Record an action again

  1. Select an action, and choose Record Again from the Actions panel menu.
  2. If a modal tool appears, use the tool to create a different result, and press Enter or Return, or just press Enter or Return to retain the same settings.
  3. If a dialog box appears, change the settings, and click OK to record them, or click Cancel to retain the same values.
„Adobe“ logotipas

Prisijunkite prie savo paskyros