Fehler „SVN: #155021. Sie können diese Datei nicht mithilfe der Subversion-Integration von Dreamweaver aktualisieren...“ | Dreamweaver CS4

Problem

Wenn Sie in Dreamweaver CS4 eine Verbindung zu einem Subversion-Server herstellen, wird die folgende Fehlermeldung angezeigt:

SVN: #155021. Sie können diese Datei nicht mit der Subversion-Integration von Dreamweaver aktualisieren, da eine neuere Subversion-Clientanwendung auf Ihrem Computer die Subversion-Metadaten der Datei aktualisiert hat.  Weitere Informationen zu diesem Problem finden Sie unter http://www.adobe.com/go/dw_svn_de.

Die Fehlermeldung wird auch in einem modalen Dialogfeld oder im Hintergrund-Dateiübertragungsprotokoll angezeigt.

Lösung

Führen Sie das Konvertierungsskript für die Dreamweaver-Erweiterung aus.

Um die Kompatibilität der Subversion 1.4.5-Clientbibliothek wiederherzustellen, führen Sie das Konvertierungsskript aus, das in eine Dreamweaver-Erweiterung eingeschlossen wurde.

Die Erweiterung löst ein Python-Skript aus. Stellen Sie daher sicher, dass der Python-Skriptinterpreter auf Ihrem lokalen Computer installiert ist. Weitere Informationen finden Sie unter Installieren von Python unter Windows.

Hinweis: Python wird als Teil der Standardinstallation unter Mac OS X installiert.

Wichtig: Sie können Ihre Site auch in Dreamweaver ändern. Dieses Problem tritt nur auf, wenn Sie versuchen, Ihre Site über den Subversion-Server zu synchronisieren. Das Problem hat keine Auswirkungen auf andere Benutzer auf Ihrem Computer, da die Änderung an den Metadaten lokal auf Ihrem Computer erfolgt. Dreamweaver kann jedoch erst mit dem Server interagieren, wenn Sie das Konvertierungsskript ausführen.

  1. Beenden Sie Dreamweaver.
  2. Laden Sie die Adobe Dreamweaver-Erweiterung herunter (Englisch).

    Hinweis: Weitere Sprachen können im Abschnitt Zusätzliche Sprachen unten in diesem Dokument heruntergeladen werden.
  3. Starten Sie Adobe Extension Manager CS4.



    HINWEIS
    :
    Unter Windows Vista und Windows 7 müssen Sie den Extension Manager als Administrator ausführen, um die übrigen Schritte erfolgreich durchzuführen. Klicken Sie dazu mit der rechten Maustaste auf das Adobe Extension Manager CS4-Symbol und wählen Sie „Als Administrator ausführen“.

     

  4. Klicken Sie auf „Installieren“.
  5. Wählen Sie die heruntergeladene Erweiterung aus und klicken Sie auf „Öffnen“. Die installierte Erweiterung wird in Extension Manager CS4 wie folgt angezeigt:

     

  6. Schließen Sie Extension Manager.
  7. Starten Sie Adobe Dreamweaver.
  8. Klicken Sie auf „Befehle“ > „Kompatibilität mit Subversion“

  9. Klicken Sie auf „OK“, um Ihre Site zu konvertieren. Die folgende Meldung wird angezeigt, wenn das Konvertierungsskript erfolgreich abgeschlossen wurde:

  10. Aktualisieren Sie die Site.

Hinweis: Sie können das Skript jederzeit ausführen. Wenn Sie Ihre lokale Site erneut mit einem anderen Subversion-Client-Programm verwendet haben, wiederholen Sie die Schritte 8 bis 10.

Weitere Informationen

Das Subversion-Entwickler-Team bietet ein Skript, das die Metadaten der Subversion-Version der Site in 1.4.x konvertiert, das mit Dreamweaver kompatibel ist.

Installieren von Python unter Windows

Installieren Sie es unter Windows, bevor Sie die Subversion-Konvertierung ausführen.

  1. Führen Sie die heruntergeladene Datei aus und befolgen Sie die Anweisungen auf dem Bildschirm.
  2. Starten Sie den Computer neu.
  3. Führen Sie die oben beschriebene Lösung der Reihe nach aus.

Installierte Dateien

Die Erweiterung verwendet ein Python-Skript, das Subversion bereitstellt, um die Metadaten Ihrer lokalen Site zu konvertieren. (Weitere Informationen finden Sie unter http://subversion.tigris.org/faq.html#working-copy-format-change.) Extension Manager installiert zwei Dateien in Ihrem Benutzerordner. Das erste ist das Python-Skript (change-svn-wc-format.py). Die andere Datei ist der Code der Erweiterung, mit dem das Skript direkt in Dreamweaver (DWSVNConvert.htm) ausgeführt wird. Nach dem Ausführen der Erweiterung wird auch eine Ausgabedatei erstellt, die Konvertierungsprotokollnachrichten enthält (change-svn-wc-format.output.txt). Falls während der Konvertierung ein Problem auftritt, werden Fehler in der Ausgabedatei aufgezeichnet.

Die Erweiterung wird an folgenden Speicherorten im Home-Verzeichnis installiert:

  • Windows: Dokumente und Einstellungen/<username>/Application Data/Adobe/Dreamweaver CS4/de_DE/Configuration/commands/DWSVNConvert
  • macOS: <username>/Library/Application Support/Adobe/Dreamweaver CS4/de_DE/Configuration/commands/DWSVNConvert

Windows-Pfadsystem und Python

Das Python-Skript wird nur ordnungsgemäß ausgeführt, wenn die PATH-Variable unter Windows festgelegt ist, die vom Python-Installationsprogramm nicht festgelegt wurde. Um diese Variable zu ändern, bearbeiten Sie die Umgebungsvariablen in Windows.

  1. Öffnen Sie die Windows-Systemeigenschaften.
  2. Klicken Sie auf der Registerkarte „Erweitert“ auf „Umgebungsvariablen“.
  3. Fügen Sie unter Systemvariablen den Pfad, in dem Sie Python installiert haben, zur Pfadvariablen hinzu (z. B. C:\Python25). Fügen Sie dem Pfad ein Semikolon hinzu, falls keines vorhanden ist (z. B. ;C\Python25).

Weitere Informationen

Die Verwendung von Adobe Dreamweaver und einem anderen Subversion-Client auf demselben Computer kann verhindern, dass Ihre Site mit dem Subversion-Server interagiert.

Client-Software von Drittanbietern kann die Subversion-Metadaten Ihrer lokalen Site auf eine neuere Client-Version aktualisieren, die von Adobe Dreamweaver CS4 nicht unterstützt wird.

Subversion-Clients von Drittanbietern können Folgendes umfassen:

  • TortoiseSVN
  • SmartSVN
  • Subclipse

Weitere Clients finden Sie unter Apache Subversion.

Beispiel

Sie verwenden Adobe Dreamweaver CS4, das die Subversion-Client-Bibliotheken 1.4.5 unterstützt. Und Sie verwenden TortoiseSVN (1.5.x), das Client-Version 1.5 unterstützt, auf demselben Computer. Sobald Sie Ihre lokale Site mit TortoiseSVN verwenden (z. B. eine Datei senden), werden die lokalen Subversion-Metadaten Ihrer Site in Version 1.5 konvertiert. Aufgrund dieser Konvertierung kann Dreamweaver nicht mehr mit dem Subversion-Server interagieren. Das neuere Subversion-Client-Format ist nicht abwärtskompatibel mit dem von Dreamweaver unterstützten 1.4-Format.

 

Adobe-Logo

Bei Ihrem Konto anmelden