User Guide Cancel

Photoshop tools, options, and task bars

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad (not available in mainland China)
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
  5. Photoshop on the web (not available in mainland China)
    1. Common questions
    2. System requirements
    3. Keyboard shortcuts
    4. Supported file types
    5. Introduction to the workspace
    6. Open and work with cloud documents
    7. Generative AI features
    8. Basic concepts of editing
    9. Quick Actions
    10. Work with layers
    11. Retouch images and remove imperfections
    12. Make quick selections
    13. Image improvements with Adjustment Layers
    14. Move, transform, and crop images
    15. Draw and paint
    16. Work with Type layers
    17. Work with anyone on the web
    18. Manage app settings
  6. Photoshop (beta) (not available in mainland China)
    1. Get started with Creative Cloud Beta apps
    2. Photoshop (beta) on the desktop
  7. Generative AI (not available in mainland China) 
    1. Common questions on generative AI in Photoshop
    2. Generative Fill in Photoshop on the desktop
    3. Generative Expand in Photoshop on the desktop
    4. Generative Fill in Photoshop on the iPad
    5. Generative Expand in Photoshop on the iPad
    6. Generative variations in Photoshop on the iPad
    7. Generative AI features in Photoshop on the web
  8. Content authenticity (not available in mainland China)
    1. Content credentials in Photoshop
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  9. Cloud documents (not available in mainland China)
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Invite others to edit your cloud documents
    9. Share files and comment in-app
  10. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  11. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  12. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  13. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
  14. Selections
    1. Get started with selections
    2. Make selections in your composite
    3. Select and Mask workspace
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Adjust pixel selections
    7. Move, copy, and delete selected pixels
    8. Create a temporary quick mask
    9. Select a color range in an image
    10. Convert between paths and selection borders
    11. Channel basics
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
  15. Image adjustments
    1. Replace object colors
    2. Perspective warp
    3. Reduce camera shake blurring
    4. Healing brush examples
    5. Export color lookup tables
    6. Adjust image sharpness and blur
    7. Understand color adjustments
    8. Apply a Brightness/Contrast adjustment
    9. Adjust shadow and highlight detail
    10. Levels adjustment
    11. Adjust hue and saturation
    12. Adjust vibrance
    13. Adjust color saturation in image areas
    14. Make quick tonal adjustments
    15. Apply special color effects to images
    16. Enhance your image with color balance adjustments
    17. High dynamic range images
    18. View histograms and pixel values
    19. Match colors in your image
    20. Crop and straighten photos
    21. Convert a color image to black and white
    22. Adjustment and fill layers
    23. Curves adjustment
    24. Blending modes
    25. Target images for press
    26. Adjust color and tone with Levels and Curves eyedroppers
    27. Adjust HDR exposure and toning
    28. Dodge or burn image areas
    29. Make selective color adjustments
  16. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. Radial Filter in Camera Raw
    10. Manage Camera Raw settings
    11. Open, process, and save images in Camera Raw
    12. Repair images with the Enhanced Spot Removal tool in Camera Raw
    13. Rotate, crop, and adjust images
    14. Adjust color rendering in Camera Raw
    15. Process versions in Camera Raw
    16. Make local adjustments in Camera Raw
  17. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  18. Image enhancement and transformation
    1. Replace sky in your images
    2. Transform objects
    3. Adjust crop, rotation, and canvas size
    4. How to crop and straighten photos
    5. Create and edit panoramic images
    6. Warp images, shapes, and paths
    7. Vanishing Point
    8. Content-aware scaling
    9. Transform images, shapes, and paths
  19. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
    27. Migrate presets, actions, and settings
  20. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
  21. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Use the Liquify filter
    9. Layer effects and styles
    10. Apply specific filters
    11. Smudge image areas
  22. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Duotones
    5. Work with color profiles
    6. Color-managing documents for online viewing
    7. Color-managing documents when printing
    8. Color-managing imported images
    9. Proofing colors
  24. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  25. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  26. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Print images to a commercial printing press
    8. Improve color prints from Photoshop
    9. Troubleshoot printing problems | Photoshop
  27. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  28. Troubleshooting
    1. Fixed issues 
    2. Known issues
    3. Optimize Photoshop performance
    4. Basic troubleshooting
    5. Troubleshoot crash or freeze
    6. Troubleshoot program errors
    7. Troubleshoot scratch disk full errors
    8. Troubleshoot GPU and graphics driver issues
    9. Find missing tools
    10. Photoshop 3D | Common questions around discontinued features

Learn more about the Tools panel and its options, some of which appear in the context-sensitive options bar.

Topics in this article:

The Tools panel appears on the left of the Photoshop application screen.

These tools have more options that appear in the context-sensitive options bar. Select the small triangle at the lower right of the tool icon to access these options. 

View their names and other information by positioning the pointer over them. 

Tools panel in Photoshop with hidden tool triangle marked
Tools panel in Photoshop

Active tool in Photoshop
Rectangular Marquee tool

For a pictorial overview of the different tools in Photoshop, see Tool galleries.

Select and display tools

Select a tool

Do one of the following: 

  • Select a tool in the Tools panel. If there is a small triangle at the tool's lower right corner, hold down the mouse button to view the button tools, and then select the tool you want to work with. 

Or, 

  • Press the tool's keyboard shortcut. The keyboard shortcut is displayed in its tooltip. For example, select the Move tool by pressing V. 

Read more about Photoshop keyboard shortcuts here

Note:

Pressing and holding a keyboard shortcut key lets you temporarily switch to a tool. When you let go of the shortcut key, Photoshop returns to the tool you were using before the temporary switch.

Cycle through hidden tools

By default, you cycle through a set of hidden tools by holding down Shift and repeatedly pressing a tool shortcut key.

If you prefer to cycle through tools without holding down Shift, you can disable this preference.

  1. Choose Edit > Preferences > General (Windows) or Photoshop > Preferences > General (macOS).

  2. Deselect Use Shift Key For Tool Switch.

Change tool pointers

Each default pointer has a different hotspot, where an effect or action in the image begins. With most tools, you can switch to precise cursors, which appear as cross hairs centered around the hotspot.

In most cases, the pointer for a tool is the same as the icon for that tool; you see that pointer when you select the tool. The default pointer for the marquee tools is the cross-hair pointer ; for the text tool, the default pointer is the I‑beam ; and for the painting tools, the default pointer is the Brush Size icon.

  1. Choose Edit > Preferences > Cursors (Windows) or choose Photoshop > Preferences > Cursors (macOS).

  2. Choose tool pointer settings under Painting Cursors or Other Cursors and select OK.

    • Standard: Displays pointers as tool icons
    • Precise: Displays pointers as cross hairs
    • Normal Brush Tip: The pointer outline corresponds to approximately 50% of the area that the tool will affect. This option shows the pixels that would be most visibly affected
    • Full-Size Brush Tip: The pointer outline corresponds to nearly 100% of the area that the tool will affect, or nearly all the pixels that would be affected
    • Show Crosshair In Brush Tip: Displays cross hairs in the center of the brush shape
    • Show Only Crosshair While Painting: Improves performance with large brushes

    Painting Cursors options control the pointers for these tools: 

    • Eraser
    • Pencil
    • Paintbrush
    • Healing Brush
    • Clone Stamp
    • Pattern Stamp
    • Quick Selection
    • Smudge
    • Blur
    • Sharpen
    • Dodge
    • Burn
    • Sponge

    Other Cursors options control the pointers for these tools:

    • Marquee
    • Lasso
    • Polygonal Lasso
    • Magic Wand
    • Crop
    • Slice
    • Patch
    • Eyedropper
    • Pen
    • Gradient
    • Line
    • Paint Bucket
    • Magnetic Lasso
    • Magnetic Pen
    • Freeform Pen
    • Measure
    • Color Sampler
Note:

Use Caps Lock on your keyboard to toggle between standard and precise cursors in some tool pointers.

Visually resize or change hardness of painting cursors

You can resize or change the hardness of a painting cursor by dragging in the image. As you drag, the painting cursor previews your changes. (Previews require OpenGL.)

To resize a cursor, press Alt+right-click (Windows) or control+option (macOS), and drag left or right. To change hardness, drag up or down.

Tool options bar

The tool options bar appears below the menu bar at the top of the workspace. The options bar is context-sensitive, which means it changes with the selection of different tools. Some settings in the options bar (such as painting modes and opacity) are common to several tools, and some are specific to one tool.

You can move the options bar in the workspace by using the gripper bar and dock it at the top or bottom of the screen. Tool tips appear when you position the pointer over a tool. To show or hide the options bar, choose Window > Options.

Marquee tool options bar in Photoshop
Marquee tool options bar in Photoshop with New selection activated

To return tools to their default settings, right-click (Windows) or control-click (macOS) the tool icon in the options bar, and then choose Reset Tool or Reset All Tools from the context menu.

For more information on setting options for a specific tool, search for the tool’s name in Photoshop Help.

Look for more topics to learn on the Photoshop Discover Panel.

Contextual Task Bar in Photoshop

Updated in Photoshop 25.0 (September 2023 release)

The Contextual Task Bar is a floating menu that presents the most relevant next steps in your workflow. 

For example, when an object is selected, the Contextual Task Bar appears on the canvas with more curated options for the potential next step, such as Select and MaskFeatherInvertCreate Adjustment Layer, or Fill Selection.

Go to Window > Contextual Task Bar to turn off this feature, as it's on by default. 

Currently, you can view and use these bars with the following workflows:

New document workflow

This bar appears when you open a new, blank document from the Photoshop home screen or from File > New.

New document workflow - Contextual Task Bar

Open image/file workflow

This bar appears when you open an image or file from the home screen (i.e. not a new, empty document) or from File > Open.

Select subject and Remove background Contextual Task Bar in Photoshop

Type tool workflow 

This bar appears when you select the Type tool from the toolbar and draw a text box on the canvas.

Type tool Contextual Task Bar in Photoshop

Selections workflow

This bar appears with options to refine a selection or create a mask after you make a selection. 

You also have the option to use the Generative Fill feature once your selection has been made.

Selections workflow Contextual Task Bar in Photoshop

More options menu

Select the three-dot icon to access the additional options menu with options to hide, reset, and pin the task bars. These actions are applied to all bars, so a pinned bar will remain pinned for future bars in your workflow, and hiding a bar will keep all bars hidden until reopened.

More options menu Contextual Task Bar in Photoshop

  • Hide bar: Remove all Contextual Task Bars from your screen. You could also reopen them by navigating to Window > Contextual Task Bar.
  • Reset bar position: The Contextual Task Bar moves with you as you work on the canvas, keeping relevant tools at your fingertips. Use the "more options menu" to reset the position of the bar.
  • Pin bar position: Pin and un-pin any Contextual Task Bar from the "more options menu". Pinning will hold your bar (and all subsequent bars) where it was placed. De-select Pin bar position from the "more options menu" to unpin a bar. 

With the release of Photoshop 25.0, you get new additions to the Contextual Task Bar to work with absolute ease on your masking and Generative Expand workflows. 

Masking workflow

This bar appears anytime you enter the Select and Mask workspace, create a mask from a selection, or select a layer mask thumbnail.

Use this bar to refine your mask by adding or subtracting from your masked area, view mode options, and modifying options for density and feather. 

Masking workflow - Contextual Task Bar in Photoshop

Generative Expand workflow

This bar appears when the Crop tool is used and has options to straighten and adjust ratio.

You also have an option to use the Generative Expand feature if the canvas is expanded rather than cropped. 

Cropping workflow - Contextual Task Bar in Photoshop

Work with more text editing capabilities directly from the Contextual Task Bar

Updated in Photoshop 25.5 (February 2024 release)

Make your creative workflows simpler and streamlined with the advanced text editing capabilities of Photoshop that can be accessed straight from the Contextual Task Bar

You can edit font properties (type, size, and color) and text alignment, leading, and spacing from the Contextual Task Bar

You can even adjust font style (bolding, italicizing, and underlining) directly from the Contextual Task Bar.

Work with more text editing capabilities directly from the Contextual Task Bar in Photoshop
Work with more text editing capabilities directly from the Contextual Task Bar

Tool presets

Tool presets let you save and reuse tool settings. You can load, edit, and create libraries of tool presets using the Tool Preset picker in the options bar, the Tool Presets panel, and the Preset Manager.

To choose a tool preset, select the Tool Preset picker in the options bar, and select a preset from the pop‑up panel. You can also choose Window > Tool Presets and select a preset in the Tools Presets panel.

Create a tool preset

  1. Choose a tool, and set the options you want to save as a tool preset in the options bar.
  2. Do one of the following:
    • Select the Tool Preset button next to the tool at the left of the options bar.

    Or, 

    • Choose Window > Tool Presets to display the Tool Presets panel.
  3. Do one of the following:
    • Select the Create New Tool Preset button .

    Or, 

    • Choose New Tool Preset from the panel menu.
  4. Enter a name for the tool preset and select OK.

Change the list of tool presets

Select the triangle to open the Tool Presets pop‑up panel menu and choose one of the following:

  • Show All Tool Presets: Shows all loaded presets
  • Sort By Tool: Sorts the presets by tool
  • Show Current Tool Presets: Shows only the loaded presets for the active tool. You can also select the Current Tool Only option in the Tool Presets pop‑up panel
  • Text Only, Small List, or Large List: Determines how presets are displayed in the pop‑up panel

To create, load, and manage libraries of tool presets, see Work with the Preset Manager.

Spring-loaded keys to quickly switch between tools

Updated in Photoshop 23.4 (June 2022)

Make quick edits in Photoshop using keyboard shortcuts for tools by using spring-loaded keys.

Spring-loading keys let you temporarily switch to a different tool as long as you press and hold down its keyboard shortcut (to use the Move tool as a spring-loaded key, select and hold down V on your keyboard). The default is 200 milliseconds, but you can adjust the timing in Preferences > Tools.

Spring-loading keys in Photoshop
Spring-loading keys in Photoshop

Once you have made your edits, release the key and you can continue to work with the tool you were previously using.

 Adobe

Get help faster and easier

New user?