After adding video and audio items to the encoding queue, you can encode and export them from the queue using presets or custom settings.

Encode using presets

  1. Add items to the Queue panel. For information, see Add and manage items in the encoding queue.

  2. Choose a video format most suitable for your output from the Format pop-up menu.

  3. Choose a video preset most suitable for your output from the Presets pop-up menu. Or drag a preset from the Preset Browser and drop it in the Queue.

  4. Choose a location for your export by clicking the text for Output File, and then finding the directory or folder for your exports in the Save As dialog box. Click Save.

  5. Allow encoding to start automatically, or press the Start Queue button.

Your files will begin to be encoded to your desired format, using your chosen preset, and in the location that you chose.

Encode using custom settings

  1. Add items to the Queue panel. For information, see Add and manage items in the encoding queue.

  2. Select one or more items in the queue and open the Export Settings dialog box by choosing Edit > Export Settings. You can also right-click the file and select Export Settings, or click the Format or Preset name to open the Export Settings dialog box.

  3. Set export options. For more information, see Export settings reference.
  4. Click OK. With the Export Settings dialog box closed, click Start Queue to begin encoding your files.


You can close the Encoding panel for optimum performance during encoding. View progress of the encoding process with the progress bars in the Queue panel instead.

You can do any of the following in the Export Settings dialog box:

  • Choose a video, audio, or still-image format from the Format menu. For more information, see File formats supported for export.

  • (Optional) Choose an encoding preset from the Preset menu.

  • Select Export Video, Export Audio, or both.

  • (Optional) Specify pre-encoding options, including cropping, trimming. For more information, see the Crop and trim source before encoding section.

  • (Optional) Set options for XMP metadata export. For more information, see Export and thin XMP metadata.

  • (Optional) Select Use Maximum Render Quality or Render At Maximum Bit Depth.

    Note:  Rendering at a higher color bit depth requires more RAM and slows rendering substantially.

  • (Optional) Select Use Frame Blending.

  • Specify a filename and location for the encoded file by clicking the underlined text next to Output Name in the upper-right section of the Export Settings dialog box and entering a filename and location. If you don’t specify a filename, Adobe Media Encoder uses the filename of the source video clip.

    Note:  When the format is set to P2 Movie, the user-assigned filename is not applied. Instead, such encodes are given a six character alphanumeric name by Adobe Media Encoder. The Output Name is saved to the clip’s metadata, and is shown as the clip name in Adobe Premiere Pro.

    You can specify a destination folder in which to save the encoded file relative to the folder containing the source video clip. When specifying a destination folder, ensure that the destination folder you specify exists. If you specify a folder that does not exist, an error message informs you that the file cannot be encoded because the folder cannot be found.


Check  Preferences > Specify Output File Destination, and click Browse to specify the destination of encoded files. For more information, see the Preferences section.

Monitor encoding progress

While an item is being encoded, the Status column of the encoding queue provides information on the status of each item. Adobe Media Encoder can encode multiple outputs from a single source simultaneously. However, source files are processed sequentially based on their order in the Queue.

You can continue to work in the application while encoding is in progress. You can add, remove, or reorder items in the queue or watch folder. However, outputs that are currently being encoded cannot be edited.


The item is in the encoding queue but has not been encoded. You can remove a file from the queue that has not been encoded and is not being encoded.


 The item has been successfully encoded.

Done with Warnings Item has been successfully encoded but a warning condition exists. See the encoding and error logs for more information.


 The user canceled the encoding process while the item was being encoded.


 Adobe Media Encoder encountered an error when attempting to encode the specified item.


The user can skip one, or more selected files. With the files selected, choose Edit > Skip Selection.

Audible alerts when jobs completed (successfully and with errors)

Adobe Media Encoder has audible alerts. It plays an audible alert at the completion of the jobs in the Queue. A different alert sounds if any error conditions are detected. These alerts can be disabled in preferences, if you do not want to hear them.


During the encoding process, click the Start Queue button once more if you would like to pause the encoding process.


Hover over the status icon to see a tool tip with the error message. Click on the status to open the log for any item for which encoding is has completed successfully, stopped, or failed.

Parallel encoding

Adobe Media Encoder encodes all sources in sequence, but encodes all outputs of a source in parallel.


Parallel encoding is on by default. To disable parallel encoding, select Edit > Preferences, and deselect Enable Parallel Encoding.

When you encode multiple outputs simultaneously, the Encoding panel displays a thumbnail preview, progress bar, and the completion time estimate of each encoding output.

In certain cases, export settings require an output to encode in serial rather than in parallel mode. In such cases, the queue returns to parallel encoding after temporary serial encoding is complete.

Watch this video2Brain video to learn more about parallel encoding in Adobe Media Encoder.

Important notes

Parallel Encoding
A. Add Source B. Add Output C. Remove Source/Output D. Duplicate 
  • You can associate multiple outputs with a source. Each output can have a different format, preset, and output file location assigned to it.
  • You can reorder outputs in the output list. You can also reorder sources in the Queue. However, you cannot move them to other sources.
  • Clicking the output file path opens the folder containing the encoded file. Previous to encoding, however, the Save As dialog appears.
    • To change the output path and filename, click the Output File link for that output. 
    • To access an encoded file, click the Output File link for that output
  • Use the Add Output button to quickly add an output to a source.
  • Both sources and outputs can be duplicated. A duplicated source uses all the outputs from the original source.


Follow the steps below to change the Output File path for multiple outputs (at the same time):

  1. Select multiple outputs in the Queue using Shift-click or drag-select.
  2. Click the Output File link of one output in the current selection.
  3. Choose a path in the Select an output folder dialog and click Choose.

Selected outputs will all point to the new directory but retain their unique output file names.

Use preview files from Adobe Premiere Pro

When encoding Adobe Premiere Pro sequences, choose Use Previews to use existing preview files (which have already been rendered and encoded) for the parts of the sequence for which they are available.


Launch Adobe Media Encoder from Adobe Premiere Pro to use preview files. Choose File > Export > Media in Premiere Pro to launch Adobe Media Encoder. Ensure that Match Sequence Settings is selected.

Using existing preview files can make encoding much faster. The disadvantage, however, is that the preview files may have been encoded using different settings than those used for the rest of the sequence—for example, the preview files may have been encoded using lossy compression.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy