تعرف على كيفية جعل Dreamweaver يتعرف على أنواع الملفات الجديدة من خلال تعديل ملفات Extensions.txt و MMDocumentTypes.xml.

اقرأ هذه المقالة إذا كنت تريد استكشاف المشكلات التالية في Dreamweaver وإصلاحها:

  • عند فتح ملف، تظهر رسالة الخطأ هذه: "لا يمكن العثور على محرر صالح لهذا الملحق الملف."
  • لا يتطابق الترميز اللوني في طريقة العرض كود مع الترميز اللوني لنوع الملف الذي تريده.
  • لا تتوفر وظيفة نموذج الخادم لنوع الملف.
  • لا يمكنك فتح صفحة في عرض "تصميم". يتم فتح الصفحة فقط في طريقة عرض "رمز".
  • عندما تنقر فوق ملف > حفظ، أو ملف > فتح، فإنك لا ترى نوع الملف الذي تريده.

يتاح لبرنامج Dreamweaver إمكانية تعديل العديد من أنواع الملفات المختلفة وعرضها. تركز هذه المقالة على تخصيص Dreamweaver للتعرف على أنواع الملفات الجديدة عن طريق تحرير ملفات Extensions.txt و MMDocumentTypes.xml. يمكنك أيضاً كمستخدم تحديد إعدادات فتح في عرض الرمز لرؤية أنواع الملف الجديدة في عرض تصميم.

  • ملف Extensions.txt
    ملف Extensions.txt هو ملف نصي يتضمن قائمة بجميع أنواع الملفات التي تم التعرف عليها بواسطة Dreamweaver. يمكن تحرير هذا الملف في أي محرر نص خارجي مثل Notepad أو Text Editor لإضافته إلى قائمة أنواع الملفات المعروفة. لا تُعدِّل ملفات تكوين Dreamweaver في Dreamweaver بالنفس.
  • ملف MMDocumentTypes.xml
    يتضمن ملف MMDocumentTypes.xml تعريفات أنواع الوثيقة وقائمة بملحقات الملف المرفقة بكل نوع وثيقة معروفه. تتيح إضافة ملحقات ملف إلى ملف Extensions.txt لـ Dreamweaver بالتعرف فقط على ملحق ملف ما وتسمح للملفات من هذا النوع بالفتح في Dreamweaver. تعمل إضافة ملحقات ملف إلى ملف MMDocumentTypes.xml على إعلام Dreamweaver عن كيفية التعامل مع ملحق الملف الجديد ولأي نوع من الوثائق ينتمي هذا الملحق.

    في هذه المقالة، تمت تناول الجوانب الأساسية فقط لتحرير ملف MMDocumentTypes.xml. اطلع على تمديد Dreamweaver من داخل Dreamweaver للحصول على لمحة مفصلة لتحرير هذا الملف. انقر فوق تعليمات > تمديد Dreamweaver، وابحث عن MMDocumentTypes.xml.

  • فتح في عرض الرمز
    مفضلات فتح في عرض الرمز التي تعرِّف ملحقات الملف التي لا تسمح بعرض تصميم. للسماح بتحرير الملف في عرض تصميم، تأكد من إزالة ملحق الملف (إن كان مُدرَجاً) من مفضلات فتح في عرض الرمز. لإعداد ذلك كمفضلة، انقر فوق تحرير > مفضلات (Windows) أو Dreamweaver > مفضلات (macOS)، وحدد موقع فئة "نوع الملف/المحرر".

تحرير ملف Extensions.txt

سترى رسالة الخطأ "تعذر العثور على ملحق الملف" عند فتح ملف ما لا يتعرف عليه Dreamweaver. يمكنك إضافة ملحقات جديدة لقائمة الملحقات التي يتعرف عليها Dreamweaver. لإضافة ملحقات جديدة، حِّرر ملف Extensions.txt. تتحكم المدخلات في ملف Extensions.txt في النظام الذي تندرج فيه الملفات في صناديق حوار الملف > فتح و ملف > حفظ. كمثال على ذلك، أضف نوع ملف .inc لـ Dreamweaver.

ملاحظة: يتطلب هذا الإجراء منك تحديد الملفات والمجلدات المخفية وملحقات أنواع الملف المعروفة. بشكل افتراضي، لا يُظهر Windows Explorer الملفات والمجلدات المخفية وملحقات أسماء الملفات التي يتعرف عليها النظام.

لإظهار الملفات والمجلدات المخفية وجميع ملحقات أنواع الملف المعروفة:

  1. قم بتنفيذ أي مما يلي في Windows Explorer:

    • في Windows XP، اختر الأدوات > خيارات المجلد.
    • في Windows Vista، اختر تنظيم > خيارات المجلد والبحث.
  2. انقر فوق علامة التبويب عرض في مربع حوار خيارات المجلد.

  3. في الإعدادات المتقدمة، حدد إظهار الملفات والمجلدات المخفية.

  4. قم بإلغاء تحديد إخفاء الملحقات لأنواع الملفات المعروفة.

  5. انقر فوق موافق.

إضافة أنواع الملف لملف Extensions.txt

لإضافة أنواع الملف لملف Extensions.txt:

  1. حدد موقع ملف Extensions.txt في مجلد تكوين مستخدم Dreamweaver. يعتمد موقع هذا المجلد على نظام التشغيل وإصدار Dreamweaver.

    • Dreamweaver CS3 on Windows Vista:
      C:\Users\[اسم المستخدم]\AppData\Roaming\Adobe\Dreamweaver 9\Configuration
    • Dreamweaver 8 on Windows Vista:
      C:\Users\[اسم المستخدم]\AppData\Roaming\Macromedia\Dreamweaver 8\Configuration
    • Dreamweaver CS3 on Windows XP:
      C:\Documents and Settings\[اسم المستخدم]\Application Data\Adobe\Dreamweaver 9\Configuration
    • Dreamweaver 8 on Windows XP & 2000:
      C:\Documents and Settings\[اسم المستخدم]\Application Data\Macromedia\Dreamweaver 8\Configuration
    • Dreamweaver CS3 on Mac OS X:
      Mac HD:Users:[username]:Library:Application Support:Adobe:Dreamweaver 9:Configuration
    • Dreamweaver 8 on Mac OS X:
      Mac HD:Users:[username]:Library:Application Support:Macromedia:Dreamweaver 8:Configuration

    ملاحظة: عمليات التحرير لهذا الملف متاحة فقط للمستخدم الحالي. التغييرات الحاصلة في الملفات داخل ملف تعريف المستخدم غير متاحة لبقية المستخدمين. لمزيد من المعلومات حول تحرير ملفات تكوين Dreamweaver في بيئة متعددة المستخدمين، انظر تخصيص Dreamweaver في بيئة متعددة المستخدمين.

  2. يمكن فتح Extensions.txt في أي محرر نص خارجي مثل Notepad أو Text Editor.

    لا تُعدِّل ملفات تكوين Dreamweaver في Dreamweaver بالنفس.

  3. أضف الملحق لخط "جميع الوثائق". يجب أن تكون الملحقات بالحروف الكبيرة ومنفصلة بفواصل. مثل HTML,HTM,SHTM,SHTML,INC.

  4. لإضافة ملحقات لمجموعة وثيقة حالية، أضف الملحق لقائمة الملحق في المجموعة المرغوبة. لإضافة مجموعة وثيقة جديدة، أضف سطر جديد يتضمن نوع الوثيقة الجديدة وقائمة بالملحقات المرفقة. مثلاً: ملفات INC:Include

    يمكنك أيضاً إضافة هذا السطر لقائمة "التضمين الثانوي للخادم" الموجودة مسبقاً في الملف.

  5. احفظ الملف وقم بإعادة تشغيل Dreamweaver.
  6. للإطلاع على التغييرات، افتح Dreamweaver ثم افتح ملفاً باستخدام ملحق الملف المضاف حديثاً. يفتح الملف في عرض الرمز فقط في Dreamweaver.

    اختر ملفحفظ باسم وانقر فوق القائمة المنبثقة حفظ كنوع. ترى الخيار *.inc كإضافة الملف المعترف بها في الخيار تضمين الملفات. ترى نفس الخيار في القائمة المنبثقة الملفات من نوع في ملف > فتح.

    ملاحظة:

    الترتيب الذي يتم سرد الملحقات به هو الترتيب الذي ستظهر به في مربعات الحوار ملف > فتح و ملف > حفظ.

    للحصول على طريقة العرض "تصميم" و "ترميز اللون" و "سلوك الأداء الوظيفي للخادم"، يجب تحرير الملف MMDocumentTypes.xml كما هو موضح في الأقسام التالية.

إضافة ملحقات لملف MMDocumentTypes.xml

يحتوي الملف MMDocumentTypes.xml على معلومات حول نموذج وحدة الخدمة ونمط ترميز اللون والوصف وهكذا لكل نوع مستند معروف.

بالإضافة إلى إضافة ملحقات إلى ملف extension.txt، يجب إضافة ملحقات جديدة إلى قوائم امتداد الملف لنوع المستند المقترن. إذا لم يكن كذلك، فلا يعرف Dreamweaver كيفية عرض نوع الملف هذا. Dreamweaver ثم يفتح الملف في عرض رمز بالوضع افتراضي.

إذا لم يتم ربط هذه الإضافة بأي نوع مستند محدد، يتم إنشاء نوع مستند جديد. لإنشاء نوع مستند جديد، راجع تمديد Dreamweaver من داخل Dreamweaver، انقر فوق تعليمات > تمديد Dreamweaver، وابحث في MMDocumentTypes.xml.

ملاحظة: في هذه المقالة، يشير "تعريف نوع المستند" إلى الملفات التي تحتوي على معلومات حول المستندات التي تم التعرف عليها بواسطة Dreamweaver. لا ينبغي الخلط بين تعريف نوع المستند من خلال "'DTDs" المذكورة في وثائق XML.

قم بتنفيذ الخطوات التالية لإضافة ملحقات لتعريف نوع الوثيقة في ملف MMDocumentTypes.xml:

  1. حدد موقع ملف MMDocumentTypes.xml في مجلد تكوين Dreamweaver الرئيسي (ليس مجلد تكوين مستخدم Dreamweaver). يعتمد موقع هذا المجلد على نظام التشغيل وإصدار Dreamweaver.
    • Dreamweaver CS3 on Windows Vista & XP:

      C:\Program Files\Adobe\Adobe Dreamweaver CS3\Configuration\DocumentTypes
    • Dreamweaver 8 on Windows Vista, XP & 2000:

      C:\Program Files\Macromedia\Dreamweaver 8\Configuration\DocumentTypes
    • Dreamweaver CS3 on Mac OS X:

      Mac HD:Applications:Adobe Dreamweaver CS3:Configuration:Document Types
    • Dreamweaver 8 on Mac OS X:

      Mac HD:Applications:Macromedia Dreamweaver 8:Configuration:Document Types
  2. يمكن فتح MMDocumentTypes.xml في أي محرر نص خارجي مثل Notepad أو Text Editor.

    لا تُعدِّل ملفات تكوين Dreamweaver باستخدام Dreamweaver.

  3. ابحث عن مجموعة العلامات لنوع المستند المطلوب.

    فيما يلي تعريف نوع المستند الافتراضي لوثائق HTML من ملف MMDocumentTypes.xml:

    <documenttype id="HTML" internaltype="HTML" winfileextension="html,htm,shtml,shtm,stm,tpl,lasso,xhtml" macfileextension="html,htm,shtml,shtm,tpl,lasso,xhtml,ssi" writebyteordermark="false">

  4. أضف الإضافة المطلوبة إلى سمات winfileextension و macfileextension للعلامة documenttype. على سبيل المثال، winfileextension="html,htm,shtml,shtm,stm,tpl,lasso,xhtml,inc"

    يضيف الرمز أعلاه ملحق ملف INC إلى قائمة الملفات التي يعاملها Dreamweaver كملفات HTML. عند إضافة ملحقات لقوائم macOS و Windows لهذا النوع من الملفات، يقوم Dreamweaver بفتح نوع الملف هذا في عرض التصميم.

  5. احفظ MMDocumentTypes.xml وأعد تشغيل Dreamweaver.
  6. للإطلاع على التغييرات، افتح Dreamweaver ثم افتح ملفاً باستخدام ملحق الملف المضاف حديثاً.

    يعمل الآن الأداء الوظيفي لعرض "تصميم" وتلوين التعليمات البرمجية ووظيفة سلوك الخادم (إن أمكن).

    ملاحظة:

    يعتبر الترتيب الذي يتم إدراج الإضافات به مهم. الملحق الأول في قائمة الإضافات هو الإضافة الافتراضية المستخدمة لنوع هذا الملف.

    إذا قمت بعمل نسخة احتياطية من MMDocumentTypes.xml ثم تركته في مجلد التكوين/DocumentTypes، فتشاهد رسائل تحذيرية منبثقة متعددة عند تشغيل Dreamweaver.

    تظهر لك رسائل خطأ مثل: "لن تتم إضافة نوع المستند "HTML" لأنه يستخدم ملحق ملف مرفق مسبقاً بنوع المستند السابق."

    ترى أيضاً رسالة الخطأ هذه إذا كان لديك نفس نوع الملف المدرج أكثر من مرة في MMDocumentTypes.xml.

    لإيقاف رسائل التحذير هذه، قم بنسخ النسخة الاحتياطية من الملف MMDocumentTypes.xml خارج مجلد التكوين/ DocumentTypes.

تحرير في مفضلات عرض "الرمز"

الخطوة الأخيرة هي التحقق من الإعدادات المفضلة لأنواع الملفات/المحررين (تحرير > المفضلات) والتأكد من أن ملحق الملف هذا غير مدرج في حقل فتح في عرض الرمز. يظهر ملحق ملف INC في هذه القائمة بشكل افتراضي. إذا قمت بإزالة ".inc" من القائمة فتح في عرض الرمز، يمكنك حينها عرض الملفات مع هذه الإضافة في عرض تصميم.

تمكين تلوين التعليمات البرمجية لأنواع الملفات المخصصة

بعد تنفيذ الخطوات لإضافة ملف MMDocumentTypes.xml، اتبع الإجراء التالي لتمكين تلوين التعليمات البرمجية في أنواع الملفات المخصصة.

  1. الخروج من تطبيق Dreamweaver.

  2. افتح ملف brackets.json من الموقع التالي، باستخدام محرر نصي:

    • Win: %appdata%\Adobe\Dreamweaver CC xxxx\en_US\Configuration\Brackets\brackets.json
    • macOS: ~/Library/Application Support/Adobe/Dreamweaver CC XXXX/en_US/Configuration/Brackets/brackets.json

    هنا، يشير xxxx لإصدار Dreamweaver. على سبيل المثال، 2017.

  3. في ملف .json، بعد آخر زوج مفتاح/القيمة، أدخل المحدد التالي، (فاصلة) و اطبع هذا النص:
    "language.fileExtensions": { ".ext": "php" }

    استبدل .ext بقائمة ملحقات ملف مفصولة بفاصلة والتي يجب إضافة تلوين التعليمات البرمجية لها.

    استبدل php بنوع المستند المطلوب. أنواع المستندات المدعومة هي:

    • bash
    • c
    • clojure
    • coffeescript
    • cpp
    • csharp
    • css
    • dart
    • diff
    • ejs
    • erb_html (متضمنة Ruby)
    • groovy
    • handlebars
    • haskell
    • html
    • hx (Haxe)
    • java
    • جافا سكريبت
    • json
    • jsx
    • less
    • lua
    • markdown
    • perl
    • php
    • خصائص
    • python
    • ruby
    • sass
    • scala
    • scss
    • sql
    • stylus
    • svg
    • turtle (RDF Turtle)
    • vb
    • vbscript
    • xml
    • yaml
  4. احفظ الملف وقم بتشغيل Dreamweaver.

معلومات إضافية

لمزيد من المعلومات حول تعديل أنواع الملفات في Dreamweaver، راجع تمديد Dreamweaver.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت