المشكلة

عند استخدام InDesign أو InCopy CS4 أو إصدار أحدث على نظام Mac OS X Lion لعام 2012، تتلقى مربع حوار تحذير فارغ. يتعطل التطبيق عند تنفيذ وظائف معينة.

الحلول

الحل 1

  • InDesign CS4 والإصدارات الأحدث: تحديث نظام Mac OS X 10.7 إلى Mac OS X 10.8.
  • InDesign CS6 فقط: قم بتثبيت آخر التحديثات الخاصة بـ InDesign CS6 عن طريق الانتقال إلى التعليمات > التحديثات ضمن التطبيق.

الحل 2

  1. قم بتنزيل البرنامج النصي التالي وتشغيله.

    تنزيل

  2. يطلب منك البرنامج النصي اختيار نسخة من InDesign/InCopy للتحديث. قم بتوجيه البرنامج النصي إلى التثبيت الحالي.

الحل 3

الخطوات التالية هي نفس الحل كالحل 1، ولكن يتم نسخ الملفات يدويًا. قم بإجرائها إذا كان الحل 2 غير ناجح.

  1. قم بإغلاق InDesign وقم بتنزيل الأرشيف المضغوط الذي يحتوي على ثلاثة رموز InDesign.

    تنزيل

    ملاحظة:

    يجب أن يستمر وضع هذه الملفات للسماح بإجراء تحديثات إضافية. ولكن يجب أن تدرك بأنك تقوم بتعديل ملف التطبيق الموجود. نقل أو تغيير محتويات التطبيق يمكن أن يجعل من الضروري إعادة تثبيت التطبيق.

    توصي Adobe بتثبيت جميع التحديثات الرسمية قبل وضع هذه الملفات ضمن التطبيق. يمكنك الوصول إلى هذه التحديثات من خلال التعليمات > التحديثات أو على موقع الويب لشركة Adobe.

  2. استخرج الرموز من الملف المضغوط إلى موقع سهل العثور عليه، مثل سطح المكتب.

  3. انتقل إلى: /Applications/Adobe InDesign CS6/ أو حيث يتم تثبيت التطبيق على نظامك.

  4. انقر بزر الماوس الأيمن أو CTRL+النقر فوق ملف تطبيق InDesign واختر "إظهار محتويات الحزمة."

  5. ضمن ملف تطبيق InDesign، انتقل إلى: /Contents/MacOS/Required/ وحدد موقع الملف "Application UI.InDesignPlugin" ومرة أخرى "إظهار محتويات الحزمة".

  6. ضمن المكونات الإضافية، انتقل إلى مجلد الموارد ثم إلى مجلد "idrc_PNGA."

  7. انسخ ملفات الرموز الثلاثة من الملف المضغوط المستخرج إلى المجلد "idrc_PNGA."

  8. أعد تشغيل InDesign.

الحل 4

لا تقم بتثبيت تحديث برنامج Mac OS X (منتصف 2012) إلى الإصدار 10.7.4. أو قم بإلغاء تثبيته إذا كان ذلك ممكنًا، وذلك باستخدام وظيفة الاسترداد في Mac OS X Lion.

معلومات إضافية

تمت إزالة آخر تحديث لنظام Mac OS X Lion ملف API الذي يستخدمه InDesign للعمل مع رموز النظام. من خلال وضع الملفات مباشرة داخل التطبيقات، أنت تعمل حول الوظيفة التي يخدمها API.

تمكنت Adobe من العمل مع Apple للمساعدة في التأكد من وجود واجهات APIs هذه ضمن الإصدار الأخير من النظام Mac OS 10.8.

في هذا الوقت، الحل الوحيد الذي يعمل مع CS4 هو تثبيت أحدث إصدار من النظام Mac OS 10.8.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت