Utilice este tema para aprender a utilizar el Inspector de propiedades para editar código en Vista de diseño en Dreamweaver.

Dreamweaver permite crear y editar visualmente páginas web sin tener que preocuparse del código fuente subyacente, pero a veces es necesario editar el código para tener un mayor control o para resolver problemas de la página web. Dreamweaver permite editar código mientras se trabaja en Vista de diseño.

Esta sección está pensada para quienes prefieren trabajar en la Vista de diseño pero también desean poder acceder al código con rapidez.

Seleccione etiquetas hijo en la Vista de diseño

Si selecciona un objeto en la vista de Diseño que contiene etiquetas hijo (por ejemplo, una tabla HTML), podrá seleccionar rápidamente la primera etiqueta hijo dicho objeto seleccionando Edición > Seleccionar hijo.

Nota:

Este comando sólo está activado en la vista de Diseño.

Por ejemplo, la etiqueta <table> normalmente tiene etiquetas <tr> hijo. Si selecciona una etiqueta <table> en el selector de etiquetas, podrá seleccionar la primera fila de la tabla seleccionando Edición > Seleccionar hijo. Dreamweaver seleccionará la primera etiqueta <tr> del selector de etiquetas. Dado que la propia etiqueta <tr> tiene etiquetas hijo, concretamente etiquetas <td>, al volver a seleccionar Edición > Seleccionar hijo, se selecciona la primera celda de la tabla.

Edición de código con el inspector de propiedades

Puede utilizar el inspector de propiedades para inspeccionar y editar los atributos del texto o de los objetos de la página. Las propiedades mostradas en el inspector de propiedades se suelen corresponder con los atributos de las etiquetas: si se cambia una propiedad en el inspector de propiedades, normalmente esto produce el mismo efecto que si se cambia el atributo correspondiente en la vista de Código.

Nota:

El inspector de etiquetas y el inspector de propiedades permiten ver y editar los atributos de las etiquetas. El inspector de etiquetas permite ver y editar cada atributo asociado a una determinada etiqueta. El inspector de propiedades muestra sólo los atributos más habituales, pero proporciona un conjunto más amplio de controles para cambiar dichos valores de atributo; además, permite editar determinados objetos (como columnas de tabla) que no corresponden a etiquetas específicas.

  1. Haga clic en el texto o seleccione un objeto de la página.

    El inspector de propiedades del texto o el objeto aparece bajo la ventana de documento. Si el inspector de propiedades no está visible, seleccione Ventana > Propiedades.

  2. Modifique los atributos en el inspector de propiedades.

Edición de CFML con el inspector de propiedades

Utilice el inspector de propiedades para inspeccionar y modificar el formato ColdFusion en la vista de Diseño.

  1. En el inspector de propiedades, haga clic en el botón Atributos para editar los atributos de la etiqueta o añadir atributos nuevos.
  2. Si la etiqueta encierra contenido entre la etiqueta de apertura y la de cierre, haga clic en el botón Contenido para editarlo.

    El botón Contenido sólo aparece si la etiqueta seleccionada no es una etiqueta vacía (es decir, si tiene etiqueta de apertura y de cierre).

  3. Si la etiqueta contiene una expresión condicional, modifíquela en el cuadro Expresión.

Introducción a Quick Tag Editor

Puede utilizar Quick Tag Editor para inspeccionar, insertar y editar etiquetas HTML de forma rápida sin salir de la Vista de diseño.

Si se escribe HTML inválido en el Quick Tag Editor, Dreamweaver procura corregirlo de manera automática, insertando comillas de cierre y paréntesis angulares cuando sea necesario.

Para establecer las opciones de Quick Tag Editor, abra Quick Tag Editor presionando Control+T (Windows) o Comando+T (Macintosh).

Quick Tag Editor dispone de tres modos de funcionamiento:

  • Insertar HTML, que se utiliza para insertar código HTML nuevo.
  • Editar etiqueta, que se utiliza para editar una etiqueta existente.
  • Insertar HTML, que se utiliza para insertar código HTML nuevo.

  • Editar etiqueta, que se utiliza para editar una etiqueta existente.

  • Ajustar etiqueta, que se utiliza para ajustar una nueva etiqueta alrededor de la selección actual.

Nota:

El modo en el que se abre Quick Tag Editor depende de la selección actual de la vista Diseño.

El funcionamiento básico de Quick Tag Editor es el mismo en los tres modos: se abre el editor, se introducen o se editan las etiquetas o atributos y se cierra el editor.

Puede alternar entre los distintos modos presionando Control+T (Windows) o Comando+T (Macintosh) con Quick Tag Editor activo.  

Edición de código con Quick Tag Editor

Utilice Quick Tag Editor ( Edit > Quick Tag Editor) para insertar y editar etiquetas HTML de forma rápida sin salir de la vista Diseño.

Inserción de una etiqueta HTML

  1. En la vista de Diseño, haga clic en la página para colocar el punto de inserción donde desee insertar código.
  2. Presione Control+T (Windows) o Comando+T (Macintosh).

    Quick Tag Editor se abre en modo Insertar HTML.

    Quick Tag Editor en modo Insertar HTML
    Quick Tag Editor en modo Insertar HTML

  3. Introduzca la etiqueta HTML y, a continuación, presione Intro.

    La etiqueta se inserta en el código junto con la correspondiente etiqueta de cierre, si procede.

  4. Presione Escape para salir sin realizar ningún cambio.

Edición de una etiqueta HTML

  1. Seleccione un objeto en la Vista de diseño.

    También puede seleccionar la etiqueta que desea editar en el selector de etiquetas situado en la parte inferior de la ventana de documento. Para más información, consulte Edición de código con el selector de etiquetas.

  2. Presione Control+T (Windows) o Comando+T (Macintosh).

    Quick Tag Editor se abre en modo Editar etiqueta.

  3. Introduzca nuevos atributos, edite atributos existentes o edite el nombre de la etiqueta.
  4. Presione Tab para pasar de un atributo al siguiente; presione Mayús+Tab para retroceder.

    Nota:

    De forma predeterminada, los cambios se aplican al documento al presionar Tab o Mayús+Tab.

  5. Para cerrar Quick Tag Editor y aplicar todos los cambios, presione Intro.
  6. Para salir sin hacer ningún otro cambio, presione Escape.

Cómo rodear la selección actual con etiquetas HTML

  1. Seleccione texto sin formato o un objeto en la vista de Diseño.

    Nota:

    Si ha seleccionado texto o un objeto que incluya una etiqueta HTML de apertura o cierre, Quick Tag Editor se abrirá en modo Editar etiqueta en lugar del modo Ajustar etiqueta.

  2. Presione Control+T (Windows) o Comando+T (Macintosh), o bien haga clic en el botón Quick Tag Editor del inspector de propiedades.

    Quick Tag Editor se abre en modo Ajustar etiqueta.

  3. Especifique una etiqueta de apertura, como strong, y presione Intro (Windows) o Retorno (Macintosh).

    La etiqueta se insertará al principio de la selección actual y se insertará la correspondiente etiqueta de cierre al final.

  4. Para salir sin hacer ningún cambio, presione Escape.

Uso del menú de sugerencias en Quick Tag Editor

Quick Tag Editor incluye un menú de sugerencias sobre atributos que muestra todos los atributos válidos de la etiqueta que está editando o insertando.

También puede desactivar el menú de sugerencias o ajustar el tiempo que debe transcurrir antes de que aparezca el menú en Quick Tag Editor.

Para ver un menú de sugerencias que enumere los atributos válidos para una etiqueta, no olvide hacer una breve pausa al editar un nombre de atributo en Quick Tag Editor. Aparecerá un menú de sugerencias con todos los atributos válidos para la etiqueta que está editando.

De modo parecido, para ver un menú de sugerencias con los nombres de etiqueta válidos, haga una breve pausa al especificar o editar un nombre de etiqueta en Quick Tag Editor.

Nota:

Las preferencias de sugerencias de código de Quick Tag Editor están regidas por las preferencias de sugerencias de código habituales. Para más información, consulte Configuración de las preferencias de sugerencias para el código.

  1. Siga uno de estos procedimientos:
    • Empiece a escribir un nombre de etiqueta o atributo. La selección del menú Sugerencias para el código salta al primer elemento que empieza por las letras que ha escrito.

    • Utilice las teclas de flecha hacia arriba y flecha hacia abajo para seleccionar un elemento.

    • Utilice la barra de desplazamiento para buscar un elemento.

  2. Presione Intro para insertar el elemento seleccionado o haga doble clic en un elemento para insertarlo.
  3. Para cerrar el menú de sugerencias sin insertar ningún elemento, presione Escape o continúe escribiendo.

Desactivación del menú de sugerencias o modificación del tiempo que debe transcurrir antes de que aparezca

  1. Seleccione Edición > Preferencias (Windows) o Dreamweaver > Preferencias (Macintosh) y seleccione Sugerencias de código.

    Se mostrará el cuadro de diálogo Preferencias para la categoría Sugerencias para el código.

  2. Para desactivar el menú de sugerencias, anule la selección de la opción Activar sugerencias para el código.

Edición de código con el selector de etiquetas

Puede utilizar el selector de etiquetas para seleccionar, editar o quitar etiquetas sin salir de la vista de Diseño. El selector de etiquetas está situado en la barra de estado de la parte inferior de la ventana de documento y muestra una serie de etiquetas.

Edición o eliminación de una etiqueta

  1. Haga clic en el documento.

    Las etiquetas presentes en el punto de inserción aparecen en el selector de etiquetas.

  2. Haga clic con el botón derecho (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en una etiqueta del selector de etiquetas.
  3. Para editar una etiqueta, seleccione Editar etiqueta del menú. Realice los cambios en Quick Tag Editor. Para más información, consulte Edición de código con Quick Tag Editor.
  4. Para eliminar una etiqueta, seleccione Quitar etiqueta del menú.

Selección de un objeto correspondiente a una etiqueta

  1. Haga clic en el documento.

    Las etiquetas presentes en el punto de inserción aparecen en el selector de etiquetas.

  2. Haga clic en una etiqueta del selector de etiquetas.

    El objeto representado por la etiqueta se selecciona en la página.

    Nota:

    Utilice esta técnica para seleccionar filas (etiquetas tr) o celdas (etiquetas td) de tabla.

Escritura y edición de scripts en la vista de Diseño

Puede trabajar con JavaScripts y VBScripts en el lado del cliente tanto en la Vista de código como en la Vista de diseño de las siguientes formas:

  • Escriba un script JavaScript o VBScript para la página sin salir de la Vista de diseño.

  • Cree un vínculo en el documento con un archivo de script externo sin salir de la Vista de diseño.

  • Edite un script sin salir de la vista de Diseño.

    Antes de empezar, seleccione Ver > Ayudas visuales > Elementos invisibles para garantizar que los marcadores de scripts aparecerán en la página.

Escritura de un script de la parte del cliente

  1. Sitúe el punto de inserción en el lugar donde desea introducir el script.
  2. Seleccione Insertar > HTML > Script.

  3. Seleccione el script en la ventana de selección de archivos.

    Nota:

    No es preciso que incluya las etiquetas de apertura y cierre de script.

La etiqueta script para el archivo seleccionado se inserta en el documento.

Edición de un script

  1. Seleccione el marcador de scripts.
  2. En el inspector de propiedades, haga clic en el botón Editar.

    El script aparece en el cuadro de diálogo Propiedades del script.

    Si ha establecido un vínculo con un archivo de script externo, dicho archivo se abre en la vista de Código, donde podrá editarlo.

    Nota:

    Si hay código entre las etiquetas de script, se abre el cuadro de diálogo Propiedades del script, incluso aunque haya también un vínculo con un archivo de script externo.

  3. En el cuadro Lenguaje, especifique JavaScript o VBScript como lenguaje de scripts.
  4. En el menú emergente Tipo, especifique el tipo de script: en el lado del cliente o en el lado del servidor.
  5. (Opcional) En el cuadro Origen, especifique un archivo de script vinculado de forma externa.

    Haga clic en el icono de carpeta o en el botón Examinar para seleccionar un archivo, o bien escriba la ruta.

  6. Edite el script y haga clic en OK.

Edición de scripts ASP en el lado del servidor en la vista de Diseño

Utilice el inspector de propiedades de script ASP para inspeccionar y modificar scripts ASP en el lado del servidor en la vista de Diseño.

  1. En la vista de Diseño, seleccione el icono visual de etiqueta de lenguaje de servidor.
  2. En el inspector de propiedades de script ASP, haga clic en el botón Editar.
  3. Edite el script ASP del lado del servidor y haga clic en OK.

Edición de scripts en la página utilizando el inspector de propiedades

  1. En el inspector de propiedades, elija el lenguaje de scripts del menú emergente Lenguaje o escriba un nombre de lenguaje en el cuadro Lenguaje.

    Nota:

    Si utiliza JavaScript y no está seguro de la versión, seleccione JavaScript en lugar de JavaScript1.1 o JavaScript1.2.

  2. En el menú emergente Tipo, especifique el tipo de script: en el lado del cliente o en el lado del servidor.
  3. (Opcional) En el cuadro Origen, especifique un archivo de script vinculado de forma externa. Haga clic en el icono de carpeta para seleccionar el archivo o escriba la ruta correspondiente.

  4. Haga clic en Editar para modificar el script.

Utilización de comportamientos de JavaScript

Puede adjuntar fácilmente comportamientos JavaScript (lado del cliente) a elementos de página empleando la ficha Comportamientos del inspector de etiquetas. Para obtener más información, consulte Aplicación de comportamientos JavaScript incorporados.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea