Visual keyboard shortcut editor

Use the visual Keyboard Shortcut editor to view the shortcuts associated with menu commands, tools, and other application functionality, and customize shortcuts for maximum workflow efficiency.

Note: The Keyboard Shortcuts dialog box is only for operations that the application can perform. Triggers are handled in the Triggers panel.

View assigned shortcuts

To view the Visual Keyboard Shortcuts, choose Edit > Keyboard Shortcuts.

  • macOS- Command+Shift+Option+K
  • Windows- Ctrl+Shift+Alt+K

The Keyboard Shortcuts dialog box appears, showing the layout of the keyboard.

The keys with shortcuts assigned are identified in purple. All the shortcuts are application-wide shortcuts. To see the full name of the command and its location in the Command list, hover over the assigned shortcut. The Command list shows all assignable commands, grouped by category (menu name or functionality in the application). You can use the search field above the list to quickly locate commands or their descriptions matching a specific word.

When you select a key in the keyboard layout, all the commands that are assigned to that key and all other modifier combinations appear in the Modifiers list.

To export a list of all commands and assigned shortcuts, click Copy To Clipboard.

Customize shortcuts

To assign a shortcut to a command, do either of the following:

  • Drag the command from the Command list and drop it onto the key in the keyboard layout. Optionally, hold down one or more modifiers while dropping the command onto the key to include those modifiers in the shortcut.
  • Click in the Shortcut column for the command in the Command list, then press the key (and optional modifiers).

If you use a shortcut assigned to another command, a warning explaining the conflict appears at the bottom of the dialog box, and the shortcut is unassigned from the other command. If unintended, click Undo.
You can assign multiple shortcuts to the same command.

Note: The menu bar and tooltips for those commands only shows one of the assigned shortcuts.

  • To remove the last assigned shortcut for a command, click Undo.
  • To remove a shortcut assigned to a command, select the shortcut in the Shortcut column of the Command list, then either click the close button next to the shortcut or click Clear.
  • To remove all shortcuts assigned to a command, select the command in the Command list and select Clear.

Note: You cannot unassign the Play command’s shortcut (Space), or assign Space to another command. Assigning a new shortcut or removing the shortcut for the Preview Frame, Next Frame, Back Ten Frames, and Forward Ten Frames command changes the nonrepeating (tap) version of those commands. The repeating (holding down the key) version is still be assigned to the original shortcut and appear in the tooltip.

Switch between different sets of shortcuts

You can save different sets of shortcuts, and switch between them based on your preference.

  • To save the current layout of shortcuts as a new preset, click the Save As button, and give the preset a name.
  • To delete a previously saved preset, select it from the Keyboard Layout Preset menu, then click the Delete button.
  • To restore the default set of shortcuts, choose Default Set (read-only) from the Keyboard Layout Preset menu.

Keyboard shortcut reference

General

Result Windows macOS
Don’t open scenes or puppets in their respective panels when launching the application Hold down Shift immediately after launching the application Hold down Shift immediately after launching the application
Create a project instead of opening the last project when launching the application Hold down Alt immediately after launching the application Hold down Option immediately after launching the application
Select a range of project items, layers in a puppet, or triggers for a puppet Select the first object, then Shift-click the object at the other end of the range Select the first object, then Shift-click the object at the other end of the range
Select or toggle selection of multiple tracks, takes, or viseme or trigger bars in the Timeline panel, or controls in the Controls panel’s Layout mode Shift-click or Ctrl-click the objects Shift-click or Command-click the objects
Select a collection of tracks, takes, or viseme or trigger bars in the Timeline panel, or controls in the Controls panel’s Layout mode Drag (marquee)-select around or across the objects Drag (marquee)-select around or across the objects
Select all project items, layers in a puppet, tracks in the timeline, controls in the Controls panel’s Layout mode, or replays for a puppet  Ctrl+A Command+A
Deselect all project items, layers in a puppet, tracks in the timeline, controls in the Controls panel’s Layout mode, or replays for a puppet
Ctrl+Shift+A Command+Shift+A
Rename selected project item, layer in a puppet, handle, marker, trigger, swap set, replay, history bookmark, or behavior parameter control ker, trigger, or swap set
Enter on main keyboard Return
Delete selected project item, layer in a puppet, handle, track, take, marker, trigger, swap set, or control (in Controls panel’s Layout mode)
Delete or Backspace Delete
Duplicate selected project items, layers, tracks, or takes Ctrl+D Command+D
Split selected tracks or takes Ctrl+Shift+D     Command+Shift+D
Select the previous or next project item or layer in a puppet Up Arrow or Down Arrow Up Arrow or Down Arrow
Extend the selection to the previous or next project item or layer in a puppet Shift+Up Arrow or Shift+Down Arrow
Shift+Up Arrow or Shift+Down Arrow
Select or deselect individual/discontiguous project items, layers in a puppet, or viseme trigger bars Ctrl-click Command-click
Open Preferences dialog box Ctrl+K Command+, (comma)
Open Keyboard Shortcut editor dialog box  Ctrl+Shift+Alt+K Command+Shift+Option+K
Show help F1 F1
Undo Ctrl+Z Command+Z
Redo Ctrl+Shift+Z Command+Shift+Z
New history bookmark  Ctrl+Alt+S  Command+Option+S 
Quit Ctrl+Q or Alt+F4 Command+Q

Projects

Result Windows macOS
New project Ctrl+Alt+N
Command+Option+N
Open project
Ctrl+O Command+O
Save project As
Ctrl+Shift+S Command+Shift+S

Artwork and audio files

Result Windows macOS
Import files into the project
Ctrl+I or double-click in an empty area of the Project panel
Command+I or double-click in an empty area of the Project panel
Add selected project items to a new scene
Ctrl+\ (backslash) or click the Add to New Scene button Command+\ (backslash) or click the Add to New Scene button
Add each selected project item to its own new scene Alt-click the Add to New Scene button, or hold down Alt while choosing Scene > Add to New Scene
Option-click the Add to New Scene button, or hold down Option while choosing Scene > Add to New Scene

Workspaces and panels

Result Windows macOS
Switch to Start workspace
Alt+Shift+1 Option+Shift+1
Switch to Rig workspace
Alt+Shift+2 Option+Shift+2
Switch to Record workspace
Alt+Shift+3 Option+Shift+3
Switch to Stream workspace
Alt+Shift+4 Option+Shift+4
Pan the contents of the Scene or Puppet panel
Alt-drag in the panel, or hold down Spacebar or middle mouse button while dragging in the Puppet panel
Option-drag in the panel, or hold down Spacebar or middle mouse button while dragging in the Puppet panel
Zoom the contents of the Scene or Puppet panel Ctrl+= (equal) / Ctrl+- (minus), or Alt-spin the mouse wheel (or vertically swipe the trackpad) while the pointer is above the panel
Command+= (equal) / Command+- (minus), or Option-spin the mouse wheel (or vertically swipe the trackpad) while the pointer is above the panel
Recenter and reset to 100% zoom of the contents in the Scene or Puppet panel
Alt-double-click in the panel Option-double-click in the panel
Maximize or restore panel under pointer
` (accent grave) ` (accent grave)
Close the frontmost content in the Scene or Puppet panel
Ctrl+W Command+W
Reset the layout of the current workspace Double-click the name of the workspace in the workspaces bar Double-click the name of the workspace in the workspaces bar

Scenes

Result Windows MacOS
Create an empty scene
Ctrl+N Command+N
Refresh the scene’s content, including restarting simulations
Ctrl+Shift+R, F5, or click Refresh Scene button in Scene panel
Command+Shift+R, F5, or click Refresh Scene button in Scene panel
Refresh the scene’s contents, including restarting simulations and deleting previously cached artwork
Alt-click Refresh Scene button in Scene panel Option-click Refresh Scene button in Scene panel
Take a scene snapshot Shift+F6 Shift+F6
Show or hide the scene snapshot F6 F6
Increase or decrease scene snapshot opacity Ctrl+Alt+= or Ctrl+Alt+- Command+Option+= or Command+Option+-

Puppets

Result Windows macOS
Create an empty puppet
Ctrl+Shift+N Command+Shift+N
Group selected layers in a puppet
Ctrl+G Command+G
Edit select puppet’s artwork in application with which it is associated (Edit Original)
Ctrl+E Command+E
Set the rest pose for a face-tracked puppet
Ctrl+P Command+P
Assign a trigger key for a layer in a puppet
Click the trigger column in the Puppet panel, choose Create Trigger, then enter the key in the Triggers panel
Click the trigger column in the Puppet panel, choose Create Trigger, then enter the key in the Triggers panel
Show trigger keys for a puppet (that uses the Triggers behavior) Select the puppet, then open the Triggers panel (Window > Triggers) Select the puppet, then open the Triggers panel (Window > Triggers)
Make a layer a clipping mask for the layers below it, or release a clipping mask Ctrl+Alt+G Command+Option+G
Constrain movement of a handle in the Puppet panel Hold down Shift as you start to drag the handle Hold down Shift as you start to drag the handle
Nudge selected handles  Arrow keys + hold down Shift as well for 10x the distance or Ctrl for 1/10th the distance Arrow keys + hold down Shift as well for 10x the distance or Command for 1/10th the distance

Charactertizer (Edit Style screen)

Results Windows macOS
Pan the style image (when zoomed)  Hold down Spacebar while dragging the image  Hold down Spacebar while dragging the image 
Zoom the style image  Alt-spin the mouse wheel (or vertically swipe the trackpad) while the pointer is above the image Option-spin the mouse wheel (or vertically swipe the trackpad) while the pointer is above the image
Select multiple edit points Drag (marquee)-select around the points Drag (marquee)-select around the points
Toggle the selection of multiple edit points Ctrl-drag-select around the points Command-drag-select around the points
Adjust the brush size Spin the mouse wheel or vertically swipe the trackpad Spin the mouse wheel or vertically swipe the trackpad
Eyedropper-pick the brush type from the region color drawn over the image Right-click above the drawn color Right-click above the drawn color

Puppet Tools

Results Windows macOS
Activate Selection tool V V
Activate Hand tool H H
Temporarily activate Hand tool Hold down Spacebar Hold down Spacebar
Activate Zoom In tool Z Z
Activate Zoom Out tool Alt (when Zoom In tool is active) Option (when Zoom In tool is active)
Activate Handle tool L L
Activate Stick tool S S
Activate Pin tool P P
Activate Dragger tool M M
Activate Dangle tool D D

Behaviors

Note:

See Lip Sync shortcuts in the Lip sync section.

Result Windows macOS
(Eye Gaze or Face) Pause eye gaze or facial movements
Hold down ; (semicolon) Hold down ; (semicolon)
(Eye Gaze Face or Head Turner) Paste face measurements data from After Effects onto a puppet
Ctrl+V Command+V
Eye Gaze) Dart eyes in specific directions (when Keyboard Input is armed) Arrow keys: Up or Down = vertical, Left or Right = horizontal, horizontal + vertical Arrow keys = diagonal Arrow keys: Up or Down = vertical, Left or Right = horizontal, horizontal + vertical Arrow keys = diagonal
(Layer Picker) Choose a different layer (when Keyboard Input is armed) Arrow keys: Left = lower-numbered layer, Right = higher-numbered layer, Up = first layer in range, Down = last layer in range
Arrow keys: Left = lower-numbered layer, Right = higher-numbered layer, Up = first layer in range, Down = last layer in range
(Lip Sync) Copy a lip sync take as Time Remap keyframes for use in After Effects
Right-click the Lip Sync take, then choose Copy Visemes for After Effects Right-click the Lip Sync take, then choose Copy Visemes for After Effects
(Particles) Emit a single particle (Continuous mode for either Point and shoot or Cannon) R R
(Particles) Remove all particles D D
(Walk) Start/stop walking (when Start is set to With Left & Right Arrow Keys)
Left Arrow or Right Arrow Left Arrow or Right Arrow

Recording and playback

Result Windows macOS
Start or stop recording
Ctrl+R Command+R
Start or stop playback
Spacebar Spacebar
Record a 1-frame take
Ctrl+1 Command+1
Record a 2-frame take
Ctrl+2 Command+2
Record a take the duration of the work area* Ctrl+3  Command+3 
Arm or disarm all behaviors for a puppet
Ctrl-click any behavior Arm for Record button in the Properties panel Command-click any behavior Arm for Record button in the Properties panel
Arm or disarm all properties of a behavior
Ctrl-click any behavior parameter’s Arm for Record button in the Properties panel Command-click any behavior parameter’s Arm for Record button in the Properties panel
Enable or disable all behaviors on a puppet Ctrl-click any behavior’s eyeball in the Properties panel Command-click any behavior’s eyeball in the Properties panel

* These shortcuts create takes for armed behavior parameters. However, if triggers or swap sets are selected in the Triggers panel and the panel has focus, these will create trigger bars instead. 

Note:

The record 1 frame take and record a 2 frame take shortcuts create takes for armed behavior parameters. However, if triggers or swap sets are selected in the Triggers panel and the panel has focus, these creates trigger bars instead.

Time navigation and work area

Result Windows macOS
Go to beginning of a scene
Home Fn+Left Arrow
Go forward 1 frame
Ctrl+Right Arrow Command+Right Arrow
Go forward 10 frames
Ctrl+Shift+Right Arrow Command+Shift+Right Arrow
Go backward 1 frame
Ctrl+Left Arrow Command+Left Arrow
Go backward 10 frames
Ctrl+Shift+Left Arrow Command+Shift+Left Arrow
Go to the previous interesting time (work area start/end, track in/out, take in/out, marker) Alt+Left Arrow  Option+Left Arrow 
Go to the next interesting time (work area start/end, track in/out, take in/out, marker) Alt+Right Arrow Option+Right Arrow
Go to the start of the work area Shift+Home Shift+Home
Go to the end of the work area Shift+End Shift+End
Scrub through time in 1-frame increments
Drag the playhead Drag the playhead
Scrub through time in subframe increments
Ctrl-drag the playhead Command-drag the playhead
Scroll left or right one “page” of the Timeline panel at a time
Page Up or Page Down Page Up or Page Down
Scroll left or right less than one “page” of the Timeline panel at a time Ctrl+Page Up or Ctrl +Page Down Command+Page Up or Command+Page Down
Enable or disable the work area Click the bar along the time ruler at the top of the Timeline panel Click the bar along the time ruler at the top of the Timeline panel
Set start of the work area to the playhead Alt+I Option+I
Set end of the work area to the playhead Alt+O Option+O
Set the work area to match the selected tracks and takes Alt+/ Option+/
Advance (shift later in time) the work area by its duration Ctrl+4 Command+4

Tracks and takes

Result Windows macOS
Move selected tracks or takes down (back) or up (front) in stacking order Ctrl+Up Arrow or Ctrl+Down Arrow Command+Up Arrow or Command+Down Arrow
While dragging a track or take, avoid snapping to start/end times of other tracks and takes
Hold down Ctrl Hold down Command
Use the previous or next take blend mode
Ctrl+B or Ctrl+Shift+B Command+B or Command+Shift+B
Trim the In point for selected tracks or takes to current time
Alt+[ (left bracket) or Alt+] (right bracket) Option+[ (left bracket) or Option+] (right bracket)
Copy a selected take Ctrl+C Command+C
Copy a selected take, then remove it from the Timeline panel Ctrl+X Command+X
Paste a previously copied or cut take at the current (playhead) time Ctrl+V Command+V
Create a hold take from the selected take at the current time Ctrl+Shift+Alt+D Command+Shift+Option+D
Replace a puppet track with a different puppet item Select the puppet track in the timeline, then hold down Alt as you drag another puppet from the Project panel into the Timeline panel Select the puppet track in the timeline, then hold down Option as you drag another puppet from the Project panel into the Timeline panel

Lip sync

Result Windows macOS
Add a viseme anywhere in time
Alt-right-click at the intended time above the Visemes row in the Timeline panel, then choose the viseme from the menu Option-right-click at the intended time above the Visemes row in the Timeline panel, then choose the viseme from the menu
Split a viseme bar
Alt-click at the intended split time Option-click at the intended split time
Select the previous or next
viseme or span of silence in time

Left Arrow or Right Arrow


Left Arrow or Right Arrow

Move the selected viseme earlier or later by one frame at a time Up Arrow or Down Arrow Up Arrow or Down Arrow
Change selected visemes to a specific viseme First letter of the viseme (e.g., A for Ah, E for Ee, W for W-Oo, etc.) First letter of the viseme (e.g., A for Ah, E for Ee, W for W-Oo, etc.)
Split selected viseme in half / (forward slash) / (forward slash)
Copy Lip Sync take to system clipboard and remove take from puppet Ctrl+X Command+X
Paste Lip Sync take to puppet Ctrl+V Command+V

Trigger bars in the Timeline panel

Result Windows macOS
Add a trigger anywhere in time Alt-right-click at the intended time above the Triggers row in the Timeline panel, then choose the trigger from the menu Option-right-click at the intended time above the Triggers row in the Timeline panel, then choose the trigger from the menu
Split a trigger bar Alt-click at the intended split time Option-click at the intended split time
Select the previous or next trigger bar in time Left Arrow or Right Arrow Left Arrow or Right Arrow
Move the selected trigger bar earlier or later by one frame at a time Up Arrow or Down Arrow Up Arrow or Down Arrow
Split selected trigger bar in half / (forward slash) / (forward slash)

Markers

Result Windows macOS
Add a marker
* (multiply) on numeric keypad Control+8
Add a stop marker
Shift+* (multiply) on numeric keypad Control+Shift+8
Rename a marker or stop marker
Press Enter or double-click
Press Enter or double-click

Controls panel

Result Windows macOS
Add controls for all of a
puppet’s triggers
Click the Refresh Layout
button
Click the Refresh Layout
button
Relayout the current
controls based on the size of the Controls panel
Alt-click the Refresh
Layout button
Option-click the Refresh
Layout button
While dragging
a control, avoid snapping to the grid layout (Layout mode)
Hold down Ctrl

Hold down Command
Pan the contents of the panel (Layout mode)  Hold down the Alt key or middle mouse button while dragging in the panel, or spin the mouse wheel to scroll vertically or hold down the Shift key as you spin it to scroll horizontally Hold down the Option key or middle mouse button while dragging in the panel, or spin the mouse wheel to scroll vertically or hold down the Shift key as you spin it to scroll horizontally
Assign a key
to a selected trigger control (Layout mode)
Press the key, or enter the
key for the trigger in the Triggers panel
Press the key, or enter the key for the trigger in the Triggers panel
Assign a MIDI
note to a selected trigger control (Layout mode)
Tap the note on the MIDI device; you can also do this while the cursor is in the MIDI Note field in the Triggers panel Tap the note on the MIDI device; you can also do this while the cursor is in the MIDI Note field in the Triggers panel
Assign a MIDI fader or knob to a
selected behavior parameter control (Layout mode)

Move the fader or knob
Move the fader or knob
Quickly switch from Layout to Perform mode* Double-click away from any control in the panel Double-click away from any control in the panel

* You can assign a shortcut to quickly switch between Layout and Perform modes. In the Keyboard Shortcut editor, look in the Window category for the Toggle Controls Panel Layout Mode command.

Export

Result Windows macOS
Export scene as video using Adobe Media Encoder
Ctrl+M Command+M
Export scene as PNG sequence and WAV audio
Ctrl+Alt+M Command+Option+M

Live streaming

Result Windows macOS
Enable or disable live streaming
Click the Stream Live button in the Scene panel Click the Stream Live button in the Scene panel
Change the active devices for live streaming
Ctrl-click the Stream Live button in the Scene panel Command-click the Stream Live button in the Scene panel

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy